]> git.pld-linux.org Git - packages/allegro.git/blame_incremental - allegro.spec
- more devel files
[packages/allegro.git] / allegro.spec
... / ...
CommitLineData
1#
2# TODO: Handle situations when there are no modules (most bconds turned off)
3#
4# Conditional build:
5%bcond_without alsa # without ALSA modules
6%bcond_without arts # without aRts module
7%bcond_without dga2 # without DGA2 module
8%bcond_without dbglib # don't build debug versions of library
9%bcond_without esd # without esound module
10%bcond_without fbcon # without framebuffer module
11%bcond_without jack # without JACK module
12%bcond_without proflib # don't debug profiling versions of library
13%bcond_without sse # build without sse
14%bcond_without static # don't build static versions of library
15%bcond_without svga # without svgalib module
16%bcond_without vga # without vga module
17#
18Summary: A game programming library
19Summary(de.UTF-8): Eine Bibliothek zur Programmierung von Spielen
20Summary(es.UTF-8): Una biblioteca de programación de juegos
21Summary(fr.UTF-8): Une librairie de programmation de jeux
22Summary(it.UTF-8): Una libreria per la programmazione di videogiochi
23Summary(pl.UTF-8): Biblioteka do programowania gier
24Name: allegro
25Version: 4.9.8
26Release: 0.1
27License: Giftware
28Group: Libraries
29Source0: http://dl.sourceforge.net/alleg/%{name}-%{version}.tar.gz
30# Source0-md5: 98c4102dc5f5195576d9817d8ea00811
31Patch0: %{name}-info.patch
32Patch1: %{name}-examples.patch
33Patch2: %{name}-opt.patch
34Patch3: %{name}-ldflags.patch
35Patch4: %{name}-frame-pointer.patch
36Patch5: %{name}-config.patch
37Patch6: %{name}-headers.patch
38URL: http://alleg.sourceforge.net/
39#%%{?with_alsa:BuildRequires: alsa-lib-devel}
40#%%{?with_arts:BuildRequires: artsc-devel}
41BuildRequires: cmake >= 2.6
42#%%{?with_esd:BuildRequires: esound-devel}
43#%%if %{with jack}
44#BuildRequires: jack-audio-connection-kit-devel
45#BuildRequires: pkgconfig
46#%%endif
47#BuildRequires: sed >= 4.0
48#%%{?with_svga:BuildRequires: svgalib-devel}
49#BuildRequires: texinfo
50#BuildRequires: xorg-lib-libX11-devel
51#BuildRequires: xorg-lib-libXcursor-devel
52#BuildRequires: xorg-lib-libXext-devel
53#BuildRequires: xorg-lib-libXpm-devel
54#BuildRequires: xorg-lib-libXxf86dga-devel
55#BuildRequires: xorg-lib-libXxf86vm-devel
56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58%description
59Allegro is a cross-platform library intended for use in computer games
60and other types of multimedia programming.
61
62%description -l de.UTF-8
63Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
64Computerspielen und anderen Formen von Multinediaprogrammierung.
65
66%description -l es.UTF-8
67Allegro es una librería multi-plataforma creada para ser usada en la
68programación de juegos u otro tipo de programación multimedia.
69
70%description -l fr.UTF-8
71Allegro est une librairie multi-plateforme destinée à être utilisée
72dans les jeux vidéo ou d'autres types de programmation multimédia.
73
74%description -l it.UTF-8
75Allegro è una libreria multipiattaforma dedicata all'uso nei
76videogiochi ed in altri tipi di programmazione multimediale.
77
78%description -l pl.UTF-8
79Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
80grach komputerowych i innych rodzajach oprogramowania multimedialnego.
81
82%package devel
83Summary: A game programming library - header files
84Summary(es.UTF-8): Archivos de inclusión
85Summary(pl.UTF-8): Biblioteka do programowania gier - pliki nagłówkowe
86Group: Development/Libraries
87Requires: %{name} = %{version}-%{release}
88
89%description devel
90Allegro is a cross-platform library intended for use in computer games
91and other types of multimedia programming.
92
93This package contains header files neccessary for compiling
94applications using allegro library.
95
96%description devel -l de.UTF-8
97Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
98Computerspielen und anderen Formen von Multinediaprogrammierung.
99Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
100verwenden.
101
102%description devel -l es.UTF-8
103Allegro es una librería multi-plataforma creada para ser usada en la
104programación de juegos u otro tipo de programación multimedia. Este
105paquete es necesario para compilar los programas que usen Allegro.
106
107%description devel -l fr.UTF-8
108Allegro est une librairie multi-plateforme destinée à être utilisée
109dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
110package est nécessaire pour compiler les programmes utilisant Allegro.
111
112%description devel -l it.UTF-8
113Allegro è una libreria multipiattaforma dedicata all'uso nei
114videogiochi ed in altri tipi di programmazione multimediale. Questo
115pacchetto è necessario per compilare programmi scritti con Allegro.
116
117%description devel -l pl.UTF-8
118Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
119grach komputerowych i innych rodzajach oprogramowania multimedialnego.
120
121Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
122aplikacji wykorzystujących bibliotekę allegro.
123
124%package static
125Summary: A game programming library - static libraries
126Summary(pl.UTF-8): Biblioteka do programowania gier - biblioteki statyczne
127Group: Development/Libraries
128Requires: %{name}-devel = %{version}-%{release}
129Requires: xorg-lib-libX11-devel
130Requires: xorg-lib-libXcursor-devel
131Requires: xorg-lib-libXext-devel
132Requires: xorg-lib-libXpm-devel
133Requires: xorg-lib-libXxf86vm-devel
134
135%description static
136Allegro is a cross-platform library intended for use in computer games
137and other types of multimedia programming.
138
139This package contains static libraries for linking with allegro
140applications.
141
142%description static -l pl.UTF-8
143Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
144grach komputerowych i innych rodzajach oprogramowania multimedialnego.
145
146Ten pakiet zawiera biblioteki statyczne do konsolidacji z aplikacjami
147wykorzystującymi allegro.
148
149%package debug
150Summary: liballd - debug version of shared allegro library
151Summary(pl.UTF-8): liballd - wersja debug dzielonej biblioteki allegro
152Group: Development/Libraries
153Requires: %{name}-devel = %{version}-%{release}
154
155%description debug
156liballd - debug version of shared allegro library (contains debugging
157symbols and other information).
158
159%description debug -l pl.UTF-8
160liballd - wersja debug dzielonej biblioteki allegro (zawierająca
161symbole i inne informacje potrzebne przy odpluskwianiu).
162
163%package debug-static
164Summary: liballd - debug version of static allegro library
165Summary(pl.UTF-8): liballd - wersja debug statycznej biblioteki allegro
166Group: Development/Libraries
167Requires: %{name}-devel = %{version}-%{release}
168
169%description debug-static
170liballd - debug version of static allegro library (contains debugging
171symbols and other information).
172
173%description debug-static -l pl.UTF-8
174liballd - wersja debug statycznej biblioteki allegro (zawierająca
175symbole i inne informacje potrzebne przy odpluskwianiu).
176
177%package profile
178Summary: liballp - profiling version of shared allegro library
179Summary(pl.UTF-8): liballp - wersja dzielonej biblioteki allegro służąca do profilowania
180Group: Development/Libraries
181Requires: %{name}-devel = %{version}-%{release}
182
183%description profile
184liballp - profiling version of shared allegro library.
185
186%description profile -l pl.UTF-8
187liballp - wersja dzielonej biblioteki allegro służąca do profilowania.
188
189%package profile-static
190Summary: liballp - profiling version of static allegro library
191Summary(pl.UTF-8): liballp - wersja statycznej biblioteki allegro służąca do profilowania
192Group: Development/Libraries
193Requires: %{name}-devel = %{version}-%{release}
194
195%description profile-static
196liballp - profiling version of static allegro library.
197
198%description profile-static -l pl.UTF-8
199liballp - wersja statycznej biblioteki allegro służąca do
200profilowania.
201
202%package svgalib
203Summary: A game programming library - svgalib module
204Summary(pl.UTF-8): Biblioteka do programowania gier - moduł dla svgalib
205Group: Libraries
206Requires: %{name} = %{version}-%{release}
207
208%description svgalib
209Allegro is a cross-platform library intended for use in computer games
210and other types of multimedia programming.
211
212This package contains module for use with allegro and svgalib.
213
214%description svgalib -l pl.UTF-8
215Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
216grach komputerowych i innych rodzajach oprogramowania multimedialnego.
217
218Ten pakiet zawiera moduł do wykorzystania allegro z svgalibem.
219
220%package dga2
221Summary: A game programming library - DGA2 module
222Summary(pl.UTF-8): Biblioteka do programowania gier - moduł dla DGA2
223Group: Libraries
224Requires: %{name} = %{version}-%{release}
225
226%description dga2
227Allegro is a cross-platform library intended for use in computer games
228and other types of multimedia programming.
229
230This package contains module for use with DGA.
231
232%description dga2 -l pl.UTF-8
233Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
234grach komputerowych i innych rodzajach oprogramowania multimedialnego.
235
236Ten pakiet zawiera moduł do wykorzystania z DGA.
237
238%package esd
239Summary: A game programming library - esound module
240Summary(pl.UTF-8): Biblioteka do programowania gier - moduł dla esound
241Group: Libraries
242Requires: %{name} = %{version}-%{release}
243
244%description esd
245Allegro is a cross-platform library intended for use in computer games
246and other types of multimedia programming.
247
248This package contains a esound module for use with ESound daemon.
249
250%description esd -l pl.UTF-8
251Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
252grach komputerowych i innych rodzajach oprogramowania multimedialnego.
253
254Ten pakiet zawiera moduł do wykorzystania z demonem ESound.
255
256%package arts
257Summary: A game programming library - aRts module
258Summary(pl.UTF-8): Biblioteka do programowania gier - moduł dla aRts
259Group: Libraries
260Requires: %{name} = %{version}-%{release}
261
262%description arts
263Allegro is a cross-platform library intended for use in computer games
264and other types of multimedia programming.
265
266This package contains a esound module for use with aRts.
267
268%description arts -l pl.UTF-8
269Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
270grach komputerowych i innych rodzajach oprogramowania multimedialnego.
271
272Ten pakiet zawiera moduł do wykorzystania z aRts.
273
274%package fbcon
275Summary: A game programming library - framebuffer module
276Summary(pl.UTF-8): Biblioteka do programowania gier - moduł dla framebuffera
277Group: Libraries
278Requires: %{name} = %{version}-%{release}
279
280%description fbcon
281Allegro is a cross-platform library intended for use in computer games
282and other types of multimedia programming.
283
284This package contains a esound module for use with framebuffer.
285
286%description fbcon -l pl.UTF-8
287Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
288grach komputerowych i innych rodzajach oprogramowania multimedialnego.
289
290Ten pakiet zawiera moduł do wykorzystania z framebufferem.
291
292%package vga
293Summary: A game programming library - vga module
294Summary(pl.UTF-8): Biblioteka do programowania gier - moduł dla vga
295Group: Libraries
296Requires: %{name} = %{version}-%{release}
297
298%description vga
299Allegro is a cross-platform library intended for use in computer games
300and other types of multimedia programming.
301
302This package contains a esound module for use with vga.
303
304%description vga -l pl.UTF-8
305Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
306grach komputerowych i innych rodzajach oprogramowania multimedialnego.
307
308Ten pakiet zawiera moduł do wykorzystania z vga.
309
310%package alsa
311Summary: A game programming library - ALSA modules
312Summary(pl.UTF-8): Biblioteka do programowania gier - moduły dla ALSA
313Group: Libraries
314Requires: %{name} = %{version}-%{release}
315Obsoletes: allegro-alsa9
316
317%description alsa
318Allegro is a cross-platform library intended for use in computer games
319and other types of multimedia programming.
320
321This package contains modules for use with ALSA sound library.
322
323%description alsa -l pl.UTF-8
324Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
325grach komputerowych i innych rodzajach oprogramowania multimedialnego.
326
327Ten pakiet zawiera moduły do wykorzystania z biblioteką dźwiękową
328ALSA.
329
330%package jack
331Summary: A game programming library - JACK module
332Summary(pl.UTF-8): Biblioteka do programowania gier - moduł dla JACK-a
333Group: Libraries
334Requires: %{name} = %{version}-%{release}
335
336%description jack
337Allegro is a cross-platform library intended for use in computer games
338and other types of multimedia programming.
339
340This package contains module for use with JACK sound library.
341
342%description jack -l pl.UTF-8
343Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
344grach komputerowych i innych rodzajach oprogramowania multimedialnego.
345
346Ten pakiet zawiera moduł do wykorzystania z biblioteką dźwiękową JACK.
347
348%package tools
349Summary: A game programming library - tools
350Summary(de.UTF-8): Zusätzliche Hilfprogramme für die Allegro Bibliothek
351Summary(es.UTF-8): Herramientas adicionales para la librería de programación Allegro
352Summary(fr.UTF-8): Outils supplémentaires pour la librairie de programmation Allegro
353Summary(it.UTF-8): Programmi di utilità aggiuntivi per la libreria Allegro
354Summary(pl.UTF-8): Biblioteka do programowania gier - narzędzia
355Group: Libraries
356Requires: %{name} = %{version}-%{release}
357
358%description tools
359Allegro is a cross-platform library intended for use in computer games
360and other types of multimedia programming.
361
362This package contains tools.
363
364%description tools -l de.UTF-8
365Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
366Computerspielen und anderen Formen von Multinediaprogrammierung.
367Dieses Paket enthält Programme, die für die Entwicklung von Allegro
368Programmen hilfreich sind.
369
370%description tools -l es.UTF-8
371Allegro es una librería multi-plataforma creada para ser usada en la
372programación de juegos u otro tipo de programación multimedia. Este
373paquete contiene herramientas adicionales que son útiles para
374desarrollar programas que usen Allegro.
375
376%description tools -l fr.UTF-8
377Allegro est une librairie multi-plateforme destinée à être utilisée
378dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
379package contient des outils supplémentaires qui sont utiles pour le
380développement de programmes avec Allegro.
381
382%description tools -l it.UTF-8
383Allegro è una libreria multipiattaforma dedicata all'uso nei
384videogiochi ed in altri tipi di programmazione multimediale. Questo
385pacchetto contiene programmi di utilità aggiuntivi utili allo sviluppo
386di programmi con Allegro.
387
388%description tools -l pl.UTF-8
389Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
390grach komputerowych i innych rodzajach oprogramowania multimedialnego.
391
392Ten pakiet zawiera narzędzia.
393
394%package tests
395Summary: A game programming library - test programs
396Summary(pl.UTF-8): Biblioteka do programowania gier - programy testujące
397Group: Development/Libraries
398Requires: %{name} = %{version}-%{release}
399
400%description tests
401This package contains programs for testing allegro library.
402
403%description tests -l pl.UTF-8
404Pakiet zawiera programy testujące bibliotekę allegro.
405
406%package examples
407Summary: A game programming library - examples
408Summary(pl.UTF-8): Biblioteka do programowania gier - programy przykładowe
409Group: Development/Libraries
410Requires: %{name} = %{version}-%{release}
411
412%description examples
413This package contains example programs which demonstrate allegro
414features.
415
416%description examples -l pl.UTF-8
417Pakiet zawiera programy przykładowe demonstrujące możliwości
418biblioteki allegro.
419
420%prep
421%setup -q
422#%%patch0 -p1
423#%%patch1 -p1
424#%%patch2 -p1
425%patch3 -p1
426#%%patch4 -p1
427#%%patch5 -p1
428#%%patch6 -p1
429
430#find include/allegro5 -name '*.h' -print0 | xargs -0 %{__sed} -i -e 's@allegro5/@%{_headers_dir}/include/allegro5@'
431#%%{__sed} -i -e 's@allegro5/@../@' include/allegro5/internal/alconfig.h
432
433%build
434#TARGET_ARCH="%{rpmcflags}" export TARGET_ARCH
435# dbglib & proflib are compiled besides normlib, so it's ok to have them here
436#%%configure \
437#% %{?with_static:--enable-static} \
438#% %{?with_dbglib:--enable-dbglib} \
439#% %{?with_proflib:--enable-proflib} \
440#%%if !%{with alsa}
441# --disable-alsadigi \
442# --disable-alsamidi \
443#%%endif
444#% %{!?with_arts:--disable-artsdigi} \
445#% %{!?with_dga2:--disable-xwin-dga2} \
446#% %{!?with_esd:--disable-esddigi} \
447#% %{!?with_fbcon:--disable-fbcon} \
448#% %{!?with_jack:--disable-jackdigi} \
449#% %{!?with_svga:--disable-svgalib} \
450#% %{!?with_vga:--disable-vga} \
451#%%if !%{with sse}
452# --disable-sse \
453# --disable-asm \
454#%%endif
455#%%ifnarch %{ix86}
456# --disable-asm \
457# --disable-mmx \
458# --disable-sse
459#%%endif
460mkdir Build
461cd Build
462%cmake .. \
463 -DCMAKE_INSTALL_PREFIX="%{_prefix}"
464
465%{__make}
466#%%{__make} \
467# MAKEINFO=makeinfo
468
469%install
470rm -rf $RPM_BUILD_ROOT
471
472#%%{__make} install install-man install-info install-lib \
473# DESTDIR=$RPM_BUILD_ROOT
474%{__make} install -C Build \
475 DESTDIR=$RPM_BUILD_ROOT
476
477#install modules.lst $RPM_BUILD_ROOT%{_libdir}/allegro/%{version}
478
479#mv $RPM_BUILD_ROOT%{_bindir}/demo{,-allegro}
480#mv $RPM_BUILD_ROOT%{_bindir}/play{,-allegro}
481#mv $RPM_BUILD_ROOT%{_bindir}/setup{,-allegro}
482#mv $RPM_BUILD_ROOT%{_bindir}/test{,-allegro}
483
484# help rpm to find reqs for ELF objects
485#chmod 755 $RPM_BUILD_ROOT%{_libdir}/{*.so,allegro/*/*.so}
486
487%clean
488rm -rf $RPM_BUILD_ROOT
489
490#%%post -p /sbin/ldconfig
491#%%postun -p /sbin/ldconfig
492
493#%%post devel -p /sbin/postshell
494#-/usr/sbin/fix-info-dir -c %{_infodir}
495
496#%%postun devel -p /sbin/postshell
497#-/usr/sbin/fix-info-dir -c %{_infodir}
498
499%files
500%defattr(644,root,root,755)
501#%%doc AUTHORS CHANGES THANKS readme.txt
502#%%attr(755,root,root) %{_libdir}/liballeg-%{version}.so
503#%%dir %{_libdir}/allegro
504#%%dir %{_libdir}/allegro/%{version}
505#%%{_libdir}/allegro/%{version}/modules.lst
506
507%files devel
508%defattr(644,root,root,755)
509%attr(755,root,root) %{_bindir}/allegro5-config
510#%%{_libdir}/liballeg_unsharable.a
511%{_includedir}/*
512#%%{_aclocaldir}/allegro.m4
513#%%{_mandir}/man3/*
514#%%{_infodir}/*.info*
515
516#%%if %{with static}
517#%%files static
518#%%defattr(644,root,root,755)
519#%%{_libdir}/liballeg.a
520#%%endif
521
522#%%if %{with dbglib}
523#%%files debug
524#%%defattr(644,root,root,755)
525#%%attr(755,root,root) %{_libdir}/liballd-%{version}.so
526#%%{_libdir}/liballd_unsharable.a
527
528#%%if %{with static}
529#%%files debug-static
530#%%defattr(644,root,root,755)
531#%%{_libdir}/liballd.a
532#%%endif
533#%%endif
534
535#%%if %{with proflib}
536#%%files profile
537#%%defattr(644,root,root,755)
538#%%attr(755,root,root) %{_libdir}/liballp-%{version}.so
539#%%{_libdir}/liballp_unsharable.a
540
541#%%if %{with static}
542#%%files profile-static
543#%%defattr(644,root,root,755)
544#%%{_libdir}/liballp.a
545#%%endif
546#%%endif
547
548#%%if %{with svga}
549#%%files svgalib
550#%%defattr(644,root,root,755)
551#%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-svgalib.so
552#%%endif
553
554#%%if %{with dga2}
555#%%files dga2
556#%%defattr(644,root,root,755)
557#%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-dga2.so
558#%%endif
559
560#%%if %{with esd}
561#%%files esd
562#%%defattr(644,root,root,755)
563#%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-esddigi.so
564#%%endif
565
566#%%if %{with arts}
567#%%files arts
568#%%defattr(644,root,root,755)
569#%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-artsdigi.so
570#%%endif
571
572#%%if %{with fbcon}
573#%%files fbcon
574#%%defattr(644,root,root,755)
575#%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-fbcon.so
576#%%endif
577
578#%%ifarch %{ix86}
579#%%if %{with vga}
580#%%files vga
581#%%defattr(644,root,root,755)
582#%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-vga.so
583#%%endif
584#%%endif
585
586#%%if %{with alsa}
587#%%files alsa
588#%%defattr(644,root,root,755)
589#%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsadigi.so
590#%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsamidi.so
591#%%endif
592
593#%%if %{with jack}
594#%%files jack
595#%%defattr(644,root,root,755)
596#%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-jackdigi.so
597#%%endif
598
599#%%files tools
600#%%defattr(644,root,root,755)
601#%%attr(755,root,root) %{_bindir}/colormap
602#%%attr(755,root,root) %{_bindir}/exedat
603#%%attr(755,root,root) %{_bindir}/pack
604#%%attr(755,root,root) %{_bindir}/rgbmap
605#%%attr(755,root,root) %{_bindir}/textconv
606#%attr(755,root,root) %{_bindir}/xkeymap
607#%%attr(755,root,root) %{_bindir}/xf2pcx
608#%%attr(755,root,root) %{_bindir}/dat
609#%%attr(755,root,root) %{_bindir}/dat2c
610#%%attr(755,root,root) %{_bindir}/dat2s
611#%%attr(755,root,root) %{_bindir}/grabber
612#%%attr(755,root,root) %{_bindir}/pat2dat
613#%attr(755,root,root) %{_bindir}/setup-allegro
614
615#%%files tests
616#%%defattr(644,root,root,755)
617#%%attr(755,root,root) %{_bindir}/afinfo
618#%%attr(755,root,root) %{_bindir}/akaitest
619#%%attr(755,root,root) %{_bindir}/cpptest
620#%%attr(755,root,root) %{_bindir}/demo-allegro
621#%%attr(755,root,root) %{_bindir}/digitest
622#%%attr(755,root,root) %{_bindir}/filetest
623#%%attr(755,root,root) %{_bindir}/gfxinfo
624#%%attr(755,root,root) %{_bindir}/mathtest
625#%%attr(755,root,root) %{_bindir}/miditest
626#%%attr(755,root,root) %{_bindir}/play-allegro
627#%%attr(755,root,root) %{_bindir}/playfli
628#%%attr(755,root,root) %{_bindir}/test-allegro
629#%%attr(755,root,root) %{_bindir}/vesainfo
630
631#%%files examples
632#%%defattr(644,root,root,755)
633#%%attr(755,root,root) %{_bindir}/ex12bit
634#%%attr(755,root,root) %{_bindir}/ex3buf
635#%%attr(755,root,root) %{_bindir}/ex3d
636#%%attr(755,root,root) %{_bindir}/exaccel
637#%%attr(755,root,root) %{_bindir}/exalpha
638#%%attr(755,root,root) %{_bindir}/exbitmap
639#%%attr(755,root,root) %{_bindir}/exblend
640#%%attr(755,root,root) %{_bindir}/excamera
641#%%attr(755,root,root) %{_bindir}/excolmap
642#%%attr(755,root,root) %{_bindir}/exconfig
643#%%attr(755,root,root) %{_bindir}/excustom
644#%%attr(755,root,root) %{_bindir}/exdata
645#%%attr(755,root,root) %{_bindir}/exdbuf
646#%%attr(755,root,root) %{_bindir}/exexedat
647#%%attr(755,root,root) %{_bindir}/exfixed
648#%%attr(755,root,root) %{_bindir}/exflame
649#%%attr(755,root,root) %{_bindir}/exflip
650#%%attr(755,root,root) %{_bindir}/exfont
651#%%attr(755,root,root) %{_bindir}/exgui
652#%%attr(755,root,root) %{_bindir}/exhello
653#%%attr(755,root,root) %{_bindir}/exjoy
654#%%attr(755,root,root) %{_bindir}/exkeys
655#%%attr(755,root,root) %{_bindir}/exlights
656#%%attr(755,root,root) %{_bindir}/exmem
657#%%attr(755,root,root) %{_bindir}/exmidi
658#%%attr(755,root,root) %{_bindir}/exmouse
659#%%attr(755,root,root) %{_bindir}/expackf
660#%%attr(755,root,root) %{_bindir}/expal
661#%%attr(755,root,root) %{_bindir}/expat
662#%%attr(755,root,root) %{_bindir}/exquat
663#%%attr(755,root,root) %{_bindir}/exrgbhsv
664#%%attr(755,root,root) %{_bindir}/exsample
665#%%attr(755,root,root) %{_bindir}/exsyscur
666#%%attr(755,root,root) %{_bindir}/exscale
667#%%attr(755,root,root) %{_bindir}/exscn3d
668#%%attr(755,root,root) %{_bindir}/exscroll
669#%%attr(755,root,root) %{_bindir}/exshade
670#%%attr(755,root,root) %{_bindir}/exspline
671#%%attr(755,root,root) %{_bindir}/exsprite
672#%%attr(755,root,root) %{_bindir}/exstars
673#%%attr(755,root,root) %{_bindir}/exstream
674#%%attr(755,root,root) %{_bindir}/exswitch
675#%%attr(755,root,root) %{_bindir}/extimer
676#%%attr(755,root,root) %{_bindir}/extrans
677#%%attr(755,root,root) %{_bindir}/extruec
678#%%attr(755,root,root) %{_bindir}/exunicod
679#%%attr(755,root,root) %{_bindir}/exupdate
680#%%attr(755,root,root) %{_bindir}/exxfade
681#%%attr(755,root,root) %{_bindir}/exzbuf
682#%%attr(755,root,root) %{_bindir}/exnew_events
This page took 0.03179 seconds and 4 git commands to generate.