]> git.pld-linux.org Git - packages/Smarty.git/blame_incremental - Smarty.spec
- tabs in preamble
[packages/Smarty.git] / Smarty.spec
... / ...
CommitLineData
1%define _doc_version 2.6.14
2%include /usr/lib/rpm/macros.php
3Summary: Template engine for PHP
4Summary(pl.UTF-8): System szablonów dla PHP
5Name: Smarty
6Version: 2.6.16
7Release: 1
8License: LGPL
9Group: Development/Languages/PHP
10Source0: http://smarty.php.net/distributions/%{name}-%{version}.tar.gz
11# Source0-md5: da67591f19b69a932c1cab7df5b0303a
12Source1: http://smarty.php.net/distributions/manual/en/%{name}-%{_doc_version}-docs.tar.gz
13# Source1-md5: 357510250885aab057853949e35845c7
14Source2: %{name}-function.html_input_image.php
15URL: http://smarty.php.net/
16BuildRequires: rpm-php-pearprov >= 4.3
17Requires: php-common
18BuildArch: noarch
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%define _smartydir %{_datadir}/php/Smarty
22
23%description
24Smarty is a template engine for PHP. Smarty provides your basic
25variable substitution and dynamic block functionality, and also takes
26a step further to be a "smart" template engine, adding features such
27as configuration files, template functions, variable modifiers, and
28making all of this functionality as easy as possible to use for both
29programmers and template designers.
30
31%description -l pl.UTF-8
32Smarty jest systemem szablonów dla PHP. Pozwala na podstawowe
33podstawianie wartości zmiennych oraz dynamiczne operacje na blokach;
34idzie o krok dalej, aby być "mądrym" silnikiem szablonów, dodając
35takie możliwości jak pliki konfiguracyjne, funkcje, zmienne
36modyfikatory oraz czyniąc całą funkcjonalność jak najłatwiejszą w
37użyciu jednocześnie dla programistów i projektantów szablonów.
38
39%package doc
40Summary: Template engine for PHP - documentation
41Summary(pl.UTF-8): System szablonów dla PHP - dokumentacja
42Version: %{_doc_version}
43Group: Development/Languages/PHP
44
45%description doc
46Documentation for Smarty template engine.
47
48%description doc -l pl.UTF-8
49Dokumentacja do systemu szablonów Smarty.
50
51%prep
52%setup -q -a 1
53
54%install
55rm -rf $RPM_BUILD_ROOT
56install -d $RPM_BUILD_ROOT{%{_smartydir}/{internals,plugins},%{php_pear_dir}}
57
58install libs/{Config_File,Smarty{,_Compiler}}.class.php $RPM_BUILD_ROOT%{_smartydir}
59install libs/debug.tpl $RPM_BUILD_ROOT%{_smartydir}
60install libs/internals/*.php $RPM_BUILD_ROOT%{_smartydir}/internals
61install libs/plugins/*.php $RPM_BUILD_ROOT%{_smartydir}/plugins
62install %{SOURCE2} $RPM_BUILD_ROOT%{_smartydir}/plugins/function.html_input_image.php
63
64# backards compatible
65ln -s %{_smartydir} $RPM_BUILD_ROOT%{php_pear_dir}/%{name}
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70# make compat symlink, the symlink is discarded using %ghost on package uninstall
71%triggerpostun -- Smarty < 2.6.10-4
72if [ -d %{php_pear_dir}/%{name}/plugins ]; then
73 mv %{php_pear_dir}/%{name}/plugins/* %{_smartydir}/plugins
74 rmdir %{php_pear_dir}/%{name}/plugins 2>/dev/null
75fi
76rmdir %{php_pear_dir}/%{name} 2>/dev/null || mv -v %{php_pear_dir}/%{name}{,.rpmsave}
77ln -s %{_smartydir} %{php_pear_dir}/%{name}
78
79%post
80[ -e %{php_pear_dir}/%{name} ] || ln -s %{_smartydir} %{php_pear_dir}/%{name}
81
82%files
83%defattr(644,root,root,755)
84%doc BUGS ChangeLog FAQ INSTALL NEWS README RELEASE_NOTES TODO
85%dir %{_smartydir}
86%dir %{_smartydir}/internals
87%dir %{_smartydir}/plugins
88%{_smartydir}/*.class.php
89%{_smartydir}/debug.tpl
90%{_smartydir}/internals/*.php
91%{_smartydir}/plugins/*.php
92
93# for the sake of bc
94%ghost %{php_pear_dir}/%{name}
95
96%files doc
97%defattr(644,root,root,755)
98%doc manual/*
This page took 0.029237 seconds and 4 git commands to generate.