]> git.pld-linux.org Git - packages/PyMSNt.git/blame_incremental - PyMSNt.spec
- cleanup, disabled broken workaround (wrong place, wrong way)
[packages/PyMSNt.git] / PyMSNt.spec
... / ...
CommitLineData
1#
2# TODO:
3# - goto and see workaround (!)
4# - real descriptions
5# ATTENTION! ACHTUNG!
6# - SNAPSHOT VERSION!
7
8Summary: Python MSN Jabber transport
9Summary(pl.UTF-8): Transport MSN dla Jabbera napisany w Pythonie
10Name: PyMSNt
11Version: 0.11.3
12Release: 0.1
13Epoch: 1
14License: GPL
15Group: Applications/Communications
16Source0: http://delx.cjb.net/pymsnt/tarballs/pymsnt-snapshot.tar.gz
17# Source0-md5: 878a3df019c3e56b832feb751a4b4502
18Source1: %{name}-config.xml
19Source2: %{name}.init
20URL: http://delx.cjb.net/pymsnt/
21BuildRequires: python
22BuildRequires: rpm-pythonprov
23BuildRequires: rpmbuild(macros) >= 1.219
24Requires: python-Imaging
25Requires: python-Twisted
26Requires: python-Twisted-ssl
27Requires: python-TwistedWeb
28Requires: python-TwistedWords
29Requires: python-TwistedXish
30Requires: python-pyOpenSSL
31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35Python MSN Jabber transport.
36
37%description -l pl.UTF-8
38Transport MSN dla Jabbera napisany w Pythonie.
39
40%prep
41%setup -q -n pymsnt-snapshot
42
43%install
44rm -rf $RPM_BUILD_ROOT
45
46install -d $RPM_BUILD_ROOT{%{_datadir}/pymsnt/src/{twistfix/words/{xish,protocols/jabber},legacy/msn,baseproto},%{_var}/lib/pymsnt}
47install -d $RPM_BUILD_ROOT{%{_sysconfdir}/jabber,/etc/rc.d/init.d}
48install -d $RPM_BUILD_ROOT%{_datadir}/pymsnt/data
49install src/twistfix/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/twistfix
50install src/twistfix/words/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/twistfix/words
51install src/twistfix/words/xish/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/twistfix/words/xish
52install src/twistfix/words/protocols/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/twistfix/words/protocols
53install src/twistfix/words/protocols/jabber/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/twistfix/words/protocols/jabber
54install src/legacy/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/legacy
55install src/legacy/msn/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/legacy/msn
56install src/baseproto/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/baseproto
57install src/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src
58install data/* $RPM_BUILD_ROOT%{_datadir}/pymsnt/data
59install PyMSNt.py $RPM_BUILD_ROOT%{_datadir}/pymsnt
60
61install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/jabber/PyMSNt.xml
62install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/PyMSNt
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%post
68# ugly workaround (FIX it here or in twisted words/xish packages)
69#ln -s %{py_sitescriptdir}/twisted/words %{py_sitedir}/twisted/words
70#ln -s %{py_sitescriptdir}/twisted/xish %{py_sitedir}/twisted/xish
71
72if [ -f %{_sysconfdir}/jabber/secret ]; then
73 SECRET=`cat %{_sysconfdir}/jabber/secret`
74 if [ -n "$SECRET" ] ; then
75 echo "Updating component authentication secret in PyMSNt.xml..."
76 %{__sed} -i -e "s/>secret</>$SECRET</" /etc/jabber/PyMSNt.xml
77 fi
78fi
79/sbin/chkconfig --add PyMSNt
80%service PyMSNt restart "Jabber MSN transport"
81
82%preun
83if [ "$1" = "0" ]; then
84 %service PyMSNt stop
85 /sbin/chkconfig --del PyMSNt
86fi
87
88#%postun
89#echo "Cleaing ugly workaround (%{py_sitedir}/twisted/{words,xish})"
90#rm -f %{py_sitedir}/twisted/words
91#rm -f %{py_sitedir}/twisted/xish
92
93%files
94%defattr(644,root,root,755)
95%doc README TODO docs
96%dir %{_datadir}/pymsnt/src/twistfix
97%{_datadir}/pymsnt/src/twistfix/*.py
98%dir %{_datadir}/pymsnt/src/twistfix/words
99%{_datadir}/pymsnt/src/twistfix/words/*.py
100%dir %{_datadir}/pymsnt/src/twistfix/words/xish
101%{_datadir}/pymsnt/src/twistfix/words/xish/*.py
102%dir %{_datadir}/pymsnt/src/twistfix/words/protocols
103%{_datadir}/pymsnt/src/twistfix/words/protocols/*.py
104%dir %{_datadir}/pymsnt/src/twistfix/words/protocols/jabber
105%{_datadir}/pymsnt/src/twistfix/words/protocols/jabber/*.py
106%dir %{_datadir}/pymsnt/src/legacy
107%{_datadir}/pymsnt/src/legacy/*.py
108%dir %{_datadir}/pymsnt/src/legacy/msn
109%{_datadir}/pymsnt/src/legacy/msn/*.py
110%dir %{_datadir}/pymsnt/src/baseproto
111%{_datadir}/pymsnt/src/baseproto/*.py
112%dir %{_datadir}/pymsnt/src
113%{_datadir}/pymsnt/src/*.py
114%dir %{_datadir}/pymsnt/data
115%{_datadir}/pymsnt/data/*
116%dir %{_datadir}/pymsnt
117%attr(755,root,root) %{_datadir}/pymsnt/*.py
118%dir %{_var}/lib/pymsnt
119%attr(754,root,root) /etc/rc.d/init.d/PyMSNt
120%attr(640,root,jabber) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/jabber/PyMSNt.xml
This page took 0.034139 seconds and 4 git commands to generate.