]> git.pld-linux.org Git - packages/OpenAL.git/blame_incremental - OpenAL.spec
- enhanced nosse patch
[packages/OpenAL.git] / OpenAL.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without alsa # ALSA backend
4%bcond_without jack # JACK backend
5%bcond_without portaudio # PortAudio backend
6%bcond_without pulseaudio # PulseAudio backend
7%bcond_with sdl # SDL2 backend
8%bcond_with sse2 # force use of SSE2 instructions (x86)
9%bcond_without gui # alsoft-config GUI
10%bcond_with qt4 # Qt 4 instead of Qt 5 for GUI
11%ifarch pentium4 x32 %{x8664}
12%define with_sse2 1
13%endif
14Summary: Open Audio Library
15Summary(pl.UTF-8): Otwarta Biblioteka Dźwięku
16Name: OpenAL
17Version: 1.21.0
18Release: 1
19License: LGPL v2+
20Group: Libraries
21Source0: http://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
22# Source0-md5: 332dc0ead285887a3da5ec6bc725fdcd
23Patch0: %{name}-pc.patch
24Patch1: %{name}-nosse.patch
25URL: http://www.openal.org/
26%{?with_sdl:BuildRequires: SDL2-devel >= 2}
27%{?with_alsa:BuildRequires: alsa-lib-devel}
28BuildRequires: cmake >= 3.0.2
29%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
30BuildRequires: libmysofa-devel
31BuildRequires: libstdc++-devel >= 6:5
32BuildRequires: pkgconfig
33%{?with_portaudio:BuildRequires: portaudio-devel}
34%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
35BuildRequires: rpmbuild(macros) >= 1.605
36%if %{with gui}
37%if %{with qt4}
38BuildRequires: QtCore-devel >= 4.8.0
39BuildRequires: QtGui-devel >= 4.8.0
40BuildRequires: qt4-build >= 4.8.0
41%else
42BuildRequires: Qt5Core-devel >= 5
43BuildRequires: Qt5Gui-devel >= 5
44BuildRequires: Qt5Widgets-devel >= 5
45BuildRequires: qt5-build >= 5
46%endif
47%endif
48%{?with_sse2:Requires: cpuinfo(sse2)}
49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
52OpenAL, the Open Audio Library, is a joint effort to create an open,
53vendor-neutral, cross-platform API for interactive, primarily
54spatialized audio. OpenAL's primary audience are application
55developers and desktop users that rely on portable standards like
56OpenGL, for games and other multimedia applications. OpenAL is already
57supported by a number of hardware vendors and developers.
58
59%description -l pl.UTF-8
60OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
61stworzenia otwartego, niezależnego od producentów, międzyplatformowego
62interfejsu projektowania aplikacji w części obsługi dźwięku.
63Biblioteka adresowana jest do twórców aplikacji i użytkowników,
64którzy wybierają przenośne standardy, jak OpenGL, w grach i
65aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
66dostarczycieli sprzętu i programistów.
67
68%package devel
69Summary: Headers for OpenAL
70Summary(pl.UTF-8): Pliki nagłówkowe do OpenAL
71Group: Development/Libraries
72Requires: %{name} = %{version}-%{release}
73
74%description devel
75Header files for OpenAL-based programs.
76
77%description devel -l pl.UTF-8
78Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
79OpenAL.
80
81%package gui
82Summary: OpenAL configuration GUI
83Summary(pl.UTF-8): Graficzny interfejs do konfiguracji biblioteki OpenAL
84Group: X11/Applications/Sound
85Requires: %{name} = %{version}-%{release}
86Requires: QtCore >= 4.8.0
87Requires: QtGui >= 4.8.0
88
89%description gui
90OpenAL configuration GUI.
91
92%description gui -l pl.UTF-8
93Graficzny interfejs do konfiguracji biblioteki OpenAL.
94
95%prep
96%setup -q -n openal-soft-%{version}
97%patch0 -p1
98%patch1 -p1
99
100%build
101cd build
102%cmake .. \
103 %{!?with_alsa:-DALSOFT_BACKEND_ALSA=OFF} \
104 %{!?with_jack:-DALSOFT_BACKEND_JACK=OFF} \
105 %{!?with_portaudio:-DALSOFT_BACKEND_PORTAUDIO=OFF} \
106 %{!?with_pulseaudio:-DALSOFT_BACKEND_PULSEAUDIO=OFF} \
107 %{?with_sdl:-DALSOFT_BACKEND_SDL2=ON} \
108 %{!?with_sse2:-DALSOFT_ENABLE_SSE2_CODEGEN=OFF} \
109 -DALSOFT_EXAMPLES=OFF \
110 %{!?with_gui:-DALSOFT_NO_CONFIG_UTIL=ON} \
111 %{?with_qt4:-DALSOFT_NO_QT5=ON} \
112
113%{__make}
114
115%install
116rm -rf $RPM_BUILD_ROOT
117install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
118
119%{__make} -C build install \
120 DESTDIR=$RPM_BUILD_ROOT
121
122install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%post -p /sbin/ldconfig
128%postun -p /sbin/ldconfig
129
130%files
131%defattr(644,root,root,755)
132%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
133%attr(755,root,root) %{_bindir}/makemhr
134%attr(755,root,root) %{_bindir}/openal-info
135%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
136%attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
137%{_datadir}/openal
138
139%files devel
140%defattr(644,root,root,755)
141%attr(755,root,root) %{_libdir}/libopenal.so
142%{_includedir}/AL
143%{_pkgconfigdir}/openal.pc
144%{_libdir}/cmake/OpenAL
145
146%if %{with gui}
147%files gui
148%defattr(644,root,root,755)
149%attr(755,root,root) %{_bindir}/alsoft-config
150%endif
This page took 0.068983 seconds and 4 git commands to generate.