]> git.pld-linux.org Git - packages/zfs.git/blame - zfs.spec
- up to 0.8.1
[packages/zfs.git] / zfs.spec
CommitLineData
06fbfb84
JB
1# TODO:
2# - PLDify init script
3# - unpackaged initramfs-tools support:
4# /usr/share/initramfs-tools/conf-hooks.d/zfs
5# /usr/share/initramfs-tools/hooks/zfs
6# /usr/share/initramfs-tools/scripts/zfs
bff0a8a1
JB
7#
8# Conditional build:
bff0a8a1
JB
9%bcond_without kernel # don't build kernel modules
10%bcond_without userspace # don't build userspace programs
6f114c88
JR
11%bcond_without python2 # CPython 2.x module
12%bcond_without python3 # CPython 3.x module
bff0a8a1
JB
13%bcond_with verbose # verbose build (V=1)
14#
3921af7f
JR
15# The goal here is to have main, userspace, package built once with
16# simple release number, and only rebuild kernel packages with kernel
17# version as part of release number, without the need to bump release
18# with every kernel change.
19%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
20%{error:kernel and userspace cannot be built at the same time on PLD builders}
21exit 1
22%endif
23
bff0a8a1
JB
24%if %{without userspace}
25# nothing to be placed to debuginfo package
26%define _enable_debug_packages 0
27%endif
3921af7f
JR
28
29%define _duplicate_files_terminate_build 0
30
ea5a5e2d 31%define rel 1
3921af7f 32%define pname zfs
bff0a8a1
JB
33Summary: Native Linux port of the ZFS filesystem
34Summary(pl.UTF-8): Natywny linuksowy port systemu plików ZFS
3921af7f 35Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
d9169846 36Version: 0.8.1
3921af7f 37Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
0b82b0f8 38License: CDDL
bff0a8a1 39Group: Applications/System
0b82b0f8 40#Source0: https://github.com/zfsonlinux/zfs/releases/download/zfs-%{version}/%{pname}-%{version}.tar.gz
ea5a5e2d 41Source0: https://github.com/zfsonlinux/zfs/archive/zfs-%{version}/%{pname}-%{version}.tar.gz
d9169846 42# Source0-md5: db6618a09f6494e1126b14a1302f77c8
0b82b0f8
JR
43Patch0: x32.patch
44Patch1: am.patch
bff0a8a1
JB
45URL: http://zfsonlinux.org/
46BuildRequires: autoconf >= 2.50
47BuildRequires: automake
48BuildRequires: libtool
0b82b0f8 49BuildRequires: rpmbuild(macros) >= 1.714
2d67b9de
JR
50%if %{with kernel}
51%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
2d67b9de 52%endif
bff0a8a1 53%if %{with userspace}
e3c62688
JB
54# only for mmap_libaio test command
55#BuildRequires: libaio-devel
bff0a8a1
JB
56BuildRequires: libblkid-devel
57BuildRequires: libselinux-devel
e3c62688
JB
58# if xdr gets removed from glibc
59#BuildRequires: libtirpc-devel
bff0a8a1 60BuildRequires: libuuid-devel
e3c62688
JB
61BuildRequires: openssl-devel
62BuildRequires: pkgconfig
63BuildRequires: udev-devel
bff0a8a1 64BuildRequires: zlib-devel
6f114c88 65%if %{with python2}
e3c62688
JB
66BuildRequires: python-cffi
67BuildRequires: python-modules >= 1:2.6
0b82b0f8
JR
68BuildRequires: python-setuptools
69%endif
6f114c88 70%if %{with python3}
e3c62688
JB
71BuildRequires: python3-cffi
72BuildRequires: python3-modules >= 1:3.4
6f114c88
JR
73BuildRequires: python3-setuptools
74%endif
56fca1f9
JB
75%if %{with python2} || %{with python3}
76BuildRequires: rpm-pythonprov
77%endif
bff0a8a1
JB
78%endif
79Requires: %{pname}-libs = %{version}-%{release}
0b82b0f8 80Obsoletes: spl < 0.7.9-2
bff0a8a1
JB
81BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
8fa57ce6
JP
83%define dracutlibdir %{_prefix}/lib/dracut
84
bff0a8a1
JB
85%description
86ZFS is an advanced file system and volume manager which was originally
87developed for Solaris and is now maintained by the Illumos community.
88
89ZFS on Linux, which is also known as ZoL, is currently feature
90complete. It includes fully functional and stable SPA, DMU, ZVOL, and
91ZPL layers.
92
93%description -l pl.UTF-8
94ZFS to zaawansowany system plików i zarządca wolumenów, oryginalnie
95stworzony dla Solarisa, obecnie utrzymywany przez społeczność Illumos.
96
97ZFS dla Linuksa, znany takża jako ZoL (ZFS on Linux), jest obecnie w
98pełni funkcjonalny. Zawiera w pełni funkcjonalne i stabilne warstwy
99SPA, DMU, ZVOL i ZPL.
100
101%package libs
102Summary: ZFS on Linux libraries
103Summary(pl.UTF-8): Biblioteki ZFS-a dla Linuksa
104License: CDDL
105Group: Libraries
8fa57ce6 106Requires(post,postun): /sbin/ldconfig
bff0a8a1
JB
107
108%description libs
109ZFS on Linux libraries.
110
111%description libs -l pl.UTF-8
112Biblioteki ZFS-a dla Linuksa.
113
114%package devel
115Summary: Header files for ZFS libraries
116Summary(pl.UTF-8): Pliki nagłówkowe bibliotek ZFS-a
117License: CDDL
118Group: Development/Libraries
119Requires: %{pname}-libs = %{version}-%{release}
120Requires: libselinux-devel
121Requires: libuuid-devel
122Requires: zlib-devel
123
124%description devel
125Header files for ZFS libraries.
126
127%description devel -l pl.UTF-8
128Pliki nagłówkowe bibliotek ZFS-a.
129
130%package static
131Summary: Static ZFS libraries
132Summary(pl.UTF-8): Statyczne biblioteki ZFS-a
133License: CDDL
134Group: Development/Libraries
135Requires: %{pname}-devel = %{version}-%{release}
136
137%description static
138Static ZFS libraries.
139
140%description static -l pl.UTF-8
141Statyczne biblioteki ZFS-a.
142
143%package -n dracut-zfs
144Summary: ZFS support for Dracut
145Summary(pl.UTF-8): Obsługa ZFS-a dla Dracuta
146Group: Applications/System
147Requires: %{pname} = %{version}-%{release}
148Requires: dracut
149
150%description -n dracut-zfs
151ZFS support for Dracut.
152
153%description -n dracut-zfs -l pl.UTF-8
154Obsługa ZFS-a dla Dracuta.
155
0b82b0f8 156%package -n python-pyzfs
56fca1f9
JB
157Summary: Python 2 wrapper for libzfs_core C library
158Summary(pl.UTF-8): Interfejs Pythona 2 do biblioteki C libzfs_core
0b82b0f8
JR
159License: Apache v2.0
160Group: Libraries/Python
161Requires: %{pname}-libs = %{version}-%{release}
162
163%description -n python-pyzfs
56fca1f9
JB
164Python 2 wrapper for libzfs_core C library.
165
166%description -n python-pyzfs -l pl.UTF-8
167Interfejs Pythona 2 do biblioteki C libzfs_core.
0b82b0f8 168
6f114c88 169%package -n python3-pyzfs
56fca1f9
JB
170Summary: Python 3 wrapper for libzfs_core C library
171Summary(pl.UTF-8): Interfejs Pythona 3 do biblioteki C libzfs_core
6f114c88
JR
172License: Apache v2.0
173Group: Libraries/Python
174Requires: %{pname}-libs = %{version}-%{release}
175
176%description -n python3-pyzfs
56fca1f9
JB
177Python 3 wrapper for libzfs_core C library.
178
179%description -n python3-pyzfs -l pl.UTF-8
180Interfejs Pythona 3 do biblioteki C libzfs_core.
6f114c88 181
3921af7f 182%package -n kernel-zfs-common-devel
bff0a8a1
JB
183Summary: ZFS Linux kernel headers
184Summary(pl.UTF-8): ZFS - pliki nagłówkowe jądra Linuksa
bff0a8a1 185Group: Development/Building
0b82b0f8 186Obsoletes: kernel-spl-common-devel < 0.7.9-2
bff0a8a1 187
3921af7f
JR
188%description -n kernel-zfs-common-devel
189ZFS Linux kernel headers common for all PLD kernel versions.
190
191%description -n kernel-zfs-common-devel -l pl.UTF-8
192ZFS - pliki nagłówkowe jądra Linuksa wspólne na wszystkich
193wersji jąder PLD.
194
195%define kernel_pkg()\
196%package -n kernel%{_alt_kernel}-zfs\
197Summary: ZFS Linux kernel modules\
198Summary(pl.UTF-8): ZFS - moduły jądra Linuksa\
199Release: %{rel}@%{_kernel_ver_str}\
200Group: Base/Kernel\
201Requires(post,postun): /sbin/depmod\
3921af7f
JR
202%requires_releq_kernel\
203Requires(postun): %releq_kernel\
3921af7f
JR
204\
205%description -n kernel%{_alt_kernel}-zfs\
206ZFS Linux kernel modules.\
207\
208%description -n kernel%{_alt_kernel}-zfs -l pl.UTF-8\
209ZFS - moduły jądra Linuksa.\
210\
211%package -n kernel%{_alt_kernel}-zfs-devel\
212Summary: ZFS Linux kernel headers\
213Summary(pl.UTF-8): ZFS - pliki nagłówkowe jądra Linuksa\
214Release: %{rel}@%{_kernel_ver_str}\
215Group: Development/Building\
3921af7f
JR
216Requires: kernel%{_alt_kernel}-headers\
217Requires: kernel-zfs-common-devel\
0b82b0f8 218Obsoletes: kernel-spl-devel < 0.7.9-2\
3921af7f
JR
219\
220%description -n kernel%{_alt_kernel}-zfs-devel\
221ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},\
222version %{_kernel_ver}.\
223\
224%description -n kernel%{_alt_kernel}-zfs-devel -l pl.UTF-8\
225ZFS - pliki nagłówkowe jądra Linuksa skonfigurowane dla jądra PLD z\
226pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
227\
228%files -n kernel%{_alt_kernel}-zfs\
229%defattr(644,root,root,755)\
0b82b0f8
JR
230%dir /lib/modules/%{_kernel_ver}/misc/lua\
231/lib/modules/%{_kernel_ver}/misc/lua/zlua.ko*\
3921af7f
JR
232%dir /lib/modules/%{_kernel_ver}/misc/avl\
233/lib/modules/%{_kernel_ver}/misc/avl/zavl.ko*\
67ee122d
JR
234%dir /lib/modules/%{_kernel_ver}/misc/icp\
235/lib/modules/%{_kernel_ver}/misc/icp/icp.ko*\
3921af7f
JR
236%dir /lib/modules/%{_kernel_ver}/misc/nvpair\
237/lib/modules/%{_kernel_ver}/misc/nvpair/znvpair.ko*\
0b82b0f8
JR
238%dir /lib/modules/%{_kernel_ver}/misc/spl\
239/lib/modules/%{_kernel_ver}/misc/spl/spl.ko*\
3921af7f
JR
240%dir /lib/modules/%{_kernel_ver}/misc/unicode\
241/lib/modules/%{_kernel_ver}/misc/unicode/zunicode.ko*\
242%dir /lib/modules/%{_kernel_ver}/misc/zcommon\
243/lib/modules/%{_kernel_ver}/misc/zcommon/zcommon.ko*\
244%dir /lib/modules/%{_kernel_ver}/misc/zfs\
245/lib/modules/%{_kernel_ver}/misc/zfs/zfs.ko*\
3921af7f
JR
246\
247%files -n kernel%{_alt_kernel}-zfs-devel\
248%defattr(644,root,root,755)\
249/usr/src/zfs-%{version}/%{_kernel_ver}\
250\
251%post -n kernel%{_alt_kernel}-zfs\
252%depmod %{_kernel_ver}\
253\
254%postun -n kernel%{_alt_kernel}-zfs\
255%depmod %{_kernel_ver}\
256%{nil}
257
258%define build_kernel_pkg()\
259%configure \\\
260 --disable-silent-rules \\\
261 --with-config="kernel" \\\
f2042a9c
JR
262 --with-linux=%{_kernelsrcdir}\\\
263 --with-linux-obj=%{_kernelsrcdir}\
3921af7f
JR
264\
265%{__make} clean\
266%{__make} %{?with_verbose:V=1}\
267p=`pwd`\
268%{__make} install DESTDIR=$p/installed INSTALL_MOD_DIR=misc\
269%{nil}
270
2d67b9de 271%{?with_kernel:%{expand:%create_kernel_packages}}
bff0a8a1
JB
272
273%prep
ea5a5e2d 274%setup -q -n %{pname}-zfs-%{version}
bff0a8a1 275%patch0 -p1
97d46215 276%patch1 -p1
bff0a8a1
JB
277
278%build
279%{__libtoolize}
280%{__aclocal} -I config
281%{__autoconf}
282%{__autoheader}
283%{__automake}
2d67b9de 284%{?with_kernel:%{expand:%build_kernel_packages}}
3921af7f
JR
285
286%if %{with userspace}
bff0a8a1
JB
287%configure \
288 --disable-silent-rules \
3921af7f 289 --with-config="user" \
bff0a8a1 290 --with-linux=%{_kernelsrcdir} \
ec61a23e
JB
291 --with-systemdunitdir=%{systemdunitdir} \
292 --with-systemdpresetdir=/etc/systemd/system-preset \
eb047319
JR
293 --with-systemdmodulesloaddir=/etc/modules-load.d \
294 --with-systemdgeneratordir=/lib/systemd/system-generators \
bff0a8a1
JB
295 --with-udevdir=/lib/udev
296
297%{__make} \
298 %{?with_verbose:V=1}
0b82b0f8 299
6f114c88
JR
300%if %{with python2}
301cd contrib/pyzfs
302%py_build
303cd ../..
304%endif
305
306%if %{with python3}
0b82b0f8 307cd contrib/pyzfs
6f114c88 308%py3_build
0b82b0f8
JR
309cd ../..
310%endif
3921af7f 311%endif
bff0a8a1
JB
312
313%install
314rm -rf $RPM_BUILD_ROOT
315
3921af7f
JR
316%if %{with kernel}
317install -d $RPM_BUILD_ROOT
318cp -a installed/* $RPM_BUILD_ROOT
cd1ae8a3 319# Drop unneeded spl compat links
3a7a22e4 320%{__rm} -r $RPM_BUILD_ROOT/usr/src/spl-%{version}
3921af7f
JR
321%endif
322
323%if %{with userspace}
bff0a8a1
JB
324%{__make} install \
325 DESTDIR=$RPM_BUILD_ROOT \
3921af7f 326 DEFAULT_INIT_DIR=/etc/rc.d/init.d
58d00fd6 327
6f114c88 328%if %{with python2}
0b82b0f8
JR
329%{__rm} -rf $RPM_BUILD_ROOT%{py_sitescriptdir}
330cd contrib/pyzfs
331%py_install
332
333%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
334%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
335
336%py_postclean
337cd ../..
338%{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/libzfs_core/test
339%endif
340
6f114c88
JR
341%if %{with python3}
342%{__rm} -rf $RPM_BUILD_ROOT{%{py3_sitescriptdir},/usr/local/share/python3*}
343cd contrib/pyzfs
344%py3_install
345cd ../..
346%{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/libzfs_core/test
347%endif
348
58d00fd6
JR
349install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
350%{__mv} $RPM_BUILD_ROOT%{_npkgconfigdir}/* $RPM_BUILD_ROOT%{_pkgconfigdir}
5bf6436c 351
0b82b0f8
JR
352# Debian specific stuff
353%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/initramfs-tools
354
5bf6436c
JR
355# Package these? These are integration tests of the implementation.
356%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/zfs/{zfs-tests,test-runner,runfiles}
357%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{raidz_test,test-runner}.1*
358%{__rm} $RPM_BUILD_ROOT%{_bindir}/raidz_test
3921af7f 359%endif
bff0a8a1
JB
360
361%clean
362rm -rf $RPM_BUILD_ROOT
363
8fa57ce6
JP
364%post libs -p /sbin/ldconfig
365%postun libs -p /sbin/ldconfig
366
bff0a8a1
JB
367%if %{with userspace}
368%files
369%defattr(644,root,root,755)
e3c62688 370%doc AUTHORS COPYRIGHT LICENSE NEWS NOTICE README.md
bff0a8a1 371%attr(755,root,root) /sbin/mount.zfs
6f114c88
JR
372%attr(755,root,root) %{_bindir}/arc_summary
373%attr(755,root,root) %{_bindir}/arcstat
374%attr(755,root,root) %{_bindir}/dbufstat
5bf6436c 375%attr(755,root,root) %{_bindir}/zgenhostid
bff0a8a1
JB
376%attr(755,root,root) %{_sbindir}/fsck.zfs
377%attr(755,root,root) %{_sbindir}/zdb
ec61a23e 378%attr(755,root,root) %{_sbindir}/zed
bff0a8a1
JB
379%attr(755,root,root) %{_sbindir}/zfs
380%attr(755,root,root) %{_sbindir}/zhack
381%attr(755,root,root) %{_sbindir}/zinject
bff0a8a1
JB
382%attr(755,root,root) %{_sbindir}/zpool
383%attr(755,root,root) %{_sbindir}/zstreamdump
384%attr(755,root,root) %{_sbindir}/ztest
385%dir %{_sysconfdir}/zfs
386# package *.example as %doc? (they cannot act as default configuration)
387%{_sysconfdir}/zfs/vdev_id.conf.*.example
ec61a23e
JB
388%dir %{_sysconfdir}/zfs/zed.d
389%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/*.sh
390%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/zed.rc
5bf6436c
JR
391%dir %{_sysconfdir}/zfs/zpool.d
392%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zpool.d/*
58d00fd6
JR
393%attr(754,root,root) /etc/rc.d/init.d/zfs-import
394%attr(754,root,root) /etc/rc.d/init.d/zfs-mount
395%attr(754,root,root) /etc/rc.d/init.d/zfs-share
396%attr(754,root,root) /etc/rc.d/init.d/zfs-zed
397%config(noreplace) %verify(not md5 mtime size) /etc/default/zfs
398/etc/zfs/zfs-functions
e8614c59 399%config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/zfs.conf
ec61a23e 400/etc/systemd/system-preset/50-zfs.preset
eb047319 401/lib/systemd/system-generators/zfs-mount-generator
ec61a23e 402%{systemdunitdir}/zfs.target
2e642361 403%{systemdunitdir}/zfs-import.target
ec61a23e
JB
404%{systemdunitdir}/zfs-import-cache.service
405%{systemdunitdir}/zfs-import-scan.service
406%{systemdunitdir}/zfs-mount.service
407%{systemdunitdir}/zfs-share.service
97dbbf93 408%{systemdunitdir}/zfs-zed.service
bff0a8a1
JB
409%attr(755,root,root) /lib/udev/vdev_id
410%attr(755,root,root) /lib/udev/zvol_id
411/lib/udev/rules.d/60-zvol.rules
412/lib/udev/rules.d/69-vdev.rules
413/lib/udev/rules.d/90-zfs.rules
2e642361
JR
414%dir %{_libexecdir}/zfs
415%dir %{_libexecdir}/zfs/zed.d
416%attr(755,root,root) %{_libexecdir}/zfs/zed.d/*.sh
417%dir %{_libexecdir}/zfs/zpool.d
418%attr(755,root,root) %{_libexecdir}/zfs/zpool.d/*
bff0a8a1
JB
419%dir %{_datadir}/zfs
420%attr(755,root,root) %{_datadir}/zfs/*.sh
bff0a8a1 421%{_mandir}/man1/zhack.1*
bff0a8a1 422%{_mandir}/man1/ztest.1*
0b82b0f8 423%{_mandir}/man5/spl-module-parameters.5*
bff0a8a1 424%{_mandir}/man5/vdev_id.conf.5*
58d00fd6 425%{_mandir}/man5/zfs-events.5*
ec61a23e 426%{_mandir}/man5/zfs-module-parameters.5*
bff0a8a1
JB
427%{_mandir}/man5/zpool-features.5*
428%{_mandir}/man8/fsck.zfs.8*
429%{_mandir}/man8/mount.zfs.8*
430%{_mandir}/man8/vdev_id.8*
431%{_mandir}/man8/zdb.8*
ec61a23e 432%{_mandir}/man8/zed.8*
bff0a8a1 433%{_mandir}/man8/zfs.8*
0b82b0f8
JR
434%{_mandir}/man8/zfs-mount-generator.8*
435%{_mandir}/man8/zfs-program.8*
5bf6436c 436%{_mandir}/man8/zgenhostid.8*
bff0a8a1
JB
437%{_mandir}/man8/zinject.8*
438%{_mandir}/man8/zpool.8*
439%{_mandir}/man8/zstreamdump.8*
440
441%files libs
442%defattr(644,root,root,755)
443%attr(755,root,root) %{_libdir}/libnvpair.so.*.*.*
444%attr(755,root,root) %ghost %{_libdir}/libnvpair.so.1
445%attr(755,root,root) %{_libdir}/libuutil.so.*.*.*
446%attr(755,root,root) %ghost %{_libdir}/libuutil.so.1
447%attr(755,root,root) %{_libdir}/libzfs.so.*.*.*
ec61a23e
JB
448%attr(755,root,root) %ghost %{_libdir}/libzfs.so.2
449%attr(755,root,root) %{_libdir}/libzfs_core.so.*.*.*
450%attr(755,root,root) %ghost %{_libdir}/libzfs_core.so.1
bff0a8a1 451%attr(755,root,root) %{_libdir}/libzpool.so.*.*.*
ec61a23e 452%attr(755,root,root) %ghost %{_libdir}/libzpool.so.2
bff0a8a1
JB
453
454%files devel
455%defattr(644,root,root,755)
456%attr(755,root,root) %{_libdir}/libnvpair.so
457%attr(755,root,root) %{_libdir}/libuutil.so
458%attr(755,root,root) %{_libdir}/libzfs.so
ec61a23e 459%attr(755,root,root) %{_libdir}/libzfs_core.so
bff0a8a1
JB
460%attr(755,root,root) %{_libdir}/libzpool.so
461%{_libdir}/libnvpair.la
462%{_libdir}/libuutil.la
463%{_libdir}/libzfs.la
ec61a23e 464%{_libdir}/libzfs_core.la
bff0a8a1
JB
465%{_libdir}/libzpool.la
466%{_includedir}/libspl
467%{_includedir}/libzfs
58d00fd6
JR
468%{_pkgconfigdir}/libzfs.pc
469%{_pkgconfigdir}/libzfs_core.pc
bff0a8a1
JB
470
471%files static
472%defattr(644,root,root,755)
473%{_libdir}/libnvpair.a
474%{_libdir}/libuutil.a
475%{_libdir}/libzfs.a
ec61a23e 476%{_libdir}/libzfs_core.a
bff0a8a1
JB
477%{_libdir}/libzpool.a
478
479%files -n dracut-zfs
480%defattr(644,root,root,755)
58d00fd6 481%doc contrib/dracut/README.dracut.markdown
5bf6436c
JR
482%dir %{dracutlibdir}/modules.d/02zfsexpandknowledge
483%attr(755,root,root) %{dracutlibdir}/modules.d/02zfsexpandknowledge/module-setup.sh
8fa57ce6 484%dir %{dracutlibdir}/modules.d/90zfs
58d00fd6 485%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/export-zfs.sh
8fa57ce6
JP
486%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/module-setup.sh
487%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/mount-zfs.sh
488%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/parse-zfs.sh
540b3d9e 489%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-env-bootfs.service
5bf6436c 490%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-generator.sh
58d00fd6 491%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-lib.sh
0b82b0f8 492%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-load-key.sh
5bf6436c 493%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-needshutdown.sh
0b82b0f8 494
6f114c88 495%if %{with python2}
0b82b0f8
JR
496%files -n python-pyzfs
497%defattr(644,root,root,755)
498%doc contrib/pyzfs/README
499%{py_sitescriptdir}/libzfs_core
500%{py_sitescriptdir}/pyzfs-*-py*.egg-info
501%endif
6f114c88
JR
502
503%if %{with python3}
504%files -n python3-pyzfs
505%defattr(644,root,root,755)
506%doc contrib/pyzfs/README
507%{py3_sitescriptdir}/libzfs_core
508%{py3_sitescriptdir}/pyzfs-*-py*.egg-info
509%endif
bff0a8a1
JB
510%endif
511
512%if %{with kernel}
3921af7f 513%files -n kernel-zfs-common-devel
bff0a8a1 514%defattr(644,root,root,755)
e11b2ec8 515%dir /usr/src/zfs-%{version}
3921af7f 516/usr/src/zfs-%{version}/include
0b82b0f8
JR
517/usr/src/zfs-%{version}/zfs.release
518/usr/src/zfs-%{version}/zfs_config.h
bff0a8a1 519%endif
This page took 0.180116 seconds and 4 git commands to generate.