]> git.pld-linux.org Git - packages/xqilla.git/blame - xqilla.spec
- new
[packages/xqilla.git] / xqilla.spec
CommitLineData
a0c0ca5d
JB
1# $Revision: 1.21 $, $Date: 2011/07/16 18:25:43 $
2# TODO: faxpp
3#
4# Conditional build:
5%bcond_without apidocs # do not build and package API docs
6#
7Summary: XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C
8Summary(pl.UTF-8): XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece Xerces-C
9Name: xqilla
10Version: 2.3.0
11Release: 1
12License: Apache v2.0
13Group: Libraries
14Source0: http://downloads.sourceforge.net/xqilla/XQilla-%{version}.tar.gz
15# Source0-md5: 7261c7b4bb5a45cbf6270073976a51ce
16Patch0: %{name}-link.patch
17URL: http://xqilla.sourceforge.net/
18BuildRequires: autoconf >= 2.59
19BuildRequires: automake
20BuildRequires: flex
21BuildRequires: libstdc++-devel
22BuildRequires: libtool
23BuildRequires: tidy-devel
24BuildRequires: xerces-c-devel >= 3
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C.
29
30%description -l pl.UTF-8
31XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece
32Xerces-C.
33
34%package devel
35Summary: Header files for XQilla library
36Summary(pl.UTF-8): Pliki nagłówkowe biblioteki XQilla
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39Requires: libstdc++-devel
40Requires: tidy-devel
41Requires: xerces-c-devel >= 3
42
43%description devel
44Header files for XQilla library.
45
46%description devel -l pl.UTF-8
47Pliki nagłówkowe biblioteki XQilla.
48
49%package static
50Summary: Static XQilla library
51Summary(pl.UTF-8): Statyczna biblioteka XQilla
52Group: Development/Libraries
53Requires: %{name}-devel = %{version}-%{release}
54
55%description static
56Static XQilla library.
57
58%description static -l pl.UTF-8
59Statyczna biblioteka XQilla.
60
61%package apidocs
62Summary: XQilla API documentation
63Summary(pl.UTF-8): Dokumentacja API biblioteki XQilla
64Group: Documentation
65
66%description apidocs
67API and internal documentation for XQilla library.
68
69%description apidocs -l pl.UTF-8
70Dokumentacja API biblioteki XQilla.
71
72%prep
73%setup -q -n XQilla-%{version}
74%patch0 -p1
75
76%build
77%{__libtoolize}
78%{__aclocal}
79%{__autoconf}
80%{__autoheader}
81%{__automake}
82%configure \
83 --with-xerces=/usr
84
85%{__make}
86
87%install
88rm -rf $RPM_BUILD_ROOT
89
90%{__make} install \
91 DESTDIR=$RPM_BUILD_ROOT
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%post -p /sbin/ldconfig
97%postun -p /sbin/ldconfig
98
99%files
100%defattr(644,root,root,755)
101%doc README TODO
102%attr(755,root,root) %{_bindir}/xqilla
103%attr(755,root,root) %{_libdir}/libxqilla.so.*.*.*
104%attr(755,root,root) %ghost %{_libdir}/libxqilla.so.6
105
106%files devel
107%defattr(644,root,root,755)
108%attr(755,root,root) %{_libdir}/libxqilla.so
109%{_libdir}/libxqilla.la
110%{_includedir}/xqilla
111%{_includedir}/xqc.h
112
113%files static
114%defattr(644,root,root,755)
115%{_libdir}/libxqilla.a
116
117%if %{with apidocs}
118%files apidocs
119%defattr(644,root,root,755)
120%doc docs/{dom3-api,simple-api,xqc-api,*.html}
121%endif
This page took 0.036155 seconds and 4 git commands to generate.