]> git.pld-linux.org Git - packages/xbmc.git/blame - xbmc.spec
- wrong Conflicts removed
[packages/xbmc.git] / xbmc.spec
CommitLineData
18b90c81
SP
1#
2# TODO:
3a71016a 3# - fix build flags - some files are compiled with -O3 and without rpm*flags
c1b45330 4# - fix linking argument order
63ff963e 5# - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports
6# only libXrandr 1.1 - with no gamma support; it causes application crash
7# on XRRSetCrtcGamma function called by SDL_SetVideoMode)
92b96980 8# - add and/or fix users/groups permissions
63ff963e 9# - split to subpackages?
92b96980 10# - check how it works with external python libraries
18b90c81 11#
92b96980 12# Conditional build:
13%bcond_with external_python
14
18b90c81
SP
15Summary: XBMC
16Name: xbmc
92b96980 17Version: 10.0
2e649bc9
AF
18Release: 0.1
19License: GPL v3
18b90c81 20Group: Applications/Multimedia
54721144 21Source0: http://www.softliste.de/xbmc/releases/source/%{name}-%{version}.tar.gz
92b96980 22# Source0-md5: 728fb514e5f43f27bb880305061b4e72
18b90c81 23URL: http://xbmc.org
01f2a87d 24Patch0: %{name}-nobash.patch
63ff963e 25Patch1: %{name}-python27.patch
92b96980 26Patch2: %{name}-libpng14.patch
18b90c81
SP
27BuildRequires: SDL_image-devel
28BuildRequires: SDL_mixer-devel
c462fd57 29BuildRequires: a52dec-libs-devel
18b90c81
SP
30BuildRequires: alsa-lib-devel
31BuildRequires: autoconf
32BuildRequires: automake
33BuildRequires: avahi-devel
5a2f2b01 34BuildRequires: boost-devel
18b90c81
SP
35BuildRequires: bzip2-devel
36BuildRequires: cmake
37BuildRequires: curl-devel
38BuildRequires: dbus-devel
ddeff5bb 39BuildRequires: enca
18b90c81
SP
40BuildRequires: enca-devel
41BuildRequires: faac-devel
5a2f2b01 42BuildRequires: faad2-devel
c462fd57 43BuildRequires: ffmpeg-devel
5a2f2b01 44BuildRequires: flac-devel
18b90c81
SP
45BuildRequires: fontconfig-devel
46BuildRequires: freetype-devel
47BuildRequires: fribidi-devel
48BuildRequires: gawk
63ff963e 49BuildRequires: gettext-autopoint
5a2f2b01 50BuildRequires: gettext-devel
18b90c81
SP
51BuildRequires: glew-devel
52BuildRequires: gperf
5a2f2b01 53BuildRequires: gtk+-devel
54BuildRequires: hal-devel
55BuildRequires: jasper-devel
56BuildRequires: libao-devel
18b90c81 57BuildRequires: libcdio-devel
c462fd57 58BuildRequires: libdts-devel
18b90c81
SP
59BuildRequires: libjpeg-devel
60BuildRequires: libmad-devel
63ff963e 61BuildRequires: libmicrohttpd-devel
18b90c81 62BuildRequires: libmms-devel
63ff963e 63BuildRequires: libmodplug-devel
c462fd57 64BuildRequires: libmpeg2-devel
18b90c81 65BuildRequires: libogg-devel
5a2f2b01 66BuildRequires: libpng-devel
18b90c81
SP
67BuildRequires: libsamplerate-devel
68BuildRequires: libsmbclient-devel
5a2f2b01 69BuildRequires: libtiff-devel
70BuildRequires: libtool
71BuildRequires: libvdpau-devel
18b90c81 72BuildRequires: libvorbis-devel
5a2f2b01 73BuildRequires: lzo-devel
74BuildRequires: mysql-devel
c1b45330 75%ifarch %{ix86}
26cae375 76BuildRequires: nasm
c1b45330 77%endif
18b90c81 78BuildRequires: openssl-devel
63ff963e 79BuildRequires: pcre-cxx-devel
5a2f2b01 80BuildRequires: pkgconfig
18b90c81 81BuildRequires: pulseaudio-devel
c462fd57 82BuildRequires: python-devel
3a71016a 83BuildRequires: rpm-pythonprov
c462fd57 84# used internally
85BuildRequires: sed >= 4.0
18b90c81 86BuildRequires: sqlite3-devel
5a2f2b01 87BuildRequires: unzip
c462fd57 88BuildRequires: wavpack-devel
5a2f2b01 89BuildRequires: xmms-devel
90BuildRequires: xorg-lib-libXinerama-devel
18b90c81 91BuildRequires: xorg-lib-libXrandr-devel
5a2f2b01 92BuildRequires: xorg-lib-libXtst-devel
18b90c81
SP
93BuildRequires: zip
94BuildRequires: zlib-devel
63ff963e 95Requires: /usr/bin/glxinfo
a58652d4
SP
96Requires: lsb-release
97Requires: xorg-app-xdpyinfo
18b90c81
SP
98BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100%description
101
102%prep
c1b45330 103%setup -q
01f2a87d 104%patch0 -p1
6d158894 105enca -L none -x ISO8859-1 xbmc/lib/libPython/xbmcmodule/xbmcaddonmodule.cpp
51b524ca 106%patch1 -p1
92b96980 107#%patch2 -p1
18b90c81
SP
108
109%build
110./bootstrap
65712ad3 111%configure \
51b524ca
KK
112 --disable-debug \
113 --enable-external-libraries \
92b96980 114 --%{?with_external_python:en}%{!?with_external_python:dis}able-external-python
18b90c81
SP
115%{__make}
116
117%install
118rm -rf $RPM_BUILD_ROOT
119
120%{__make} install \
92b96980 121 DESTDIR=$RPM_BUILD_ROOT
18b90c81
SP
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
0fc95f40 126%posttrans
127%banner -e xbmc <<EOF
128WARNING!
129If you use nvidia binary drivers be sure that SDL is compiled without
130XRandR and VidMode gamma ramps support.
131This means that you need to rebuild it with command:
132builder -bb --without new_gamma_ramp SDL
133EOF
134
18b90c81
SP
135%files
136%defattr(644,root,root,755)
47308569 137#doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
18b90c81 138
47308569 139#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
18b90c81
SP
140%attr(755,root,root) %{_bindir}/*
141%{_datadir}/%{name}
92b96980 142%attr(755,root,root) %{_libdir}/%{name}
143%{_docdir}/%{name}
c1b45330 144%{_desktopdir}/%{name}.desktop
92b96980 145%{_iconsdir}/hicolor/256x256/apps/%{name}.png
146%{_iconsdir}/hicolor/48x48/apps/%{name}.png
3a71016a 147%{_datadir}/xsessions/XBMC.desktop
This page took 0.052836 seconds and 5 git commands to generate.