]> git.pld-linux.org Git - packages/vtun.git/blame - vtun.spec
- updated to 2.1b4
[packages/vtun.git] / vtun.spec
CommitLineData
c3d615ff 1Summary: Virtual tunnel over TCP/IP networks.
1dc48ba5 2Name: vtun
e034d232 3Version: 2.1b4
1dc48ba5 4Release: 1
5License: GPL
6Group: Networking/Daemons
7Group(pl): Sieciowe/Serwery
c3d615ff 8Vendor: Maxim Krasnyansky <max_mk@yahoo.com>
1dc48ba5 9Source0: http://vtun.netpedia.net/%{name}-%{version}.tar.gz
10Source1: %{name}.init
11Patch: %{name}-makefile.patch
c3d615ff 12URL: http://vtun.netpedia.net
13BuildRequires: openssl-devel
14BuildRequires: zlib-devel
c8345a95 15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1dc48ba5 16Obsoletes: vppp
17
18%define _localstatedir /var
19
20%description
21VTun provides the method for creating Virtual Tunnels over TCP/IP networks
c3d615ff 22and allows to shape, compress, encrypt traffic in that tunnels. Supported
23type of tunnels are: PPP, IP, Ethernet and most of other serial protocols
24and programs. VTun is easily and highly configurable, it can be used for
1dc48ba5 25various network task like VPN, Mobil IP, Shaped Internet access, IP address
c3d615ff 26saving, etc. It is completely user space implementation and does not require
27modification to any kernel parts. You need SSLeay-devel and lzo-devel to
28build it.
1dc48ba5 29
30%prep
31%setup -q
32%patch -p1
33%build
34LDFLAGS="-s"; export LDFLAGS
35%configure \
c3d615ff 36 --with-crypto-headers=%{_includedir}/openssl
1dc48ba5 37make
38
39%install
40rm -rf $RPM_BUILD_ROOT
c3d615ff 41install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
42 $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_localstatedir}/log/vtun}
1dc48ba5 43
44make install DESTDIR=$RPM_BUILD_ROOT
45
46install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/vtund
47
48gzip -9nf ChangeLog Credits README README.Setup README.Shaper FAQ TODO \
49 $RPM_BUILD_ROOT%{_mandir}/*/*
50
51%post
52/sbin/chkconfig --add vtund
c3d615ff 53if [ -f /var/lock/subsys/vtund ]; then
1dc48ba5 54 /etc/rc.d/init.d/vtund restart >&2
55else
56 echo "Run \"/etc/rc.d/init.d/vtund start\" to start vtun daemons."
57fi
58
59%preun
60if [ "$1" = "0" ]; then
c3d615ff 61 if [ -f /var/lock/subsys/vtund ]; then
62 /etc/rc.d/init.d/vtund stop >&2
63 fi
1dc48ba5 64 /sbin/chkconfig --del vtund
65fi
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(644,root,root,755)
72%doc {ChangeLog,Credits,README,README.Setup,README.Shaper,FAQ,TODO}.gz
73%attr(754,root,root) %{_sysconfdir}/rc.d/init.d/vtund
74%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/vtund.conf
75%attr(755,root,root) %{_sbindir}/vtund
76%attr(755,root,root) %dir /var/log/vtund
77%{_mandir}/man8/*.gz
This page took 0.064087 seconds and 4 git commands to generate.