]> git.pld-linux.org Git - packages/vala.git/blame - vala.spec
Update to 0.38.2
[packages/vala.git] / vala.spec
CommitLineData
787370ed
MB
1# Conditional build:
2%bcond_with bootstrap # bootstrap build
3
50430cbc 4%define major_ver 0.38
2100e356 5Summary: GObject-based language compiler
62a0034d 6Summary(pl.UTF-8): Kompilator języka opartego na bibliotece GObject
2100e356 7Name: vala
50430cbc 8Version: 0.38.2
113c79bf 9Release: 1
c258620e 10Epoch: 2
6a5cf96c 11License: LGPL v2+
37af0a44 12Group: Development/Languages
50430cbc
MB
13Source0: http://ftp.gnome.org/pub/GNOME/sources/vala/0.38/%{name}-%{version}.tar.xz
14# Source0-md5: 720846116448fc20b0ab3c0921e19798
9278bb59 15URL: http://live.gnome.org/Vala
27a73cba 16BuildRequires: autoconf >= 2.65
7ace0cac 17BuildRequires: automake >= 1:1.11
6a5cf96c 18BuildRequires: bison
2ac0ddb6 19BuildRequires: flex
50430cbc
MB
20BuildRequires: glib2-devel >= 1:2.40.0
21BuildRequires: graphviz-devel >= 2.16
e675a7aa 22BuildRequires: libtool >= 2:2.2.6
7f0c5943 23BuildRequires: libxslt-progs
e675a7aa 24BuildRequires: pkgconfig >= 1:0.21
7ace0cac 25BuildRequires: tar >= 1:1.22
787370ed 26%{!?with_bootstrap:BuildRequires: vala >= 2:0.25.1}
7ace0cac 27BuildRequires: xz
50430cbc 28Requires: glib2 >= 1:2.40.0
a147192b 29Conflicts: gdk-pixbuf2 < 2.23.3-1
2100e356 30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33Vala is a new programming language that aims to bring modern
34programming language features to GNOME developers without imposing any
35additional runtime requirements and without using a different ABI
36compared to applications and libraries written in C.
37
38valac, the Vala compiler, is a self-hosting compiler that translates
39Vala source code into C source and header files. It uses the GObject
40type system to create classes and interfaces declared in the Vala
41source code. It's also planned to generate GIDL files when
42gobject-introspection is ready.
43
44The syntax of Vala is similar to C#, modified to better fit the
45GObject type system.
46
a030a99c
JR
47%description -l pl.UTF-8
48Vala to nowy język programowania, którego celem jest udostępnienie
49cech nowoczesnych języków programowania programistom GNOME bez
50wymuszania dodatkowych wymagań co do środowiska uruchomieniowego i
51używania API innego niż w aplikacjach i bibliotekach napisanych w C.
fc5b0e4f 52
a030a99c
JR
53valac - kompilator języka Vala - to napisany w sobie samym kompilator
54tłumaczący kod źródłowy w języku Vala na pliki źródłowe i nagłówkowe w
55C. Używa systemu typów GObject do tworzenia klas i interfejsów
56zadeklarowanych w kodzie źródłowym w języku Vala. Planowane jest także
57generowanie plików GIDL, kiedy system gobject-introspection będzie
fc5b0e4f
JB
58gotowy.
59
a030a99c
JR
60Składnia języka Vala jest podobna do C#, zmodyfikowana tak, aby lepiej
61pasować do systemu typów GObject.
fc5b0e4f 62
b0568d57 63%package apidocs
64Summary: vala API documentation
65Summary(pl.UTF-8): Dokumentacja API vala
66Group: Documentation
8634ffb4 67Requires: devhelp
e826d452
ER
68%if "%{_rpmversion}" >= "5"
69BuildArch: noarch
70%endif
b0568d57 71
72%description apidocs
73vala API documentation.
74
75%description apidocs -l pl.UTF-8
76Dokumentacja API vala.
77
50430cbc
MB
78%package -n valadoc
79Summary: Documentation tool for Vala
80Summary(pl.UTF-8): Narzędzie obsługujące dokumentację dla języka Vala
81Group: Development/Tools
82Requires: %{name} = %{epoch}:%{version}-%{release}
83
84%description -n valadoc
85Documentation tool for Vala.
86
87%description -n valadoc -l pl.UTF-8
88Narzędzie obsługujące dokumentację dla języka Vala.
89
90%package -n valadoc-devel
91Summary: Header file for Valadoc library
92Summary(pl.UTF-8): Plik nagłówkowy biblioteki Valadoc
93Group: Development/Libraries
94Requires: glib2-devel >= 1:2.40.0
95Requires: graphviz-devel >= 2.16
96Requires: valadoc = %{epoch}:%{version}-%{release}
97
98%description -n valadoc-devel
99Header file for Valadoc library.
100
101%description -n valadoc-devel -l pl.UTF-8
102Plik nagłówkowy biblioteki Valadoc.
103
104%package -n vala-valadoc
105Summary: Vala API for Valadoc library
106Summary(pl.UTF-8): API języka Vala do biblioteki Valadoc
107Group: Development/Libraries
108Requires: vala
109Requires: valadoc-devel = %{epoch}:%{version}-%{release}
110%if "%{_rpmversion}" >= "5"
111BuildArch: noarch
112%endif
113
114%description -n vala-valadoc
115Vala API for Valadoc library.
116
117%description -n vala-valadoc -l pl.UTF-8
118API języka Vala do biblioteki Valadoc.
119
2100e356 120%prep
121%setup -q
122
123%build
1d8bfdb9 124%{__libtoolize}
7ace0cac 125%{__aclocal} -I m4
1d8bfdb9 126%{__autoconf}
127%{__autoheader}
128%{__automake}
129%configure \
7ec7f175 130 --disable-silent-rules
2100e356 131%{__make}
132
133%install
134rm -rf $RPM_BUILD_ROOT
a3c413c5
PZ
135install -d $RPM_BUILD_ROOT%{_datadir}/vala/vapi
136
2100e356 137%{__make} install \
138 DESTDIR=$RPM_BUILD_ROOT
139
a3c413c5
PZ
140%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
141
50430cbc
MB
142# loadable modules
143%{__rm} $RPM_BUILD_ROOT%{_libdir}/valadoc/*/*/*.la
144
2100e356 145%clean
146rm -rf $RPM_BUILD_ROOT
147
6a5cf96c
JB
148%post -p /sbin/ldconfig
149%postun -p /sbin/ldconfig
150
50430cbc
MB
151%post -n valadoc -p /sbin/ldconfig
152%postun -n valadoc -p /sbin/ldconfig
153
2100e356 154%files
155%defattr(644,root,root,755)
787370ed 156%doc AUTHORS ChangeLog NEWS README THANKS
a393e7a8
JB
157%attr(755,root,root) %{_bindir}/vala
158%attr(755,root,root) %{_bindir}/vala-%{major_ver}
159%attr(755,root,root) %{_bindir}/vala-gen-introspect
160%attr(755,root,root) %{_bindir}/vala-gen-introspect-%{major_ver}
161%attr(755,root,root) %{_bindir}/valac
162%attr(755,root,root) %{_bindir}/valac-%{major_ver}
163%attr(755,root,root) %{_bindir}/vapicheck
164%attr(755,root,root) %{_bindir}/vapicheck-%{major_ver}
165%attr(755,root,root) %{_bindir}/vapigen
166%attr(755,root,root) %{_bindir}/vapigen-%{major_ver}
a3c413c5
PZ
167%attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so.*.*.*
168%attr(755,root,root) %ghost %{_libdir}/libvala-%{major_ver}.so.0
169%attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so
092cc603 170%{_includedir}/vala-%{major_ver}
e6241369 171%{_pkgconfigdir}/libvala-%{major_ver}.pc
27a73cba
MB
172%{_pkgconfigdir}/vapigen-%{major_ver}.pc
173%{_pkgconfigdir}/vapigen.pc
a3c413c5 174%dir %{_datadir}/vala
ce788c9c 175%{_datadir}/vala/Makefile.vapigen
a3c413c5 176%dir %{_datadir}/vala/vapi
092cc603
JK
177%dir %{_datadir}/vala-%{major_ver}
178%dir %{_datadir}/vala-%{major_ver}/vapi
179%{_datadir}/vala-%{major_ver}/vapi/*.vapi
180%{_datadir}/vala-%{major_ver}/vapi/*.deps
092cc603
JK
181%dir %{_libdir}/vala-%{major_ver}
182%attr(755,root,root) %{_libdir}/vala-%{major_ver}/gen-introspect-%{major_ver}
cbe6d1d3 183%{_mandir}/man1/vala-gen-introspect.1*
092cc603 184%{_mandir}/man1/vala-gen-introspect-%{major_ver}.1*
a393e7a8
JB
185%{_mandir}/man1/valac.1*
186%{_mandir}/man1/valac-%{major_ver}.1*
cbe6d1d3 187%{_mandir}/man1/vapigen.1*
092cc603
JK
188%{_mandir}/man1/vapigen-%{major_ver}.1*
189%{_aclocaldir}/vala.m4
ce788c9c 190%{_aclocaldir}/vapigen.m4
b0568d57 191
192%files apidocs
193%defattr(644,root,root,755)
092cc603 194%{_datadir}/devhelp/books/vala-%{major_ver}
50430cbc
MB
195
196%files -n valadoc
197%defattr(644,root,root,755)
198%attr(755,root,root) %{_bindir}/valadoc
199%attr(755,root,root) %{_bindir}/valadoc-0.38
200%attr(755,root,root) %{_libdir}/libvaladoc-0.38.so.*.*.*
201%attr(755,root,root) %ghost %{_libdir}/libvaladoc-0.38.so.0
202%dir %{_libdir}/valadoc
203%dir %{_libdir}/valadoc/doclets
204%dir %{_libdir}/valadoc/doclets/devhelp
205%attr(755,root,root) %{_libdir}/valadoc/doclets/devhelp/libdoclet.so
206%dir %{_libdir}/valadoc/doclets/gtkdoc
207%attr(755,root,root) %{_libdir}/valadoc/doclets/gtkdoc/libdoclet.so
208%dir %{_libdir}/valadoc/doclets/html
209%attr(755,root,root) %{_libdir}/valadoc/doclets/html/libdoclet.so
210%{_datadir}/valadoc
211%{_mandir}/man1/valadoc-0.38.1*
212%{_mandir}/man1/valadoc.1*
213
214%files -n valadoc-devel
215%defattr(644,root,root,755)
216%attr(755,root,root) %{_libdir}/libvaladoc-0.38.so
217%{_includedir}/valadoc-0.38
218%{_pkgconfigdir}/valadoc-0.38.pc
219
220%files -n vala-valadoc
221%defattr(644,root,root,755)
222%{_datadir}/vala/vapi/libvala-0.38.vapi
223%{_datadir}/vala/vapi/valadoc-0.38.deps
224%{_datadir}/vala/vapi/valadoc-0.38.vapi
This page took 0.126944 seconds and 4 git commands to generate.