]> git.pld-linux.org Git - packages/vala.git/blame - vala.spec
- added atk-update patch (update atk vapi for atk 2.12)
[packages/vala.git] / vala.spec
CommitLineData
c745517a 1%define major_ver 0.24
2100e356 2Summary: GObject-based language compiler
62a0034d 3Summary(pl.UTF-8): Kompilator języka opartego na bibliotece GObject
2100e356 4Name: vala
c745517a 5Version: 0.24.0
44c75fb5 6Release: 2
c258620e 7Epoch: 2
6a5cf96c 8License: LGPL v2+
37af0a44 9Group: Development/Languages
c745517a
ŁK
10Source0: http://ftp.gnome.org/pub/GNOME/sources/vala/0.24/%{name}-%{version}.tar.xz
11# Source0-md5: beddeff9c06d3c278988b237da0e7401
44c75fb5 12Patch0: %{name}-atk-update.patch
9278bb59 13URL: http://live.gnome.org/Vala
a393e7a8 14BuildRequires: autoconf >= 2.50
7ace0cac 15BuildRequires: automake >= 1:1.11
6a5cf96c 16BuildRequires: bison
2ac0ddb6 17BuildRequires: flex
a393e7a8 18BuildRequires: glib2-devel >= 1:2.18.0
1d8bfdb9 19BuildRequires: libtool
7f0c5943 20BuildRequires: libxslt-progs
6a5cf96c 21BuildRequires: pkgconfig
7ace0cac
AF
22BuildRequires: tar >= 1:1.22
23BuildRequires: xz
a393e7a8 24Requires: glib2 >= 1:2.18.0
a147192b 25Conflicts: gdk-pixbuf2 < 2.23.3-1
2100e356 26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29Vala is a new programming language that aims to bring modern
30programming language features to GNOME developers without imposing any
31additional runtime requirements and without using a different ABI
32compared to applications and libraries written in C.
33
34valac, the Vala compiler, is a self-hosting compiler that translates
35Vala source code into C source and header files. It uses the GObject
36type system to create classes and interfaces declared in the Vala
37source code. It's also planned to generate GIDL files when
38gobject-introspection is ready.
39
40The syntax of Vala is similar to C#, modified to better fit the
41GObject type system.
42
a030a99c
JR
43%description -l pl.UTF-8
44Vala to nowy język programowania, którego celem jest udostępnienie
45cech nowoczesnych języków programowania programistom GNOME bez
46wymuszania dodatkowych wymagań co do środowiska uruchomieniowego i
47używania API innego niż w aplikacjach i bibliotekach napisanych w C.
fc5b0e4f 48
a030a99c
JR
49valac - kompilator języka Vala - to napisany w sobie samym kompilator
50tłumaczący kod źródłowy w języku Vala na pliki źródłowe i nagłówkowe w
51C. Używa systemu typów GObject do tworzenia klas i interfejsów
52zadeklarowanych w kodzie źródłowym w języku Vala. Planowane jest także
53generowanie plików GIDL, kiedy system gobject-introspection będzie
fc5b0e4f
JB
54gotowy.
55
a030a99c
JR
56Składnia języka Vala jest podobna do C#, zmodyfikowana tak, aby lepiej
57pasować do systemu typów GObject.
fc5b0e4f 58
b0568d57 59%package apidocs
60Summary: vala API documentation
61Summary(pl.UTF-8): Dokumentacja API vala
62Group: Documentation
8634ffb4 63Requires: devhelp
b0568d57 64
65%description apidocs
66vala API documentation.
67
68%description apidocs -l pl.UTF-8
69Dokumentacja API vala.
70
2100e356 71%prep
72%setup -q
44c75fb5 73%patch0 -p1
2100e356 74
75%build
1d8bfdb9 76%{__libtoolize}
7ace0cac 77%{__aclocal} -I m4
1d8bfdb9 78%{__autoconf}
79%{__autoheader}
80%{__automake}
81%configure \
9278bb59 82 --disable-silent-rules \
2ca28226 83 --enable-vapigen
2100e356 84%{__make}
85
86%install
87rm -rf $RPM_BUILD_ROOT
a3c413c5
PZ
88install -d $RPM_BUILD_ROOT%{_datadir}/vala/vapi
89
2100e356 90%{__make} install \
91 DESTDIR=$RPM_BUILD_ROOT
92
a3c413c5
PZ
93%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
94
2100e356 95%clean
96rm -rf $RPM_BUILD_ROOT
97
6a5cf96c
JB
98%post -p /sbin/ldconfig
99%postun -p /sbin/ldconfig
100
2100e356 101%files
102%defattr(644,root,root,755)
f7af4f63 103%doc AUTHORS ChangeLog MAINTAINERS NEWS README THANKS
a393e7a8
JB
104%attr(755,root,root) %{_bindir}/vala
105%attr(755,root,root) %{_bindir}/vala-%{major_ver}
106%attr(755,root,root) %{_bindir}/vala-gen-introspect
107%attr(755,root,root) %{_bindir}/vala-gen-introspect-%{major_ver}
108%attr(755,root,root) %{_bindir}/valac
109%attr(755,root,root) %{_bindir}/valac-%{major_ver}
110%attr(755,root,root) %{_bindir}/vapicheck
111%attr(755,root,root) %{_bindir}/vapicheck-%{major_ver}
112%attr(755,root,root) %{_bindir}/vapigen
113%attr(755,root,root) %{_bindir}/vapigen-%{major_ver}
a3c413c5
PZ
114%attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so.*.*.*
115%attr(755,root,root) %ghost %{_libdir}/libvala-%{major_ver}.so.0
116%attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so
092cc603 117%{_includedir}/vala-%{major_ver}
e6241369 118%{_pkgconfigdir}/libvala-%{major_ver}.pc
ce788c9c
MB
119%{_npkgconfigdir}/vapigen-%{major_ver}.pc
120%{_npkgconfigdir}/vapigen.pc
a3c413c5 121%dir %{_datadir}/vala
ce788c9c 122%{_datadir}/vala/Makefile.vapigen
a3c413c5 123%dir %{_datadir}/vala/vapi
092cc603
JK
124%dir %{_datadir}/vala-%{major_ver}
125%dir %{_datadir}/vala-%{major_ver}/vapi
126%{_datadir}/vala-%{major_ver}/vapi/*.vapi
127%{_datadir}/vala-%{major_ver}/vapi/*.deps
092cc603
JK
128%dir %{_libdir}/vala-%{major_ver}
129%attr(755,root,root) %{_libdir}/vala-%{major_ver}/gen-introspect-%{major_ver}
cbe6d1d3 130%{_mandir}/man1/vala-gen-introspect.1*
092cc603 131%{_mandir}/man1/vala-gen-introspect-%{major_ver}.1*
a393e7a8
JB
132%{_mandir}/man1/valac.1*
133%{_mandir}/man1/valac-%{major_ver}.1*
cbe6d1d3 134%{_mandir}/man1/vapigen.1*
092cc603
JK
135%{_mandir}/man1/vapigen-%{major_ver}.1*
136%{_aclocaldir}/vala.m4
ce788c9c 137%{_aclocaldir}/vapigen.m4
b0568d57 138
139%files apidocs
140%defattr(644,root,root,755)
092cc603 141%{_datadir}/devhelp/books/vala-%{major_ver}
This page took 0.076169 seconds and 4 git commands to generate.