]> git.pld-linux.org Git - packages/tmux.git/blame - tmux.spec
Rel 3; update from git
[packages/tmux.git] / tmux.spec
CommitLineData
21dfa491
ZU
1# TODO:
2# - vim doesn't detect filetype
73fd702d
JP
3#
4# Conditional build:
5%bcond_without systemd # without system integration
6
5724a193 7%define commit e809c2ec359b0fd6151cf33929244b7a7d637119
341bb9ad 8
0a168b43 9Summary: tmux - a terminal multiplexer
df1e8c4e 10Summary(hu.UTF-8): tmux egy terminál-sokszorozó
0a168b43 11Summary(pl.UTF-8): tmux - multiplekser terminali
df1e8c4e 12Name: tmux
d0a365e4 13Version: 3.3a
5724a193 14Release: 3
c4f39c44 15License: ISC
df1e8c4e 16Group: Applications/Terminal
1a940cea 17#Source0Download: https://github.com/tmux/tmux/releases
341bb9ad
AM
18# Source0: https://github.com/tmux/tmux/releases/download/%{version}/%{name}-%{version}.tar.gz
19Source0: https://github.com/tmux/tmux/archive/%{commit}.zip
5724a193 20# Source0-md5: f8eeb580e28377656d1d60f3b29e4dad
df1e8c4e 21Source1: %{name}-filedetect.vim
466bc6bc 22Source2: https://raw.githubusercontent.com/keith/tmux.vim/master/syntax/tmux.vim
101ede04 23# Source2-md5: cd1169a1757b515b5c57816d339c6f72
13f42450 24Source3: https://raw.githubusercontent.com/imomaliev/tmux-bash-completion/master/completions/tmux
7a54b8d0 25# Source3-md5: 6d65c0f42c74f61602a399d7bb04a85c
095bed52 26Source4: tmux@.service
a018f7c2 27URL: http://tmux.github.io/
05eab483 28BuildRequires: libevent-devel
ea24db7e 29BuildRequires: libutempter-devel
c4f39c44
JB
30BuildRequires: ncurses-devel >= 5
31BuildRequires: pkgconfig
1a940cea 32BuildRequires: rpmbuild(macros) >= 1.673
73fd702d 33%{?with_systemd:BuildRequires: systemd-devel}
df1e8c4e
ZU
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37tmux is a terminal multiplexer: it enables a number of terminals (or
38windows), each running a separate program, to be created, accessed,
39and controlled from a single screen. tmux may be detached from a
40screen and continue running in the background, then later reattached.
41
42%description -l hu.UTF-8
43tmux egy terminál-sokszorozó: terminálok (vagy ablakok) sokaságát
44hozhatd létre, mindegyikben egy külön program fut, létrehozhatsz,
45csatlakozhatsz és irányíthatod egyetlen képernyőről. tmux
46lecsatlakozhat a képernyőről és folytathatja a futását a háttérben, és
47később újracsatlakozhatsz.
48
0a168b43
JB
49%description -l pl.UTF-8
50tmux to multiplekser terminali: pozwala na tworzenie wielu terminali
51(lub okien) z osobnymi programami, dostęp do nich i sterowanie z
52pojedynczego ekranu. tmux może być odłączony od ekranu i nadal działać
53w tle, a następnie ponownie podłączony.
54
df1e8c4e
ZU
55%package -n vim-syntax-tmux
56Summary: Vim syntax file to tmux config files
57Summary(hu.UTF-8): Vim syntax fájl a tmux konfigurációs fájljához
0a168b43 58Summary(pl.UTF-8): Plik składni Vima dla plików konfiguracyjnych tmuksa
df1e8c4e 59Group: Applications/Editors/Vim
0a168b43 60Requires: vim-rt
df1e8c4e
ZU
61
62%description -n vim-syntax-tmux
63Vim syntax file to tmux config files.
64
65%description -n vim-syntax-tmux -l hu.UTF-8
66Vim syntax fájl a tmux konfigurációs fájljához.
67
ee0f9a2f
ZU
68%package -n bash-completion-tmux
69Summary: Bash completion for tmux
0a168b43 70Summary(pl.UTF-8): Bashowe dopełnianie poleceń dla tmuksa
596f5bca 71Group: Applications/Shells
0a168b43 72Requires: %{name} = %{version}-%{release}
1a940cea 73Requires: bash-completion >= 2.0
ee0f9a2f
ZU
74
75%description -n bash-completion-tmux
76This package provides bash-completion for tmux.
77
0a168b43
JB
78%description -n bash-completion-tmux -l pl.UTF-8
79Ten pakiet dostarcza bashowe dopełnianie składni dla polecenia tmux.
80
df1e8c4e 81%prep
341bb9ad 82%setup -q -n %{name}-%{commit}
df1e8c4e
ZU
83
84%build
341bb9ad 85[ ! -x configure ] && ./autogen.sh
c4f39c44 86# note: on Linux use plain glibc functions instead of utf8proc
bdef13e9 87%configure \
73fd702d
JP
88 CPPFLAGS="%{rpmcppflags} -I/usr/include/ncursesw" \
89 %{__enable_disable systemd}
bdef13e9 90
27a56cc0 91%{__make}
df1e8c4e
ZU
92
93%install
94rm -rf $RPM_BUILD_ROOT
95
96%{__make} install \
97 DESTDIR=$RPM_BUILD_ROOT \
98 PREFIX=%{_prefix}
99
100install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/{ftdetect,syntax}
101install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/ftdetect/tmux.vim
466bc6bc 102install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
1a940cea 103install -d $RPM_BUILD_ROOT%{bash_compdir}
efc13735 104sed -e '1s,#!/usr/bin/env bash,#!/bin/bash,' %{SOURCE3} > $RPM_BUILD_ROOT%{bash_compdir}/%{name}
095bed52
JP
105install -d $RPM_BUILD_ROOT%{systemdunitdir}
106install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}
df1e8c4e
ZU
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%files
112%defattr(644,root,root,755)
13f42450 113%doc CHANGES COPYING README
0a168b43
JB
114%attr(755,root,root) %{_bindir}/tmux
115%{_mandir}/man1/tmux.1*
095bed52 116%{systemdunitdir}/tmux@.service
df1e8c4e
ZU
117
118%files -n vim-syntax-tmux
119%defattr(644,root,root,755)
120%{_datadir}/vim/vimfiles/ftdetect/tmux.vim
121%{_datadir}/vim/vimfiles/syntax/tmux.vim
ee0f9a2f
ZU
122
123%files -n bash-completion-tmux
124%defattr(644,root,root,755)
1a940cea 125%{bash_compdir}/%{name}
This page took 0.202052 seconds and 4 git commands to generate.