]> git.pld-linux.org Git - packages/tesseract.git/blame - tesseract.spec
fixed x32 arch workaround
[packages/tesseract.git] / tesseract.spec
CommitLineData
2fecdb4d
PG
1# TODO:
2# - warnings at compile stage about pointer size on amd64 - needs check
a7d2de0d 3Summary: Tesseract Open Source OCR Engine
877b8a7e 4Summary(pl.UTF-8): Tesseract - silnik OCR o otwartych źródłach
afaac0e1 5Name: tesseract
6f607027 6Version: 3.04.00
ba6a7995 7Release: 1
187eebd6 8License: Apache v2.0
afaac0e1 9Group: Applications/Graphics
6f607027
TP
10Source0: https://github.com/tesseract-ocr/tesseract/archive/%{version}.tar.gz
11# Source0-md5: 078130b9c7d28c558a0e49d432505864
520e1ed8 12URL: http://code.google.com/p/tesseract-ocr/
f7537631 13BuildRequires: autoconf >= 2.50
a7d2de0d 14BuildRequires: automake
caa3afbb 15BuildRequires: cairo-devel
6f607027 16BuildRequires: leptonlib-devel >= 1.71
ba6a7995 17BuildRequires: libicu-devel
61b2992b 18BuildRequires: libstdc++-devel
f7537631 19BuildRequires: libtool
caa3afbb 20BuildRequires: pango-devel
f7537631 21Suggests: tesseract-data >= 3
afaac0e1
ER
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25A commercial quality OCR engine originally developed at HP between
261985 and 1995. In 1995, this engine was among the top 3 evaluated by
27UNLV. It was open-sourced by HP and UNLV in 2005.
28
ac8a5dbe
JR
29%description -l pl.UTF-8
30Silnik OCR o komercyjnej jakości oryginalnie stworzony przez HP w
31latach 1985-1995. W 1995 roku był jednym z 3 najlepszych wg UNLV.
32Źródła zostały uwolnione przez HP i UNLV w 2005 roku.
a1b42a34 33
ba6a7995
TP
34%package training
35Summary: Tesseract training tools
36Summary(pl.UTF-8): Pliki treningowe tesseracta
37Group: Applications/Graphics
38Requires: %{name} = %{version}
39
40%description training
41This package contains the Tesseract training tools.
42
43%description training -l pl.UTF-8
44Ten pakiet zawiera programy do trenowania tesseracta.
45
f7537631
JB
46%package devel
47Summary: Header files for Tesseract libraries
48Summary(pl.UTF-8): Pliki nagłówkowe bibliotek Tesseracta
49Group: Development/Libraries
2fecdb4d 50Requires: %{name} = %{version}-%{release}
f7537631
JB
51Requires: leptonlib-devel
52Requires: libstdc++-devel
2fecdb4d 53
f7537631
JB
54%description devel
55This package contains the development header files necessary to
56develop applications using Tesseract API.
2fecdb4d 57
f7537631
JB
58%description devel -l pl.UTF-8
59Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
60wykorzystujących API Tesseracta.
2fecdb4d 61
f7537631
JB
62%package static
63Summary: Static Tesseract libraries
64Summary(pl.UTF-8): Statyczne biblioteki Tesseracta
2fecdb4d 65Group: Development/Libraries
f7537631 66Requires: %{name}-devel = %{version}-%{release}
2fecdb4d 67
f7537631
JB
68%description static
69Static Tesseract libraries.
70
71%description static -l pl.UTF-8
72Statyczne biblioteki Tesseracta.
2fecdb4d 73
afaac0e1 74%prep
6f607027 75%setup -q
ba6a7995 76# workaround for 'off_t undefined when -std=c++11' workaround
8b41e4f5 77%ifarch x32
ba6a7995
TP
78%{__sed} -e 's|typedef long off_t;|//typedef long off_t;|' -i ccutil/scanutils.cpp
79%endif
afaac0e1
ER
80
81%build
f7537631
JB
82%{__libtoolize}
83%{__aclocal}
84%{__autoconf}
85%{__autoheader}
86%{__automake}
afaac0e1
ER
87%configure
88%{__make}
caa3afbb 89%{__make} training
afaac0e1
ER
90
91%install
92rm -rf $RPM_BUILD_ROOT
93
94%{__make} install \
95 DESTDIR=$RPM_BUILD_ROOT
96
caa3afbb
TP
97%{__make} training-install \
98 DESTDIR=$RPM_BUILD_ROOT
99
6f607027
TP
100%{__rm} $RPM_BUILD_ROOT%{_libdir}/libtesseract.la
101
afaac0e1
ER
102%clean
103rm -rf $RPM_BUILD_ROOT
104
0527fb34
BS
105%post -p /sbin/ldconfig
106%postun -p /sbin/ldconfig
107
afaac0e1
ER
108%files
109%defattr(644,root,root,755)
f7537631 110%doc AUTHORS COPYING ChangeLog README ReleaseNotes
ba6a7995
TP
111%attr(755,root,root) %{_bindir}/tesseract
112%attr(755,root,root) %{_libdir}/libtesseract.so.*.*.*
8028172e 113%attr(755,root,root) %ghost %{_libdir}/libtesseract.so.3
caa3afbb 114%{_datadir}/tessdata
ba6a7995
TP
115%{_mandir}/man1/tesseract.1*
116
117%files training
118%defattr(644,root,root,755)
119%attr(755,root,root) %{_bindir}/ambiguous_words
120%attr(755,root,root) %{_bindir}/cntraining
121%attr(755,root,root) %{_bindir}/combine_tessdata
122%attr(755,root,root) %{_bindir}/dawg2wordlist
123%attr(755,root,root) %{_bindir}/mftraining
124%attr(755,root,root) %{_bindir}/set_unicharset_properties
125%attr(755,root,root) %{_bindir}/shapeclustering
126%attr(755,root,root) %{_bindir}/text2image
127%attr(755,root,root) %{_bindir}/unicharset_extractor
128%attr(755,root,root) %{_bindir}/wordlist2dawg
854e1083 129%{_mandir}/man1/ambiguous_words.1*
8028172e
JB
130%{_mandir}/man1/cntraining.1*
131%{_mandir}/man1/combine_tessdata.1*
854e1083 132%{_mandir}/man1/dawg2wordlist.1*
8028172e 133%{_mandir}/man1/mftraining.1*
854e1083 134%{_mandir}/man1/shapeclustering.1*
8028172e
JB
135%{_mandir}/man1/unicharset_extractor.1*
136%{_mandir}/man1/wordlist2dawg.1*
2da6320c 137
2fecdb4d 138%files devel
2da6320c 139%defattr(644,root,root,755)
8028172e 140%attr(755,root,root) %{_libdir}/libtesseract.so
f7537631 141%{_includedir}/%{name}
854e1083 142%{_pkgconfigdir}/tesseract.pc
8028172e
JB
143%{_mandir}/man5/unicharambigs.5*
144%{_mandir}/man5/unicharset.5*
f7537631
JB
145
146%files static
147%defattr(644,root,root,755)
8028172e 148%{_libdir}/libtesseract.a
This page took 0.164171 seconds and 4 git commands to generate.