]> git.pld-linux.org Git - projects/template-specs.git/blame - template.spec
- tabs in preamble
[projects/template-specs.git] / template.spec
CommitLineData
52ff2772 1#
66c7fa65
ER
2# Conditional build:
3%bcond_with tests # build with tests
4%bcond_without tests # build without tests
52ff2772 5#
e8b9df06 6Summary: -
ce39d734 7Summary(pl.UTF-8): -
5e539df2
ER
8Name: template
9Version: _
c1981b58 10Release: 0.1
73d26d4a 11License: - (enter GPL/GPL v2/LGPL/BSD/BSD-like/other license name here)
4b97f9d0 12Group: Applications
f1b2d418 13Source0: %{name}-%{version}.tar.gz
023a0cc4 14# Source0-md5: -
4b97f9d0 15#Source1: -
023a0cc4 16# Source1-md5: -
49683e54 17#Patch0: %{name}-DESTDIR.patch
e8b9df06 18URL: -
c0c12927
ER
19%if %{with initscript}
20BuildRequires: rpmbuild(macros) >= 1.228
c0c12927
ER
21Requires(post,preun): /sbin/chkconfig
22%endif
5e539df2 23#BuildRequires: -
6d0e4f88 24#BuildRequires: autoconf
fdeb11aa 25#BuildRequires: automake
bd5b2cfe 26#BuildRequires: intltool
6d0e4f88 27#BuildRequires: libtool
5e539df2 28#Requires(postun): -
4b97f9d0
ER
29#Requires(pre,post): -
30#Requires(preun): -
4b97f9d0 31#Requires: -
44d5bb3a 32#Provides: -
c0c12927
ER
33#Provides: group(foo)
34#Provides: user(foo)
4b97f9d0
ER
35#Obsoletes: -
36#Conflicts: -
c1981b58 37#BuildArch: noarch
5e539df2 38#ExclusiveArch: %{ix86}
e8b9df06
SZ
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42
9be49f18 43%description -l pl.UTF-8
e8b9df06 44
352b3a3c
TP
45%package subpackage
46Summary: -
ce39d734 47Summary(pl.UTF-8): -
352b3a3c 48Group: -
352b3a3c
TP
49
50%description subpackage
51
9be49f18 52%description subpackage -l pl.UTF-8
352b3a3c 53
5261abf9
ER
54%package libs
55Summary: -
ce39d734 56Summary(pl.UTF-8): -
5261abf9
ER
57Group: Libraries
58
59%description libs
60
9be49f18 61%description libs -l pl.UTF-8
5261abf9 62
88a5dbe9 63%package devel
c934cc1b 64Summary: Header files for ... library
ce39d734 65Summary(pl.UTF-8): Pliki nagłówkowe biblioteki ...
88a5dbe9 66Group: Development/Libraries
9a2e1218 67# if base package contains shared library for which these headers are
49683e54 68#Requires: %{name} = %{version}-%{release}
9a2e1218
JB
69# if -libs package contains shared library for which these headers are
70#Requires: %{name}-libs = %{version}-%{release}
88a5dbe9
ER
71
72%description devel
9a2e1218 73Header files for ... library.
c934cc1b 74
9be49f18
JR
75%description devel -l pl.UTF-8
76Pliki nagłówkowe biblioteki ....
88a5dbe9
ER
77
78%package static
79Summary: Static ... library
ce39d734 80Summary(pl.UTF-8): Statyczna biblioteka ...
88a5dbe9 81Group: Development/Libraries
c0c12927 82Requires: %{name}-devel = %{version}-%{release}
88a5dbe9
ER
83
84%description static
85Static ... library.
c0c12927 86
9be49f18 87%description static -l pl.UTF-8
c934cc1b
JB
88Statyczna biblioteka ....
89
e8b9df06 90%prep
c0c12927
ER
91%setup -q
92#%setup -q -c -T
93#%setup -q -n %{name}
10428dcb 94#%setup -q -n %{name}-%{version}.orig -a 1
4b97f9d0 95#%patch0 -p1
e8b9df06 96
c0c12927 97# undos the source
bd5b2cfe 98#find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 sed -i -e 's,\r$,,'
c0c12927
ER
99
100# remove CVS control files
101#find -name CVS -print0 | xargs -0 rm -rf
102
c2bc0219
ER
103# you'll need this if you cp -a complete dir in source
104# cleanup backups after patching
105find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
106
e8b9df06 107%build
c42a30cf
JB
108# if ac/am/* rebuilding is necessary, do it in this order and add
109# appropriate BuildRequires
bd5b2cfe 110#%%{__intltoolize}
37416b6e 111#%%{__gettextize}
8f37ba72 112#%%{__libtoolize}
37416b6e 113#%%{__aclocal}
114#%%{__autoconf}
115#%%{__autoheader}
116#%%{__automake}
de41dae9 117#cp -f /usr/share/automake/config.sub .
19bf1c4b 118%configure
e8b9df06
SZ
119%{__make}
120
c0c12927
ER
121#%{__make} \
122# CFLAGS="%{rpmcflags}" \
123# LDFLAGS="%{rpmldflags}"
124
e8b9df06
SZ
125%install
126rm -rf $RPM_BUILD_ROOT
d43856e1
JB
127# create directories if necessary
128#install -d $RPM_BUILD_ROOT
c0c12927 129#install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
e8b9df06 130
a984843b
SP
131%{__make} install \
132 DESTDIR=$RPM_BUILD_ROOT
e8b9df06 133
f5bb3874
JB
134%clean
135rm -rf $RPM_BUILD_ROOT
136
e8b9df06
SZ
137%pre
138
e8b9df06
SZ
139%post
140
b187ef53
JB
141%preun
142
e8b9df06 143%postun
c0c12927
ER
144
145%if %{with ldconfig}
146%post -p /sbin/ldconfig
147%postun -p /sbin/ldconfig
148%endif
149
150%if %{with initscript}
151%post init
152/sbin/chkconfig --add %{name}
153%service %{name} restart
154
155%preun init
156if [ "$1" = "0" ]; then
157 %service -q %{name} stop
158 /sbin/chkconfig --del %{name}
159fi
160%endif
e8b9df06 161
e8b9df06
SZ
162%files
163%defattr(644,root,root,755)
024e628a 164%doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
cec32492 165
5e539df2 166%if 0
11877175
ER
167# if _sysconfdir != /etc:
168#%%dir %{_sysconfdir}
9c3f0ed0 169%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
0b279ca0 170%attr(755,root,root) %{_bindir}/*
171%{_datadir}/%{name}
5e539df2 172%endif
f1b2d418 173
d1184c8c 174# initscript and its config
5e539df2 175%if %{with initscript}
2482ba2c 176%attr(754,root,root) /etc/rc.d/init.d/%{name}
9c3f0ed0 177%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
5e539df2 178%endif
2482ba2c 179
c0c12927
ER
180#%{_examplesdir}/%{name}-%{version}
181
49683e54 182%if %{with subpackage}
f1b2d418
TP
183%files subpackage
184%defattr(644,root,root,755)
5e539df2
ER
185#%doc extras/*.gz
186#%{_datadir}/%{name}-ext
49683e54 187%endif
This page took 0.092533 seconds and 4 git commands to generate.