]> git.pld-linux.org Git - packages/systemtap.git/blame - systemtap.spec
- add rpm5 support (patch from mandriva)
[packages/systemtap.git] / systemtap.spec
CommitLineData
87230ea0 1#
2# TODO: - enable server
3# - BRs
4# - more configure options
5#
099db71a 6%bcond_with doc
aa39e90e 7Summary: Instrumentation System
7ad1ccd0 8Summary(pl.UTF-8): System oprzyrządowania
aa39e90e 9Name: systemtap
099db71a
AM
10Version: 1.8
11Release: 0.1
839ed024 12License: GPL v2+
aa39e90e 13Group: Base
43d6c0ff 14Source0: http://sources.redhat.com/systemtap/ftp/releases/%{name}-%{version}.tar.gz
099db71a 15# Source0-md5: 5b7ab0ae0efc520f0b19f9dbf11977c9
459a2a3b 16Patch0: %{name}-configure.patch
099db71a 17Patch1: %{name}-build.patch
6fbeb569 18Patch2: %{name}-rpm5-support.patch
ff9bc29b 19URL: http://sourceware.org/systemtap/
60a0430a
JB
20BuildRequires: autoconf
21BuildRequires: automake
099db71a
AM
22BuildRequires: xmlto
23BuildRequires: avahi-devel
aa39e90e
AM
24BuildRequires: elfutils-devel
25BuildRequires: glib2-devel
26BuildRequires: mysql-devel
099db71a
AM
27BuildRequires: nss-devel
28BuildRequires: sqlite3-devel
29BuildRequires: texlive-latex
aa39e90e
AM
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33SystemTap is an instrumentation system for systems running Linux 2.6.
34Developers can write instrumentation to collect data on the operation
35of the system.
36
3bf8b266
JR
37%description -l pl.UTF-8
38SystemTap to system oprzyrządowania dla systemów opartych na Linuksie
392.6. Programiści mogą pisać narzędzia do zbierania danych dotyczących
ff9bc29b
JB
40operacji w systemie.
41
099db71a
AM
42%package server
43Summary: Instrumentation System Server
44License: GPL v2+
45Group: Applications/System
46URL: http://sourceware.org/systemtap/
47Requires: /bin/mktemp
48Requires: systemtap-devel = %{version}-%{release}
49Requires: unzip
50Requires: zip
51Requires(post): /sbin/chkconfig
52Requires(preun): /sbin/chkconfig
53
54%description server
55This is the remote script compilation server component of systemtap.
56It announces itself to nearby clients with avahi (if available), and
57compiles systemtap scripts to kernel objects on their demand.
58
59
60%package devel
61Summary: Programmable system-wide instrumentation system - development headers, tools
62License: GPL v2+
63Group: Development/Libraries
64URL: http://sourceware.org/systemtap/
65Requires: gcc
66Requires: linux-libc-headers
67Requires: make
68
69%description devel
70This package contains the components needed to compile a systemtap
71script from source form into executable (.ko) forms. It may be
72installed on a self-contained developer workstation (along with the
73systemtap-client and systemtap-runtime packages), or on a dedicated
74remote server (alongside the systemtap-server package). It includes a
75copy of the standard tapset library and the runtime library C files.
76
77%package runtime
78Summary: Programmable system-wide instrumentation system - runtime
79License: GPL v2+
80Group: Base
81URL: http://sourceware.org/systemtap/
82
83%description runtime
84SystemTap runtime contains the components needed to execute a
85systemtap script that was already compiled into a module using a local
86or remote systemtap-devel installation.
87
88%package client
89Summary: Programmable system-wide instrumentation system - client
90License: GPL v2+
91Group: Base
92URL: http://sourceware.org/systemtap/
93Requires: coreutils
94Requires: grep
95Requires: openssh-clients
96Requires: sed
97Requires: systemtap-runtime = %{version}-%{release}
98Requires: unzip
99Requires: zip
100
101%description client
102This package contains/requires the components needed to develop
103systemtap scripts, and compile them using a local systemtap-devel or a
104remote systemtap-server installation, then run them using a local or
105remote systemtap-runtime. It includes script samples and
106documentation, and a copy of the tapset library for reference.
107
108
109%package initscript
110Summary: Systemtap Initscripts
111License: GPL v2+
112Group: Base
113URL: http://sourceware.org/systemtap/
114Requires: systemtap = %{version}-%{release}
115Requires(post): /sbin/chkconfig
116Requires(preun): /sbin/chkconfig
117Requires(preun): rc-scripts
118Requires(postun): rc-scripts
119
120%description initscript
121Sysvinit scripts to launch selected systemtap scripts at system
122startup.
123
124%package sdt-devel
125Summary: Static probe support tools
126License: GPLv2+ and Public Domain
127Group: Development/Libraries
128URL: http://sourceware.org/systemtap/
129
130%description sdt-devel
131This package includes the <sys/sdt.h> header file used for static
132instrumentation compiled into userspace programs and libraries, along
133with the optional dtrace-compatibility preprocessor to process related
134.d files into tracing-macro-laden .h headers.
135
aa39e90e 136%prep
459a2a3b 137%setup -q
138%patch0 -p1
099db71a 139%patch1 -p1
6fbeb569 140%patch2 -p1
26f73914 141
aa39e90e 142%build
459a2a3b 143%{__aclocal}
144%{__autoconf}
145%{__autoheader}
146%{__automake}
147%configure \
099db71a
AM
148 --disable-silent-rules \
149 --enable-pie \
150 --enable-sqlite \
151 --%{?with_doc:en}%{!?with_doc:dis}able-docs \
152 --enable-server
aa39e90e
AM
153%{__make}
154
155%install
156rm -rf $RPM_BUILD_ROOT
aa39e90e 157
43d6c0ff 158%{__make} install \
aa39e90e
AM
159 DESTDIR=$RPM_BUILD_ROOT
160
43d6c0ff 161install -d $RPM_BUILD_ROOT/var/cache/%{name}
aa39e90e 162
099db71a
AM
163%find_lang %{name}
164
a3bbe4b0 165%clean
166rm -rf $RPM_BUILD_ROOT
167
aa39e90e
AM
168%files
169%defattr(644,root,root,755)
839ed024 170%doc AUTHORS HACKING NEWS README*
43d6c0ff 171%doc %{_docdir}
46b51978 172%attr(755,root,root) %{_bindir}/stap
839ed024 173%attr(755,root,root) %{_bindir}/stap-merge
174%attr(755,root,root) %{_bindir}/stap-report
175%attr(755,root,root) %{_bindir}/stapgraph
46b51978 176%attr(755,root,root) %{_bindir}/staprun
43d6c0ff 177%{_datadir}/%{name}
178%{_libexecdir}/%{name}
179%dir /var/cache/%{name}
099db71a
AM
180#%{_mandir}/man1/*.1*
181#%{_mandir}/man3/*.3*
182#%{_mandir}/man7/*.7*
183#%{_mandir}/man8/*.8*
184
185%files sdt-devel -f %{name}.lang
186%defattr(644,root,root,755)
187%attr(755,root,root) %{_bindir}/dtrace
188%{_includedir}/sys/sdt.h
189%{_includedir}/sys/sdt-config.h
190%{_mandir}/man1/dtrace.1*
This page took 0.065301 seconds and 4 git commands to generate.