]> git.pld-linux.org Git - packages/systemd.git/blame - systemd.spec
- fix dirs
[packages/systemd.git] / systemd.spec
CommitLineData
ede8d3e5 1#
9c4bd736 2# TODO:
3# - gtk BRs: libnotify 0.7 and gtk+3
4# - subpackages: bash-autocompletion, dbus(?), gtk, others?
5# - more BRs
6#
ede8d3e5 7
9c0b975d 8%bcond_with gtk # build gtk tools
9
ede8d3e5 10Summary: systemd - a system and service manager for Linux
11Summary(pl.UTF-8): systemd - zarządca systemu i usług dla Linuksa
12Name: systemd
13Version: 15
14Release: 0.1
15License: GPL v2+
16Group: Base
17Source0: http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.bz2
18# Source0-md5: 36011aa8593862ca78e3e909f6143570
19URL: http://www.freedesktop.org/wiki/Software/systemd
ede8d3e5 20BuildRequires: autoconf
21BuildRequires: automake
9c0b975d 22BuildRequires: dbus-devel
9c0b975d 23%if %{with gtk}
24BuildRequires: libnotify-devel >= 0.7.0
25%endif
ede8d3e5 26BuildRequires: libtool
27BuildRequires: udev-devel >= 160
eb2fda66 28BuildRequires: vala >= 0.11
ede8d3e5 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
1c239f8b 32systemd is a system and service manager for Linux, compatible with
ede8d3e5 33SysV and LSB init scripts. systemd provides aggressive parallelization
34capabilities, uses socket and D-Bus activation for starting services,
35offers on-demand starting of daemons, keeps track of processes using
36Linux cgroups, supports snapshotting and restoring of the system
37state, maintains mount and automount points and implements an
38elaborate transactional dependency-based service control logic. It can
1c239f8b 39work as a drop-in replacement for sysvinit.
ede8d3e5 40
41%description -l pl.UTF-8
42systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
43skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
44paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
45oferuje uruchamianie usług na życzenie, monitoruje procesy używając
46linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
47(restore) stanu systemu, zarządza (auto)mount pointami oraz
48implementuje starannie opracowaną transakcjonalną, bazującą na
49zależnościach logikę kontroli usług. Może pracować jako zastepca dla
50sysvinit.
51
52%prep
53%setup -q
54
55%build
ede8d3e5 56%{__autoconf}
57%{__automake}
9c0b975d 58%configure \
e1d9cc15 59 --with-distro=other \
60 --%{?with_gtk:en}%{!?with_gtk:dis}able-gtk \
61 --with-syslog-service=syslog-ng \
62 --with-sysvinit-path=/etc/rc.d/init.d \
1c239f8b 63 --with-sysvrcd-path=/etc/rc.d \
64 --with-rootdir=/usr
e1d9cc15 65
ede8d3e5 66%{__make}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70
71%{__make} install \
72 DESTDIR=$RPM_BUILD_ROOT
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%files
78%defattr(644,root,root,755)
1c239f8b 79%doc DISTRO_PORTING README TODO
80%attr(755,root,root) %{_bindir}/systemctl
81%attr(755,root,root) %{_bindir}/systemd
82%attr(755,root,root) %{_bindir}/systemd-ask-password
83%attr(755,root,root) %{_bindir}/systemd-cgls
84%attr(755,root,root) %{_bindir}/systemd-notify
85%attr(755,root,root) %{_bindir}/systemd-tty-ask-password-agent
86%{_prefix}/lib/systemd/
87/etc/dbus-1/system.d/org.freedesktop.systemd1.conf
58f74834 88%{_sysconfdir}/systemd
89%{_sysconfdir}/tmpfiles.d
90%{_sysconfdir}/xdg/systemd
1c239f8b 91/lib/udev/rules.d/99-systemd.rules
92%{_lib}/security/pam_systemd.la
93%attr(755,root,root) %{_lib}/security/pam_systemd.so
94%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Automount.xml
95%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Device.xml
96%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Job.xml
97%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Manager.xml
98%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Mount.xml
99%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Path.xml
100%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Service.xml
101%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Snapshot.xml
102%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Socket.xml
103%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Swap.xml
104%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Target.xml
105%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Timer.xml
106%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Unit.xml
107%{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
108%{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
109%{_mandir}/man1/init.1
110%{_mandir}/man1/systemadm.1*
111%{_mandir}/man1/systemctl.1*
112%{_mandir}/man1/systemd-cgls.1*
113%{_mandir}/man1/systemd-notify.1*
114%{_mandir}/man1/systemd.1*
115%{_mandir}/man3/sd_booted.3*
116%{_mandir}/man3/sd_is_fifo.3*
117%{_mandir}/man3/sd_is_socket.3
118%{_mandir}/man3/sd_is_socket_inet.3
119%{_mandir}/man3/sd_is_socket_unix.3
120%{_mandir}/man3/sd_listen_fds.3*
121%{_mandir}/man3/sd_notify.3*
122%{_mandir}/man3/sd_notifyf.3
123%{_mandir}/man3/sd_readahead.3*
124%{_mandir}/man5/hostname.5*
125%{_mandir}/man5/locale.conf.5*
126%{_mandir}/man5/modules-load.d.5*
127%{_mandir}/man5/os-release.5*
128%{_mandir}/man5/systemd.automount.5*
129%{_mandir}/man5/systemd.conf.5*
130%{_mandir}/man5/systemd.device.5*
131%{_mandir}/man5/systemd.exec.5*
132%{_mandir}/man5/systemd.mount.5*
133%{_mandir}/man5/systemd.path.5*
134%{_mandir}/man5/systemd.service.5*
135%{_mandir}/man5/systemd.snapshot.5*
136%{_mandir}/man5/systemd.socket.5*
137%{_mandir}/man5/systemd.swap.5*
138%{_mandir}/man5/systemd.target.5*
139%{_mandir}/man5/systemd.timer.5*
140%{_mandir}/man5/systemd.unit.5*
141%{_mandir}/man5/tmpfiles.d.5*
142%{_mandir}/man5/vconsole.conf.5*
143%{_mandir}/man7/daemon.7*
144%{_mandir}/man7/sd-daemon.7*
145%{_mandir}/man7/sd-readahead.7*
146%{_mandir}/man7/systemd.special.7*
147%{_mandir}/man8/halt.8*
148%{_mandir}/man8/pam_systemd.8*
149%{_mandir}/man8/poweroff.8
150%{_mandir}/man8/reboot.8
151%{_mandir}/man8/runlevel.8*
152%{_mandir}/man8/shutdown.8*
153%{_mandir}/man8/telinit.8*
154%{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
155%{_datadir}/systemd
This page took 0.083393 seconds and 4 git commands to generate.