]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- rel 5
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
b4d1f957 2# - fix java build with java-gcj-compat and s/java-sun/jdk/
1930bef0 3# - remove net_client_only and add db bcond (then without apache and
4# without db => net_client_only - spec will be more simpler, I think)
d46e45ba 5# - finish ruby
9688ba4c 6# - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
1930bef0 7#
bab73684 8# Conditional build:
65c1d4bd 9%bcond_with net_client_only # build only net client
3fc01170 10%bcond_without neon # use serf instead of neon
65c1d4bd
JB
11%bcond_without python # build without python bindings (broken)
12%bcond_without perl # build without perl bindings
73ab938a 13%bcond_without ruby # build without ruby bindings
65c1d4bd
JB
14%bcond_without apache # build without apache support (webdav, etc)
15%bcond_without javahl # build without javahl support (Java high-level bindings)
16%bcond_without tests # don't perform "make check"
65f2befa 17%bcond_without kwallet # build without kde4 wallet support
bfb248d0 18%bcond_without gnome # build without gnome keyring support
7b27380f 19#
bc126282 20%ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
c2f5643d 21%undefine with_javahl
bc126282
AG
22%endif
23#
b56474ff 24%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 25%define apxs /usr/sbin/apxs
1f630180
ER
26%define pdir SVN
27%define pnam _Core
12ae68c1 28#
04129f48 29%if %{with neon}
a510fada 30%define webdavlib neon
04129f48
AG
31%else
32%define webdavlib serf
a510fada
AM
33%endif
34#
67cb9518 35Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
36Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
37Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 38Name: subversion
dc8fcc41 39Version: 1.6.9
ba425c92 40Release: 5
6f88d80e 41License: Apache/BSD-like
93b78127 42Group: Development/Version Control
a5c00029 43Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
dc8fcc41 44# Source0-md5: 9c30a47b1d48664e7afef68bb4834c53
93b78127 45Source1: %{name}-dav_svn.conf
65318afa 46Source2: %{name}-authz_svn.conf
b56474ff
AM
47Source3: %{name}-svnserve.init
48Source4: %{name}-svnserve.sysconfig
a510fada
AM
49# current subversion tarball has correct *.swg files
50# but after regeneration these are broken again, so
51# we still need this script
f313e9a9 52Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 53Patch0: %{name}-home_etc.patch
d46e45ba 54Patch1: %{name}-DESTDIR.patch
00664663 55Patch2: %{name}-ruby-datadir-path.patch
dc8fcc41 56URL: http://subversion.apache.org/
4945947e
AM
57%if %{with net_client_only}
58%global apache_modules_api 0
59%else
f2a757d6 60%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 61BuildRequires: automake
3817faf5 62BuildRequires: db-devel >= 4.1.25
e8d9186f 63BuildRequires: rpmbuild(macros) >= 1.268
0905b458 64%if %{with perl}
522a69b4 65BuildRequires: perl-devel >= 1:5.8.0
66BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 67BuildRequires: swig-perl >= 1.3.24
536b3fd3 68%endif
6ac3574b
AM
69%if %{with python}
70BuildRequires: python-ctypesgen
71BuildRequires: python-devel >= 2.2
72BuildRequires: swig-python >= 1.3.24
73%endif
74%if %{with ruby}
75BuildRequires: ruby-devel
76BuildRequires: swig-ruby >= 1.3.24
77%endif
af0d490b
AM
78%if %{with javahl}
79BuildRequires: java-sun
80BuildRequires: java-sun-tools
81%endif
6ac3574b 82BuildRequires: cyrus-sasl-devel
0905b458 83%endif
16429189 84BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 85BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 86BuildRequires: autoconf >= 2.59
79d8c53c 87BuildRequires: bison
93b78127 88BuildRequires: expat-devel
86ea8fde 89BuildRequires: gettext-devel
bfb248d0 90%{?with_gnome:BuildRequires: gnome-keyring-devel}
65f2befa 91%{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
f4e6a380 92BuildRequires: libtool >= 1.4-9
54271075 93BuildRequires: pkgconfig
a562165a 94BuildRequires: sed >= 4.0
c26d84c4 95BuildRequires: sqlite3-devel >= 3.6.11
a562165a
JB
96BuildRequires: texinfo
97BuildRequires: which
98%if %{with neon}
bd3c99a8 99BuildRequires: neon-devel >= 0.26.0
a562165a
JB
100%else
101BuildRequires: serf-devel
e3ad24ea 102%endif
53855fbf 103BuildRequires: python >= 2.2
ed6210a2 104BuildRequires: python-modules >= 2.2
027f8ebe 105Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
106BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
f4070f5f 108%define _libexecdir %{_libdir}/svn
1af5e34d
ER
109%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
110%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127
AM
111
112%description
113The goal of the Subversion project is to build a version control
114system that is a compelling replacement for CVS in the open source
115community.
116
117Our goals are:
118- All current CVS features.
119- Directories, renames, and file meta-data are versioned.
120- Symbolic links, etc, are supported
121- Commits are truly atomic.
122- Branching and tagging are cheap (constant time) operations
123- Repeated merges are handled gracefully
124- Support for plug-in client side diff programs
125- Natively client/server
126- Client/server protocol sends diffs in both directions
127- Costs are proportional to change size, not project size
128- Internationalization
129- Progressive multi-lingual support
130
aa59005f 131%description -l pl.UTF-8
93b78127
AM
132Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
133zamiennika dla CVS.
134
135Cele projektu to:
aa59005f 136- Wszystkie aktualne możliwości CVS.
24406120
JB
137- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
138- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
139- Commity są w pełni atomowe.
140- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
141- Dobra obsługa powtarzanego łączenia (merge).
142- Obsługa wtyczek diff po stronie klienta.
93b78127 143- Natywny klient/serwer.
aa59005f 144- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
145- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
146- Internacjonalizacja.
aa59005f 147- Postępujące wsparcie dla wielu języków.
93b78127 148
aa59005f
JR
149%description -l pt_BR.UTF-8
150O objetivo do projeto Subversion é construir um sistema de controle de
151versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 152System) na comunidade opensource, fornecendo grandes melhorias.
153
f4e6a380
AM
154%package libs
155Summary: Subversion libraries and modules
abe3c421 156Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 157Group: Libraries
04129f48 158%{?with_neon:Requires: neon >= 0.26.0}
53855fbf 159Obsoletes: libsubversion0
f4e6a380
AM
160
161%description libs
162Subversion libraries and modules.
163
aa59005f
JR
164%description libs -l pl.UTF-8
165Biblioteka subversion oraz ładowalne moduły.
f4e6a380 166
93b78127
AM
167%package devel
168Summary: Header files and develpment documentation for subversion
abe3c421
ER
169Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
170Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 171Group: Development/Libraries
9cb7e099 172Requires: %{name}-libs = %{version}-%{release}
c5b1d686 173Requires: apr-util-devel >= 1:1.0.0
04129f48 174%{?with_neon:Requires: neon-devel >= 0.26.0}
12cf252c 175Obsoletes: libsubversion0-devel
93b78127
AM
176
177%description devel
178Header files and develpment documentation for subversion.
179
aa59005f
JR
180%description devel -l pl.UTF-8
181Pliki nagłówkowe i dokumetacja do subversion.
93b78127 182
aa59005f
JR
183%description devel -l pt_BR.UTF-8
184Este pacote provê os arquivos necessários para desenvolvedores
92066deb 185interagirem com o Subversion.
186
93b78127
AM
187%package static
188Summary: Static subversion library
abe3c421
ER
189Summary(pl.UTF-8): Biblioteka statyczna subversion
190Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
191Group: Development/Libraries
192Requires: %{name}-devel = %{version}
12cf252c 193Obsoletes: libsubversion0-static-devel
93b78127
AM
194
195%description static
196Static subversion library.
197
aa59005f 198%description static -l pl.UTF-8
93b78127
AM
199Biblioteka statyczna subversion.
200
aa59005f
JR
201%description static -l pt_BR.UTF-8
202Este pacote provê um cliente estático do subversion.
92066deb 203
b56474ff
AM
204%package svnserve
205Summary: Subversion svnserve
abe3c421 206Summary(pl.UTF-8): Subversion svnserve
b56474ff 207Group: Networking/Daemons
3817faf5 208Requires(post,preun): /sbin/chkconfig
93f1d402 209Requires(postun): /usr/sbin/groupdel
210Requires(postun): /usr/sbin/userdel
211Requires(pre): /bin/id
212Requires(pre): /usr/bin/getgid
213Requires(pre): /usr/lib/rpm/user_group.sh
214Requires(pre): /usr/sbin/groupadd
215Requires(pre): /usr/sbin/useradd
216Requires(pre): /usr/sbin/usermod
9cb7e099 217Requires: %{name} = %{version}-%{release}
7b27380f 218Requires: rc-scripts
a1bac09d
219Provides: group(svn)
220Provides: user(svn)
b56474ff
AM
221
222%description svnserve
223Subversion svnserve server.
224
aa59005f 225%description svnserve -l pl.UTF-8
b56474ff
AM
226Serwer subversion svnserve.
227
4bbdbbf8
AM
228%package tools
229Summary: Subversion tools and scripts
abe3c421
ER
230Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
231Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 232Group: Applications
4bbdbbf8 233%pyrequires_eq python
7b27380f 234Requires: %{name} = %{version}-%{release}
4bbdbbf8
AM
235Requires: python-subversion = %{version}
236
237%description tools
238Subversion tools and scripts.
239
aa59005f
JR
240%description tools -l pl.UTF-8
241Narzędzia oraz skrypty dla subversion.
4bbdbbf8 242
fe5bb6bb 243%package -n bash-completion-subversion
244Summary: bash completion for subversion
abe3c421 245Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 246Group: Applications/Shells
e30588c4 247Requires: %{name} = %{version}-%{release}
53855fbf 248Requires: bash-completion
e30588c4 249Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 250
251%description -n bash-completion-subversion
252Bash completion for subversion.
253
aa59005f
JR
254%description -n bash-completion-subversion -l pl.UTF-8
255Dopełnienia basha dla subversion.
fe5bb6bb 256
1cc7453a 257%package -n java-subversion
65c1d4bd
JB
258Summary: Subversion Java bindings
259Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 260Group: Development/Languages/Java
261Requires: %{name}-libs = %{version}-%{release}
262
263%description -n java-subversion
264This is a set of Java classes which provide the functionality of
265subversion-libs, the Subversion libraries. It is useful if you want
266to, for example, write a Java class that manipulates a Subversion
267repository or working copy. See the 'subversion' package for more
268information.
269
65c1d4bd
JB
270%description -n java-subversion -l pl.UTF-8
271Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
272subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
d46e45ba
AM
273pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
274roboczą. Więcej informacji w pakiecie subversion.
65c1d4bd 275
fa3ff1b2 276%package -n python-subversion
65c1d4bd
JB
277Summary: Subversion Python bindings
278Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
279Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 280Group: Development/Languages/Python
f4e6a380 281%pyrequires_eq python
9cb7e099 282Requires: %{name}-libs = %{version}-%{release}
53855fbf 283Obsoletes: subversion-python
f4e6a380 284
fa3ff1b2 285%description -n python-subversion
65c1d4bd 286Subversion Python bindings.
f4e6a380 287
aa59005f 288%description -n python-subversion -l pl.UTF-8
65c1d4bd 289Dowiązania do Subversion dla Pythona.
f4e6a380 290
aa59005f 291%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 292Módulos Python para acessar os recursos do Subversion.
92066deb 293
137fcafd
AM
294%package -n python-csvn
295Summary: CTypes Subversion Python bindings
296Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
297Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
298Group: Development/Languages/Python
299%pyrequires_eq python
300Requires: %{name}-libs = %{version}-%{release}
301
302%description -n python-csvn
303Subversion CTypes Python bindings.
304
305%description -n python-csvn -l pl.UTF-8
306Dowiązania do Subversion dla Pythona używające CTypes.
307
308%description -n python-csvn -l pt_BR.UTF-8
309Módulos Python para acessar os recursos do Subversion.
310
b56474ff 311%package -n perl-subversion
65c1d4bd
JB
312Summary: Subversion Perl bindings
313Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
314Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 315Group: Development/Languages/Perl
9cb7e099 316Requires: %{name}-libs = %{version}-%{release}
53855fbf 317Obsoletes: subversion-perl
b56474ff
AM
318
319%description -n perl-subversion
65c1d4bd 320Subversion Perl bindings.
b56474ff 321
aa59005f 322%description -n perl-subversion -l pl.UTF-8
65c1d4bd 323Dowiązania do Subversion dla Perla.
b56474ff 324
aa59005f 325%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 326Módulos Perl para acessar os recursos do Subversion.
b56474ff 327
d46e45ba
AM
328%package -n ruby-subversion
329Summary: Subversion Ruby bindings
d2bf70bf 330Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
d46e45ba
AM
331Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
332Group: Development/Languages
333Requires: %{name}-libs = %{version}-%{release}
334Obsoletes: subversion-ruby
335
336%description -n ruby-subversion
337Subversion Ruby bindings.
338
339%description -n ruby-subversion -l pl.UTF-8
d2bf70bf 340Dowiązania do Subversion dla języka Ruby.
d46e45ba
AM
341
342%description -n ruby-subversion -l pt_BR.UTF-8
343Módulos Ruby para acessar os recursos do Subversion.
344
93b78127
AM
345%package -n apache-mod_dav_svn
346Summary: Apache module: Subversion Server
abe3c421 347Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 348Group: Networking/Daemons
7b27380f 349Requires: %{name} = %{version}-%{release}
53855fbf 350Requires: apache(modules-api) = %apache_modules_api
7887b1ac 351Requires: apache-mod_dav
93b78127
AM
352
353%description -n apache-mod_dav_svn
354Apache module: Subversion Server.
355
aa59005f
JR
356%description -n apache-mod_dav_svn -l pl.UTF-8
357Moduł apache: Serwer Subversion.
93b78127 358
65318afa
AF
359%package -n apache-mod_authz_svn
360Summary: Apache module: Subversion Server - path-based authorization
abe3c421 361Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 362Group: Networking/Daemons
53855fbf 363Requires: apache(modules-api) = %apache_modules_api
9cb7e099 364Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
365
366%description -n apache-mod_authz_svn
367Apache module: Subversion Server - path-based authorization.
368
aa59005f
JR
369%description -n apache-mod_authz_svn -l pl.UTF-8
370Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 371
1429fa1c
AM
372%package -n gnome-keyring-subversion
373Summary: Subversion module for Gnome Keyring
374Summary(pl.UTF-8): Moduł subversion dla zarządcy kluczy Gnome
375Group: X11/Applications
376
377%description -n gnome-keyring-subversion
378Subversion module for Gnome Keyring.
379
380%description -n gnome-keyring-subversion -l pl.UTF-8
381Moduł subversion dla zarządcy kluczy Gnome.
382
383%package -n kde4-kwallet-subversion
384Summary: Subversion module for KDE Wallet
385Summary(pl.UTF-8): Moduł subversion dla Portfela KDE
386Group: X11/Applications
387
388%description -n kde4-kwallet-subversion
389Subversion module for KDE Wallet.
390
391%description -n kde4-kwallet-subversion -l pl.UTF-8
392Moduł subversion dla Portfela KDE.
393
93b78127 394%prep
a5c00029 395%setup -q
e30588c4 396rm -rf apr apr-util neon
ed6210a2 397%patch0 -p0
d4bccc60 398%patch1 -p1
00664663 399%patch2 -p0
a510fada
AM
400
401sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
402
403# serf.m4 macro is broken and ignores --without serf
244bdb04 404%{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
027f8ebe 405
93b78127 406%build
93f1d402 407rm subversion/bindings/swig/proxy/*.swg
24406120 408cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 409cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 410chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 411
93b78127 412%configure \
5dfeafd7 413 --with-editor=vi \
12ae68c1 414 --with-zlib=%{_libdir} \
536b3fd3
AM
415%if %{with net_client_only}
416 --without-apache \
417 --without-swig \
418 --without-apxs \
419 --without-berkeley-db \
420%else
fa6fa2cf 421 --disable-runtime-module-search \
86ee97d3 422 --disable-mod-activation \
ad5c551e 423 --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
0905b458 424%if %{with apache}
536b3fd3 425 --with-apxs=%{_sbindir}/apxs \
0905b458 426%else
427 --without-apache \
428 --without-apxs \
0905b458 429%endif
73ab938a 430%if !%{with python} && !%{with perl} && !%{with ruby}
0905b458 431 --without-swig \
432%endif
137fcafd 433 %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
1cc7453a 434 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 435%endif
1cc7453a 436 --with-jdk="%{java_home}" \
04129f48 437%if %{with neon}
e3ad24ea 438 --without-serf \
e30588c4 439 --with-neon=%{_prefix} \
78f330c4 440 --disable-neon-version-check \
04129f48
AG
441%else
442 --with-serf=%{_prefix} \
443 --without-neon \
e3ad24ea 444%endif
16429189 445 --with-apr=%{_bindir}/apr-1-config \
1429fa1c 446 --with-apr-util=%{_bindir}/apu-1-config \
65f2befa 447%if %{with kwallet}
1429fa1c 448 --with-kwallet \
65f2befa 449%endif
bfb248d0 450%if %{with gnome}
1429fa1c 451 --with-gnome-keyring
bfb248d0 452%endif
536b3fd3 453
1f630180 454%{__make} -j1
536b3fd3 455
cf353d53 456%if !%{with net_client_only}
b56474ff 457# python
0905b458 458%if %{with python}
137fcafd
AM
459# ctypes bindings
460%{__make} ctypes-python
461# swig bindings
86a4919e 462%{__make} swig-py \
65318afa
AF
463 swig_pydir=%{py_sitedir}/libsvn \
464 swig_pydir_extra=%{py_sitedir}/svn
0905b458 465%endif
b56474ff 466# perl
0905b458 467%if %{with perl}
390bb8f4 468%{__make} -j1 swig-pl-lib
bf539998
AM
469odir=$(pwd)
470cd subversion/bindings/swig/perl/native
471%{__perl} Makefile.PL INSTALLDIRS=vendor
b445847c 472%{__make} -j1
bf539998 473cd $odir
536b3fd3 474%endif
1cc7453a 475%if %{with javahl}
b445847c 476%{__make} -j1 javahl \
1cc7453a 477 javahl_javadir="%{_javadir}"
478%endif
d46e45ba
AM
479# ruby
480%if %{with ruby}
481%{__make} swig-rb
482%endif
12ae68c1
AM
483%endif
484
485%if %{with tests}
486%{__make} check
d46e45ba 487%if %{with python}
137fcafd 488%{__make} check-ctypes-python
d46e45ba
AM
489%{__make} check-swig-py
490%endif
491%if %{with perl}
492%{__make} check-swig-pl
493%endif
494%if %{with ruby}
495%{__make} check-swig-rb
496%endif
0905b458 497%endif
93b78127
AM
498
499%install
500rm -rf $RPM_BUILD_ROOT
1326bb99 501install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 502 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 503 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 504 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 505
1f630180 506%{__make} install -j1 \
1cc7453a 507%if %{with javahl}
508 install-javahl \
509 javahl_javadir="%{_javadir}" \
510%endif
d46e45ba
AM
511%if !%{with net_client_only}
512%if %{with python}
0905b458 513 install-swig-py \
137fcafd 514 install-ctypes-python \
d46e45ba
AM
515%endif
516%if %{with ruby}
517 install-swig-rb install-swig-rb-doc \
518%endif
0905b458 519%endif
f2a757d6 520 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 521 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
522 swig_pydir=%{py_sitedir}/libsvn \
523 swig_pydir_extra=%{py_sitedir}/svn
93b78127 524
cf353d53 525%if !%{with net_client_only} && %{with perl}
bf539998
AM
526%{__make} install-swig-pl-lib \
527 DESTDIR=$RPM_BUILD_ROOT
b445847c 528%{__make} -C subversion/bindings/swig/perl/native install \
bf539998
AM
529 DESTDIR=$RPM_BUILD_ROOT \
530 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
531 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
bf539998
AM
532%endif
533
0905b458 534%if %{with apache}
1af5e34d
ER
535install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
536install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
537install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
538install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 539%endif
93b78127 540
cf353d53 541%if !%{with net_client_only}
1326bb99 542install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 543%if %{with python}
f4e6a380
AM
544%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
545%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
546find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
547install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 548%endif
0905b458 549%endif
f4e6a380 550
1326bb99
JK
551install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
552install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 553
205a3ddc
AM
554%find_lang %{name}
555
dd73606c 556%{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
c39b6844 557rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
558rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
a6ecf312 559
e23909be
JB
560%clean
561rm -rf $RPM_BUILD_ROOT
562
a1bac09d
563%pre svnserve
564%groupadd -g 86 svn
565%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
566
d2bf70bf
JB
567%post libs -p /sbin/ldconfig
568%postun libs -p /sbin/ldconfig
569
570%post devel -p /sbin/postshell
6f99c3bd 571-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 572
d2bf70bf 573%postun devel -p /sbin/postshell
6f99c3bd 574-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 575
d2bf70bf
JB
576%post -n perl-subversion -p /sbin/ldconfig
577%postun -n perl-subversion -p /sbin/ldconfig
578
579%post -n python-subversion -p /sbin/ldconfig
580%postun -n python-subversion -p /sbin/ldconfig
f4e6a380 581
b56474ff 582%post svnserve
e8d9186f
ER
583/sbin/chkconfig --add svnserve
584%service svnserve restart "svnserve daemon"
585
b56474ff
AM
586%preun svnserve
587if [ "$1" = "0" ]; then
e8d9186f
ER
588 %service svnserve stop
589 /sbin/chkconfig --del svnserve
b56474ff
AM
590fi
591
a1bac09d
592%postun svnserve
593if [ "$1" = "0" ]; then
594 %userremove svn
595 %groupremove svn
596fi
597
93b78127 598%post -n apache-mod_dav_svn
e8d9186f 599%service -q httpd restart
93b78127 600
ba425c92 601%postun -n apache-mod_dav_svn
93b78127 602if [ "$1" = "0" ]; then
e8d9186f 603 %service -q httpd restart
93b78127
AM
604fi
605
9688ba4c
JR
606%post -n apache-mod_authz_svn
607%service -q httpd restart
608
ba425c92 609%postun -n apache-mod_authz_svn
9688ba4c
JR
610if [ "$1" = "0" ]; then
611 %service -q httpd restart
612fi
613
93b78127
AM
614%files
615%defattr(644,root,root,755)
983a49f6 616%doc BUGS CHANGES COPYING INSTALL README
d37298dc 617%doc doc/*/*.html
4bbdbbf8
AM
618%doc tools/hook-scripts/*.{pl,py,example}
619%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 620%doc tools/xslt/*
b445847c
JB
621%attr(755,root,root) %{_bindir}/svn
622%attr(755,root,root) %{_bindir}/svnadmin
623%attr(755,root,root) %{_bindir}/svndumpfilter
624%attr(755,root,root) %{_bindir}/svnlook
625%attr(755,root,root) %{_bindir}/svnsync
626%attr(755,root,root) %{_bindir}/svnversion
627%{_mandir}/man1/svn.1*
628%{_mandir}/man1/svnadmin.1*
629%{_mandir}/man1/svndumpfilter.1*
630%{_mandir}/man1/svnlook.1*
631%{_mandir}/man1/svnsync.1*
632%{_mandir}/man1/svnversion.1*
f4e6a380 633
205a3ddc 634%files libs -f %{name}.lang
f4e6a380 635%defattr(644,root,root,755)
b445847c
JB
636%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
637%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
638%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
639%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
640%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
641%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
642%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
643%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
644%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
645%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
646%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
647%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
648%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
649%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
650%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
651%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
652%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
653%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
a510fada
AM
654%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
655%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
b445847c
JB
656%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
657%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
658%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
659%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
660%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
661%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
662%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
663%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
93b78127
AM
664
665%files devel
666%defattr(644,root,root,755)
b445847c
JB
667%attr(755,root,root) %{_libdir}/libsvn_client-1.so
668%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
669%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
670%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
671%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
672%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
673%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
674%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
675%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
a510fada 676%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
b445847c
JB
677%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
678%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
679%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
680%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
681%{_libdir}/libsvn_client-1.la
682%{_libdir}/libsvn_delta-1.la
683%{_libdir}/libsvn_diff-1.la
684%{_libdir}/libsvn_fs-1.la
685%{_libdir}/libsvn_fs_base-1.la
686%{_libdir}/libsvn_fs_fs-1.la
687%{_libdir}/libsvn_fs_util-1.la
688%{_libdir}/libsvn_ra-1.la
689%{_libdir}/libsvn_ra_local-1.la
a510fada 690%{_libdir}/libsvn_ra_%{webdavlib}-1.la
b445847c
JB
691%{_libdir}/libsvn_ra_svn-1.la
692%{_libdir}/libsvn_repos-1.la
693%{_libdir}/libsvn_subr-1.la
694%{_libdir}/libsvn_wc-1.la
695%{_includedir}/%{name}-1
1326bb99 696%{_examplesdir}/%{name}-%{version}
93b78127
AM
697
698%files static
699%defattr(644,root,root,755)
b445847c
JB
700%{_libdir}/libsvn_client-1.a
701%{_libdir}/libsvn_delta-1.a
702%{_libdir}/libsvn_diff-1.a
703%{_libdir}/libsvn_fs-1.a
704%{_libdir}/libsvn_fs_base-1.a
705%{_libdir}/libsvn_fs_fs-1.a
706%{_libdir}/libsvn_fs_util-1.a
707%{_libdir}/libsvn_ra-1.a
708%{_libdir}/libsvn_ra_local-1.a
a510fada 709%{_libdir}/libsvn_ra_%{webdavlib}-1.a
b445847c
JB
710%{_libdir}/libsvn_ra_svn-1.a
711%{_libdir}/libsvn_repos-1.a
712%{_libdir}/libsvn_subr-1.a
713%{_libdir}/libsvn_wc-1.a
93b78127 714
bfb248d0 715%if %{with gnome}
1429fa1c
AM
716%files -n gnome-keyring-subversion
717%defattr(644,root,root,755)
718%attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
719%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
bfb248d0 720%endif
1429fa1c 721
65f2befa 722%if %{with kwallet}
1429fa1c
AM
723%files -n kde4-kwallet-subversion
724%defattr(644,root,root,755)
725%attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
726%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
65f2befa 727%endif
1429fa1c 728
cf353d53 729%if !%{with net_client_only}
b56474ff
AM
730%files svnserve
731%defattr(644,root,root,755)
732%attr(755,root,root) %{_bindir}/svnserve
b445847c
JB
733%{_mandir}/man5/svnserve.conf.5*
734%{_mandir}/man8/svnserve.8*
a1bac09d
735%dir %attr(750,svn,svn) /home/services/subversion
736%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 737%if %{with apache}
b56474ff 738%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 739%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 740%endif
b56474ff 741
4bbdbbf8
AM
742%files tools
743%defattr(644,root,root,755)
1326bb99 744%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 745
746%files -n bash-completion-subversion
101e74de 747%defattr(644,root,root,755)
1326bb99 748/etc/bash_completion.d/%{name}
536b3fd3 749
1cc7453a 750%if %{with javahl}
751%files -n java-subversion
752%defattr(644,root,root,755)
b445847c
JB
753%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
754%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
755%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
1cc7453a 756%{_javadir}/svn-javahl.jar
757%endif
758
0905b458 759%if %{with python}
fa3ff1b2 760%files -n python-subversion
f4e6a380 761%defattr(644,root,root,755)
4bbdbbf8 762%doc tools/backup/*.py tools/examples/*.py
b445847c
JB
763%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
764%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
765%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
65318afa 766%dir %{py_sitedir}/libsvn
65318afa 767%{py_sitedir}/libsvn/*.py[co]
b445847c
JB
768%dir %{py_sitedir}/svn
769%{py_sitedir}/svn/*.py[co]
65318afa 770%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 771%{_examplesdir}/python-%{name}-%{version}
137fcafd
AM
772
773%files -n python-csvn
774%defattr(644,root,root,755)
775%doc subversion/bindings/ctypes-python/{README,TODO}
776%doc subversion/bindings/ctypes-python/examples/*.py
777%dir %{py_sitescriptdir}/csvn
778%{py_sitescriptdir}/csvn/*.py[co]
779%dir %{py_sitescriptdir}/csvn/core
780%{py_sitescriptdir}/csvn/core/*.py[co]
781%dir %{py_sitescriptdir}/csvn/ext
782%{py_sitescriptdir}/csvn/ext/*.py[co]
783%{py_sitescriptdir}/*.egg-info
0905b458 784%endif
f4e6a380 785
0905b458 786%if %{with perl}
b56474ff
AM
787%files -n perl-subversion
788%defattr(644,root,root,755)
b445847c
JB
789%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
790%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
791%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
b56474ff
AM
792%{perl_vendorarch}/SVN
793%dir %{perl_vendorarch}/auto/SVN
794%dir %{perl_vendorarch}/auto/SVN/*
795%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
796%{perl_vendorarch}/auto/SVN/*/*.bs
797%{_mandir}/man3/*.3pm*
0905b458 798%endif
b56474ff 799
d46e45ba
AM
800%if %{with ruby}
801%files -n ruby-subversion
802%defattr(644,root,root,755)
b445847c
JB
803%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
804%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
805%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
916011ef
JR
806%dir %{ruby_sitelibdir}/svn
807%{ruby_sitelibdir}/svn/*.rb
808%dir %{ruby_sitearchdir}/svn
809%dir %{ruby_sitearchdir}/svn/ext
e2c6dc67 810%attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
916011ef 811%{ruby_ridir}/Svn
d46e45ba
AM
812%endif
813
0905b458 814%if %{with apache}
93b78127
AM
815%files -n apache-mod_dav_svn
816%defattr(644,root,root,755)
1af5e34d
ER
817%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
818%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
819
820%files -n apache-mod_authz_svn
821%defattr(644,root,root,755)
822%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
823%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
824%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 825%endif
7b27380f
ER
826
827%endif # net_client_only
This page took 0.226831 seconds and 4 git commands to generate.