]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- rel 3
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
1930bef0 2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
d46e45ba 4# - finish ruby
9688ba4c 5# - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
1930bef0 6#
bab73684 7# Conditional build:
65c1d4bd 8%bcond_with net_client_only # build only net client
3fc01170 9%bcond_without neon # use serf instead of neon
65c1d4bd
JB
10%bcond_without python # build without python bindings (broken)
11%bcond_without perl # build without perl bindings
73ab938a 12%bcond_without ruby # build without ruby bindings
65c1d4bd
JB
13%bcond_without apache # build without apache support (webdav, etc)
14%bcond_without javahl # build without javahl support (Java high-level bindings)
15%bcond_without tests # don't perform "make check"
65f2befa 16%bcond_without kwallet # build without kde4 wallet support
bfb248d0 17%bcond_without gnome # build without gnome keyring support
7b27380f 18#
b56474ff 19%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 20%define apxs /usr/sbin/apxs
1f630180
ER
21%define pdir SVN
22%define pnam _Core
12ae68c1 23#
04129f48 24%if %{with neon}
a510fada 25%define webdavlib neon
04129f48
AG
26%else
27%define webdavlib serf
a510fada
AM
28%endif
29#
67cb9518 30Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
31Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
32Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 33Name: subversion
5a0b4697 34Version: 1.6.13
99d08670 35Release: 3
6f88d80e 36License: Apache/BSD-like
93b78127 37Group: Development/Version Control
a5c00029 38Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
5a0b4697 39# Source0-md5: 7ae1c827689f21cf975804005be30aeb
93b78127 40Source1: %{name}-dav_svn.conf
65318afa 41Source2: %{name}-authz_svn.conf
b56474ff
AM
42Source3: %{name}-svnserve.init
43Source4: %{name}-svnserve.sysconfig
a510fada
AM
44# current subversion tarball has correct *.swg files
45# but after regeneration these are broken again, so
46# we still need this script
f313e9a9 47Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 48Patch0: %{name}-home_etc.patch
d46e45ba 49Patch1: %{name}-DESTDIR.patch
00664663 50Patch2: %{name}-ruby-datadir-path.patch
dc8fcc41 51URL: http://subversion.apache.org/
4945947e
AM
52%if %{with net_client_only}
53%global apache_modules_api 0
54%else
f2a757d6 55%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 56BuildRequires: automake
3817faf5 57BuildRequires: db-devel >= 4.1.25
58f4b627 58BuildRequires: rpmbuild(macros) >= 1.583
0905b458 59%if %{with perl}
522a69b4 60BuildRequires: perl-devel >= 1:5.8.0
61BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 62BuildRequires: swig-perl >= 1.3.24
536b3fd3 63%endif
6ac3574b
AM
64%if %{with python}
65BuildRequires: python-ctypesgen
66BuildRequires: python-devel >= 2.2
67BuildRequires: swig-python >= 1.3.24
68%endif
69%if %{with ruby}
70BuildRequires: ruby-devel
71BuildRequires: swig-ruby >= 1.3.24
72%endif
af0d490b 73%if %{with javahl}
20c5f543 74BuildRequires: jdk
af0d490b 75%endif
6ac3574b 76BuildRequires: cyrus-sasl-devel
0905b458 77%endif
16429189 78BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 79BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 80BuildRequires: autoconf >= 2.59
79d8c53c 81BuildRequires: bison
93b78127 82BuildRequires: expat-devel
86ea8fde 83BuildRequires: gettext-devel
7b9fe651 84%{?with_gnome:BuildRequires: libgnome-keyring-devel}
65f2befa 85%{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
f4e6a380 86BuildRequires: libtool >= 1.4-9
54271075 87BuildRequires: pkgconfig
a562165a 88BuildRequires: sed >= 4.0
c26d84c4 89BuildRequires: sqlite3-devel >= 3.6.11
a562165a
JB
90BuildRequires: texinfo
91BuildRequires: which
92%if %{with neon}
bd3c99a8 93BuildRequires: neon-devel >= 0.26.0
a562165a
JB
94%else
95BuildRequires: serf-devel
e3ad24ea 96%endif
53855fbf 97BuildRequires: python >= 2.2
ed6210a2 98BuildRequires: python-modules >= 2.2
027f8ebe 99Requires: %{name}-libs = %{version}-%{release}
8b023a9d 100%requires_ge sqlite3
93b78127
AM
101BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
f4070f5f 103%define _libexecdir %{_libdir}/svn
1af5e34d
ER
104%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
105%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127 106
58f4b627
JR
107%define skip_post_check_so libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
108
93b78127
AM
109%description
110The goal of the Subversion project is to build a version control
111system that is a compelling replacement for CVS in the open source
112community.
113
114Our goals are:
115- All current CVS features.
116- Directories, renames, and file meta-data are versioned.
117- Symbolic links, etc, are supported
118- Commits are truly atomic.
119- Branching and tagging are cheap (constant time) operations
120- Repeated merges are handled gracefully
121- Support for plug-in client side diff programs
122- Natively client/server
123- Client/server protocol sends diffs in both directions
124- Costs are proportional to change size, not project size
125- Internationalization
126- Progressive multi-lingual support
127
aa59005f 128%description -l pl.UTF-8
93b78127
AM
129Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
130zamiennika dla CVS.
131
132Cele projektu to:
aa59005f 133- Wszystkie aktualne możliwości CVS.
24406120
JB
134- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
135- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
136- Commity są w pełni atomowe.
137- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
138- Dobra obsługa powtarzanego łączenia (merge).
139- Obsługa wtyczek diff po stronie klienta.
93b78127 140- Natywny klient/serwer.
aa59005f 141- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
142- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
143- Internacjonalizacja.
aa59005f 144- Postępujące wsparcie dla wielu języków.
93b78127 145
aa59005f
JR
146%description -l pt_BR.UTF-8
147O objetivo do projeto Subversion é construir um sistema de controle de
148versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 149System) na comunidade opensource, fornecendo grandes melhorias.
150
f4e6a380
AM
151%package libs
152Summary: Subversion libraries and modules
abe3c421 153Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 154Group: Libraries
04129f48 155%{?with_neon:Requires: neon >= 0.26.0}
53855fbf 156Obsoletes: libsubversion0
f4e6a380
AM
157
158%description libs
159Subversion libraries and modules.
160
aa59005f
JR
161%description libs -l pl.UTF-8
162Biblioteka subversion oraz ładowalne moduły.
f4e6a380 163
93b78127
AM
164%package devel
165Summary: Header files and develpment documentation for subversion
abe3c421
ER
166Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
167Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 168Group: Development/Libraries
9cb7e099 169Requires: %{name}-libs = %{version}-%{release}
c5b1d686 170Requires: apr-util-devel >= 1:1.0.0
04129f48 171%{?with_neon:Requires: neon-devel >= 0.26.0}
12cf252c 172Obsoletes: libsubversion0-devel
93b78127
AM
173
174%description devel
175Header files and develpment documentation for subversion.
176
aa59005f
JR
177%description devel -l pl.UTF-8
178Pliki nagłówkowe i dokumetacja do subversion.
93b78127 179
aa59005f
JR
180%description devel -l pt_BR.UTF-8
181Este pacote provê os arquivos necessários para desenvolvedores
92066deb 182interagirem com o Subversion.
183
93b78127
AM
184%package static
185Summary: Static subversion library
abe3c421
ER
186Summary(pl.UTF-8): Biblioteka statyczna subversion
187Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
188Group: Development/Libraries
189Requires: %{name}-devel = %{version}
12cf252c 190Obsoletes: libsubversion0-static-devel
93b78127
AM
191
192%description static
193Static subversion library.
194
aa59005f 195%description static -l pl.UTF-8
93b78127
AM
196Biblioteka statyczna subversion.
197
aa59005f
JR
198%description static -l pt_BR.UTF-8
199Este pacote provê um cliente estático do subversion.
92066deb 200
b56474ff
AM
201%package svnserve
202Summary: Subversion svnserve
abe3c421 203Summary(pl.UTF-8): Subversion svnserve
b56474ff 204Group: Networking/Daemons
3817faf5 205Requires(post,preun): /sbin/chkconfig
93f1d402 206Requires(postun): /usr/sbin/groupdel
207Requires(postun): /usr/sbin/userdel
208Requires(pre): /bin/id
209Requires(pre): /usr/bin/getgid
210Requires(pre): /usr/lib/rpm/user_group.sh
211Requires(pre): /usr/sbin/groupadd
212Requires(pre): /usr/sbin/useradd
213Requires(pre): /usr/sbin/usermod
9cb7e099 214Requires: %{name} = %{version}-%{release}
7b27380f 215Requires: rc-scripts
a1bac09d
216Provides: group(svn)
217Provides: user(svn)
b56474ff
AM
218
219%description svnserve
220Subversion svnserve server.
221
aa59005f 222%description svnserve -l pl.UTF-8
b56474ff
AM
223Serwer subversion svnserve.
224
4bbdbbf8
AM
225%package tools
226Summary: Subversion tools and scripts
abe3c421
ER
227Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
228Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 229Group: Applications
4bbdbbf8 230%pyrequires_eq python
7b27380f 231Requires: %{name} = %{version}-%{release}
4bbdbbf8
AM
232Requires: python-subversion = %{version}
233
234%description tools
235Subversion tools and scripts.
236
aa59005f
JR
237%description tools -l pl.UTF-8
238Narzędzia oraz skrypty dla subversion.
4bbdbbf8 239
fe5bb6bb 240%package -n bash-completion-subversion
241Summary: bash completion for subversion
abe3c421 242Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 243Group: Applications/Shells
e30588c4 244Requires: %{name} = %{version}-%{release}
53855fbf 245Requires: bash-completion
e30588c4 246Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 247
248%description -n bash-completion-subversion
249Bash completion for subversion.
250
aa59005f
JR
251%description -n bash-completion-subversion -l pl.UTF-8
252Dopełnienia basha dla subversion.
fe5bb6bb 253
1cc7453a 254%package -n java-subversion
65c1d4bd
JB
255Summary: Subversion Java bindings
256Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 257Group: Development/Languages/Java
258Requires: %{name}-libs = %{version}-%{release}
259
260%description -n java-subversion
261This is a set of Java classes which provide the functionality of
262subversion-libs, the Subversion libraries. It is useful if you want
263to, for example, write a Java class that manipulates a Subversion
264repository or working copy. See the 'subversion' package for more
265information.
266
65c1d4bd
JB
267%description -n java-subversion -l pl.UTF-8
268Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
269subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
d46e45ba
AM
270pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
271roboczą. Więcej informacji w pakiecie subversion.
65c1d4bd 272
fa3ff1b2 273%package -n python-subversion
65c1d4bd
JB
274Summary: Subversion Python bindings
275Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
276Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 277Group: Development/Languages/Python
f4e6a380 278%pyrequires_eq python
9cb7e099 279Requires: %{name}-libs = %{version}-%{release}
53855fbf 280Obsoletes: subversion-python
f4e6a380 281
fa3ff1b2 282%description -n python-subversion
65c1d4bd 283Subversion Python bindings.
f4e6a380 284
aa59005f 285%description -n python-subversion -l pl.UTF-8
65c1d4bd 286Dowiązania do Subversion dla Pythona.
f4e6a380 287
aa59005f 288%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 289Módulos Python para acessar os recursos do Subversion.
92066deb 290
137fcafd
AM
291%package -n python-csvn
292Summary: CTypes Subversion Python bindings
293Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
294Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
295Group: Development/Languages/Python
296%pyrequires_eq python
297Requires: %{name}-libs = %{version}-%{release}
298
299%description -n python-csvn
300Subversion CTypes Python bindings.
301
302%description -n python-csvn -l pl.UTF-8
303Dowiązania do Subversion dla Pythona używające CTypes.
304
305%description -n python-csvn -l pt_BR.UTF-8
306Módulos Python para acessar os recursos do Subversion.
307
b56474ff 308%package -n perl-subversion
65c1d4bd
JB
309Summary: Subversion Perl bindings
310Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
311Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 312Group: Development/Languages/Perl
9cb7e099 313Requires: %{name}-libs = %{version}-%{release}
53855fbf 314Obsoletes: subversion-perl
b56474ff
AM
315
316%description -n perl-subversion
65c1d4bd 317Subversion Perl bindings.
b56474ff 318
aa59005f 319%description -n perl-subversion -l pl.UTF-8
65c1d4bd 320Dowiązania do Subversion dla Perla.
b56474ff 321
aa59005f 322%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 323Módulos Perl para acessar os recursos do Subversion.
b56474ff 324
d46e45ba
AM
325%package -n ruby-subversion
326Summary: Subversion Ruby bindings
d2bf70bf 327Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
d46e45ba
AM
328Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
329Group: Development/Languages
330Requires: %{name}-libs = %{version}-%{release}
331Obsoletes: subversion-ruby
332
333%description -n ruby-subversion
334Subversion Ruby bindings.
335
336%description -n ruby-subversion -l pl.UTF-8
d2bf70bf 337Dowiązania do Subversion dla języka Ruby.
d46e45ba
AM
338
339%description -n ruby-subversion -l pt_BR.UTF-8
340Módulos Ruby para acessar os recursos do Subversion.
341
93b78127
AM
342%package -n apache-mod_dav_svn
343Summary: Apache module: Subversion Server
abe3c421 344Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 345Group: Networking/Daemons
7b27380f 346Requires: %{name} = %{version}-%{release}
53855fbf 347Requires: apache(modules-api) = %apache_modules_api
7887b1ac 348Requires: apache-mod_dav
93b78127
AM
349
350%description -n apache-mod_dav_svn
351Apache module: Subversion Server.
352
aa59005f
JR
353%description -n apache-mod_dav_svn -l pl.UTF-8
354Moduł apache: Serwer Subversion.
93b78127 355
65318afa
AF
356%package -n apache-mod_authz_svn
357Summary: Apache module: Subversion Server - path-based authorization
abe3c421 358Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 359Group: Networking/Daemons
53855fbf 360Requires: apache(modules-api) = %apache_modules_api
9cb7e099 361Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
362
363%description -n apache-mod_authz_svn
364Apache module: Subversion Server - path-based authorization.
365
aa59005f
JR
366%description -n apache-mod_authz_svn -l pl.UTF-8
367Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 368
1429fa1c
AM
369%package -n gnome-keyring-subversion
370Summary: Subversion module for Gnome Keyring
371Summary(pl.UTF-8): Moduł subversion dla zarządcy kluczy Gnome
372Group: X11/Applications
373
374%description -n gnome-keyring-subversion
375Subversion module for Gnome Keyring.
376
377%description -n gnome-keyring-subversion -l pl.UTF-8
378Moduł subversion dla zarządcy kluczy Gnome.
379
380%package -n kde4-kwallet-subversion
381Summary: Subversion module for KDE Wallet
382Summary(pl.UTF-8): Moduł subversion dla Portfela KDE
383Group: X11/Applications
384
385%description -n kde4-kwallet-subversion
386Subversion module for KDE Wallet.
387
388%description -n kde4-kwallet-subversion -l pl.UTF-8
389Moduł subversion dla Portfela KDE.
390
93b78127 391%prep
a5c00029 392%setup -q
e30588c4 393rm -rf apr apr-util neon
ed6210a2 394%patch0 -p0
d4bccc60 395%patch1 -p1
00664663 396%patch2 -p0
a510fada
AM
397
398sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
399
400# serf.m4 macro is broken and ignores --without serf
244bdb04 401%{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
027f8ebe 402
93b78127 403%build
93f1d402 404rm subversion/bindings/swig/proxy/*.swg
24406120 405cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 406cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 407chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 408
93b78127 409%configure \
5dfeafd7 410 --with-editor=vi \
12ae68c1 411 --with-zlib=%{_libdir} \
536b3fd3
AM
412%if %{with net_client_only}
413 --without-apache \
414 --without-swig \
415 --without-apxs \
416 --without-berkeley-db \
417%else
fa6fa2cf 418 --disable-runtime-module-search \
86ee97d3 419 --disable-mod-activation \
ad5c551e 420 --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
0905b458 421%if %{with apache}
536b3fd3 422 --with-apxs=%{_sbindir}/apxs \
0905b458 423%else
424 --without-apache \
425 --without-apxs \
0905b458 426%endif
73ab938a 427%if !%{with python} && !%{with perl} && !%{with ruby}
0905b458 428 --without-swig \
429%endif
137fcafd 430 %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
1cc7453a 431 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 432%endif
1cc7453a 433 --with-jdk="%{java_home}" \
cf2589d0 434 --without-jikes \
04129f48 435%if %{with neon}
e3ad24ea 436 --without-serf \
e30588c4 437 --with-neon=%{_prefix} \
78f330c4 438 --disable-neon-version-check \
04129f48
AG
439%else
440 --with-serf=%{_prefix} \
441 --without-neon \
e3ad24ea 442%endif
16429189 443 --with-apr=%{_bindir}/apr-1-config \
1429fa1c 444 --with-apr-util=%{_bindir}/apu-1-config \
65f2befa 445%if %{with kwallet}
1429fa1c 446 --with-kwallet \
65f2befa 447%endif
bfb248d0 448%if %{with gnome}
1429fa1c 449 --with-gnome-keyring
bfb248d0 450%endif
536b3fd3 451
1f630180 452%{__make} -j1
536b3fd3 453
cf353d53 454%if !%{with net_client_only}
b56474ff 455# python
0905b458 456%if %{with python}
137fcafd
AM
457# ctypes bindings
458%{__make} ctypes-python
459# swig bindings
86a4919e 460%{__make} swig-py \
65318afa
AF
461 swig_pydir=%{py_sitedir}/libsvn \
462 swig_pydir_extra=%{py_sitedir}/svn
0905b458 463%endif
b56474ff 464# perl
0905b458 465%if %{with perl}
390bb8f4 466%{__make} -j1 swig-pl-lib
bf539998
AM
467odir=$(pwd)
468cd subversion/bindings/swig/perl/native
469%{__perl} Makefile.PL INSTALLDIRS=vendor
b445847c 470%{__make} -j1
bf539998 471cd $odir
536b3fd3 472%endif
1cc7453a 473%if %{with javahl}
b445847c 474%{__make} -j1 javahl \
1cc7453a 475 javahl_javadir="%{_javadir}"
476%endif
d46e45ba
AM
477# ruby
478%if %{with ruby}
479%{__make} swig-rb
480%endif
12ae68c1
AM
481%endif
482
483%if %{with tests}
484%{__make} check
d46e45ba 485%if %{with python}
137fcafd 486%{__make} check-ctypes-python
d46e45ba
AM
487%{__make} check-swig-py
488%endif
489%if %{with perl}
490%{__make} check-swig-pl
491%endif
492%if %{with ruby}
493%{__make} check-swig-rb
494%endif
0905b458 495%endif
93b78127
AM
496
497%install
498rm -rf $RPM_BUILD_ROOT
1326bb99 499install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 500 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 501 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 502 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 503
1f630180 504%{__make} install -j1 \
1cc7453a 505%if %{with javahl}
506 install-javahl \
507 javahl_javadir="%{_javadir}" \
508%endif
d46e45ba
AM
509%if !%{with net_client_only}
510%if %{with python}
0905b458 511 install-swig-py \
137fcafd 512 install-ctypes-python \
d46e45ba
AM
513%endif
514%if %{with ruby}
515 install-swig-rb install-swig-rb-doc \
516%endif
0905b458 517%endif
f2a757d6 518 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 519 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
520 swig_pydir=%{py_sitedir}/libsvn \
521 swig_pydir_extra=%{py_sitedir}/svn
93b78127 522
cf353d53 523%if !%{with net_client_only} && %{with perl}
bf539998
AM
524%{__make} install-swig-pl-lib \
525 DESTDIR=$RPM_BUILD_ROOT
b445847c 526%{__make} -C subversion/bindings/swig/perl/native install \
bf539998
AM
527 DESTDIR=$RPM_BUILD_ROOT \
528 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
529 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
bf539998
AM
530%endif
531
0905b458 532%if %{with apache}
1af5e34d
ER
533install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
534install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
535install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
536install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 537%endif
93b78127 538
cf353d53 539%if !%{with net_client_only}
1326bb99 540install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 541%if %{with python}
f4e6a380
AM
542%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
543%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
544find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
545install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 546%endif
0905b458 547%endif
f4e6a380 548
1326bb99
JK
549install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
550install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 551
205a3ddc
AM
552%find_lang %{name}
553
dd73606c 554%{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
c39b6844 555rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
556rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
a6ecf312 557
e23909be
JB
558%clean
559rm -rf $RPM_BUILD_ROOT
560
a1bac09d
561%pre svnserve
562%groupadd -g 86 svn
563%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
564
d2bf70bf
JB
565%post libs -p /sbin/ldconfig
566%postun libs -p /sbin/ldconfig
567
568%post devel -p /sbin/postshell
6f99c3bd 569-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 570
d2bf70bf 571%postun devel -p /sbin/postshell
6f99c3bd 572-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 573
d2bf70bf
JB
574%post -n perl-subversion -p /sbin/ldconfig
575%postun -n perl-subversion -p /sbin/ldconfig
576
577%post -n python-subversion -p /sbin/ldconfig
578%postun -n python-subversion -p /sbin/ldconfig
f4e6a380 579
b56474ff 580%post svnserve
e8d9186f
ER
581/sbin/chkconfig --add svnserve
582%service svnserve restart "svnserve daemon"
583
b56474ff
AM
584%preun svnserve
585if [ "$1" = "0" ]; then
e8d9186f
ER
586 %service svnserve stop
587 /sbin/chkconfig --del svnserve
b56474ff
AM
588fi
589
a1bac09d
590%postun svnserve
591if [ "$1" = "0" ]; then
592 %userremove svn
593 %groupremove svn
594fi
595
93b78127 596%post -n apache-mod_dav_svn
e8d9186f 597%service -q httpd restart
93b78127 598
ba425c92 599%postun -n apache-mod_dav_svn
93b78127 600if [ "$1" = "0" ]; then
e8d9186f 601 %service -q httpd restart
93b78127
AM
602fi
603
9688ba4c
JR
604%post -n apache-mod_authz_svn
605%service -q httpd restart
606
ba425c92 607%postun -n apache-mod_authz_svn
9688ba4c
JR
608if [ "$1" = "0" ]; then
609 %service -q httpd restart
610fi
611
93b78127
AM
612%files
613%defattr(644,root,root,755)
983a49f6 614%doc BUGS CHANGES COPYING INSTALL README
d37298dc 615%doc doc/*/*.html
4bbdbbf8
AM
616%doc tools/hook-scripts/*.{pl,py,example}
617%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 618%doc tools/xslt/*
b445847c
JB
619%attr(755,root,root) %{_bindir}/svn
620%attr(755,root,root) %{_bindir}/svnadmin
621%attr(755,root,root) %{_bindir}/svndumpfilter
622%attr(755,root,root) %{_bindir}/svnlook
623%attr(755,root,root) %{_bindir}/svnsync
624%attr(755,root,root) %{_bindir}/svnversion
625%{_mandir}/man1/svn.1*
626%{_mandir}/man1/svnadmin.1*
627%{_mandir}/man1/svndumpfilter.1*
628%{_mandir}/man1/svnlook.1*
629%{_mandir}/man1/svnsync.1*
630%{_mandir}/man1/svnversion.1*
f4e6a380 631
205a3ddc 632%files libs -f %{name}.lang
f4e6a380 633%defattr(644,root,root,755)
b445847c
JB
634%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
635%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
636%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
637%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
638%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
639%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
640%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
641%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
642%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
643%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
644%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
645%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
646%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
647%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
648%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
649%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
650%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
651%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
a510fada
AM
652%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
653%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
b445847c
JB
654%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
655%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
656%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
657%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
658%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
659%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
660%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
661%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
93b78127
AM
662
663%files devel
664%defattr(644,root,root,755)
b445847c
JB
665%attr(755,root,root) %{_libdir}/libsvn_client-1.so
666%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
667%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
668%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
669%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
670%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
671%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
672%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
673%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
a510fada 674%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
b445847c
JB
675%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
676%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
677%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
678%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
679%{_libdir}/libsvn_client-1.la
680%{_libdir}/libsvn_delta-1.la
681%{_libdir}/libsvn_diff-1.la
682%{_libdir}/libsvn_fs-1.la
683%{_libdir}/libsvn_fs_base-1.la
684%{_libdir}/libsvn_fs_fs-1.la
685%{_libdir}/libsvn_fs_util-1.la
686%{_libdir}/libsvn_ra-1.la
687%{_libdir}/libsvn_ra_local-1.la
a510fada 688%{_libdir}/libsvn_ra_%{webdavlib}-1.la
b445847c
JB
689%{_libdir}/libsvn_ra_svn-1.la
690%{_libdir}/libsvn_repos-1.la
691%{_libdir}/libsvn_subr-1.la
692%{_libdir}/libsvn_wc-1.la
693%{_includedir}/%{name}-1
1326bb99 694%{_examplesdir}/%{name}-%{version}
93b78127
AM
695
696%files static
697%defattr(644,root,root,755)
b445847c
JB
698%{_libdir}/libsvn_client-1.a
699%{_libdir}/libsvn_delta-1.a
700%{_libdir}/libsvn_diff-1.a
701%{_libdir}/libsvn_fs-1.a
702%{_libdir}/libsvn_fs_base-1.a
703%{_libdir}/libsvn_fs_fs-1.a
704%{_libdir}/libsvn_fs_util-1.a
705%{_libdir}/libsvn_ra-1.a
706%{_libdir}/libsvn_ra_local-1.a
a510fada 707%{_libdir}/libsvn_ra_%{webdavlib}-1.a
b445847c
JB
708%{_libdir}/libsvn_ra_svn-1.a
709%{_libdir}/libsvn_repos-1.a
710%{_libdir}/libsvn_subr-1.a
711%{_libdir}/libsvn_wc-1.a
93b78127 712
bfb248d0 713%if %{with gnome}
1429fa1c
AM
714%files -n gnome-keyring-subversion
715%defattr(644,root,root,755)
716%attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
717%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
bfb248d0 718%endif
1429fa1c 719
65f2befa 720%if %{with kwallet}
1429fa1c
AM
721%files -n kde4-kwallet-subversion
722%defattr(644,root,root,755)
723%attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
724%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
65f2befa 725%endif
1429fa1c 726
cf353d53 727%if !%{with net_client_only}
b56474ff
AM
728%files svnserve
729%defattr(644,root,root,755)
730%attr(755,root,root) %{_bindir}/svnserve
b445847c
JB
731%{_mandir}/man5/svnserve.conf.5*
732%{_mandir}/man8/svnserve.8*
a1bac09d
733%dir %attr(750,svn,svn) /home/services/subversion
734%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 735%if %{with apache}
b56474ff 736%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 737%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 738%endif
b56474ff 739
4bbdbbf8
AM
740%files tools
741%defattr(644,root,root,755)
1326bb99 742%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 743
744%files -n bash-completion-subversion
101e74de 745%defattr(644,root,root,755)
1326bb99 746/etc/bash_completion.d/%{name}
536b3fd3 747
1cc7453a 748%if %{with javahl}
749%files -n java-subversion
750%defattr(644,root,root,755)
b445847c
JB
751%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
752%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
753%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
1cc7453a 754%{_javadir}/svn-javahl.jar
755%endif
756
0905b458 757%if %{with python}
fa3ff1b2 758%files -n python-subversion
f4e6a380 759%defattr(644,root,root,755)
4bbdbbf8 760%doc tools/backup/*.py tools/examples/*.py
b445847c
JB
761%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
762%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
763%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
65318afa 764%dir %{py_sitedir}/libsvn
65318afa 765%{py_sitedir}/libsvn/*.py[co]
b445847c
JB
766%dir %{py_sitedir}/svn
767%{py_sitedir}/svn/*.py[co]
65318afa 768%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 769%{_examplesdir}/python-%{name}-%{version}
137fcafd
AM
770
771%files -n python-csvn
772%defattr(644,root,root,755)
773%doc subversion/bindings/ctypes-python/{README,TODO}
774%doc subversion/bindings/ctypes-python/examples/*.py
775%dir %{py_sitescriptdir}/csvn
776%{py_sitescriptdir}/csvn/*.py[co]
777%dir %{py_sitescriptdir}/csvn/core
778%{py_sitescriptdir}/csvn/core/*.py[co]
779%dir %{py_sitescriptdir}/csvn/ext
780%{py_sitescriptdir}/csvn/ext/*.py[co]
781%{py_sitescriptdir}/*.egg-info
0905b458 782%endif
f4e6a380 783
0905b458 784%if %{with perl}
b56474ff
AM
785%files -n perl-subversion
786%defattr(644,root,root,755)
b445847c
JB
787%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
788%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
789%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
b56474ff
AM
790%{perl_vendorarch}/SVN
791%dir %{perl_vendorarch}/auto/SVN
792%dir %{perl_vendorarch}/auto/SVN/*
793%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
794%{perl_vendorarch}/auto/SVN/*/*.bs
795%{_mandir}/man3/*.3pm*
0905b458 796%endif
b56474ff 797
d46e45ba
AM
798%if %{with ruby}
799%files -n ruby-subversion
800%defattr(644,root,root,755)
b445847c
JB
801%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
802%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
803%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
916011ef
JR
804%dir %{ruby_sitelibdir}/svn
805%{ruby_sitelibdir}/svn/*.rb
806%dir %{ruby_sitearchdir}/svn
807%dir %{ruby_sitearchdir}/svn/ext
e2c6dc67 808%attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
916011ef 809%{ruby_ridir}/Svn
d46e45ba
AM
810%endif
811
0905b458 812%if %{with apache}
93b78127
AM
813%files -n apache-mod_dav_svn
814%defattr(644,root,root,755)
1af5e34d
ER
815%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
816%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
817
818%files -n apache-mod_authz_svn
819%defattr(644,root,root,755)
820%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
821%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
822%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 823%endif
7b27380f
ER
824
825%endif # net_client_only
This page took 0.204572 seconds and 4 git commands to generate.