]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- up to 1.6.11
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
1930bef0 2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
d46e45ba 4# - finish ruby
9688ba4c 5# - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
1930bef0 6#
bab73684 7# Conditional build:
65c1d4bd 8%bcond_with net_client_only # build only net client
3fc01170 9%bcond_without neon # use serf instead of neon
65c1d4bd
JB
10%bcond_without python # build without python bindings (broken)
11%bcond_without perl # build without perl bindings
73ab938a 12%bcond_without ruby # build without ruby bindings
65c1d4bd
JB
13%bcond_without apache # build without apache support (webdav, etc)
14%bcond_without javahl # build without javahl support (Java high-level bindings)
15%bcond_without tests # don't perform "make check"
65f2befa 16%bcond_without kwallet # build without kde4 wallet support
bfb248d0 17%bcond_without gnome # build without gnome keyring support
7b27380f 18#
b56474ff 19%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 20%define apxs /usr/sbin/apxs
1f630180
ER
21%define pdir SVN
22%define pnam _Core
12ae68c1 23#
04129f48 24%if %{with neon}
a510fada 25%define webdavlib neon
04129f48
AG
26%else
27%define webdavlib serf
a510fada
AM
28%endif
29#
67cb9518 30Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
31Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
32Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 33Name: subversion
93db1b5f
AM
34Version: 1.6.11
35Release: 1
6f88d80e 36License: Apache/BSD-like
93b78127 37Group: Development/Version Control
a5c00029 38Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
93db1b5f 39# Source0-md5: 75419159b50661092c4137449940b5cc
93b78127 40Source1: %{name}-dav_svn.conf
65318afa 41Source2: %{name}-authz_svn.conf
b56474ff
AM
42Source3: %{name}-svnserve.init
43Source4: %{name}-svnserve.sysconfig
a510fada
AM
44# current subversion tarball has correct *.swg files
45# but after regeneration these are broken again, so
46# we still need this script
f313e9a9 47Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 48Patch0: %{name}-home_etc.patch
d46e45ba 49Patch1: %{name}-DESTDIR.patch
00664663 50Patch2: %{name}-ruby-datadir-path.patch
dc8fcc41 51URL: http://subversion.apache.org/
4945947e
AM
52%if %{with net_client_only}
53%global apache_modules_api 0
54%else
f2a757d6 55%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 56BuildRequires: automake
3817faf5 57BuildRequires: db-devel >= 4.1.25
e8d9186f 58BuildRequires: rpmbuild(macros) >= 1.268
0905b458 59%if %{with perl}
522a69b4 60BuildRequires: perl-devel >= 1:5.8.0
61BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 62BuildRequires: swig-perl >= 1.3.24
536b3fd3 63%endif
6ac3574b
AM
64%if %{with python}
65BuildRequires: python-ctypesgen
66BuildRequires: python-devel >= 2.2
67BuildRequires: swig-python >= 1.3.24
68%endif
69%if %{with ruby}
70BuildRequires: ruby-devel
71BuildRequires: swig-ruby >= 1.3.24
72%endif
af0d490b 73%if %{with javahl}
20c5f543 74BuildRequires: jdk
af0d490b 75%endif
6ac3574b 76BuildRequires: cyrus-sasl-devel
0905b458 77%endif
16429189 78BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 79BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 80BuildRequires: autoconf >= 2.59
79d8c53c 81BuildRequires: bison
93b78127 82BuildRequires: expat-devel
86ea8fde 83BuildRequires: gettext-devel
bfb248d0 84%{?with_gnome:BuildRequires: gnome-keyring-devel}
65f2befa 85%{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
f4e6a380 86BuildRequires: libtool >= 1.4-9
54271075 87BuildRequires: pkgconfig
a562165a 88BuildRequires: sed >= 4.0
c26d84c4 89BuildRequires: sqlite3-devel >= 3.6.11
a562165a
JB
90BuildRequires: texinfo
91BuildRequires: which
92%if %{with neon}
bd3c99a8 93BuildRequires: neon-devel >= 0.26.0
a562165a
JB
94%else
95BuildRequires: serf-devel
e3ad24ea 96%endif
53855fbf 97BuildRequires: python >= 2.2
ed6210a2 98BuildRequires: python-modules >= 2.2
027f8ebe 99Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
100BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
f4070f5f 102%define _libexecdir %{_libdir}/svn
1af5e34d
ER
103%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
104%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127
AM
105
106%description
107The goal of the Subversion project is to build a version control
108system that is a compelling replacement for CVS in the open source
109community.
110
111Our goals are:
112- All current CVS features.
113- Directories, renames, and file meta-data are versioned.
114- Symbolic links, etc, are supported
115- Commits are truly atomic.
116- Branching and tagging are cheap (constant time) operations
117- Repeated merges are handled gracefully
118- Support for plug-in client side diff programs
119- Natively client/server
120- Client/server protocol sends diffs in both directions
121- Costs are proportional to change size, not project size
122- Internationalization
123- Progressive multi-lingual support
124
aa59005f 125%description -l pl.UTF-8
93b78127
AM
126Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
127zamiennika dla CVS.
128
129Cele projektu to:
aa59005f 130- Wszystkie aktualne możliwości CVS.
24406120
JB
131- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
132- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
133- Commity są w pełni atomowe.
134- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
135- Dobra obsługa powtarzanego łączenia (merge).
136- Obsługa wtyczek diff po stronie klienta.
93b78127 137- Natywny klient/serwer.
aa59005f 138- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
139- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
140- Internacjonalizacja.
aa59005f 141- Postępujące wsparcie dla wielu języków.
93b78127 142
aa59005f
JR
143%description -l pt_BR.UTF-8
144O objetivo do projeto Subversion é construir um sistema de controle de
145versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 146System) na comunidade opensource, fornecendo grandes melhorias.
147
f4e6a380
AM
148%package libs
149Summary: Subversion libraries and modules
abe3c421 150Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 151Group: Libraries
04129f48 152%{?with_neon:Requires: neon >= 0.26.0}
53855fbf 153Obsoletes: libsubversion0
f4e6a380
AM
154
155%description libs
156Subversion libraries and modules.
157
aa59005f
JR
158%description libs -l pl.UTF-8
159Biblioteka subversion oraz ładowalne moduły.
f4e6a380 160
93b78127
AM
161%package devel
162Summary: Header files and develpment documentation for subversion
abe3c421
ER
163Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
164Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 165Group: Development/Libraries
9cb7e099 166Requires: %{name}-libs = %{version}-%{release}
c5b1d686 167Requires: apr-util-devel >= 1:1.0.0
04129f48 168%{?with_neon:Requires: neon-devel >= 0.26.0}
12cf252c 169Obsoletes: libsubversion0-devel
93b78127
AM
170
171%description devel
172Header files and develpment documentation for subversion.
173
aa59005f
JR
174%description devel -l pl.UTF-8
175Pliki nagłówkowe i dokumetacja do subversion.
93b78127 176
aa59005f
JR
177%description devel -l pt_BR.UTF-8
178Este pacote provê os arquivos necessários para desenvolvedores
92066deb 179interagirem com o Subversion.
180
93b78127
AM
181%package static
182Summary: Static subversion library
abe3c421
ER
183Summary(pl.UTF-8): Biblioteka statyczna subversion
184Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
185Group: Development/Libraries
186Requires: %{name}-devel = %{version}
12cf252c 187Obsoletes: libsubversion0-static-devel
93b78127
AM
188
189%description static
190Static subversion library.
191
aa59005f 192%description static -l pl.UTF-8
93b78127
AM
193Biblioteka statyczna subversion.
194
aa59005f
JR
195%description static -l pt_BR.UTF-8
196Este pacote provê um cliente estático do subversion.
92066deb 197
b56474ff
AM
198%package svnserve
199Summary: Subversion svnserve
abe3c421 200Summary(pl.UTF-8): Subversion svnserve
b56474ff 201Group: Networking/Daemons
3817faf5 202Requires(post,preun): /sbin/chkconfig
93f1d402 203Requires(postun): /usr/sbin/groupdel
204Requires(postun): /usr/sbin/userdel
205Requires(pre): /bin/id
206Requires(pre): /usr/bin/getgid
207Requires(pre): /usr/lib/rpm/user_group.sh
208Requires(pre): /usr/sbin/groupadd
209Requires(pre): /usr/sbin/useradd
210Requires(pre): /usr/sbin/usermod
9cb7e099 211Requires: %{name} = %{version}-%{release}
7b27380f 212Requires: rc-scripts
a1bac09d
213Provides: group(svn)
214Provides: user(svn)
b56474ff
AM
215
216%description svnserve
217Subversion svnserve server.
218
aa59005f 219%description svnserve -l pl.UTF-8
b56474ff
AM
220Serwer subversion svnserve.
221
4bbdbbf8
AM
222%package tools
223Summary: Subversion tools and scripts
abe3c421
ER
224Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
225Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 226Group: Applications
4bbdbbf8 227%pyrequires_eq python
7b27380f 228Requires: %{name} = %{version}-%{release}
4bbdbbf8
AM
229Requires: python-subversion = %{version}
230
231%description tools
232Subversion tools and scripts.
233
aa59005f
JR
234%description tools -l pl.UTF-8
235Narzędzia oraz skrypty dla subversion.
4bbdbbf8 236
fe5bb6bb 237%package -n bash-completion-subversion
238Summary: bash completion for subversion
abe3c421 239Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 240Group: Applications/Shells
e30588c4 241Requires: %{name} = %{version}-%{release}
53855fbf 242Requires: bash-completion
e30588c4 243Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 244
245%description -n bash-completion-subversion
246Bash completion for subversion.
247
aa59005f
JR
248%description -n bash-completion-subversion -l pl.UTF-8
249Dopełnienia basha dla subversion.
fe5bb6bb 250
1cc7453a 251%package -n java-subversion
65c1d4bd
JB
252Summary: Subversion Java bindings
253Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 254Group: Development/Languages/Java
255Requires: %{name}-libs = %{version}-%{release}
256
257%description -n java-subversion
258This is a set of Java classes which provide the functionality of
259subversion-libs, the Subversion libraries. It is useful if you want
260to, for example, write a Java class that manipulates a Subversion
261repository or working copy. See the 'subversion' package for more
262information.
263
65c1d4bd
JB
264%description -n java-subversion -l pl.UTF-8
265Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
266subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
d46e45ba
AM
267pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
268roboczą. Więcej informacji w pakiecie subversion.
65c1d4bd 269
fa3ff1b2 270%package -n python-subversion
65c1d4bd
JB
271Summary: Subversion Python bindings
272Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
273Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 274Group: Development/Languages/Python
f4e6a380 275%pyrequires_eq python
9cb7e099 276Requires: %{name}-libs = %{version}-%{release}
53855fbf 277Obsoletes: subversion-python
f4e6a380 278
fa3ff1b2 279%description -n python-subversion
65c1d4bd 280Subversion Python bindings.
f4e6a380 281
aa59005f 282%description -n python-subversion -l pl.UTF-8
65c1d4bd 283Dowiązania do Subversion dla Pythona.
f4e6a380 284
aa59005f 285%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 286Módulos Python para acessar os recursos do Subversion.
92066deb 287
137fcafd
AM
288%package -n python-csvn
289Summary: CTypes Subversion Python bindings
290Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
291Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
292Group: Development/Languages/Python
293%pyrequires_eq python
294Requires: %{name}-libs = %{version}-%{release}
295
296%description -n python-csvn
297Subversion CTypes Python bindings.
298
299%description -n python-csvn -l pl.UTF-8
300Dowiązania do Subversion dla Pythona używające CTypes.
301
302%description -n python-csvn -l pt_BR.UTF-8
303Módulos Python para acessar os recursos do Subversion.
304
b56474ff 305%package -n perl-subversion
65c1d4bd
JB
306Summary: Subversion Perl bindings
307Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
308Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 309Group: Development/Languages/Perl
9cb7e099 310Requires: %{name}-libs = %{version}-%{release}
53855fbf 311Obsoletes: subversion-perl
b56474ff
AM
312
313%description -n perl-subversion
65c1d4bd 314Subversion Perl bindings.
b56474ff 315
aa59005f 316%description -n perl-subversion -l pl.UTF-8
65c1d4bd 317Dowiązania do Subversion dla Perla.
b56474ff 318
aa59005f 319%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 320Módulos Perl para acessar os recursos do Subversion.
b56474ff 321
d46e45ba
AM
322%package -n ruby-subversion
323Summary: Subversion Ruby bindings
d2bf70bf 324Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
d46e45ba
AM
325Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
326Group: Development/Languages
327Requires: %{name}-libs = %{version}-%{release}
328Obsoletes: subversion-ruby
329
330%description -n ruby-subversion
331Subversion Ruby bindings.
332
333%description -n ruby-subversion -l pl.UTF-8
d2bf70bf 334Dowiązania do Subversion dla języka Ruby.
d46e45ba
AM
335
336%description -n ruby-subversion -l pt_BR.UTF-8
337Módulos Ruby para acessar os recursos do Subversion.
338
93b78127
AM
339%package -n apache-mod_dav_svn
340Summary: Apache module: Subversion Server
abe3c421 341Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 342Group: Networking/Daemons
7b27380f 343Requires: %{name} = %{version}-%{release}
53855fbf 344Requires: apache(modules-api) = %apache_modules_api
7887b1ac 345Requires: apache-mod_dav
93b78127
AM
346
347%description -n apache-mod_dav_svn
348Apache module: Subversion Server.
349
aa59005f
JR
350%description -n apache-mod_dav_svn -l pl.UTF-8
351Moduł apache: Serwer Subversion.
93b78127 352
65318afa
AF
353%package -n apache-mod_authz_svn
354Summary: Apache module: Subversion Server - path-based authorization
abe3c421 355Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 356Group: Networking/Daemons
53855fbf 357Requires: apache(modules-api) = %apache_modules_api
9cb7e099 358Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
359
360%description -n apache-mod_authz_svn
361Apache module: Subversion Server - path-based authorization.
362
aa59005f
JR
363%description -n apache-mod_authz_svn -l pl.UTF-8
364Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 365
1429fa1c
AM
366%package -n gnome-keyring-subversion
367Summary: Subversion module for Gnome Keyring
368Summary(pl.UTF-8): Moduł subversion dla zarządcy kluczy Gnome
369Group: X11/Applications
370
371%description -n gnome-keyring-subversion
372Subversion module for Gnome Keyring.
373
374%description -n gnome-keyring-subversion -l pl.UTF-8
375Moduł subversion dla zarządcy kluczy Gnome.
376
377%package -n kde4-kwallet-subversion
378Summary: Subversion module for KDE Wallet
379Summary(pl.UTF-8): Moduł subversion dla Portfela KDE
380Group: X11/Applications
381
382%description -n kde4-kwallet-subversion
383Subversion module for KDE Wallet.
384
385%description -n kde4-kwallet-subversion -l pl.UTF-8
386Moduł subversion dla Portfela KDE.
387
93b78127 388%prep
a5c00029 389%setup -q
e30588c4 390rm -rf apr apr-util neon
ed6210a2 391%patch0 -p0
d4bccc60 392%patch1 -p1
00664663 393%patch2 -p0
a510fada
AM
394
395sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
396
397# serf.m4 macro is broken and ignores --without serf
244bdb04 398%{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
027f8ebe 399
93b78127 400%build
93f1d402 401rm subversion/bindings/swig/proxy/*.swg
24406120 402cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 403cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 404chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 405
93b78127 406%configure \
5dfeafd7 407 --with-editor=vi \
12ae68c1 408 --with-zlib=%{_libdir} \
536b3fd3
AM
409%if %{with net_client_only}
410 --without-apache \
411 --without-swig \
412 --without-apxs \
413 --without-berkeley-db \
414%else
fa6fa2cf 415 --disable-runtime-module-search \
86ee97d3 416 --disable-mod-activation \
ad5c551e 417 --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
0905b458 418%if %{with apache}
536b3fd3 419 --with-apxs=%{_sbindir}/apxs \
0905b458 420%else
421 --without-apache \
422 --without-apxs \
0905b458 423%endif
73ab938a 424%if !%{with python} && !%{with perl} && !%{with ruby}
0905b458 425 --without-swig \
426%endif
137fcafd 427 %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
1cc7453a 428 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 429%endif
1cc7453a 430 --with-jdk="%{java_home}" \
04129f48 431%if %{with neon}
e3ad24ea 432 --without-serf \
e30588c4 433 --with-neon=%{_prefix} \
78f330c4 434 --disable-neon-version-check \
04129f48
AG
435%else
436 --with-serf=%{_prefix} \
437 --without-neon \
e3ad24ea 438%endif
16429189 439 --with-apr=%{_bindir}/apr-1-config \
1429fa1c 440 --with-apr-util=%{_bindir}/apu-1-config \
65f2befa 441%if %{with kwallet}
1429fa1c 442 --with-kwallet \
65f2befa 443%endif
bfb248d0 444%if %{with gnome}
1429fa1c 445 --with-gnome-keyring
bfb248d0 446%endif
536b3fd3 447
1f630180 448%{__make} -j1
536b3fd3 449
cf353d53 450%if !%{with net_client_only}
b56474ff 451# python
0905b458 452%if %{with python}
137fcafd
AM
453# ctypes bindings
454%{__make} ctypes-python
455# swig bindings
86a4919e 456%{__make} swig-py \
65318afa
AF
457 swig_pydir=%{py_sitedir}/libsvn \
458 swig_pydir_extra=%{py_sitedir}/svn
0905b458 459%endif
b56474ff 460# perl
0905b458 461%if %{with perl}
390bb8f4 462%{__make} -j1 swig-pl-lib
bf539998
AM
463odir=$(pwd)
464cd subversion/bindings/swig/perl/native
465%{__perl} Makefile.PL INSTALLDIRS=vendor
b445847c 466%{__make} -j1
bf539998 467cd $odir
536b3fd3 468%endif
1cc7453a 469%if %{with javahl}
b445847c 470%{__make} -j1 javahl \
1cc7453a 471 javahl_javadir="%{_javadir}"
472%endif
d46e45ba
AM
473# ruby
474%if %{with ruby}
475%{__make} swig-rb
476%endif
12ae68c1
AM
477%endif
478
479%if %{with tests}
480%{__make} check
d46e45ba 481%if %{with python}
137fcafd 482%{__make} check-ctypes-python
d46e45ba
AM
483%{__make} check-swig-py
484%endif
485%if %{with perl}
486%{__make} check-swig-pl
487%endif
488%if %{with ruby}
489%{__make} check-swig-rb
490%endif
0905b458 491%endif
93b78127
AM
492
493%install
494rm -rf $RPM_BUILD_ROOT
1326bb99 495install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 496 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 497 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 498 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 499
1f630180 500%{__make} install -j1 \
1cc7453a 501%if %{with javahl}
502 install-javahl \
503 javahl_javadir="%{_javadir}" \
504%endif
d46e45ba
AM
505%if !%{with net_client_only}
506%if %{with python}
0905b458 507 install-swig-py \
137fcafd 508 install-ctypes-python \
d46e45ba
AM
509%endif
510%if %{with ruby}
511 install-swig-rb install-swig-rb-doc \
512%endif
0905b458 513%endif
f2a757d6 514 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 515 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
516 swig_pydir=%{py_sitedir}/libsvn \
517 swig_pydir_extra=%{py_sitedir}/svn
93b78127 518
cf353d53 519%if !%{with net_client_only} && %{with perl}
bf539998
AM
520%{__make} install-swig-pl-lib \
521 DESTDIR=$RPM_BUILD_ROOT
b445847c 522%{__make} -C subversion/bindings/swig/perl/native install \
bf539998
AM
523 DESTDIR=$RPM_BUILD_ROOT \
524 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
525 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
bf539998
AM
526%endif
527
0905b458 528%if %{with apache}
1af5e34d
ER
529install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
530install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
531install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
532install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 533%endif
93b78127 534
cf353d53 535%if !%{with net_client_only}
1326bb99 536install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 537%if %{with python}
f4e6a380
AM
538%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
539%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
540find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
541install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 542%endif
0905b458 543%endif
f4e6a380 544
1326bb99
JK
545install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
546install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 547
205a3ddc
AM
548%find_lang %{name}
549
dd73606c 550%{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
c39b6844 551rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
552rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
a6ecf312 553
e23909be
JB
554%clean
555rm -rf $RPM_BUILD_ROOT
556
a1bac09d
557%pre svnserve
558%groupadd -g 86 svn
559%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
560
d2bf70bf
JB
561%post libs -p /sbin/ldconfig
562%postun libs -p /sbin/ldconfig
563
564%post devel -p /sbin/postshell
6f99c3bd 565-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 566
d2bf70bf 567%postun devel -p /sbin/postshell
6f99c3bd 568-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 569
d2bf70bf
JB
570%post -n perl-subversion -p /sbin/ldconfig
571%postun -n perl-subversion -p /sbin/ldconfig
572
573%post -n python-subversion -p /sbin/ldconfig
574%postun -n python-subversion -p /sbin/ldconfig
f4e6a380 575
b56474ff 576%post svnserve
e8d9186f
ER
577/sbin/chkconfig --add svnserve
578%service svnserve restart "svnserve daemon"
579
b56474ff
AM
580%preun svnserve
581if [ "$1" = "0" ]; then
e8d9186f
ER
582 %service svnserve stop
583 /sbin/chkconfig --del svnserve
b56474ff
AM
584fi
585
a1bac09d
586%postun svnserve
587if [ "$1" = "0" ]; then
588 %userremove svn
589 %groupremove svn
590fi
591
93b78127 592%post -n apache-mod_dav_svn
e8d9186f 593%service -q httpd restart
93b78127 594
ba425c92 595%postun -n apache-mod_dav_svn
93b78127 596if [ "$1" = "0" ]; then
e8d9186f 597 %service -q httpd restart
93b78127
AM
598fi
599
9688ba4c
JR
600%post -n apache-mod_authz_svn
601%service -q httpd restart
602
ba425c92 603%postun -n apache-mod_authz_svn
9688ba4c
JR
604if [ "$1" = "0" ]; then
605 %service -q httpd restart
606fi
607
93b78127
AM
608%files
609%defattr(644,root,root,755)
983a49f6 610%doc BUGS CHANGES COPYING INSTALL README
d37298dc 611%doc doc/*/*.html
4bbdbbf8
AM
612%doc tools/hook-scripts/*.{pl,py,example}
613%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 614%doc tools/xslt/*
b445847c
JB
615%attr(755,root,root) %{_bindir}/svn
616%attr(755,root,root) %{_bindir}/svnadmin
617%attr(755,root,root) %{_bindir}/svndumpfilter
618%attr(755,root,root) %{_bindir}/svnlook
619%attr(755,root,root) %{_bindir}/svnsync
620%attr(755,root,root) %{_bindir}/svnversion
621%{_mandir}/man1/svn.1*
622%{_mandir}/man1/svnadmin.1*
623%{_mandir}/man1/svndumpfilter.1*
624%{_mandir}/man1/svnlook.1*
625%{_mandir}/man1/svnsync.1*
626%{_mandir}/man1/svnversion.1*
f4e6a380 627
205a3ddc 628%files libs -f %{name}.lang
f4e6a380 629%defattr(644,root,root,755)
b445847c
JB
630%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
631%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
632%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
633%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
634%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
635%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
636%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
637%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
638%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
639%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
640%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
641%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
642%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
643%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
644%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
645%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
646%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
647%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
a510fada
AM
648%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
649%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
b445847c
JB
650%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
651%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
652%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
653%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
654%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
655%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
656%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
657%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
93b78127
AM
658
659%files devel
660%defattr(644,root,root,755)
b445847c
JB
661%attr(755,root,root) %{_libdir}/libsvn_client-1.so
662%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
663%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
664%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
665%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
666%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
667%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
668%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
669%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
a510fada 670%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
b445847c
JB
671%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
672%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
673%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
674%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
675%{_libdir}/libsvn_client-1.la
676%{_libdir}/libsvn_delta-1.la
677%{_libdir}/libsvn_diff-1.la
678%{_libdir}/libsvn_fs-1.la
679%{_libdir}/libsvn_fs_base-1.la
680%{_libdir}/libsvn_fs_fs-1.la
681%{_libdir}/libsvn_fs_util-1.la
682%{_libdir}/libsvn_ra-1.la
683%{_libdir}/libsvn_ra_local-1.la
a510fada 684%{_libdir}/libsvn_ra_%{webdavlib}-1.la
b445847c
JB
685%{_libdir}/libsvn_ra_svn-1.la
686%{_libdir}/libsvn_repos-1.la
687%{_libdir}/libsvn_subr-1.la
688%{_libdir}/libsvn_wc-1.la
689%{_includedir}/%{name}-1
1326bb99 690%{_examplesdir}/%{name}-%{version}
93b78127
AM
691
692%files static
693%defattr(644,root,root,755)
b445847c
JB
694%{_libdir}/libsvn_client-1.a
695%{_libdir}/libsvn_delta-1.a
696%{_libdir}/libsvn_diff-1.a
697%{_libdir}/libsvn_fs-1.a
698%{_libdir}/libsvn_fs_base-1.a
699%{_libdir}/libsvn_fs_fs-1.a
700%{_libdir}/libsvn_fs_util-1.a
701%{_libdir}/libsvn_ra-1.a
702%{_libdir}/libsvn_ra_local-1.a
a510fada 703%{_libdir}/libsvn_ra_%{webdavlib}-1.a
b445847c
JB
704%{_libdir}/libsvn_ra_svn-1.a
705%{_libdir}/libsvn_repos-1.a
706%{_libdir}/libsvn_subr-1.a
707%{_libdir}/libsvn_wc-1.a
93b78127 708
bfb248d0 709%if %{with gnome}
1429fa1c
AM
710%files -n gnome-keyring-subversion
711%defattr(644,root,root,755)
712%attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
713%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
bfb248d0 714%endif
1429fa1c 715
65f2befa 716%if %{with kwallet}
1429fa1c
AM
717%files -n kde4-kwallet-subversion
718%defattr(644,root,root,755)
719%attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
720%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
65f2befa 721%endif
1429fa1c 722
cf353d53 723%if !%{with net_client_only}
b56474ff
AM
724%files svnserve
725%defattr(644,root,root,755)
726%attr(755,root,root) %{_bindir}/svnserve
b445847c
JB
727%{_mandir}/man5/svnserve.conf.5*
728%{_mandir}/man8/svnserve.8*
a1bac09d
729%dir %attr(750,svn,svn) /home/services/subversion
730%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 731%if %{with apache}
b56474ff 732%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 733%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 734%endif
b56474ff 735
4bbdbbf8
AM
736%files tools
737%defattr(644,root,root,755)
1326bb99 738%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 739
740%files -n bash-completion-subversion
101e74de 741%defattr(644,root,root,755)
1326bb99 742/etc/bash_completion.d/%{name}
536b3fd3 743
1cc7453a 744%if %{with javahl}
745%files -n java-subversion
746%defattr(644,root,root,755)
b445847c
JB
747%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
748%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
749%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
1cc7453a 750%{_javadir}/svn-javahl.jar
751%endif
752
0905b458 753%if %{with python}
fa3ff1b2 754%files -n python-subversion
f4e6a380 755%defattr(644,root,root,755)
4bbdbbf8 756%doc tools/backup/*.py tools/examples/*.py
b445847c
JB
757%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
758%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
759%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
65318afa 760%dir %{py_sitedir}/libsvn
65318afa 761%{py_sitedir}/libsvn/*.py[co]
b445847c
JB
762%dir %{py_sitedir}/svn
763%{py_sitedir}/svn/*.py[co]
65318afa 764%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 765%{_examplesdir}/python-%{name}-%{version}
137fcafd
AM
766
767%files -n python-csvn
768%defattr(644,root,root,755)
769%doc subversion/bindings/ctypes-python/{README,TODO}
770%doc subversion/bindings/ctypes-python/examples/*.py
771%dir %{py_sitescriptdir}/csvn
772%{py_sitescriptdir}/csvn/*.py[co]
773%dir %{py_sitescriptdir}/csvn/core
774%{py_sitescriptdir}/csvn/core/*.py[co]
775%dir %{py_sitescriptdir}/csvn/ext
776%{py_sitescriptdir}/csvn/ext/*.py[co]
777%{py_sitescriptdir}/*.egg-info
0905b458 778%endif
f4e6a380 779
0905b458 780%if %{with perl}
b56474ff
AM
781%files -n perl-subversion
782%defattr(644,root,root,755)
b445847c
JB
783%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
784%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
785%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
b56474ff
AM
786%{perl_vendorarch}/SVN
787%dir %{perl_vendorarch}/auto/SVN
788%dir %{perl_vendorarch}/auto/SVN/*
789%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
790%{perl_vendorarch}/auto/SVN/*/*.bs
791%{_mandir}/man3/*.3pm*
0905b458 792%endif
b56474ff 793
d46e45ba
AM
794%if %{with ruby}
795%files -n ruby-subversion
796%defattr(644,root,root,755)
b445847c
JB
797%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
798%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
799%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
916011ef
JR
800%dir %{ruby_sitelibdir}/svn
801%{ruby_sitelibdir}/svn/*.rb
802%dir %{ruby_sitearchdir}/svn
803%dir %{ruby_sitearchdir}/svn/ext
e2c6dc67 804%attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
916011ef 805%{ruby_ridir}/Svn
d46e45ba
AM
806%endif
807
0905b458 808%if %{with apache}
93b78127
AM
809%files -n apache-mod_dav_svn
810%defattr(644,root,root,755)
1af5e34d
ER
811%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
812%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
813
814%files -n apache-mod_authz_svn
815%defattr(644,root,root,755)
816%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
817%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
818%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 819%endif
7b27380f
ER
820
821%endif # net_client_only
This page took 0.184449 seconds and 4 git commands to generate.