]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- no root rights required, use user svn
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
1930bef0 2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
4#
bab73684 5# Conditional build:
bc526ca4 6%bcond_with net_client_only # build only net client
8f179f02 7%bcond_without python # build without python bindings (broken)
0905b458 8%bcond_without perl # build without perl bindings
9%bcond_without apache # build without apache support (webdav, etc)
12ae68c1 10%bcond_without tests
7b27380f 11#
b56474ff 12%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 13%define apxs /usr/sbin/apxs
1f630180
ER
14%define pdir SVN
15%define pnam _Core
12ae68c1
AM
16#
17%define snap rc4
67cb9518 18Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
19Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
20Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 21Name: subversion
12ae68c1
AM
22Version: 1.5.0
23Release: 0.%{snap}.1
6f88d80e 24License: Apache/BSD-like
93b78127 25Group: Development/Version Control
12ae68c1
AM
26# Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.gz
27Source0: http://orac.ece.utexas.edu/pub/svn/%{version}-%{snap}/leander-hackberry/%{name}-%{version}-%{snap}.tar.gz
28# Source0-md5: 905fc5030be179d4d387803b8397668a
93b78127 29Source1: %{name}-dav_svn.conf
65318afa 30Source2: %{name}-authz_svn.conf
b56474ff
AM
31Source3: %{name}-svnserve.init
32Source4: %{name}-svnserve.sysconfig
f313e9a9 33Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 34Patch0: %{name}-home_etc.patch
d4bccc60 35Patch1: %{name}-DESTDIR.patch
93b78127 36URL: http://subversion.tigris.org/
4945947e
AM
37%if %{with net_client_only}
38%global apache_modules_api 0
39%else
f2a757d6 40%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 41BuildRequires: automake
3817faf5 42BuildRequires: db-devel >= 4.1.25
e8d9186f 43BuildRequires: rpmbuild(macros) >= 1.268
0905b458 44%if %{with perl}
522a69b4 45BuildRequires: perl-devel >= 1:5.8.0
46BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 47BuildRequires: swig-perl >= 1.3.24
536b3fd3 48%endif
0905b458 49%endif
16429189 50BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 51BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 52BuildRequires: autoconf >= 2.59
79d8c53c 53BuildRequires: bison
12ae68c1 54BuildRequires: cyrus-sasl-devel
93b78127 55BuildRequires: expat-devel
86ea8fde 56BuildRequires: gettext-devel
f4e6a380 57BuildRequires: libtool >= 1.4-9
bd3c99a8 58BuildRequires: neon-devel >= 0.26.0
53855fbf 59BuildRequires: python >= 2.2
ed6210a2 60BuildRequires: python-modules >= 2.2
f313e9a9 61%if %{with python}
62BuildRequires: python-devel >= 2.2
1f16145f 63BuildRequires: sed >= 4.0
15f9818d 64BuildRequires: swig-python >= 1.3.24
0905b458 65%endif
93b78127 66BuildRequires: texinfo
7b35d179 67BuildRequires: which
027f8ebe 68Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
69BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
f4070f5f 71%define _libexecdir %{_libdir}/svn
1af5e34d
ER
72%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
73%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127
AM
74
75%description
76The goal of the Subversion project is to build a version control
77system that is a compelling replacement for CVS in the open source
78community.
79
80Our goals are:
81- All current CVS features.
82- Directories, renames, and file meta-data are versioned.
83- Symbolic links, etc, are supported
84- Commits are truly atomic.
85- Branching and tagging are cheap (constant time) operations
86- Repeated merges are handled gracefully
87- Support for plug-in client side diff programs
88- Natively client/server
89- Client/server protocol sends diffs in both directions
90- Costs are proportional to change size, not project size
91- Internationalization
92- Progressive multi-lingual support
93
aa59005f 94%description -l pl.UTF-8
93b78127
AM
95Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
96zamiennika dla CVS.
97
98Cele projektu to:
aa59005f 99- Wszystkie aktualne możliwości CVS.
24406120
JB
100- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
101- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
102- Commity są w pełni atomowe.
103- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
104- Dobra obsługa powtarzanego łączenia (merge).
105- Obsługa wtyczek diff po stronie klienta.
93b78127 106- Natywny klient/serwer.
aa59005f 107- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
108- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
109- Internacjonalizacja.
aa59005f 110- Postępujące wsparcie dla wielu języków.
93b78127 111
aa59005f
JR
112%description -l pt_BR.UTF-8
113O objetivo do projeto Subversion é construir um sistema de controle de
114versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 115System) na comunidade opensource, fornecendo grandes melhorias.
116
f4e6a380
AM
117%package libs
118Summary: Subversion libraries and modules
abe3c421 119Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 120Group: Libraries
24406120 121Requires: neon >= 0.26.0
53855fbf 122Obsoletes: libsubversion0
f4e6a380
AM
123
124%description libs
125Subversion libraries and modules.
126
aa59005f
JR
127%description libs -l pl.UTF-8
128Biblioteka subversion oraz ładowalne moduły.
f4e6a380 129
93b78127
AM
130%package devel
131Summary: Header files and develpment documentation for subversion
abe3c421
ER
132Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
133Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 134Group: Development/Libraries
9cb7e099 135Requires: %{name}-libs = %{version}-%{release}
c5b1d686 136Requires: apr-util-devel >= 1:1.0.0
24406120 137Requires: neon-devel >= 0.26.0
12cf252c 138Obsoletes: libsubversion0-devel
93b78127
AM
139
140%description devel
141Header files and develpment documentation for subversion.
142
aa59005f
JR
143%description devel -l pl.UTF-8
144Pliki nagłówkowe i dokumetacja do subversion.
93b78127 145
aa59005f
JR
146%description devel -l pt_BR.UTF-8
147Este pacote provê os arquivos necessários para desenvolvedores
92066deb 148interagirem com o Subversion.
149
93b78127
AM
150%package static
151Summary: Static subversion library
abe3c421
ER
152Summary(pl.UTF-8): Biblioteka statyczna subversion
153Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
154Group: Development/Libraries
155Requires: %{name}-devel = %{version}
12cf252c 156Obsoletes: libsubversion0-static-devel
93b78127
AM
157
158%description static
159Static subversion library.
160
aa59005f 161%description static -l pl.UTF-8
93b78127
AM
162Biblioteka statyczna subversion.
163
aa59005f
JR
164%description static -l pt_BR.UTF-8
165Este pacote provê um cliente estático do subversion.
92066deb 166
b56474ff
AM
167%package svnserve
168Summary: Subversion svnserve
abe3c421 169Summary(pl.UTF-8): Subversion svnserve
b56474ff 170Group: Networking/Daemons
3817faf5 171Requires(post,preun): /sbin/chkconfig
9cb7e099 172Requires: %{name} = %{version}-%{release}
7b27380f 173Requires: rc-scripts
b56474ff
AM
174
175%description svnserve
176Subversion svnserve server.
177
aa59005f 178%description svnserve -l pl.UTF-8
b56474ff
AM
179Serwer subversion svnserve.
180
4bbdbbf8
AM
181%package tools
182Summary: Subversion tools and scripts
abe3c421
ER
183Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
184Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 185Group: Applications
4bbdbbf8 186%pyrequires_eq python
7b27380f 187Requires: %{name} = %{version}-%{release}
1271c9bd 188Requires: python-rcsparse >= 0.1-0.20031026.0
4bbdbbf8
AM
189Requires: python-subversion = %{version}
190
191%description tools
192Subversion tools and scripts.
193
aa59005f
JR
194%description tools -l pl.UTF-8
195Narzędzia oraz skrypty dla subversion.
4bbdbbf8 196
fe5bb6bb 197%package -n bash-completion-subversion
198Summary: bash completion for subversion
abe3c421 199Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 200Group: Applications/Shells
e30588c4 201Requires: %{name} = %{version}-%{release}
53855fbf 202Requires: bash-completion
e30588c4 203Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 204
205%description -n bash-completion-subversion
206Bash completion for subversion.
207
aa59005f
JR
208%description -n bash-completion-subversion -l pl.UTF-8
209Dopełnienia basha dla subversion.
fe5bb6bb 210
fa3ff1b2 211%package -n python-subversion
f4e6a380 212Summary: Subversion python bindings
abe3c421
ER
213Summary(pl.UTF-8): Dowiązania do subversion dla pythona
214Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
f4e6a380 215Group: Development/Languages/Python
f4e6a380 216%pyrequires_eq python
9cb7e099 217Requires: %{name}-libs = %{version}-%{release}
53855fbf 218Obsoletes: subversion-python
f4e6a380 219
fa3ff1b2 220%description -n python-subversion
f4e6a380
AM
221Subversion python bindings.
222
aa59005f
JR
223%description -n python-subversion -l pl.UTF-8
224Dowiązania do subversion dla pythona.
f4e6a380 225
aa59005f
JR
226%description -n python-subversion -l pt_BR.UTF-8
227Módulos python para acessar os recursos do Subversion.
92066deb 228
b56474ff
AM
229%package -n perl-subversion
230Summary: Subversion perl bindings
abe3c421
ER
231Summary(pl.UTF-8): Dowiązania do subversion dla perla
232Summary(pt_BR.UTF-8): Módulos perl para acessar os recursos do Subversion
b56474ff 233Group: Development/Languages/Perl
9cb7e099 234Requires: %{name}-libs = %{version}-%{release}
53855fbf 235Obsoletes: subversion-perl
b56474ff
AM
236
237%description -n perl-subversion
238Subversion perl bindings.
239
aa59005f
JR
240%description -n perl-subversion -l pl.UTF-8
241Dowiązania do subversion dla perl.
b56474ff 242
aa59005f
JR
243%description -n perl-subversion -l pt_BR.UTF-8
244Módulos perl para acessar os recursos do Subversion.
b56474ff 245
93b78127
AM
246%package -n apache-mod_dav_svn
247Summary: Apache module: Subversion Server
abe3c421 248Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 249Group: Networking/Daemons
7b27380f 250Requires: %{name} = %{version}-%{release}
53855fbf 251Requires: apache(modules-api) = %apache_modules_api
7887b1ac 252Requires: apache-mod_dav
93b78127
AM
253
254%description -n apache-mod_dav_svn
255Apache module: Subversion Server.
256
aa59005f
JR
257%description -n apache-mod_dav_svn -l pl.UTF-8
258Moduł apache: Serwer Subversion.
93b78127 259
65318afa
AF
260%package -n apache-mod_authz_svn
261Summary: Apache module: Subversion Server - path-based authorization
abe3c421 262Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 263Group: Networking/Daemons
53855fbf 264Requires: apache(modules-api) = %apache_modules_api
9cb7e099 265Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
266
267%description -n apache-mod_authz_svn
268Apache module: Subversion Server - path-based authorization.
269
aa59005f
JR
270%description -n apache-mod_authz_svn -l pl.UTF-8
271Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 272
93b78127 273%prep
12ae68c1 274%setup -q -n %{name}-%{version}-%{snap}
e30588c4 275rm -rf apr apr-util neon
ed6210a2 276%patch0 -p0
d4bccc60 277%patch1 -p1
027f8ebe 278
93b78127 279%build
f313e9a9 280rm subversion/bindings/swig/proxy/*.swg
24406120 281cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 282cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 283chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 284
fa3ff1b2 285# don't enable dso - currently it's broken
93b78127 286%configure \
5dfeafd7 287 --with-editor=vi \
12ae68c1 288 --with-zlib=%{_libdir} \
497058f9
AM
289 --with-python=%{_bindir}/python \
290 --with-perl5=%{_bindir}/perl \
536b3fd3
AM
291%if %{with net_client_only}
292 --without-apache \
293 --without-swig \
294 --without-apxs \
295 --without-berkeley-db \
296%else
227d7ab4 297 --disable-dso \
86ee97d3 298 --disable-mod-activation \
0905b458 299%if %{with apache}
536b3fd3 300 --with-apxs=%{_sbindir}/apxs \
0905b458 301%else
302 --without-apache \
303 --without-apxs \
536b3fd3 304 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
0905b458 305%endif
cf353d53 306%if !%{with python} && !%{with perl}
0905b458 307 --without-swig \
308%endif
536b3fd3 309%endif
e30588c4 310 --with-neon=%{_prefix} \
78f330c4 311 --disable-neon-version-check \
16429189 312 --with-apr=%{_bindir}/apr-1-config \
313 --with-apr-util=%{_bindir}/apu-1-config
536b3fd3 314
1f630180 315%{__make} -j1
536b3fd3 316
cf353d53 317%if !%{with net_client_only}
b56474ff 318# python
0905b458 319%if %{with python}
86a4919e 320%{__make} swig-py \
65318afa
AF
321 swig_pydir=%{py_sitedir}/libsvn \
322 swig_pydir_extra=%{py_sitedir}/svn
0905b458 323%endif
b56474ff 324# perl
0905b458 325%if %{with perl}
bf539998
AM
326%{__make} swig-pl-lib
327odir=$(pwd)
328cd subversion/bindings/swig/perl/native
329%{__perl} Makefile.PL INSTALLDIRS=vendor
330%{__make}
331cd $odir
536b3fd3 332%endif
12ae68c1
AM
333%endif
334
335%if %{with tests}
336%{__make} check
0905b458 337%endif
93b78127
AM
338
339%install
340rm -rf $RPM_BUILD_ROOT
1326bb99 341install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 342 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 343 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 344 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 345
1f630180 346%{__make} install -j1 \
cf353d53 347%if !%{with net_client_only} && %{with python}
0905b458 348 install-swig-py \
349%endif
f2a757d6 350 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 351 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
352 swig_pydir=%{py_sitedir}/libsvn \
353 swig_pydir_extra=%{py_sitedir}/svn
93b78127 354
cf353d53 355%if !%{with net_client_only} && %{with perl}
bf539998
AM
356%{__make} install-swig-pl-lib \
357 DESTDIR=$RPM_BUILD_ROOT
358odir=$(pwd)
359cd subversion/bindings/swig/perl/native
360%{__make} install \
361 DESTDIR=$RPM_BUILD_ROOT \
362 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
363 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
364cd $odir
365%endif
366
0905b458 367%if %{with apache}
1af5e34d
ER
368install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
369install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
370install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
371install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 372%endif
93b78127 373
cf353d53 374%if !%{with net_client_only}
1326bb99 375install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 376%if %{with python}
f4e6a380
AM
377%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
378%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
379find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
380install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 381%endif
0905b458 382%endif
f4e6a380 383
1326bb99
JK
384install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
385install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 386
205a3ddc
AM
387%find_lang %{name}
388
a6ecf312 389rm -f $RPM_BUILD_ROOT%{_libdir}/lib*swig*.la
390
e23909be
JB
391%clean
392rm -rf $RPM_BUILD_ROOT
393
6f99c3bd
ER
394%post devel -p /sbin/postshell
395-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 396
6f99c3bd
ER
397%postun devel -p /sbin/postshell
398-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 399
e23909be
JB
400%post libs -p /sbin/ldconfig
401%postun libs -p /sbin/ldconfig
164f681b
AM
402%post -n python-subversion -p /sbin/ldconfig
403%postun -n perl-subversion -p /sbin/ldconfig
f4e6a380 404
b56474ff 405%post svnserve
e8d9186f
ER
406/sbin/chkconfig --add svnserve
407%service svnserve restart "svnserve daemon"
408
b56474ff
AM
409%preun svnserve
410if [ "$1" = "0" ]; then
e8d9186f
ER
411 %service svnserve stop
412 /sbin/chkconfig --del svnserve
b56474ff
AM
413fi
414
93b78127 415%post -n apache-mod_dav_svn
e8d9186f 416%service -q httpd restart
93b78127
AM
417
418%preun -n apache-mod_dav_svn
419if [ "$1" = "0" ]; then
e8d9186f 420 %service -q httpd restart
93b78127
AM
421fi
422
93b78127
AM
423%files
424%defattr(644,root,root,755)
983a49f6 425%doc BUGS CHANGES COPYING INSTALL README
d37298dc 426%doc doc/*/*.html
4bbdbbf8
AM
427%doc tools/hook-scripts/*.{pl,py,example}
428%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 429%doc tools/xslt/*
fa3ff1b2 430%attr(755,root,root) %{_bindir}/svn*
b56474ff 431%exclude %{_bindir}/svnserve
cf353d53 432%if !%{with net_client_only}
9cb7e099 433%exclude %{_bindir}/svn-hot-backup
d62de3c9 434%endif
f4e6a380 435%{_mandir}/man1/*
af654ba5
AM
436%{_mandir}/man5/*
437%{_mandir}/man8/*
b56474ff 438%exclude %{_mandir}/man?/svnserve*
f4e6a380 439
205a3ddc 440%files libs -f %{name}.lang
f4e6a380 441%defattr(644,root,root,755)
227d7ab4 442%attr(755,root,root) %{_libdir}/lib*.so.*
164f681b
AM
443%if %{with perl} || %{with python}
444%exclude %{_libdir}/lib*_swig_*.so.*
445%endif
93b78127
AM
446
447%files devel
448%defattr(644,root,root,755)
227d7ab4
AM
449%{_includedir}/%{name}*
450%attr(755,root,root) %{_libdir}/lib*.so
b2bcb22a 451%{_libdir}/lib*.la
b72a2fbb 452%if %{with perl} || %{with python}
c00fdf6f 453%exclude %{_libdir}/lib*_swig_*.so
b72a2fbb 454%endif
1326bb99 455%{_examplesdir}/%{name}-%{version}
93b78127
AM
456
457%files static
458%defattr(644,root,root,755)
459%{_libdir}/lib*.a
460
cf353d53 461%if !%{with net_client_only}
b56474ff
AM
462%files svnserve
463%defattr(644,root,root,755)
464%attr(755,root,root) %{_bindir}/svnserve
465%{_mandir}/man?/svnserve*
afb35189 466%dir /home/services/subversion
a54611db 467%dir /home/services/subversion/repos
0905b458 468%if %{with apache}
b56474ff 469%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 470%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 471%endif
b56474ff 472
4bbdbbf8
AM
473%files tools
474%defattr(644,root,root,755)
1326bb99 475%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 476
477%files -n bash-completion-subversion
101e74de 478%defattr(644,root,root,755)
1326bb99 479/etc/bash_completion.d/%{name}
536b3fd3 480
0905b458 481%if %{with python}
fa3ff1b2 482%files -n python-subversion
f4e6a380 483%defattr(644,root,root,755)
4bbdbbf8 484%doc tools/backup/*.py tools/examples/*.py
f4e6a380 485%dir %{py_sitedir}/svn
65318afa 486%dir %{py_sitedir}/libsvn
f4e6a380 487%{py_sitedir}/svn/*.py[co]
65318afa
AF
488%{py_sitedir}/libsvn/*.py[co]
489%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 490%{_examplesdir}/python-%{name}-%{version}
c00fdf6f 491%attr(755,root,root) %{_libdir}/lib*_swig_py*.so*
0905b458 492%endif
f4e6a380 493
0905b458 494%if %{with perl}
b56474ff
AM
495%files -n perl-subversion
496%defattr(644,root,root,755)
497%{perl_vendorarch}/SVN
498%dir %{perl_vendorarch}/auto/SVN
499%dir %{perl_vendorarch}/auto/SVN/*
500%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
501%{perl_vendorarch}/auto/SVN/*/*.bs
502%{_mandir}/man3/*.3pm*
c00fdf6f 503%attr(755,root,root) %{_libdir}/lib*_swig_perl*.so*
0905b458 504%endif
b56474ff 505
0905b458 506%if %{with apache}
93b78127
AM
507%files -n apache-mod_dav_svn
508%defattr(644,root,root,755)
1af5e34d
ER
509%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
510%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
511
512%files -n apache-mod_authz_svn
513%defattr(644,root,root,755)
514%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
515%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
516%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 517%endif
7b27380f
ER
518
519%endif # net_client_only
This page took 0.153655 seconds and 4 git commands to generate.