]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- perl 5.10 workaround
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
1930bef0 2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
d46e45ba 4# - finish ruby
1930bef0 5#
bab73684 6# Conditional build:
65c1d4bd 7%bcond_with net_client_only # build only net client
e3ad24ea 8%bcond_with serf # use serf instead of neon
65c1d4bd
JB
9%bcond_without python # build without python bindings (broken)
10%bcond_without perl # build without perl bindings
73ab938a 11%bcond_without ruby # build without ruby bindings
65c1d4bd
JB
12%bcond_without apache # build without apache support (webdav, etc)
13%bcond_without javahl # build without javahl support (Java high-level bindings)
14%bcond_without tests # don't perform "make check"
7b27380f 15#
bc126282 16%ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
c2f5643d 17%undefine with_javahl
bc126282
AG
18%endif
19#
b56474ff 20%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 21%define apxs /usr/sbin/apxs
1f630180
ER
22%define pdir SVN
23%define pnam _Core
12ae68c1 24#
67cb9518 25Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
26Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
27Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 28Name: subversion
62e481b4
AM
29Version: 1.5.1
30Release: 1
6f88d80e 31License: Apache/BSD-like
93b78127 32Group: Development/Version Control
af7b0bac 33Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
62e481b4 34# Source0-md5: 8dbdaa625d6b18887702885df07fc87e
93b78127 35Source1: %{name}-dav_svn.conf
65318afa 36Source2: %{name}-authz_svn.conf
b56474ff
AM
37Source3: %{name}-svnserve.init
38Source4: %{name}-svnserve.sysconfig
f313e9a9 39Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 40Patch0: %{name}-home_etc.patch
d46e45ba 41Patch1: %{name}-DESTDIR.patch
00664663 42Patch2: %{name}-ruby-datadir-path.patch
d2bf70bf 43URL: http://subversion.tigris.org/
4945947e
AM
44%if %{with net_client_only}
45%global apache_modules_api 0
46%else
f2a757d6 47%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 48BuildRequires: automake
3817faf5 49BuildRequires: db-devel >= 4.1.25
e8d9186f 50BuildRequires: rpmbuild(macros) >= 1.268
0905b458 51%if %{with perl}
522a69b4 52BuildRequires: perl-devel >= 1:5.8.0
53BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 54BuildRequires: swig-perl >= 1.3.24
536b3fd3 55%endif
1cc7453a 56%{?with_javahl:BuildRequires: jdk}
0905b458 57%endif
16429189 58BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 59BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 60BuildRequires: autoconf >= 2.59
79d8c53c 61BuildRequires: bison
12ae68c1 62BuildRequires: cyrus-sasl-devel
93b78127 63BuildRequires: expat-devel
86ea8fde 64BuildRequires: gettext-devel
f4e6a380 65BuildRequires: libtool >= 1.4-9
e3ad24ea
AM
66%if %{with serf}
67BuildRequires: serf-devel
68%else
bd3c99a8 69BuildRequires: neon-devel >= 0.26.0
e3ad24ea 70%endif
53855fbf 71BuildRequires: python >= 2.2
ed6210a2 72BuildRequires: python-modules >= 2.2
f313e9a9 73%if %{with python}
74BuildRequires: python-devel >= 2.2
1f16145f 75BuildRequires: sed >= 4.0
15f9818d 76BuildRequires: swig-python >= 1.3.24
0905b458 77%endif
0baf7ef5 78%{?with_ruby:BuildRequires: ruby-devel}
73ab938a 79%{?with_ruby:BuildRequires: swig-ruby >= 1.3.24}
93b78127 80BuildRequires: texinfo
7b35d179 81BuildRequires: which
027f8ebe 82Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
83BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
f4070f5f 85%define _libexecdir %{_libdir}/svn
1af5e34d
ER
86%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
87%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127
AM
88
89%description
90The goal of the Subversion project is to build a version control
91system that is a compelling replacement for CVS in the open source
92community.
93
94Our goals are:
95- All current CVS features.
96- Directories, renames, and file meta-data are versioned.
97- Symbolic links, etc, are supported
98- Commits are truly atomic.
99- Branching and tagging are cheap (constant time) operations
100- Repeated merges are handled gracefully
101- Support for plug-in client side diff programs
102- Natively client/server
103- Client/server protocol sends diffs in both directions
104- Costs are proportional to change size, not project size
105- Internationalization
106- Progressive multi-lingual support
107
aa59005f 108%description -l pl.UTF-8
93b78127
AM
109Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
110zamiennika dla CVS.
111
112Cele projektu to:
aa59005f 113- Wszystkie aktualne możliwości CVS.
24406120
JB
114- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
115- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
116- Commity są w pełni atomowe.
117- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
118- Dobra obsługa powtarzanego łączenia (merge).
119- Obsługa wtyczek diff po stronie klienta.
93b78127 120- Natywny klient/serwer.
aa59005f 121- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
122- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
123- Internacjonalizacja.
aa59005f 124- Postępujące wsparcie dla wielu języków.
93b78127 125
aa59005f
JR
126%description -l pt_BR.UTF-8
127O objetivo do projeto Subversion é construir um sistema de controle de
128versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 129System) na comunidade opensource, fornecendo grandes melhorias.
130
f4e6a380
AM
131%package libs
132Summary: Subversion libraries and modules
abe3c421 133Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 134Group: Libraries
e3ad24ea 135%{!?with_serf:Requires: neon >= 0.26.0}
53855fbf 136Obsoletes: libsubversion0
f4e6a380
AM
137
138%description libs
139Subversion libraries and modules.
140
aa59005f
JR
141%description libs -l pl.UTF-8
142Biblioteka subversion oraz ładowalne moduły.
f4e6a380 143
93b78127
AM
144%package devel
145Summary: Header files and develpment documentation for subversion
abe3c421
ER
146Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
147Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 148Group: Development/Libraries
9cb7e099 149Requires: %{name}-libs = %{version}-%{release}
c5b1d686 150Requires: apr-util-devel >= 1:1.0.0
e3ad24ea 151%{!?with_serf:Requires: neon-devel >= 0.26.0}
12cf252c 152Obsoletes: libsubversion0-devel
93b78127
AM
153
154%description devel
155Header files and develpment documentation for subversion.
156
aa59005f
JR
157%description devel -l pl.UTF-8
158Pliki nagłówkowe i dokumetacja do subversion.
93b78127 159
aa59005f
JR
160%description devel -l pt_BR.UTF-8
161Este pacote provê os arquivos necessários para desenvolvedores
92066deb 162interagirem com o Subversion.
163
93b78127
AM
164%package static
165Summary: Static subversion library
abe3c421
ER
166Summary(pl.UTF-8): Biblioteka statyczna subversion
167Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
168Group: Development/Libraries
169Requires: %{name}-devel = %{version}
12cf252c 170Obsoletes: libsubversion0-static-devel
93b78127
AM
171
172%description static
173Static subversion library.
174
aa59005f 175%description static -l pl.UTF-8
93b78127
AM
176Biblioteka statyczna subversion.
177
aa59005f
JR
178%description static -l pt_BR.UTF-8
179Este pacote provê um cliente estático do subversion.
92066deb 180
b56474ff
AM
181%package svnserve
182Summary: Subversion svnserve
abe3c421 183Summary(pl.UTF-8): Subversion svnserve
b56474ff 184Group: Networking/Daemons
3817faf5 185Requires(post,preun): /sbin/chkconfig
93f1d402 186Requires(postun): /usr/sbin/groupdel
187Requires(postun): /usr/sbin/userdel
188Requires(pre): /bin/id
189Requires(pre): /usr/bin/getgid
190Requires(pre): /usr/lib/rpm/user_group.sh
191Requires(pre): /usr/sbin/groupadd
192Requires(pre): /usr/sbin/useradd
193Requires(pre): /usr/sbin/usermod
9cb7e099 194Requires: %{name} = %{version}-%{release}
7b27380f 195Requires: rc-scripts
a1bac09d
196Provides: group(svn)
197Provides: user(svn)
b56474ff
AM
198
199%description svnserve
200Subversion svnserve server.
201
aa59005f 202%description svnserve -l pl.UTF-8
b56474ff
AM
203Serwer subversion svnserve.
204
4bbdbbf8
AM
205%package tools
206Summary: Subversion tools and scripts
abe3c421
ER
207Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
208Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 209Group: Applications
4bbdbbf8 210%pyrequires_eq python
7b27380f 211Requires: %{name} = %{version}-%{release}
1271c9bd 212Requires: python-rcsparse >= 0.1-0.20031026.0
4bbdbbf8
AM
213Requires: python-subversion = %{version}
214
215%description tools
216Subversion tools and scripts.
217
aa59005f
JR
218%description tools -l pl.UTF-8
219Narzędzia oraz skrypty dla subversion.
4bbdbbf8 220
fe5bb6bb 221%package -n bash-completion-subversion
222Summary: bash completion for subversion
abe3c421 223Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 224Group: Applications/Shells
e30588c4 225Requires: %{name} = %{version}-%{release}
53855fbf 226Requires: bash-completion
e30588c4 227Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 228
229%description -n bash-completion-subversion
230Bash completion for subversion.
231
aa59005f
JR
232%description -n bash-completion-subversion -l pl.UTF-8
233Dopełnienia basha dla subversion.
fe5bb6bb 234
1cc7453a 235%package -n java-subversion
65c1d4bd
JB
236Summary: Subversion Java bindings
237Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 238Group: Development/Languages/Java
239Requires: %{name}-libs = %{version}-%{release}
240
241%description -n java-subversion
242This is a set of Java classes which provide the functionality of
243subversion-libs, the Subversion libraries. It is useful if you want
244to, for example, write a Java class that manipulates a Subversion
245repository or working copy. See the 'subversion' package for more
246information.
247
65c1d4bd
JB
248%description -n java-subversion -l pl.UTF-8
249Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
250subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
d46e45ba
AM
251pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
252roboczą. Więcej informacji w pakiecie subversion.
65c1d4bd 253
fa3ff1b2 254%package -n python-subversion
65c1d4bd
JB
255Summary: Subversion Python bindings
256Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
257Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 258Group: Development/Languages/Python
f4e6a380 259%pyrequires_eq python
9cb7e099 260Requires: %{name}-libs = %{version}-%{release}
53855fbf 261Obsoletes: subversion-python
f4e6a380 262
fa3ff1b2 263%description -n python-subversion
65c1d4bd 264Subversion Python bindings.
f4e6a380 265
aa59005f 266%description -n python-subversion -l pl.UTF-8
65c1d4bd 267Dowiązania do Subversion dla Pythona.
f4e6a380 268
aa59005f 269%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 270Módulos Python para acessar os recursos do Subversion.
92066deb 271
b56474ff 272%package -n perl-subversion
65c1d4bd
JB
273Summary: Subversion Perl bindings
274Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
275Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 276Group: Development/Languages/Perl
9cb7e099 277Requires: %{name}-libs = %{version}-%{release}
53855fbf 278Obsoletes: subversion-perl
b56474ff
AM
279
280%description -n perl-subversion
65c1d4bd 281Subversion Perl bindings.
b56474ff 282
aa59005f 283%description -n perl-subversion -l pl.UTF-8
65c1d4bd 284Dowiązania do Subversion dla Perla.
b56474ff 285
aa59005f 286%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 287Módulos Perl para acessar os recursos do Subversion.
b56474ff 288
d46e45ba
AM
289%package -n ruby-subversion
290Summary: Subversion Ruby bindings
d2bf70bf 291Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
d46e45ba
AM
292Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
293Group: Development/Languages
294Requires: %{name}-libs = %{version}-%{release}
295Obsoletes: subversion-ruby
296
297%description -n ruby-subversion
298Subversion Ruby bindings.
299
300%description -n ruby-subversion -l pl.UTF-8
d2bf70bf 301Dowiązania do Subversion dla języka Ruby.
d46e45ba
AM
302
303%description -n ruby-subversion -l pt_BR.UTF-8
304Módulos Ruby para acessar os recursos do Subversion.
305
93b78127
AM
306%package -n apache-mod_dav_svn
307Summary: Apache module: Subversion Server
abe3c421 308Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 309Group: Networking/Daemons
7b27380f 310Requires: %{name} = %{version}-%{release}
53855fbf 311Requires: apache(modules-api) = %apache_modules_api
7887b1ac 312Requires: apache-mod_dav
93b78127
AM
313
314%description -n apache-mod_dav_svn
315Apache module: Subversion Server.
316
aa59005f
JR
317%description -n apache-mod_dav_svn -l pl.UTF-8
318Moduł apache: Serwer Subversion.
93b78127 319
65318afa
AF
320%package -n apache-mod_authz_svn
321Summary: Apache module: Subversion Server - path-based authorization
abe3c421 322Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 323Group: Networking/Daemons
53855fbf 324Requires: apache(modules-api) = %apache_modules_api
9cb7e099 325Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
326
327%description -n apache-mod_authz_svn
328Apache module: Subversion Server - path-based authorization.
329
aa59005f
JR
330%description -n apache-mod_authz_svn -l pl.UTF-8
331Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 332
93b78127 333%prep
af7b0bac 334%setup -q
e30588c4 335rm -rf apr apr-util neon
ed6210a2 336%patch0 -p0
d4bccc60 337%patch1 -p1
00664663 338%patch2 -p0
027f8ebe 339
93b78127 340%build
93f1d402 341rm subversion/bindings/swig/proxy/*.swg
24406120 342cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 343cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 344chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 345
93b78127 346%configure \
5dfeafd7 347 --with-editor=vi \
12ae68c1 348 --with-zlib=%{_libdir} \
536b3fd3
AM
349%if %{with net_client_only}
350 --without-apache \
351 --without-swig \
352 --without-apxs \
353 --without-berkeley-db \
354%else
fa6fa2cf 355 --disable-runtime-module-search \
86ee97d3 356 --disable-mod-activation \
0905b458 357%if %{with apache}
536b3fd3 358 --with-apxs=%{_sbindir}/apxs \
0905b458 359%else
360 --without-apache \
361 --without-apxs \
536b3fd3 362 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
0905b458 363%endif
73ab938a 364%if !%{with python} && !%{with perl} && !%{with ruby}
0905b458 365 --without-swig \
366%endif
1cc7453a 367 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 368%endif
1cc7453a 369 --with-jdk="%{java_home}" \
e3ad24ea
AM
370%if %{with serf}
371 --with-serf=%{_prefix} \
372 --without-neon \
373%else
374 --without-serf \
e30588c4 375 --with-neon=%{_prefix} \
78f330c4 376 --disable-neon-version-check \
e3ad24ea 377%endif
16429189 378 --with-apr=%{_bindir}/apr-1-config \
379 --with-apr-util=%{_bindir}/apu-1-config
536b3fd3 380
1f630180 381%{__make} -j1
536b3fd3 382
cf353d53 383%if !%{with net_client_only}
b56474ff 384# python
0905b458 385%if %{with python}
86a4919e 386%{__make} swig-py \
65318afa
AF
387 swig_pydir=%{py_sitedir}/libsvn \
388 swig_pydir_extra=%{py_sitedir}/svn
0905b458 389%endif
b56474ff 390# perl
0905b458 391%if %{with perl}
bf539998
AM
392%{__make} swig-pl-lib
393odir=$(pwd)
394cd subversion/bindings/swig/perl/native
395%{__perl} Makefile.PL INSTALLDIRS=vendor
b445847c 396%{__make} -j1
bf539998 397cd $odir
536b3fd3 398%endif
1cc7453a 399%if %{with javahl}
b445847c 400%{__make} -j1 javahl \
1cc7453a 401 javahl_javadir="%{_javadir}"
402%endif
d46e45ba
AM
403# ruby
404%if %{with ruby}
405%{__make} swig-rb
406%endif
12ae68c1
AM
407%endif
408
409%if %{with tests}
410%{__make} check
d46e45ba
AM
411%if %{with python}
412%{__make} check-swig-py
413%endif
414%if %{with perl}
415%{__make} check-swig-pl
416%endif
417%if %{with ruby}
418%{__make} check-swig-rb
419%endif
0905b458 420%endif
93b78127
AM
421
422%install
423rm -rf $RPM_BUILD_ROOT
1326bb99 424install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 425 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 426 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 427 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 428
1f630180 429%{__make} install -j1 \
1cc7453a 430%if %{with javahl}
431 install-javahl \
432 javahl_javadir="%{_javadir}" \
433%endif
d46e45ba
AM
434%if !%{with net_client_only}
435%if %{with python}
0905b458 436 install-swig-py \
d46e45ba
AM
437%endif
438%if %{with ruby}
439 install-swig-rb install-swig-rb-doc \
440%endif
0905b458 441%endif
f2a757d6 442 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 443 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
444 swig_pydir=%{py_sitedir}/libsvn \
445 swig_pydir_extra=%{py_sitedir}/svn
93b78127 446
cf353d53 447%if !%{with net_client_only} && %{with perl}
bf539998
AM
448%{__make} install-swig-pl-lib \
449 DESTDIR=$RPM_BUILD_ROOT
b445847c 450%{__make} -C subversion/bindings/swig/perl/native install \
bf539998
AM
451 DESTDIR=$RPM_BUILD_ROOT \
452 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
453 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
bf539998
AM
454%endif
455
0905b458 456%if %{with apache}
1af5e34d
ER
457install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
458install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
459install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
460install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 461%endif
93b78127 462
cf353d53 463%if !%{with net_client_only}
1326bb99 464install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 465%if %{with python}
f4e6a380
AM
466%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
467%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
468find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
469install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 470%endif
0905b458 471%endif
f4e6a380 472
1326bb99
JK
473install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
474install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 475
205a3ddc
AM
476%find_lang %{name}
477
b445847c
JB
478rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn{javahl,_swig}*.{la,a}
479rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/svn/ext/*.la
a6ecf312 480
e23909be
JB
481%clean
482rm -rf $RPM_BUILD_ROOT
483
a1bac09d
484%pre svnserve
485%groupadd -g 86 svn
486%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
487
d2bf70bf
JB
488%post libs -p /sbin/ldconfig
489%postun libs -p /sbin/ldconfig
490
491%post devel -p /sbin/postshell
6f99c3bd 492-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 493
d2bf70bf 494%postun devel -p /sbin/postshell
6f99c3bd 495-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 496
d2bf70bf
JB
497%post -n perl-subversion -p /sbin/ldconfig
498%postun -n perl-subversion -p /sbin/ldconfig
499
500%post -n python-subversion -p /sbin/ldconfig
501%postun -n python-subversion -p /sbin/ldconfig
f4e6a380 502
b56474ff 503%post svnserve
e8d9186f
ER
504/sbin/chkconfig --add svnserve
505%service svnserve restart "svnserve daemon"
506
b56474ff
AM
507%preun svnserve
508if [ "$1" = "0" ]; then
e8d9186f
ER
509 %service svnserve stop
510 /sbin/chkconfig --del svnserve
b56474ff
AM
511fi
512
a1bac09d
513%postun svnserve
514if [ "$1" = "0" ]; then
515 %userremove svn
516 %groupremove svn
517fi
518
93b78127 519%post -n apache-mod_dav_svn
e8d9186f 520%service -q httpd restart
93b78127
AM
521
522%preun -n apache-mod_dav_svn
523if [ "$1" = "0" ]; then
e8d9186f 524 %service -q httpd restart
93b78127
AM
525fi
526
93b78127
AM
527%files
528%defattr(644,root,root,755)
983a49f6 529%doc BUGS CHANGES COPYING INSTALL README
d37298dc 530%doc doc/*/*.html
4bbdbbf8
AM
531%doc tools/hook-scripts/*.{pl,py,example}
532%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 533%doc tools/xslt/*
b445847c
JB
534%attr(755,root,root) %{_bindir}/svn
535%attr(755,root,root) %{_bindir}/svnadmin
536%attr(755,root,root) %{_bindir}/svndumpfilter
537%attr(755,root,root) %{_bindir}/svnlook
538%attr(755,root,root) %{_bindir}/svnsync
539%attr(755,root,root) %{_bindir}/svnversion
540%{_mandir}/man1/svn.1*
541%{_mandir}/man1/svnadmin.1*
542%{_mandir}/man1/svndumpfilter.1*
543%{_mandir}/man1/svnlook.1*
544%{_mandir}/man1/svnsync.1*
545%{_mandir}/man1/svnversion.1*
f4e6a380 546
205a3ddc 547%files libs -f %{name}.lang
f4e6a380 548%defattr(644,root,root,755)
b445847c
JB
549%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
550%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
551%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
552%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
553%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
554%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
555%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
556%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
557%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
558%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
559%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
560%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
561%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
562%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
563%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
564%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
565%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
566%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
567%attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so.*.*.*
568%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_neon-1.so.0
569%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
570%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
571%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
572%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
573%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
574%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
575%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
576%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
93b78127
AM
577
578%files devel
579%defattr(644,root,root,755)
b445847c
JB
580%attr(755,root,root) %{_libdir}/libsvn_client-1.so
581%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
582%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
583%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
584%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
585%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
586%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
587%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
588%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
589%attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so
590%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
591%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
592%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
593%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
594%{_libdir}/libsvn_client-1.la
595%{_libdir}/libsvn_delta-1.la
596%{_libdir}/libsvn_diff-1.la
597%{_libdir}/libsvn_fs-1.la
598%{_libdir}/libsvn_fs_base-1.la
599%{_libdir}/libsvn_fs_fs-1.la
600%{_libdir}/libsvn_fs_util-1.la
601%{_libdir}/libsvn_ra-1.la
602%{_libdir}/libsvn_ra_local-1.la
603%{_libdir}/libsvn_ra_neon-1.la
604%{_libdir}/libsvn_ra_svn-1.la
605%{_libdir}/libsvn_repos-1.la
606%{_libdir}/libsvn_subr-1.la
607%{_libdir}/libsvn_wc-1.la
608%{_includedir}/%{name}-1
1326bb99 609%{_examplesdir}/%{name}-%{version}
93b78127
AM
610
611%files static
612%defattr(644,root,root,755)
b445847c
JB
613%{_libdir}/libsvn_client-1.a
614%{_libdir}/libsvn_delta-1.a
615%{_libdir}/libsvn_diff-1.a
616%{_libdir}/libsvn_fs-1.a
617%{_libdir}/libsvn_fs_base-1.a
618%{_libdir}/libsvn_fs_fs-1.a
619%{_libdir}/libsvn_fs_util-1.a
620%{_libdir}/libsvn_ra-1.a
621%{_libdir}/libsvn_ra_local-1.a
622%{_libdir}/libsvn_ra_neon-1.a
623%{_libdir}/libsvn_ra_svn-1.a
624%{_libdir}/libsvn_repos-1.a
625%{_libdir}/libsvn_subr-1.a
626%{_libdir}/libsvn_wc-1.a
93b78127 627
cf353d53 628%if !%{with net_client_only}
b56474ff
AM
629%files svnserve
630%defattr(644,root,root,755)
631%attr(755,root,root) %{_bindir}/svnserve
b445847c
JB
632%{_mandir}/man5/svnserve.conf.5*
633%{_mandir}/man8/svnserve.8*
a1bac09d
634%dir %attr(750,svn,svn) /home/services/subversion
635%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 636%if %{with apache}
b56474ff 637%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 638%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 639%endif
b56474ff 640
4bbdbbf8
AM
641%files tools
642%defattr(644,root,root,755)
1326bb99 643%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 644
645%files -n bash-completion-subversion
101e74de 646%defattr(644,root,root,755)
1326bb99 647/etc/bash_completion.d/%{name}
536b3fd3 648
1cc7453a 649%if %{with javahl}
650%files -n java-subversion
651%defattr(644,root,root,755)
b445847c
JB
652%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
653%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
654%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
1cc7453a 655%{_javadir}/svn-javahl.jar
656%endif
657
0905b458 658%if %{with python}
fa3ff1b2 659%files -n python-subversion
f4e6a380 660%defattr(644,root,root,755)
4bbdbbf8 661%doc tools/backup/*.py tools/examples/*.py
b445847c
JB
662%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
663%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
664%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
65318afa 665%dir %{py_sitedir}/libsvn
65318afa 666%{py_sitedir}/libsvn/*.py[co]
b445847c
JB
667%dir %{py_sitedir}/svn
668%{py_sitedir}/svn/*.py[co]
65318afa 669%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 670%{_examplesdir}/python-%{name}-%{version}
0905b458 671%endif
f4e6a380 672
0905b458 673%if %{with perl}
b56474ff
AM
674%files -n perl-subversion
675%defattr(644,root,root,755)
b445847c
JB
676%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
677%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
678%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
b56474ff
AM
679%{perl_vendorarch}/SVN
680%dir %{perl_vendorarch}/auto/SVN
681%dir %{perl_vendorarch}/auto/SVN/*
682%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
683%{perl_vendorarch}/auto/SVN/*/*.bs
684%{_mandir}/man3/*.3pm*
0905b458 685%endif
b56474ff 686
d46e45ba
AM
687%if %{with ruby}
688%files -n ruby-subversion
689%defattr(644,root,root,755)
b445847c
JB
690%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
691%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
692%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
693%dir %{_libdir}/ruby/site_ruby/svn
694%{_libdir}/ruby/site_ruby/svn/*.rb
695%dir %{_libdir}/ruby/site_ruby/svn/ext
696%attr(755,root,root) %{_libdir}/ruby/site_ruby/svn/ext/*.so
ab6adef9 697%{_datadir}/ri/*.*/system/OptionParser
00664663 698%{_datadir}/ri/*.*/system/Svn
699%{_datadir}/ri/*.*/system/Time
700%{_datadir}/ri/*.*/system/Uconv
701%{_datadir}/ri/*.*/system/*.rid
702%{_datadir}/ri/*.*/system/Kernel/*
d46e45ba
AM
703%endif
704
0905b458 705%if %{with apache}
93b78127
AM
706%files -n apache-mod_dav_svn
707%defattr(644,root,root,755)
1af5e34d
ER
708%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
709%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
710
711%files -n apache-mod_authz_svn
712%defattr(644,root,root,755)
713%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
714%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
715%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 716%endif
7b27380f
ER
717
718%endif # net_client_only
This page took 0.231852 seconds and 4 git commands to generate.