]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- added tests patch (disables auth test, which fails when subversion cannot load...
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
1930bef0 2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
d46e45ba 4# - finish ruby
9688ba4c 5# - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
1930bef0 6#
bab73684 7# Conditional build:
65c1d4bd 8%bcond_with net_client_only # build only net client
3fc01170 9%bcond_without neon # use serf instead of neon
65c1d4bd
JB
10%bcond_without python # build without python bindings (broken)
11%bcond_without perl # build without perl bindings
73ab938a 12%bcond_without ruby # build without ruby bindings
65c1d4bd
JB
13%bcond_without apache # build without apache support (webdav, etc)
14%bcond_without javahl # build without javahl support (Java high-level bindings)
15%bcond_without tests # don't perform "make check"
65f2befa 16%bcond_without kwallet # build without kde4 wallet support
bfb248d0 17%bcond_without gnome # build without gnome keyring support
12c96b58 18
b56474ff 19%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 20%define apxs /usr/sbin/apxs
1f630180
ER
21%define pdir SVN
22%define pnam _Core
12c96b58 23
04129f48 24%if %{with neon}
a510fada 25%define webdavlib neon
04129f48
AG
26%else
27%define webdavlib serf
a510fada 28%endif
67cb9518 29Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
30Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
31Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 32Name: subversion
5a0b4697 33Version: 1.6.13
c130f9d2 34Release: 4
6f88d80e 35License: Apache/BSD-like
93b78127 36Group: Development/Version Control
a5c00029 37Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
5a0b4697 38# Source0-md5: 7ae1c827689f21cf975804005be30aeb
93b78127 39Source1: %{name}-dav_svn.conf
65318afa 40Source2: %{name}-authz_svn.conf
b56474ff
AM
41Source3: %{name}-svnserve.init
42Source4: %{name}-svnserve.sysconfig
a510fada
AM
43# current subversion tarball has correct *.swg files
44# but after regeneration these are broken again, so
45# we still need this script
f313e9a9 46Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 47Patch0: %{name}-home_etc.patch
d46e45ba 48Patch1: %{name}-DESTDIR.patch
00664663 49Patch2: %{name}-ruby-datadir-path.patch
1cfe7af2 50Patch3: %{name}-tests.patch
dc8fcc41 51URL: http://subversion.apache.org/
4945947e
AM
52%if %{with net_client_only}
53%global apache_modules_api 0
54%else
f2a757d6 55%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
1cfe7af2 56BuildRequires: autoconf
7b27380f 57BuildRequires: automake
3817faf5 58BuildRequires: db-devel >= 4.1.25
1cfe7af2 59BuildRequires: libtool
58f4b627 60BuildRequires: rpmbuild(macros) >= 1.583
0905b458 61%if %{with perl}
522a69b4 62BuildRequires: perl-devel >= 1:5.8.0
63BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 64BuildRequires: swig-perl >= 1.3.24
536b3fd3 65%endif
6ac3574b
AM
66%if %{with python}
67BuildRequires: python-ctypesgen
68BuildRequires: python-devel >= 2.2
69BuildRequires: swig-python >= 1.3.24
70%endif
71%if %{with ruby}
72BuildRequires: ruby-devel
73BuildRequires: swig-ruby >= 1.3.24
74%endif
af0d490b 75%if %{with javahl}
20c5f543 76BuildRequires: jdk
af0d490b 77%endif
6ac3574b 78BuildRequires: cyrus-sasl-devel
0905b458 79%endif
16429189 80BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 81BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 82BuildRequires: autoconf >= 2.59
79d8c53c 83BuildRequires: bison
93b78127 84BuildRequires: expat-devel
86ea8fde 85BuildRequires: gettext-devel
7b9fe651 86%{?with_gnome:BuildRequires: libgnome-keyring-devel}
65f2befa 87%{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
f4e6a380 88BuildRequires: libtool >= 1.4-9
54271075 89BuildRequires: pkgconfig
a562165a 90BuildRequires: sed >= 4.0
c26d84c4 91BuildRequires: sqlite3-devel >= 3.6.11
a562165a
JB
92BuildRequires: texinfo
93BuildRequires: which
94%if %{with neon}
bd3c99a8 95BuildRequires: neon-devel >= 0.26.0
a562165a
JB
96%else
97BuildRequires: serf-devel
e3ad24ea 98%endif
53855fbf 99BuildRequires: python >= 2.2
ed6210a2 100BuildRequires: python-modules >= 2.2
027f8ebe 101Requires: %{name}-libs = %{version}-%{release}
8b023a9d 102%requires_ge sqlite3
93b78127
AM
103BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
f4070f5f 105%define _libexecdir %{_libdir}/svn
1af5e34d
ER
106%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
107%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127 108
58f4b627
JR
109%define skip_post_check_so libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
110
93b78127
AM
111%description
112The goal of the Subversion project is to build a version control
113system that is a compelling replacement for CVS in the open source
114community.
115
116Our goals are:
117- All current CVS features.
118- Directories, renames, and file meta-data are versioned.
119- Symbolic links, etc, are supported
120- Commits are truly atomic.
121- Branching and tagging are cheap (constant time) operations
122- Repeated merges are handled gracefully
123- Support for plug-in client side diff programs
124- Natively client/server
125- Client/server protocol sends diffs in both directions
126- Costs are proportional to change size, not project size
127- Internationalization
128- Progressive multi-lingual support
129
aa59005f 130%description -l pl.UTF-8
93b78127
AM
131Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
132zamiennika dla CVS.
133
134Cele projektu to:
aa59005f 135- Wszystkie aktualne możliwości CVS.
24406120
JB
136- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
137- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
138- Commity są w pełni atomowe.
139- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
140- Dobra obsługa powtarzanego łączenia (merge).
141- Obsługa wtyczek diff po stronie klienta.
93b78127 142- Natywny klient/serwer.
aa59005f 143- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
144- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
145- Internacjonalizacja.
aa59005f 146- Postępujące wsparcie dla wielu języków.
93b78127 147
aa59005f
JR
148%description -l pt_BR.UTF-8
149O objetivo do projeto Subversion é construir um sistema de controle de
150versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 151System) na comunidade opensource, fornecendo grandes melhorias.
152
f4e6a380
AM
153%package libs
154Summary: Subversion libraries and modules
abe3c421 155Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 156Group: Libraries
04129f48 157%{?with_neon:Requires: neon >= 0.26.0}
53855fbf 158Obsoletes: libsubversion0
f4e6a380
AM
159
160%description libs
161Subversion libraries and modules.
162
aa59005f
JR
163%description libs -l pl.UTF-8
164Biblioteka subversion oraz ładowalne moduły.
f4e6a380 165
93b78127
AM
166%package devel
167Summary: Header files and develpment documentation for subversion
abe3c421
ER
168Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
169Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 170Group: Development/Libraries
9cb7e099 171Requires: %{name}-libs = %{version}-%{release}
c5b1d686 172Requires: apr-util-devel >= 1:1.0.0
04129f48 173%{?with_neon:Requires: neon-devel >= 0.26.0}
12cf252c 174Obsoletes: libsubversion0-devel
93b78127
AM
175
176%description devel
177Header files and develpment documentation for subversion.
178
aa59005f
JR
179%description devel -l pl.UTF-8
180Pliki nagłówkowe i dokumetacja do subversion.
93b78127 181
aa59005f
JR
182%description devel -l pt_BR.UTF-8
183Este pacote provê os arquivos necessários para desenvolvedores
92066deb 184interagirem com o Subversion.
185
93b78127
AM
186%package static
187Summary: Static subversion library
abe3c421
ER
188Summary(pl.UTF-8): Biblioteka statyczna subversion
189Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
190Group: Development/Libraries
191Requires: %{name}-devel = %{version}
12cf252c 192Obsoletes: libsubversion0-static-devel
93b78127
AM
193
194%description static
195Static subversion library.
196
aa59005f 197%description static -l pl.UTF-8
93b78127
AM
198Biblioteka statyczna subversion.
199
aa59005f
JR
200%description static -l pt_BR.UTF-8
201Este pacote provê um cliente estático do subversion.
92066deb 202
b56474ff
AM
203%package svnserve
204Summary: Subversion svnserve
abe3c421 205Summary(pl.UTF-8): Subversion svnserve
b56474ff 206Group: Networking/Daemons
3817faf5 207Requires(post,preun): /sbin/chkconfig
93f1d402 208Requires(postun): /usr/sbin/groupdel
209Requires(postun): /usr/sbin/userdel
210Requires(pre): /bin/id
211Requires(pre): /usr/bin/getgid
212Requires(pre): /usr/lib/rpm/user_group.sh
213Requires(pre): /usr/sbin/groupadd
214Requires(pre): /usr/sbin/useradd
215Requires(pre): /usr/sbin/usermod
9cb7e099 216Requires: %{name} = %{version}-%{release}
7b27380f 217Requires: rc-scripts
a1bac09d
218Provides: group(svn)
219Provides: user(svn)
b56474ff
AM
220
221%description svnserve
222Subversion svnserve server.
223
aa59005f 224%description svnserve -l pl.UTF-8
b56474ff
AM
225Serwer subversion svnserve.
226
4bbdbbf8
AM
227%package tools
228Summary: Subversion tools and scripts
abe3c421
ER
229Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
230Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 231Group: Applications
4bbdbbf8 232%pyrequires_eq python
7b27380f 233Requires: %{name} = %{version}-%{release}
4bbdbbf8
AM
234Requires: python-subversion = %{version}
235
236%description tools
237Subversion tools and scripts.
238
aa59005f
JR
239%description tools -l pl.UTF-8
240Narzędzia oraz skrypty dla subversion.
4bbdbbf8 241
fe5bb6bb 242%package -n bash-completion-subversion
243Summary: bash completion for subversion
abe3c421 244Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 245Group: Applications/Shells
e30588c4 246Requires: %{name} = %{version}-%{release}
53855fbf 247Requires: bash-completion
e30588c4 248Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 249
250%description -n bash-completion-subversion
251Bash completion for subversion.
252
aa59005f
JR
253%description -n bash-completion-subversion -l pl.UTF-8
254Dopełnienia basha dla subversion.
fe5bb6bb 255
1cc7453a 256%package -n java-subversion
65c1d4bd
JB
257Summary: Subversion Java bindings
258Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 259Group: Development/Languages/Java
260Requires: %{name}-libs = %{version}-%{release}
261
262%description -n java-subversion
263This is a set of Java classes which provide the functionality of
264subversion-libs, the Subversion libraries. It is useful if you want
265to, for example, write a Java class that manipulates a Subversion
266repository or working copy. See the 'subversion' package for more
267information.
268
65c1d4bd
JB
269%description -n java-subversion -l pl.UTF-8
270Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
271subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
d46e45ba
AM
272pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
273roboczą. Więcej informacji w pakiecie subversion.
65c1d4bd 274
fa3ff1b2 275%package -n python-subversion
65c1d4bd
JB
276Summary: Subversion Python bindings
277Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
278Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 279Group: Development/Languages/Python
f4e6a380 280%pyrequires_eq python
9cb7e099 281Requires: %{name}-libs = %{version}-%{release}
53855fbf 282Obsoletes: subversion-python
f4e6a380 283
fa3ff1b2 284%description -n python-subversion
65c1d4bd 285Subversion Python bindings.
f4e6a380 286
aa59005f 287%description -n python-subversion -l pl.UTF-8
65c1d4bd 288Dowiązania do Subversion dla Pythona.
f4e6a380 289
aa59005f 290%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 291Módulos Python para acessar os recursos do Subversion.
92066deb 292
137fcafd
AM
293%package -n python-csvn
294Summary: CTypes Subversion Python bindings
295Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
296Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
297Group: Development/Languages/Python
298%pyrequires_eq python
299Requires: %{name}-libs = %{version}-%{release}
300
301%description -n python-csvn
302Subversion CTypes Python bindings.
303
304%description -n python-csvn -l pl.UTF-8
305Dowiązania do Subversion dla Pythona używające CTypes.
306
307%description -n python-csvn -l pt_BR.UTF-8
308Módulos Python para acessar os recursos do Subversion.
309
b56474ff 310%package -n perl-subversion
65c1d4bd
JB
311Summary: Subversion Perl bindings
312Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
313Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 314Group: Development/Languages/Perl
9cb7e099 315Requires: %{name}-libs = %{version}-%{release}
53855fbf 316Obsoletes: subversion-perl
b56474ff
AM
317
318%description -n perl-subversion
65c1d4bd 319Subversion Perl bindings.
b56474ff 320
aa59005f 321%description -n perl-subversion -l pl.UTF-8
65c1d4bd 322Dowiązania do Subversion dla Perla.
b56474ff 323
aa59005f 324%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 325Módulos Perl para acessar os recursos do Subversion.
b56474ff 326
d46e45ba
AM
327%package -n ruby-subversion
328Summary: Subversion Ruby bindings
d2bf70bf 329Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
d46e45ba
AM
330Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
331Group: Development/Languages
332Requires: %{name}-libs = %{version}-%{release}
333Obsoletes: subversion-ruby
334
335%description -n ruby-subversion
336Subversion Ruby bindings.
337
338%description -n ruby-subversion -l pl.UTF-8
d2bf70bf 339Dowiązania do Subversion dla języka Ruby.
d46e45ba
AM
340
341%description -n ruby-subversion -l pt_BR.UTF-8
342Módulos Ruby para acessar os recursos do Subversion.
343
93b78127
AM
344%package -n apache-mod_dav_svn
345Summary: Apache module: Subversion Server
abe3c421 346Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 347Group: Networking/Daemons
7b27380f 348Requires: %{name} = %{version}-%{release}
53855fbf 349Requires: apache(modules-api) = %apache_modules_api
7887b1ac 350Requires: apache-mod_dav
93b78127
AM
351
352%description -n apache-mod_dav_svn
353Apache module: Subversion Server.
354
aa59005f
JR
355%description -n apache-mod_dav_svn -l pl.UTF-8
356Moduł apache: Serwer Subversion.
93b78127 357
65318afa
AF
358%package -n apache-mod_authz_svn
359Summary: Apache module: Subversion Server - path-based authorization
abe3c421 360Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 361Group: Networking/Daemons
53855fbf 362Requires: apache(modules-api) = %apache_modules_api
9cb7e099 363Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
364
365%description -n apache-mod_authz_svn
366Apache module: Subversion Server - path-based authorization.
367
aa59005f
JR
368%description -n apache-mod_authz_svn -l pl.UTF-8
369Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 370
1429fa1c
AM
371%package -n gnome-keyring-subversion
372Summary: Subversion module for Gnome Keyring
373Summary(pl.UTF-8): Moduł subversion dla zarządcy kluczy Gnome
374Group: X11/Applications
375
376%description -n gnome-keyring-subversion
377Subversion module for Gnome Keyring.
378
379%description -n gnome-keyring-subversion -l pl.UTF-8
380Moduł subversion dla zarządcy kluczy Gnome.
381
382%package -n kde4-kwallet-subversion
383Summary: Subversion module for KDE Wallet
384Summary(pl.UTF-8): Moduł subversion dla Portfela KDE
385Group: X11/Applications
386
387%description -n kde4-kwallet-subversion
388Subversion module for KDE Wallet.
389
390%description -n kde4-kwallet-subversion -l pl.UTF-8
391Moduł subversion dla Portfela KDE.
392
93b78127 393%prep
a5c00029 394%setup -q
e30588c4 395rm -rf apr apr-util neon
ed6210a2 396%patch0 -p0
d4bccc60 397%patch1 -p1
00664663 398%patch2 -p0
1cfe7af2 399%patch3 -p1
a510fada
AM
400
401sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
402
403# serf.m4 macro is broken and ignores --without serf
244bdb04 404%{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
027f8ebe 405
93b78127 406%build
1cfe7af2
JB
407# disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
408#%{__rm} subversion/bindings/swig/proxy/*.swg
409#cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
67cb9518 410chmod +x ./autogen.sh && ./autogen.sh
1cfe7af2 411%{__libtoolize}
93b78127 412%configure \
5dfeafd7 413 --with-editor=vi \
12ae68c1 414 --with-zlib=%{_libdir} \
536b3fd3
AM
415%if %{with net_client_only}
416 --without-apache \
417 --without-swig \
418 --without-apxs \
419 --without-berkeley-db \
420%else
fa6fa2cf 421 --disable-runtime-module-search \
86ee97d3 422 --disable-mod-activation \
ad5c551e 423 --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
0905b458 424%if %{with apache}
536b3fd3 425 --with-apxs=%{_sbindir}/apxs \
0905b458 426%else
427 --without-apache \
428 --without-apxs \
0905b458 429%endif
73ab938a 430%if !%{with python} && !%{with perl} && !%{with ruby}
0905b458 431 --without-swig \
432%endif
137fcafd 433 %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
1cc7453a 434 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 435%endif
1cc7453a 436 --with-jdk="%{java_home}" \
cf2589d0 437 --without-jikes \
04129f48 438%if %{with neon}
e3ad24ea 439 --without-serf \
e30588c4 440 --with-neon=%{_prefix} \
78f330c4 441 --disable-neon-version-check \
04129f48
AG
442%else
443 --with-serf=%{_prefix} \
444 --without-neon \
e3ad24ea 445%endif
16429189 446 --with-apr=%{_bindir}/apr-1-config \
1429fa1c 447 --with-apr-util=%{_bindir}/apu-1-config \
65f2befa 448%if %{with kwallet}
1429fa1c 449 --with-kwallet \
65f2befa 450%endif
bfb248d0 451%if %{with gnome}
1429fa1c 452 --with-gnome-keyring
bfb248d0 453%endif
536b3fd3 454
1f630180 455%{__make} -j1
536b3fd3 456
cf353d53 457%if !%{with net_client_only}
b56474ff 458# python
0905b458 459%if %{with python}
137fcafd
AM
460# ctypes bindings
461%{__make} ctypes-python
462# swig bindings
86a4919e 463%{__make} swig-py \
65318afa
AF
464 swig_pydir=%{py_sitedir}/libsvn \
465 swig_pydir_extra=%{py_sitedir}/svn
0905b458 466%endif
b56474ff 467# perl
0905b458 468%if %{with perl}
390bb8f4 469%{__make} -j1 swig-pl-lib
bf539998
AM
470odir=$(pwd)
471cd subversion/bindings/swig/perl/native
472%{__perl} Makefile.PL INSTALLDIRS=vendor
b445847c 473%{__make} -j1
bf539998 474cd $odir
536b3fd3 475%endif
1cc7453a 476%if %{with javahl}
b445847c 477%{__make} -j1 javahl \
1cc7453a 478 javahl_javadir="%{_javadir}"
479%endif
d46e45ba
AM
480# ruby
481%if %{with ruby}
482%{__make} swig-rb
483%endif
12ae68c1
AM
484%endif
485
486%if %{with tests}
487%{__make} check
d46e45ba 488%if %{with python}
137fcafd 489%{__make} check-ctypes-python
d46e45ba
AM
490%{__make} check-swig-py
491%endif
492%if %{with perl}
493%{__make} check-swig-pl
494%endif
495%if %{with ruby}
496%{__make} check-swig-rb
497%endif
0905b458 498%endif
93b78127
AM
499
500%install
501rm -rf $RPM_BUILD_ROOT
1326bb99 502install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 503 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 504 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 505 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 506
1f630180 507%{__make} install -j1 \
1cc7453a 508%if %{with javahl}
509 install-javahl \
510 javahl_javadir="%{_javadir}" \
511%endif
d46e45ba
AM
512%if !%{with net_client_only}
513%if %{with python}
0905b458 514 install-swig-py \
137fcafd 515 install-ctypes-python \
d46e45ba
AM
516%endif
517%if %{with ruby}
518 install-swig-rb install-swig-rb-doc \
519%endif
0905b458 520%endif
f2a757d6 521 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 522 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
523 swig_pydir=%{py_sitedir}/libsvn \
524 swig_pydir_extra=%{py_sitedir}/svn
93b78127 525
cf353d53 526%if !%{with net_client_only} && %{with perl}
bf539998
AM
527%{__make} install-swig-pl-lib \
528 DESTDIR=$RPM_BUILD_ROOT
b445847c 529%{__make} -C subversion/bindings/swig/perl/native install \
bf539998
AM
530 DESTDIR=$RPM_BUILD_ROOT \
531 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
532 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
bf539998
AM
533%endif
534
0905b458 535%if %{with apache}
1af5e34d
ER
536install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
537install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
538install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
539install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 540%endif
93b78127 541
cf353d53 542%if !%{with net_client_only}
1326bb99 543install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 544%if %{with python}
f4e6a380
AM
545%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
546%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
547find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
548install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 549%endif
0905b458 550%endif
f4e6a380 551
1326bb99
JK
552install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
553install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 554
205a3ddc
AM
555%find_lang %{name}
556
dd73606c 557%{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
c39b6844 558rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
559rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
a6ecf312 560
e23909be
JB
561%clean
562rm -rf $RPM_BUILD_ROOT
563
a1bac09d
564%pre svnserve
565%groupadd -g 86 svn
566%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
567
d2bf70bf
JB
568%post libs -p /sbin/ldconfig
569%postun libs -p /sbin/ldconfig
570
571%post devel -p /sbin/postshell
6f99c3bd 572-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 573
d2bf70bf 574%postun devel -p /sbin/postshell
6f99c3bd 575-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 576
12c96b58
ER
577%post -n java-subversion -p /sbin/ldconfig
578%postun -n java-subversion -p /sbin/ldconfig
579
d2bf70bf
JB
580%post -n perl-subversion -p /sbin/ldconfig
581%postun -n perl-subversion -p /sbin/ldconfig
582
583%post -n python-subversion -p /sbin/ldconfig
584%postun -n python-subversion -p /sbin/ldconfig
f4e6a380 585
12c96b58
ER
586%post -n ruby-subversion -p /sbin/ldconfig
587%postun -n ruby-subversion -p /sbin/ldconfig
588
589%post -n gnome-keyring-subversion -p /sbin/ldconfig
590%postun -n gnome-keyring-subversion -p /sbin/ldconfig
591
592%post -n kde4-kwallet-subversion -p /sbin/ldconfig
593%postun -n kde4-kwallet-subversion -p /sbin/ldconfig
594
b56474ff 595%post svnserve
e8d9186f
ER
596/sbin/chkconfig --add svnserve
597%service svnserve restart "svnserve daemon"
598
b56474ff
AM
599%preun svnserve
600if [ "$1" = "0" ]; then
e8d9186f
ER
601 %service svnserve stop
602 /sbin/chkconfig --del svnserve
b56474ff
AM
603fi
604
a1bac09d
605%postun svnserve
606if [ "$1" = "0" ]; then
12c96b58
ER
607 %userremove svn
608 %groupremove svn
a1bac09d
609fi
610
93b78127 611%post -n apache-mod_dav_svn
e8d9186f 612%service -q httpd restart
93b78127 613
ba425c92 614%postun -n apache-mod_dav_svn
93b78127 615if [ "$1" = "0" ]; then
e8d9186f 616 %service -q httpd restart
93b78127
AM
617fi
618
9688ba4c
JR
619%post -n apache-mod_authz_svn
620%service -q httpd restart
621
ba425c92 622%postun -n apache-mod_authz_svn
9688ba4c
JR
623if [ "$1" = "0" ]; then
624 %service -q httpd restart
625fi
626
93b78127
AM
627%files
628%defattr(644,root,root,755)
983a49f6 629%doc BUGS CHANGES COPYING INSTALL README
d37298dc 630%doc doc/*/*.html
4bbdbbf8
AM
631%doc tools/hook-scripts/*.{pl,py,example}
632%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 633%doc tools/xslt/*
b445847c
JB
634%attr(755,root,root) %{_bindir}/svn
635%attr(755,root,root) %{_bindir}/svnadmin
636%attr(755,root,root) %{_bindir}/svndumpfilter
637%attr(755,root,root) %{_bindir}/svnlook
638%attr(755,root,root) %{_bindir}/svnsync
639%attr(755,root,root) %{_bindir}/svnversion
640%{_mandir}/man1/svn.1*
641%{_mandir}/man1/svnadmin.1*
642%{_mandir}/man1/svndumpfilter.1*
643%{_mandir}/man1/svnlook.1*
644%{_mandir}/man1/svnsync.1*
645%{_mandir}/man1/svnversion.1*
f4e6a380 646
205a3ddc 647%files libs -f %{name}.lang
f4e6a380 648%defattr(644,root,root,755)
b445847c
JB
649%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
650%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
651%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
652%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
653%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
654%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
655%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
656%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
657%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
658%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
659%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
660%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
661%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
662%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
663%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
664%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
665%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
666%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
a510fada
AM
667%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
668%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
b445847c
JB
669%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
670%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
671%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
672%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
673%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
674%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
675%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
676%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
93b78127
AM
677
678%files devel
679%defattr(644,root,root,755)
b445847c
JB
680%attr(755,root,root) %{_libdir}/libsvn_client-1.so
681%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
682%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
683%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
684%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
685%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
686%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
687%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
688%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
a510fada 689%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
b445847c
JB
690%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
691%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
692%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
693%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
694%{_libdir}/libsvn_client-1.la
695%{_libdir}/libsvn_delta-1.la
696%{_libdir}/libsvn_diff-1.la
697%{_libdir}/libsvn_fs-1.la
698%{_libdir}/libsvn_fs_base-1.la
699%{_libdir}/libsvn_fs_fs-1.la
700%{_libdir}/libsvn_fs_util-1.la
701%{_libdir}/libsvn_ra-1.la
702%{_libdir}/libsvn_ra_local-1.la
a510fada 703%{_libdir}/libsvn_ra_%{webdavlib}-1.la
b445847c
JB
704%{_libdir}/libsvn_ra_svn-1.la
705%{_libdir}/libsvn_repos-1.la
706%{_libdir}/libsvn_subr-1.la
707%{_libdir}/libsvn_wc-1.la
708%{_includedir}/%{name}-1
1326bb99 709%{_examplesdir}/%{name}-%{version}
93b78127
AM
710
711%files static
712%defattr(644,root,root,755)
b445847c
JB
713%{_libdir}/libsvn_client-1.a
714%{_libdir}/libsvn_delta-1.a
715%{_libdir}/libsvn_diff-1.a
716%{_libdir}/libsvn_fs-1.a
717%{_libdir}/libsvn_fs_base-1.a
718%{_libdir}/libsvn_fs_fs-1.a
719%{_libdir}/libsvn_fs_util-1.a
720%{_libdir}/libsvn_ra-1.a
721%{_libdir}/libsvn_ra_local-1.a
a510fada 722%{_libdir}/libsvn_ra_%{webdavlib}-1.a
b445847c
JB
723%{_libdir}/libsvn_ra_svn-1.a
724%{_libdir}/libsvn_repos-1.a
725%{_libdir}/libsvn_subr-1.a
726%{_libdir}/libsvn_wc-1.a
93b78127 727
bfb248d0 728%if %{with gnome}
1429fa1c
AM
729%files -n gnome-keyring-subversion
730%defattr(644,root,root,755)
731%attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
732%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
bfb248d0 733%endif
1429fa1c 734
65f2befa 735%if %{with kwallet}
1429fa1c
AM
736%files -n kde4-kwallet-subversion
737%defattr(644,root,root,755)
738%attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
739%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
65f2befa 740%endif
1429fa1c 741
12c96b58 742%if %{without net_client_only}
b56474ff
AM
743%files svnserve
744%defattr(644,root,root,755)
745%attr(755,root,root) %{_bindir}/svnserve
b445847c
JB
746%{_mandir}/man5/svnserve.conf.5*
747%{_mandir}/man8/svnserve.8*
a1bac09d
748%dir %attr(750,svn,svn) /home/services/subversion
749%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 750%if %{with apache}
b56474ff 751%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 752%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 753%endif
b56474ff 754
4bbdbbf8
AM
755%files tools
756%defattr(644,root,root,755)
1326bb99 757%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 758
759%files -n bash-completion-subversion
101e74de 760%defattr(644,root,root,755)
1326bb99 761/etc/bash_completion.d/%{name}
536b3fd3 762
1cc7453a 763%if %{with javahl}
764%files -n java-subversion
765%defattr(644,root,root,755)
b445847c
JB
766%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
767%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
768%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
1cc7453a 769%{_javadir}/svn-javahl.jar
770%endif
771
0905b458 772%if %{with python}
fa3ff1b2 773%files -n python-subversion
f4e6a380 774%defattr(644,root,root,755)
4bbdbbf8 775%doc tools/backup/*.py tools/examples/*.py
b445847c
JB
776%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
777%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
778%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
65318afa 779%dir %{py_sitedir}/libsvn
65318afa 780%{py_sitedir}/libsvn/*.py[co]
b445847c
JB
781%dir %{py_sitedir}/svn
782%{py_sitedir}/svn/*.py[co]
65318afa 783%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 784%{_examplesdir}/python-%{name}-%{version}
137fcafd
AM
785
786%files -n python-csvn
787%defattr(644,root,root,755)
788%doc subversion/bindings/ctypes-python/{README,TODO}
789%doc subversion/bindings/ctypes-python/examples/*.py
790%dir %{py_sitescriptdir}/csvn
791%{py_sitescriptdir}/csvn/*.py[co]
792%dir %{py_sitescriptdir}/csvn/core
793%{py_sitescriptdir}/csvn/core/*.py[co]
794%dir %{py_sitescriptdir}/csvn/ext
795%{py_sitescriptdir}/csvn/ext/*.py[co]
796%{py_sitescriptdir}/*.egg-info
0905b458 797%endif
f4e6a380 798
0905b458 799%if %{with perl}
b56474ff
AM
800%files -n perl-subversion
801%defattr(644,root,root,755)
b445847c
JB
802%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
803%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
804%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
b56474ff
AM
805%{perl_vendorarch}/SVN
806%dir %{perl_vendorarch}/auto/SVN
807%dir %{perl_vendorarch}/auto/SVN/*
808%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
809%{perl_vendorarch}/auto/SVN/*/*.bs
810%{_mandir}/man3/*.3pm*
0905b458 811%endif
b56474ff 812
d46e45ba
AM
813%if %{with ruby}
814%files -n ruby-subversion
815%defattr(644,root,root,755)
b445847c
JB
816%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
817%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
818%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
916011ef
JR
819%dir %{ruby_sitelibdir}/svn
820%{ruby_sitelibdir}/svn/*.rb
821%dir %{ruby_sitearchdir}/svn
822%dir %{ruby_sitearchdir}/svn/ext
e2c6dc67 823%attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
916011ef 824%{ruby_ridir}/Svn
d46e45ba
AM
825%endif
826
0905b458 827%if %{with apache}
93b78127
AM
828%files -n apache-mod_dav_svn
829%defattr(644,root,root,755)
1af5e34d
ER
830%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
831%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
832
833%files -n apache-mod_authz_svn
834%defattr(644,root,root,755)
835%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
836%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
837%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 838%endif
7b27380f
ER
839
840%endif # net_client_only
This page took 0.298967 seconds and 4 git commands to generate.