]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- ruby site dir is packaged as system dir in pld
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
1930bef0 2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
d46e45ba 4# - finish ruby
1930bef0 5#
bab73684 6# Conditional build:
65c1d4bd
JB
7%bcond_with net_client_only # build only net client
8%bcond_without python # build without python bindings (broken)
9%bcond_without perl # build without perl bindings
73ab938a 10%bcond_without ruby # build without ruby bindings
65c1d4bd
JB
11%bcond_without apache # build without apache support (webdav, etc)
12%bcond_without javahl # build without javahl support (Java high-level bindings)
13%bcond_without tests # don't perform "make check"
7b27380f 14#
bc126282 15%ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
c2f5643d 16%undefine with_javahl
bc126282
AG
17%endif
18#
b56474ff 19%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 20%define apxs /usr/sbin/apxs
1f630180
ER
21%define pdir SVN
22%define pnam _Core
12ae68c1 23#
67cb9518 24Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
25Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
26Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 27Name: subversion
12ae68c1 28Version: 1.5.0
00664663 29Release: 2
6f88d80e 30License: Apache/BSD-like
93b78127 31Group: Development/Version Control
af7b0bac
AG
32Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
33# Source0-md5: 004b57643406dd10957ec87955702189
93b78127 34Source1: %{name}-dav_svn.conf
65318afa 35Source2: %{name}-authz_svn.conf
b56474ff
AM
36Source3: %{name}-svnserve.init
37Source4: %{name}-svnserve.sysconfig
f313e9a9 38Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 39Patch0: %{name}-home_etc.patch
d46e45ba 40Patch1: %{name}-DESTDIR.patch
00664663 41Patch2: %{name}-ruby-datadir-path.patch
d2bf70bf 42URL: http://subversion.tigris.org/
4945947e
AM
43%if %{with net_client_only}
44%global apache_modules_api 0
45%else
f2a757d6 46%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 47BuildRequires: automake
3817faf5 48BuildRequires: db-devel >= 4.1.25
e8d9186f 49BuildRequires: rpmbuild(macros) >= 1.268
0905b458 50%if %{with perl}
522a69b4 51BuildRequires: perl-devel >= 1:5.8.0
52BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 53BuildRequires: swig-perl >= 1.3.24
536b3fd3 54%endif
1cc7453a 55%{?with_javahl:BuildRequires: jdk}
0905b458 56%endif
16429189 57BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 58BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 59BuildRequires: autoconf >= 2.59
79d8c53c 60BuildRequires: bison
12ae68c1 61BuildRequires: cyrus-sasl-devel
93b78127 62BuildRequires: expat-devel
86ea8fde 63BuildRequires: gettext-devel
f4e6a380 64BuildRequires: libtool >= 1.4-9
bd3c99a8 65BuildRequires: neon-devel >= 0.26.0
53855fbf 66BuildRequires: python >= 2.2
ed6210a2 67BuildRequires: python-modules >= 2.2
f313e9a9 68%if %{with python}
69BuildRequires: python-devel >= 2.2
1f16145f 70BuildRequires: sed >= 4.0
15f9818d 71BuildRequires: swig-python >= 1.3.24
0905b458 72%endif
73ab938a 73%{?with_ruby:BuildRequires: swig-ruby >= 1.3.24}
93b78127 74BuildRequires: texinfo
7b35d179 75BuildRequires: which
027f8ebe 76Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
77BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
f4070f5f 79%define _libexecdir %{_libdir}/svn
1af5e34d
ER
80%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
81%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127
AM
82
83%description
84The goal of the Subversion project is to build a version control
85system that is a compelling replacement for CVS in the open source
86community.
87
88Our goals are:
89- All current CVS features.
90- Directories, renames, and file meta-data are versioned.
91- Symbolic links, etc, are supported
92- Commits are truly atomic.
93- Branching and tagging are cheap (constant time) operations
94- Repeated merges are handled gracefully
95- Support for plug-in client side diff programs
96- Natively client/server
97- Client/server protocol sends diffs in both directions
98- Costs are proportional to change size, not project size
99- Internationalization
100- Progressive multi-lingual support
101
aa59005f 102%description -l pl.UTF-8
93b78127
AM
103Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
104zamiennika dla CVS.
105
106Cele projektu to:
aa59005f 107- Wszystkie aktualne możliwości CVS.
24406120
JB
108- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
109- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
110- Commity są w pełni atomowe.
111- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
112- Dobra obsługa powtarzanego łączenia (merge).
113- Obsługa wtyczek diff po stronie klienta.
93b78127 114- Natywny klient/serwer.
aa59005f 115- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
116- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
117- Internacjonalizacja.
aa59005f 118- Postępujące wsparcie dla wielu języków.
93b78127 119
aa59005f
JR
120%description -l pt_BR.UTF-8
121O objetivo do projeto Subversion é construir um sistema de controle de
122versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 123System) na comunidade opensource, fornecendo grandes melhorias.
124
f4e6a380
AM
125%package libs
126Summary: Subversion libraries and modules
abe3c421 127Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 128Group: Libraries
24406120 129Requires: neon >= 0.26.0
53855fbf 130Obsoletes: libsubversion0
f4e6a380
AM
131
132%description libs
133Subversion libraries and modules.
134
aa59005f
JR
135%description libs -l pl.UTF-8
136Biblioteka subversion oraz ładowalne moduły.
f4e6a380 137
93b78127
AM
138%package devel
139Summary: Header files and develpment documentation for subversion
abe3c421
ER
140Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
141Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 142Group: Development/Libraries
9cb7e099 143Requires: %{name}-libs = %{version}-%{release}
c5b1d686 144Requires: apr-util-devel >= 1:1.0.0
24406120 145Requires: neon-devel >= 0.26.0
12cf252c 146Obsoletes: libsubversion0-devel
93b78127
AM
147
148%description devel
149Header files and develpment documentation for subversion.
150
aa59005f
JR
151%description devel -l pl.UTF-8
152Pliki nagłówkowe i dokumetacja do subversion.
93b78127 153
aa59005f
JR
154%description devel -l pt_BR.UTF-8
155Este pacote provê os arquivos necessários para desenvolvedores
92066deb 156interagirem com o Subversion.
157
93b78127
AM
158%package static
159Summary: Static subversion library
abe3c421
ER
160Summary(pl.UTF-8): Biblioteka statyczna subversion
161Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
162Group: Development/Libraries
163Requires: %{name}-devel = %{version}
12cf252c 164Obsoletes: libsubversion0-static-devel
93b78127
AM
165
166%description static
167Static subversion library.
168
aa59005f 169%description static -l pl.UTF-8
93b78127
AM
170Biblioteka statyczna subversion.
171
aa59005f
JR
172%description static -l pt_BR.UTF-8
173Este pacote provê um cliente estático do subversion.
92066deb 174
b56474ff
AM
175%package svnserve
176Summary: Subversion svnserve
abe3c421 177Summary(pl.UTF-8): Subversion svnserve
b56474ff 178Group: Networking/Daemons
3817faf5 179Requires(post,preun): /sbin/chkconfig
93f1d402 180Requires(postun): /usr/sbin/groupdel
181Requires(postun): /usr/sbin/userdel
182Requires(pre): /bin/id
183Requires(pre): /usr/bin/getgid
184Requires(pre): /usr/lib/rpm/user_group.sh
185Requires(pre): /usr/sbin/groupadd
186Requires(pre): /usr/sbin/useradd
187Requires(pre): /usr/sbin/usermod
9cb7e099 188Requires: %{name} = %{version}-%{release}
7b27380f 189Requires: rc-scripts
a1bac09d
190Provides: group(svn)
191Provides: user(svn)
b56474ff
AM
192
193%description svnserve
194Subversion svnserve server.
195
aa59005f 196%description svnserve -l pl.UTF-8
b56474ff
AM
197Serwer subversion svnserve.
198
4bbdbbf8
AM
199%package tools
200Summary: Subversion tools and scripts
abe3c421
ER
201Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
202Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 203Group: Applications
4bbdbbf8 204%pyrequires_eq python
7b27380f 205Requires: %{name} = %{version}-%{release}
1271c9bd 206Requires: python-rcsparse >= 0.1-0.20031026.0
4bbdbbf8
AM
207Requires: python-subversion = %{version}
208
209%description tools
210Subversion tools and scripts.
211
aa59005f
JR
212%description tools -l pl.UTF-8
213Narzędzia oraz skrypty dla subversion.
4bbdbbf8 214
fe5bb6bb 215%package -n bash-completion-subversion
216Summary: bash completion for subversion
abe3c421 217Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 218Group: Applications/Shells
e30588c4 219Requires: %{name} = %{version}-%{release}
53855fbf 220Requires: bash-completion
e30588c4 221Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 222
223%description -n bash-completion-subversion
224Bash completion for subversion.
225
aa59005f
JR
226%description -n bash-completion-subversion -l pl.UTF-8
227Dopełnienia basha dla subversion.
fe5bb6bb 228
1cc7453a 229%package -n java-subversion
65c1d4bd
JB
230Summary: Subversion Java bindings
231Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 232Group: Development/Languages/Java
233Requires: %{name}-libs = %{version}-%{release}
234
235%description -n java-subversion
236This is a set of Java classes which provide the functionality of
237subversion-libs, the Subversion libraries. It is useful if you want
238to, for example, write a Java class that manipulates a Subversion
239repository or working copy. See the 'subversion' package for more
240information.
241
65c1d4bd
JB
242%description -n java-subversion -l pl.UTF-8
243Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
244subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
d46e45ba
AM
245pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
246roboczą. Więcej informacji w pakiecie subversion.
65c1d4bd 247
fa3ff1b2 248%package -n python-subversion
65c1d4bd
JB
249Summary: Subversion Python bindings
250Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
251Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 252Group: Development/Languages/Python
f4e6a380 253%pyrequires_eq python
9cb7e099 254Requires: %{name}-libs = %{version}-%{release}
53855fbf 255Obsoletes: subversion-python
f4e6a380 256
fa3ff1b2 257%description -n python-subversion
65c1d4bd 258Subversion Python bindings.
f4e6a380 259
aa59005f 260%description -n python-subversion -l pl.UTF-8
65c1d4bd 261Dowiązania do Subversion dla Pythona.
f4e6a380 262
aa59005f 263%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 264Módulos Python para acessar os recursos do Subversion.
92066deb 265
b56474ff 266%package -n perl-subversion
65c1d4bd
JB
267Summary: Subversion Perl bindings
268Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
269Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 270Group: Development/Languages/Perl
9cb7e099 271Requires: %{name}-libs = %{version}-%{release}
53855fbf 272Obsoletes: subversion-perl
b56474ff
AM
273
274%description -n perl-subversion
65c1d4bd 275Subversion Perl bindings.
b56474ff 276
aa59005f 277%description -n perl-subversion -l pl.UTF-8
65c1d4bd 278Dowiązania do Subversion dla Perla.
b56474ff 279
aa59005f 280%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 281Módulos Perl para acessar os recursos do Subversion.
b56474ff 282
d46e45ba
AM
283%package -n ruby-subversion
284Summary: Subversion Ruby bindings
d2bf70bf 285Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
d46e45ba
AM
286Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
287Group: Development/Languages
288Requires: %{name}-libs = %{version}-%{release}
289Obsoletes: subversion-ruby
290
291%description -n ruby-subversion
292Subversion Ruby bindings.
293
294%description -n ruby-subversion -l pl.UTF-8
d2bf70bf 295Dowiązania do Subversion dla języka Ruby.
d46e45ba
AM
296
297%description -n ruby-subversion -l pt_BR.UTF-8
298Módulos Ruby para acessar os recursos do Subversion.
299
93b78127
AM
300%package -n apache-mod_dav_svn
301Summary: Apache module: Subversion Server
abe3c421 302Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 303Group: Networking/Daemons
7b27380f 304Requires: %{name} = %{version}-%{release}
53855fbf 305Requires: apache(modules-api) = %apache_modules_api
7887b1ac 306Requires: apache-mod_dav
93b78127
AM
307
308%description -n apache-mod_dav_svn
309Apache module: Subversion Server.
310
aa59005f
JR
311%description -n apache-mod_dav_svn -l pl.UTF-8
312Moduł apache: Serwer Subversion.
93b78127 313
65318afa
AF
314%package -n apache-mod_authz_svn
315Summary: Apache module: Subversion Server - path-based authorization
abe3c421 316Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 317Group: Networking/Daemons
53855fbf 318Requires: apache(modules-api) = %apache_modules_api
9cb7e099 319Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
320
321%description -n apache-mod_authz_svn
322Apache module: Subversion Server - path-based authorization.
323
aa59005f
JR
324%description -n apache-mod_authz_svn -l pl.UTF-8
325Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 326
93b78127 327%prep
af7b0bac 328%setup -q
e30588c4 329rm -rf apr apr-util neon
ed6210a2 330%patch0 -p0
d4bccc60 331%patch1 -p1
00664663 332%patch2 -p0
027f8ebe 333
93b78127 334%build
93f1d402 335rm subversion/bindings/swig/proxy/*.swg
24406120 336cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 337cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 338chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 339
93b78127 340%configure \
5dfeafd7 341 --with-editor=vi \
12ae68c1 342 --with-zlib=%{_libdir} \
536b3fd3
AM
343%if %{with net_client_only}
344 --without-apache \
345 --without-swig \
346 --without-apxs \
347 --without-berkeley-db \
348%else
fa6fa2cf 349 --disable-runtime-module-search \
86ee97d3 350 --disable-mod-activation \
0905b458 351%if %{with apache}
536b3fd3 352 --with-apxs=%{_sbindir}/apxs \
0905b458 353%else
354 --without-apache \
355 --without-apxs \
536b3fd3 356 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
0905b458 357%endif
73ab938a 358%if !%{with python} && !%{with perl} && !%{with ruby}
0905b458 359 --without-swig \
360%endif
1cc7453a 361 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 362%endif
1cc7453a 363 --with-jdk="%{java_home}" \
e30588c4 364 --with-neon=%{_prefix} \
78f330c4 365 --disable-neon-version-check \
16429189 366 --with-apr=%{_bindir}/apr-1-config \
367 --with-apr-util=%{_bindir}/apu-1-config
536b3fd3 368
1f630180 369%{__make} -j1
536b3fd3 370
cf353d53 371%if !%{with net_client_only}
b56474ff 372# python
0905b458 373%if %{with python}
86a4919e 374%{__make} swig-py \
65318afa
AF
375 swig_pydir=%{py_sitedir}/libsvn \
376 swig_pydir_extra=%{py_sitedir}/svn
0905b458 377%endif
b56474ff 378# perl
0905b458 379%if %{with perl}
bf539998
AM
380%{__make} swig-pl-lib
381odir=$(pwd)
382cd subversion/bindings/swig/perl/native
383%{__perl} Makefile.PL INSTALLDIRS=vendor
b445847c 384%{__make} -j1
bf539998 385cd $odir
536b3fd3 386%endif
1cc7453a 387%if %{with javahl}
b445847c 388%{__make} -j1 javahl \
1cc7453a 389 javahl_javadir="%{_javadir}"
390%endif
d46e45ba
AM
391# ruby
392%if %{with ruby}
393%{__make} swig-rb
394%endif
12ae68c1
AM
395%endif
396
397%if %{with tests}
398%{__make} check
d46e45ba
AM
399%if %{with python}
400%{__make} check-swig-py
401%endif
402%if %{with perl}
403%{__make} check-swig-pl
404%endif
405%if %{with ruby}
406%{__make} check-swig-rb
407%endif
0905b458 408%endif
93b78127
AM
409
410%install
411rm -rf $RPM_BUILD_ROOT
1326bb99 412install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 413 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 414 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 415 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 416
1f630180 417%{__make} install -j1 \
1cc7453a 418%if %{with javahl}
419 install-javahl \
420 javahl_javadir="%{_javadir}" \
421%endif
d46e45ba
AM
422%if !%{with net_client_only}
423%if %{with python}
0905b458 424 install-swig-py \
d46e45ba
AM
425%endif
426%if %{with ruby}
427 install-swig-rb install-swig-rb-doc \
428%endif
0905b458 429%endif
f2a757d6 430 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 431 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
432 swig_pydir=%{py_sitedir}/libsvn \
433 swig_pydir_extra=%{py_sitedir}/svn
93b78127 434
cf353d53 435%if !%{with net_client_only} && %{with perl}
bf539998
AM
436%{__make} install-swig-pl-lib \
437 DESTDIR=$RPM_BUILD_ROOT
b445847c 438%{__make} -C subversion/bindings/swig/perl/native install \
bf539998
AM
439 DESTDIR=$RPM_BUILD_ROOT \
440 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
441 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
bf539998
AM
442%endif
443
0905b458 444%if %{with apache}
1af5e34d
ER
445install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
446install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
447install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
448install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 449%endif
93b78127 450
cf353d53 451%if !%{with net_client_only}
1326bb99 452install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 453%if %{with python}
f4e6a380
AM
454%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
455%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
456find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
457install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 458%endif
0905b458 459%endif
f4e6a380 460
1326bb99
JK
461install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
462install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 463
205a3ddc
AM
464%find_lang %{name}
465
b445847c
JB
466rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn{javahl,_swig}*.{la,a}
467rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/svn/ext/*.la
a6ecf312 468
e23909be
JB
469%clean
470rm -rf $RPM_BUILD_ROOT
471
a1bac09d
472%pre svnserve
473%groupadd -g 86 svn
474%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
475
d2bf70bf
JB
476%post libs -p /sbin/ldconfig
477%postun libs -p /sbin/ldconfig
478
479%post devel -p /sbin/postshell
6f99c3bd 480-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 481
d2bf70bf 482%postun devel -p /sbin/postshell
6f99c3bd 483-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 484
d2bf70bf
JB
485%post -n perl-subversion -p /sbin/ldconfig
486%postun -n perl-subversion -p /sbin/ldconfig
487
488%post -n python-subversion -p /sbin/ldconfig
489%postun -n python-subversion -p /sbin/ldconfig
f4e6a380 490
b56474ff 491%post svnserve
e8d9186f
ER
492/sbin/chkconfig --add svnserve
493%service svnserve restart "svnserve daemon"
494
b56474ff
AM
495%preun svnserve
496if [ "$1" = "0" ]; then
e8d9186f
ER
497 %service svnserve stop
498 /sbin/chkconfig --del svnserve
b56474ff
AM
499fi
500
a1bac09d
501%postun svnserve
502if [ "$1" = "0" ]; then
503 %userremove svn
504 %groupremove svn
505fi
506
93b78127 507%post -n apache-mod_dav_svn
e8d9186f 508%service -q httpd restart
93b78127
AM
509
510%preun -n apache-mod_dav_svn
511if [ "$1" = "0" ]; then
e8d9186f 512 %service -q httpd restart
93b78127
AM
513fi
514
93b78127
AM
515%files
516%defattr(644,root,root,755)
983a49f6 517%doc BUGS CHANGES COPYING INSTALL README
d37298dc 518%doc doc/*/*.html
4bbdbbf8
AM
519%doc tools/hook-scripts/*.{pl,py,example}
520%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 521%doc tools/xslt/*
b445847c
JB
522%attr(755,root,root) %{_bindir}/svn
523%attr(755,root,root) %{_bindir}/svnadmin
524%attr(755,root,root) %{_bindir}/svndumpfilter
525%attr(755,root,root) %{_bindir}/svnlook
526%attr(755,root,root) %{_bindir}/svnsync
527%attr(755,root,root) %{_bindir}/svnversion
528%{_mandir}/man1/svn.1*
529%{_mandir}/man1/svnadmin.1*
530%{_mandir}/man1/svndumpfilter.1*
531%{_mandir}/man1/svnlook.1*
532%{_mandir}/man1/svnsync.1*
533%{_mandir}/man1/svnversion.1*
f4e6a380 534
205a3ddc 535%files libs -f %{name}.lang
f4e6a380 536%defattr(644,root,root,755)
b445847c
JB
537%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
538%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
539%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
540%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
541%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
542%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
543%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
544%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
545%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
546%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
547%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
548%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
549%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
550%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
551%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
552%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
553%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
554%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
555%attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so.*.*.*
556%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_neon-1.so.0
557%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
558%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
559%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
560%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
561%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
562%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
563%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
564%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
93b78127
AM
565
566%files devel
567%defattr(644,root,root,755)
b445847c
JB
568%attr(755,root,root) %{_libdir}/libsvn_client-1.so
569%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
570%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
571%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
572%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
573%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
574%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
575%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
576%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
577%attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so
578%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
579%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
580%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
581%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
582%{_libdir}/libsvn_client-1.la
583%{_libdir}/libsvn_delta-1.la
584%{_libdir}/libsvn_diff-1.la
585%{_libdir}/libsvn_fs-1.la
586%{_libdir}/libsvn_fs_base-1.la
587%{_libdir}/libsvn_fs_fs-1.la
588%{_libdir}/libsvn_fs_util-1.la
589%{_libdir}/libsvn_ra-1.la
590%{_libdir}/libsvn_ra_local-1.la
591%{_libdir}/libsvn_ra_neon-1.la
592%{_libdir}/libsvn_ra_svn-1.la
593%{_libdir}/libsvn_repos-1.la
594%{_libdir}/libsvn_subr-1.la
595%{_libdir}/libsvn_wc-1.la
596%{_includedir}/%{name}-1
1326bb99 597%{_examplesdir}/%{name}-%{version}
93b78127
AM
598
599%files static
600%defattr(644,root,root,755)
b445847c
JB
601%{_libdir}/libsvn_client-1.a
602%{_libdir}/libsvn_delta-1.a
603%{_libdir}/libsvn_diff-1.a
604%{_libdir}/libsvn_fs-1.a
605%{_libdir}/libsvn_fs_base-1.a
606%{_libdir}/libsvn_fs_fs-1.a
607%{_libdir}/libsvn_fs_util-1.a
608%{_libdir}/libsvn_ra-1.a
609%{_libdir}/libsvn_ra_local-1.a
610%{_libdir}/libsvn_ra_neon-1.a
611%{_libdir}/libsvn_ra_svn-1.a
612%{_libdir}/libsvn_repos-1.a
613%{_libdir}/libsvn_subr-1.a
614%{_libdir}/libsvn_wc-1.a
93b78127 615
cf353d53 616%if !%{with net_client_only}
b56474ff
AM
617%files svnserve
618%defattr(644,root,root,755)
619%attr(755,root,root) %{_bindir}/svnserve
b445847c
JB
620%{_mandir}/man5/svnserve.conf.5*
621%{_mandir}/man8/svnserve.8*
a1bac09d
622%dir %attr(750,svn,svn) /home/services/subversion
623%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 624%if %{with apache}
b56474ff 625%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 626%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 627%endif
b56474ff 628
4bbdbbf8
AM
629%files tools
630%defattr(644,root,root,755)
1326bb99 631%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 632
633%files -n bash-completion-subversion
101e74de 634%defattr(644,root,root,755)
1326bb99 635/etc/bash_completion.d/%{name}
536b3fd3 636
1cc7453a 637%if %{with javahl}
638%files -n java-subversion
639%defattr(644,root,root,755)
b445847c
JB
640%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
641%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
642%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
1cc7453a 643%{_javadir}/svn-javahl.jar
644%endif
645
0905b458 646%if %{with python}
fa3ff1b2 647%files -n python-subversion
f4e6a380 648%defattr(644,root,root,755)
4bbdbbf8 649%doc tools/backup/*.py tools/examples/*.py
b445847c
JB
650%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
651%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
652%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
65318afa 653%dir %{py_sitedir}/libsvn
65318afa 654%{py_sitedir}/libsvn/*.py[co]
b445847c
JB
655%dir %{py_sitedir}/svn
656%{py_sitedir}/svn/*.py[co]
65318afa 657%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 658%{_examplesdir}/python-%{name}-%{version}
0905b458 659%endif
f4e6a380 660
0905b458 661%if %{with perl}
b56474ff
AM
662%files -n perl-subversion
663%defattr(644,root,root,755)
b445847c
JB
664%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
665%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
666%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
b56474ff
AM
667%{perl_vendorarch}/SVN
668%dir %{perl_vendorarch}/auto/SVN
669%dir %{perl_vendorarch}/auto/SVN/*
670%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
671%{perl_vendorarch}/auto/SVN/*/*.bs
672%{_mandir}/man3/*.3pm*
0905b458 673%endif
b56474ff 674
d46e45ba
AM
675%if %{with ruby}
676%files -n ruby-subversion
677%defattr(644,root,root,755)
b445847c
JB
678%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
679%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
680%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
681%dir %{_libdir}/ruby/site_ruby/svn
682%{_libdir}/ruby/site_ruby/svn/*.rb
683%dir %{_libdir}/ruby/site_ruby/svn/ext
684%attr(755,root,root) %{_libdir}/ruby/site_ruby/svn/ext/*.so
00664663 685%{_datadir}/ri/*.*/system/Svn
686%{_datadir}/ri/*.*/system/Time
687%{_datadir}/ri/*.*/system/Uconv
688%{_datadir}/ri/*.*/system/*.rid
689%{_datadir}/ri/*.*/system/Kernel/*
690%{_datadir}/ri/*.*/system/OptionParser/*
d46e45ba
AM
691%endif
692
0905b458 693%if %{with apache}
93b78127
AM
694%files -n apache-mod_dav_svn
695%defattr(644,root,root,755)
1af5e34d
ER
696%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
697%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
698
699%files -n apache-mod_authz_svn
700%defattr(644,root,root,755)
701%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
702%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
703%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 704%endif
7b27380f
ER
705
706%endif # net_client_only
This page took 0.20174 seconds and 4 git commands to generate.