]> git.pld-linux.org Git - packages/sqlite3.git/blame - sqlite3.spec
- adapted to 3.5.4
[packages/sqlite3.git] / sqlite3.spec
CommitLineData
c743401f 1# TODO:
f1015391
JR
2# - some tests fail with tcl8.5, it's tcl fault,
3# if someone REALLY cares (s)he can look into it
17b8c9f1 4#
5# Conditional build:
f1015391
JR
6%bcond_with tests # run tests
7%bcond_without tcl # disable tcl extension
8%bcond_without doc # disable documentation building
17b8c9f1 9#
f1015391
JR
10%ifarch alpha sparc %{x8664}
11%undefine with_tests
12%endif
13
14# disabling tcl currently breaks making test target,
15# some hack in Makefile needs to be done
16%if !%{with tcl}
17%undefine with_tests
18%endif
19
20%define _ulibdir /usr/lib
21%define tclver %(rpm -q --qf '%{V}' tcl)
22
17b8c9f1 23Summary: SQLite library
e882a99f 24Summary(pl.UTF-8): Biblioteka SQLite
22ef5ab8 25Name: sqlite3
fea34507 26Version: 3.5.4
d48bf0c8 27Release: 1
17b8c9f1 28License: LGPL
29Group: Libraries
30# Source0Download: http://sqlite.org/download.html
e56bde73 31Source0: http://sqlite.org/sqlite-%{version}.tar.gz
fea34507 32# Source0-md5: f17da840eed792e896c3408d0ce97718
a3d8a32d 33Patch0: %{name}-sign-function.patch
1cd2f537 34Patch1: %{name}-pkgconfig.patch
17b8c9f1 35URL: http://sqlite.org/
36BuildRequires: autoconf
37BuildRequires: automake
38BuildRequires: libtool
39BuildRequires: readline-devel
1a6aae8d 40%{?with_tcl:BuildRequires: tcl-devel}
17b8c9f1 41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%description
44SQLite is a C library that implements an SQL database engine. A large
45subset of SQL92 is supported. A complete database is stored in a
46single disk file. The API is designed for convenience and ease of use.
47Applications that link against SQLite can enjoy the power and
48flexiblity of an SQL database without the administrative hassles of
49supporting a separate database server. Because it omits the
50client-server interaction overhead and writes directly to disk, SQLite
51is also faster than the big database servers for most operations. In
52addition to the C library, the SQLite distribution includes a
53command-line tool for interacting with SQLite databases and SQLite
54bindings for Tcl/Tk.
55
b7c0e1f2
JR
56%description -l pl.UTF-8
57SQLite jest biblioteką języka C, która implementuje silnik baz danych
58SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
59przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
60bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
61danych bez konieczności utrzymywania osobnego serwera baz danych.
62Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
63bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
64bazodanowych przy większości operacji na bazie danych. Dodatkowo
65oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 66bazami danych.
67
68%package devel
69Summary: Header files for SQLite development
e882a99f 70Summary(pl.UTF-8): Pliki nagłówkowe SQLite
17b8c9f1 71Group: Development/Libraries
72Requires: %{name} = %{version}-%{release}
73
74%description devel
75SQLite is a C library that implements an SQL database engine. A large
76subset of SQL92 is supported. A complete database is stored in a
77single disk file. The API is designed for convenience and ease of use.
78Applications that link against SQLite can enjoy the power and
79flexiblity of an SQL database without the administrative hassles of
80supporting a separate database server. Because it omits the
81client-server interaction overhead and writes directly to disk, SQLite
82is also faster than the big database servers for most operations. In
83addition to the C library, the SQLite distribution includes a
84command-line tool for interacting with SQLite databases and SQLite
85bindings for Tcl/Tk.
86
87This package contains the header files needed to develop programs that
88use these SQLite.
89
b7c0e1f2
JR
90%description devel -l pl.UTF-8
91SQLite jest biblioteką języka C, która implementuje silnik baz danych
92SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
93przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
94bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
95danych bez konieczności utrzymywania osobnego serwera baz danych.
96Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
97bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
98bazodanowych przy większości operacji na bazie danych. Dodatkowo
99oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 100bazami danych.
101
b7c0e1f2
JR
102Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
103używających biblioteki SQLite.
17b8c9f1 104
105%package static
106Summary: Static libraries for SQLite development
e882a99f 107Summary(pl.UTF-8): Statyczne biblioteki SQLite
17b8c9f1 108Group: Development/Libraries
109Requires: %{name}-devel = %{version}-%{release}
110
111%description static
112SQLite is a C library that implements an SQL database engine. A large
113subset of SQL92 is supported. A complete database is stored in a
114single disk file. The API is designed for convenience and ease of use.
115Applications that link against SQLite can enjoy the power and
116flexiblity of an SQL database without the administrative hassles of
117supporting a separate database server. Because it omits the
118client-server interaction overhead and writes directly to disk, SQLite
119is also faster than the big database servers for most operations. In
120addition to the C library, the SQLite distribution includes a
121command-line tool for interacting with SQLite databases and SQLite
122bindings for Tcl/Tk.
123
124This package contains the static SQLite libraries.
125
b7c0e1f2
JR
126%description static -l pl.UTF-8
127SQLite jest biblioteką języka C, która implementuje silnik baz danych
128SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
129przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
130bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
131danych bez konieczności utrzymywania osobnego serwera baz danych.
132Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
133bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
134bazodanowych przy większości operacji na bazie danych. Dodatkowo
135oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 136bazami danych.
137
138Pakiet zawiera statyczne biblioteki SQLite.
139
c743401f 140%package -n tcl-%{name}
8e66772b 141Summary: sqlite3 tcl extension
e882a99f 142Summary(pl.UTF-8): Rozszerzenie sqlite3 dla Tcl
8e66772b 143Group: Development/Languages/Tcl
c743401f
AM
144
145%description -n tcl-%{name}
146sqlite3 tcl extension.
147
b7c0e1f2 148%description -n tcl-%{name} -l pl.UTF-8
c743401f
AM
149Rozszerzenie sqlite3 dla Tcl.
150
17b8c9f1 151%prep
c743401f 152%setup -q -n sqlite-%{version}
30682d5a 153%patch0 -p1
1cd2f537 154%patch1 -p1
155
17b8c9f1 156sed -i 's/mkdir doc/#mkdir doc/' Makefile*
157
158%build
159%{__libtoolize}
160cp -f /usr/share/automake/config.sub .
161%{__aclocal}
162%{__autoconf}
f1015391
JR
163CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1"
164export CFLAGS
17b8c9f1 165%configure \
1a6aae8d 166 %{?with_tcl:--with-tcl=%{_ulibdir}} \
167 %{!?with_tcl:--disable-tcl} \
17b8c9f1 168 --enable-threadsafe
169%{__make}
1a6aae8d 170
e16bc4b1 171%if %{with doc}
17b8c9f1 172%{__make} doc
1a6aae8d 173%endif
17b8c9f1 174
3e5df83c 175%{?with_tests:LC_ALL=C %{__make} test}
17b8c9f1 176
177%install
178rm -rf $RPM_BUILD_ROOT
179install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
180
181%{__make} install \
80deaf18
JR
182 DESTDIR=$RPM_BUILD_ROOT \
183 TCLLIBDIR=%{_libdir}/tcl%{tclver}
17b8c9f1 184
22de4c1c 185%if %{with tcl}
80deaf18 186sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl*/sqlite3/*.tcl
22de4c1c 187%endif
ec30f86a 188
c743401f 189install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
17b8c9f1 190
191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%post -p /sbin/ldconfig
195%postun -p /sbin/ldconfig
196
197%files
198%defattr(644,root,root,755)
199%doc README
200%attr(755,root,root) %{_bindir}/sqlite3
201%attr(755,root,root) %{_libdir}/lib*.so.*.*
c743401f 202%{_mandir}/man1/sqlite3.1*
17b8c9f1 203
204%files devel
205%defattr(644,root,root,755)
206%doc doc/*
207%attr(755,root,root) %{_libdir}/lib*.so
208%{_libdir}/lib*.la
209%{_includedir}/sqlite3.h
ef88c71c 210%{_includedir}/sqlite3ext.h
17b8c9f1 211%{_pkgconfigdir}/*.pc
212
213%files static
214%defattr(644,root,root,755)
215%{_libdir}/lib*.a
c743401f 216
1a6aae8d 217%if %{with tcl}
c743401f
AM
218%files -n tcl-%{name}
219%defattr(644,root,root,755)
80deaf18
JR
220%dir %{_libdir}/tcl*/sqlite3
221%attr(755,root,root) %{_libdir}/tcl*/sqlite3/*.so
222%{_libdir}/tcl*/sqlite3/*.tcl
1a6aae8d 223%endif
This page took 0.098947 seconds and 4 git commands to generate.