]> git.pld-linux.org Git - packages/spl.git/blame - spl.spec
- use kernel-specific release also for kernel -devel package
[packages/spl.git] / spl.spec
CommitLineData
465ece3e
JB
1#
2# Conditional build:
3%bcond_without dist_kernel # allow non-distribution kernel
4%bcond_without kernel # don't build kernel modules
5%bcond_without userspace # don't build userspace programs
6%bcond_with verbose # verbose build (V=1)
7#
8%if %{without kernel}
9%undefine with_dist_kernel
10%endif
11%if "%{_alt_kernel}" != "%{nil}"
12%undefine with_userspace
13%endif
14%if %{without userspace}
15# nothing to be placed to debuginfo package
16%define _enable_debug_packages 0
17%endif
18Summary: Solaris Porting Layer
19Summary(pl.UTF-8): Solaris Porting Layer - warstwa do portowania kodu z Solarisa
20%define pname spl
21Name: %{pname}%{_alt_kernel}
22Version: 0.6.2
23%define rel 1
24Release: %{rel}
25License: GPL v2+
26Group: Applications/System
27Source0: http://archive.zfsonlinux.org/downloads/zfsonlinux/spl/%{name}-%{version}.tar.gz
28# Source0-md5: f00535bf89a7fde0e08f44a14a1f1e03
29URL: http://zfsonlinux.org/
30%if %{with kernel}
31%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
32BuildRequires: rpmbuild(macros) >= 1.379
33%endif
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37Solaris Porting Layer.
38
39%description -l pl.UTF-8
40Solaris Porting Layer - warstwa do portowania kodu z Solarisa.
41
42%package -n kernel%{_alt_kernel}-spl
43Summary: Solaris Porting Layer - Linux kernel modules
44Summary(pl.UTF-8): Solaris Porting Layer - moduły jądra Linuksa
45Release: %{rel}@%{_kernel_ver_str}
46Group: Base/Kernel
47Requires(post,postun): /sbin/depmod
48%if %{with dist_kernel}
49%requires_releq_kernel
50Requires(postun): %releq_kernel
51%endif
52
53%description -n kernel%{_alt_kernel}-spl
54Solaris Porting Layer - Linux kernel modules.
55
56%description -n kernel%{_alt_kernel}-spl -l pl.UTF-8
57Solaris Porting Layer - moduły jądra Linuksa.
58
59%package -n kernel%{_alt_kernel}-spl-devel
60Summary: Solaris Porting Layer - Linux kernel headers
61Summary(pl.UTF-8): Solaris Porting Layer - pliki nagłówkowe jądra Linuksa
e073ff64 62Release: %{rel}@%{_kernel_ver_str}
465ece3e
JB
63Group: Development/Building
64%{?with_dist_kernel:Requires: kernel%{_alt_kernel}-headers}
65
66%description -n kernel%{_alt_kernel}-spl-devel
67Solaris Porting Layer - Linux kernel headers configured for PLD
68kernel%{_alt_kernel}, version %{_kernel_ver}.
69
70%description -n kernel%{_alt_kernel}-spl-devel -l pl.UTF-8
71Solaris Porting Layer - pliki nagłówkowe jądra Linuksa skonfigurowane
72dla jądra PLD z pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.
73
74%prep
75%setup -q
76
77%build
78%configure \
79 --disable-silent-rules \
80 --with-config="%{?with_kernel:%{?with_userspace:all}}%{!?with_kernel:user}%{!?with_userspace:kernel}" \
81 --with-linux=%{_kernelsrcdir}
82
83%{__make}
84
85%install
86rm -rf $RPM_BUILD_ROOT
87
88%{__make} install \
89 DESTDIR=$RPM_BUILD_ROOT \
90 INSTALL_MOD_DIR=misc
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%if %{with userspace}
96%files
97%defattr(644,root,root,755)
98%doc AUTHORS DISCLAIMER
99%attr(755,root,root) %{_sbindir}/splat
100%{_mandir}/man1/splat.1*
101%endif
102
103%if %{with kernel}
104%files -n kernel%{_alt_kernel}-spl
105%defattr(644,root,root,755)
106%dir /lib/modules/%{_kernel_ver}/misc/spl
107/lib/modules/%{_kernel_ver}/misc/spl/spl.ko*
108%dir /lib/modules/%{_kernel_ver}/misc/splat
109/lib/modules/%{_kernel_ver}/misc/splat/splat.ko*
110
111%files -n kernel%{_alt_kernel}-spl-devel
112%defattr(644,root,root,755)
113/usr/src/spl-%{version}
114%endif
This page took 0.083525 seconds and 4 git commands to generate.