]> git.pld-linux.org Git - packages/sparse.git/blame - sparse.spec
- llvm rebuild
[packages/sparse.git] / sparse.spec
CommitLineData
12d186d8 1Summary: Sparse - a semantic parser of source files
7ddda079 2Summary(pl.UTF-8): Sparse - analizator semantyczny plików źródłowych
ab4aea11 3Name: sparse
bf29ecfd 4Version: 0.6.0
d23be38a 5Release: 2
7ddda079 6License: OSL v1.1
ab4aea11 7Group: Development/Debuggers
791ad46d 8Source0: https://www.kernel.org/pub/software/devel/sparse/dist/%{name}-%{version}.tar.xz
bf29ecfd 9# Source0-md5: 2723361d267250723b8225256df9aa70
791ad46d
JB
10URL: https://www.kernel.org/pub/software/devel/sparse/
11BuildRequires: gtk+3-devel >= 3.0
204719fb
JB
12BuildRequires: libxml2-devel >= 2.0
13BuildRequires: llvm-devel >= 3.0
14BuildRequires: pkgconfig
15BuildRequires: tar >= 1:1.22
16BuildRequires: xz
ab4aea11
AM
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20Sparse is a semantic parser of source files: it's neither a compiler
21(although it could be used as a front-end for one) nor is it a
22preprocessor (although it contains as a part of it a preprocessing
23phase).
24
25It is meant to be a small - and simple - library. Scanty and meager,
26and partly because of that easy to use. It has one mission in life:
27create a semantic parse tree for some arbitrary user for further
28analysis. It's not a tokenizer, nor is it some generic context-free
29parser. In fact, context (semantics) is what it's all about - figuring
30out not just what the grouping of tokens are, but what the _types_ are
31that the grouping implies.
32
12d186d8
JB
33%description -l pl.UTF-8
34Sparse to analizator semantyczny plików źródłowych - nie jest to ani
35kompilator (choć mógłby być używany jako frontend dla niego) ani
36preprocesor (choć zawiera jako część fazę preprocesingu).
37
38Sparse ma być małą i prostą biblioteką. Ledwie wystarczającą i
39niewielką, i po części dlatego łatwą w użyciu. Ma jedno zadanie:
40utworzyć drzewo semantyczne analizy do dowolnego późniejszego
41wykorzystania. Nie jest to tokenizer ani żaden ogólny analizator
42bezkontekstowy. Właściwie kontekst (semantyka) to wszystko co
43istotne - przedstawianie nie tylko czym są grupowane tokeny, ale tego,
44czym są _typy_ obejmowane przez grupowanie.
45
ab4aea11
AM
46%prep
47%setup -q
48
49%build
50%{__make} \
51 CC="%{__cc}" \
52 CFLAGS="%{rpmcflags} -fpic" \
b9398d97
AM
53 LDFLAGS="%{rpmldflags}" \
54 PREFIX="%{_prefix}" \
204719fb
JB
55 LIBDIR="%{_libdir}" \
56 V=1
ab4aea11
AM
57
58%install
59rm -rf $RPM_BUILD_ROOT
60
61%{__make} install \
62 PREFIX="%{_prefix}" \
b9398d97 63 LIBDIR="%{_libdir}" \
ab4aea11
AM
64 DESTDIR=$RPM_BUILD_ROOT
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%files
70%defattr(644,root,root,755)
71%doc FAQ LICENSE README
7ddda079
JB
72%attr(755,root,root) %{_bindir}/c2xml
73%attr(755,root,root) %{_bindir}/cgcc
74%attr(755,root,root) %{_bindir}/sparse
204719fb
JB
75%attr(755,root,root) %{_bindir}/sparse-llvm
76%attr(755,root,root) %{_bindir}/sparsec
7ddda079 77%attr(755,root,root) %{_bindir}/test-inspect
7ddda079
JB
78%{_mandir}/man1/cgcc.1*
79%{_mandir}/man1/sparse.1*
This page took 0.401972 seconds and 4 git commands to generate.