]> git.pld-linux.org Git - packages/setup.git/blame - setup.spec
- added provides fuse group
[packages/setup.git] / setup.spec
CommitLineData
86056b15 1#
bf515c7b
PG
2# TODO:
3# - make some README.PLD with system features description
86056b15 4#
d0a84d4c 5%define iana_etc_ver 2.20
33031197 6%undefine with_ccache
0b6becf4 7#
f97bd99d 8Summary: Simple setup files
8551200d
ER
9Summary(de.UTF-8): Einfache Setup-Dateien
10Summary(es.UTF-8): Varios archivos básicos de configuración
11Summary(fr.UTF-8): Fichiers de configuration simples
12Summary(ja.UTF-8): サンプルセットアップファイル
13Summary(pl.UTF-8): Podstawowe pliki systemu Linux
14Summary(pt_BR.UTF-8): Vários arquivos básicos de configuração
15Summary(tr.UTF-8): Basit kurulum dosyaları
f97bd99d 16Name: setup
146ebe9b 17Version: 2.4.12
ca31bea4 18Release: 2
bf515c7b 19License: Public Domain, partially BSD-like
f97bd99d 20Group: Base
a2b3dd01 21Source0: ftp://distfiles.pld-linux.org/src/%{name}-%{version}.tar.bz2
146ebe9b 22# Source0-md5: b082df276e6ed931e8f31c3e265713c2
d0a84d4c
JB
23Source1: http://sethwklein.net/projects/iana-etc/downloads/iana-etc-%{iana_etc_ver}.tar.bz2
24# Source1-md5: 51d584b7b6115528c21e8ea32250f2b1
7cf4e42c 25Source2: %{name}-update-fstab.c
47f42bc8 26Source3: postshell.c
a6928fbf 27Patch0: %{name}-securetty.patch
33031197 28Patch1: %{name}-profile.env.patch
d0a84d4c
JB
29Patch2: %{name}-iana-etc.patch
30# This is source of non-iana changes in services file
31Patch3: %{name}-services.patch
2181f706 32Patch4: %{name}-dquo.patch
ca31bea4 33Patch5: %{name}-fuse.patch
fe293510 34BuildRequires: dietlibc-static
36832d85 35BuildRequires: gawk
e23f948a 36Conflicts: FHS < 2.3
ee80b4de 37Conflicts: glibc < 6:2.4-4.1
cd421432 38Provides: group(fuse)
c14440b1 39AutoReqProv: no
50ba189c 40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6be1ce2e 41
3d5c2a8f
PG
42%define _sbindir /sbin
43
6be1ce2e 44%description
7a8444bd
SZ
45This package contains a number of very important configuration and
46setup files, including the passwd, group, profile files, etc.
6be1ce2e 47
2f487416
JR
48%description -l de.UTF-8
49Dieses Paket enthält wichtige Konfigurations- und Setup-Dateien, u.a.
a9f190e7 50passwd-, group-, profile-Dateien usw.
6be1ce2e 51
2f487416
JR
52%description -l es.UTF-8
53Este paquete contiene una variedad de archivos de configuración y
05f14211
TP
54setup muy importantes, incluyendo el passwd, group, archivos de
55"perfil", etc.
56
2f487416
JR
57%description -l fr.UTF-8
58Ce paquetage contient un nombre de fichiers de configuration très
6be1ce2e 59importants, comme passwd, group, les fichiers profile, etc.
60
2f487416
JR
61%description -l ja.UTF-8
62このsetupパッケージには、passwd, group, profile などの、
63重要なシステム設定ファイルが含まれてます。
05f14211 64
2f487416
JR
65%description -l pl.UTF-8
66Pakiet ten zawiera wiele bardzo ważnych plików konfiguracyjnych dla
a6f7ca8d 67Twojego systemu.
87946706 68
2f487416
JR
69%description -l pt_BR.UTF-8
70Este pacote contém uma variedade de arquivos de configuração e setup
ea4c6647
JB
71muito importantes, incluindo o passwd, group, arquivos de "perfil",
72etc.
d0944bc6 73
2f487416
JR
74%description -l tr.UTF-8
75Bu paket, passwd, group, profile gibi çok önemli ayar ve kurulum
76dosyalarını içerir.
d0944bc6 77
6be1ce2e 78%prep
0b6becf4 79%setup -q -a1
a6928fbf 80%patch0 -p1
33031197 81%patch1 -p1
176c880b 82%patch2 -p1
7cf4e42c 83install %{SOURCE2} update-fstab.c
47f42bc8 84install %{SOURCE3} postshell.c
2181f706 85%patch4 -p1
ca31bea4 86%patch5 -p1
bf515c7b
PG
87
88%build
36832d85 89%{__make} -C iana-etc-%{iana_etc_ver}
d0a84d4c 90%{__patch} iana-etc-%{iana_etc_ver}/services %{PATCH3}
0b6becf4 91
bf515c7b 92%{__make} \
c1e81666 93 OPT_FLAGS="%{rpmcflags}" \
d3b7c683 94 LDFLAGS="%{rpmcflags} %{rpmldflags}" \
fe293510 95 CC="diet %{__cc}"
47f42bc8 96%{__make} postshell update-fstab \
97 OPT_FLAGS="%{rpmcflags} -Os" \
d3b7c683 98 LDFLAGS="%{rpmcflags} %{rpmldflags}" \
7cf4e42c 99 CC="diet %{__cc}"
6be1ce2e 100
101%install
797d0215 102rm -rf $RPM_BUILD_ROOT
93f8153d 103install -d $RPM_BUILD_ROOT%{_sysconfdir}/shrc.d
0b6becf4 104
bf515c7b
PG
105%{__make} install \
106 DESTDIR=$RPM_BUILD_ROOT
0b6becf4 107
47f42bc8 108install postshell $RPM_BUILD_ROOT%{_sbindir}
7cf4e42c 109install update-fstab $RPM_BUILD_ROOT%{_sbindir}
110
9310ed4f 111install iana-etc-%{iana_etc_ver}/protocols $RPM_BUILD_ROOT%{_sysconfdir}/protocols
d0a84d4c
JB
112# don't overwrite files from setup tarball, apply changes to setup module instead
113%if "%{version}" == "2.4.11"
114# 2.4.12 will contain iana-etc update
115install iana-etc-%{iana_etc_ver}/services $RPM_BUILD_ROOT%{_sysconfdir}/services
116%endif
0b6becf4 117
6be1ce2e 118%clean
797d0215 119rm -rf $RPM_BUILD_ROOT
6be1ce2e 120
50ba189c 121%triggerpostun -p %{_sbindir}/joinpasswd -- %{name} < %{version}-%{release}
81b992a1 122
7cf4e42c 123%triggerin -p %{_sbindir}/update-fstab -- %{name} < 2.4.10-1
a2b3dd01 124
544edbb0
ER
125%post -p /sbin/postshell
126-/sbin/env-update -u
127
128%postun -p /sbin/postshell
129-/sbin/env-update -u
130
6be1ce2e 131%files
f97bd99d 132%defattr(644,root,root,755)
bf515c7b
PG
133%doc ChangeLog
134%attr(755,root,root) %{_sbindir}/joinpasswd
47f42bc8 135%attr(755,root,root) %{_sbindir}/postshell
7cf4e42c 136%attr(755,root,root) %{_sbindir}/update-fstab
c6c53392 137%attr(755,root,root) /etc/profile.d/*.sh
138%attr(755,root,root) /etc/profile.d/*.csh
bf515c7b 139%dir /etc/profile.d
9310ed4f 140%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/env.d/*
4db3fb34 141%dir %{_sysconfdir}/env.d
142%dir %{_sysconfdir}/shrc.d
9310ed4f
ER
143%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fstab
144%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/group
145%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/host.conf
146%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hosts
147%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/passwd
148%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/profile
149%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/protocols
9b899961 150%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/secure*
9310ed4f
ER
151%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/services
152%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/filesystems
153%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/motd
154%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/resolv.conf
bf515c7b 155%ghost %{_sysconfdir}/shells
This page took 0.142992 seconds and 4 git commands to generate.