]> git.pld-linux.org Git - packages/ruby-re2.git/blame - ruby-re2.spec
- updated to 1.4.0
[packages/ruby-re2.git] / ruby-re2.spec
CommitLineData
0fb22d2b
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
5%define pkgname re2
6Summary: Ruby bindings to re2
87cdd28d 7Summary(pl.UTF-8): Wiązania języka Ruby do re2
0fb22d2b 8Name: ruby-%{pkgname}
03991203 9Version: 1.4.0
87cdd28d 10Release: 1
0fb22d2b
ER
11License: BSD
12Group: Development/Languages
13Source0: http://rubygems.org/downloads/%{pkgname}-%{version}.gem
03991203 14# Source0-md5: 8575c95f217df60f7db3ae89dfd1e02a
87cdd28d
JB
15URL: https://github.com/mudge/re2
16BuildRequires: libstdc++-devel >= 6:4.8
03991203 17BuildRequires: re2-devel >= 20200302
0fb22d2b
ER
18BuildRequires: rpm-rubyprov
19BuildRequires: rpmbuild(macros) >= 1.656
87cdd28d 20BuildRequires: ruby-devel >= 1:1.8.7
0fb22d2b
ER
21%if %{with tests}
22BuildRequires: ruby-minitest < 6
23BuildRequires: ruby-minitest >= 5.4
24BuildRequires: ruby-rake-compiler < 1
25BuildRequires: ruby-rake-compiler >= 0.9
26%endif
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30Ruby bindings to re2, an efficient, principled regular expression
31library.
32
87cdd28d
JB
33%description -l pl.UTF-8
34Wiązania języka Ruby do re2 - wydajnej, zasadniczej biblioteki
35wyrażeń regularnych.
36
0fb22d2b
ER
37%prep
38%setup -q -n %{pkgname}-%{version}
39
03991203
JB
40# required by gem helper
41%{__tar} xf %{SOURCE0} metadata.gz
42
0fb22d2b
ER
43%build
44# write .gemspec
45%__gem_helper spec
46
47cd ext/%{pkgname}
48%{__ruby} extconf.rb
49%{__make} \
50 CC="%{__cc}" \
51 LDFLAGS="%{rpmldflags}" \
52 CFLAGS="%{rpmcflags} -fPIC"
53
54%install
55rm -rf $RPM_BUILD_ROOT
56install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_vendorarchdir},%{ruby_specdir}}
87cdd28d 57
0fb22d2b
ER
58cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
59cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
60install -p ext/re2/re2.so $RPM_BUILD_ROOT%{ruby_vendorarchdir}
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files
66%defattr(644,root,root,755)
03991203 67%doc LICENSE.txt README.md
87cdd28d 68%attr(755,root,root) %{ruby_vendorarchdir}/re2.so
0fb22d2b
ER
69%{ruby_vendorlibdir}/re2.rb
70%{ruby_vendorlibdir}/re2
0fb22d2b 71%{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.044311 seconds and 4 git commands to generate.