]> git.pld-linux.org Git - packages/ruby-rb-inotify.git/blame - ruby-rb-inotify.spec
- rebuild without versioned ruby abi dep
[packages/ruby-rb-inotify.git] / ruby-rb-inotify.spec
CommitLineData
b296a845
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
5%define pkgname rb-inotify
6Summary: A Ruby wrapper for Linux's inotify, using FFI
7Name: ruby-%{pkgname}
8Version: 0.9.5
126875b4 9Release: 2
b296a845
ER
10License: MIT
11Group: Development/Languages
12Source0: http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13# Source0-md5: 865ed70ff9f90d5d23dc4ab906358650
14URL: http://github.com/nex3/rb-inotify
15BuildRequires: rpm-rubyprov
16BuildRequires: rpmbuild(macros) >= 1.656
17%if %{with tests}
18BuildRequires: ruby-yard >= 0.4.0
19%endif
20Requires: ruby-ffi >= 0.5.0
21BuildArch: noarch
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25A Ruby wrapper for Linux's inotify, using FFI
26
27%prep
28%setup -q -n %{pkgname}-%{version}
29
30%build
31# write .gemspec
32%__gem_helper spec
33
34%install
35rm -rf $RPM_BUILD_ROOT
36install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
37cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
38cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
39
40%clean
41rm -rf $RPM_BUILD_ROOT
42
43%files
44%defattr(644,root,root,755)
45%doc README.md MIT-LICENSE VERSION
46%{ruby_vendorlibdir}/rb-inotify.rb
47%{ruby_vendorlibdir}/rb-inotify
48%{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.063666 seconds and 4 git commands to generate.