]> git.pld-linux.org Git - packages/rstudio.git/blame - rstudio.spec
- updated to 0.99.39
[packages/rstudio.git] / rstudio.spec
CommitLineData
9d0bf5de
JR
1Summary: IDE for R
2Summary(pl.UTF-8): IDE dla R
3Name: rstudio
57694567
JR
4Version: 0.99.39
5Release: 0.1
9d0bf5de
JR
6License: AGPLv3
7Group: Applications
57694567
JR
8Source0: https://github.com/rstudio/rstudio/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
9# Source0-md5: 8b340edf12a40806daafffad9e3849f0
10Source1: https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip
11# Source1-md5: 0e03798b8e53096c4a906bde05e32378
12Source2: https://s3.amazonaws.com/rstudio-buildtools/gwt-2.6.0.zip
13# Source2-md5: b08b2b0c50ef2249703aa8422388d5db
14Source3: https://s3.amazonaws.com/rstudio-buildtools/gin-1.5.zip
15# Source3-md5: 2409168cc18bf5f341e107e6887fe359
16Source4: https://s3.amazonaws.com/rstudio-buildtools/mathjax-23.zip
17# Source4-md5: 5853c0494c6b28557d6b7cecaa790019
18Source5: https://s3.amazonaws.com/rstudio-buildtools/pandoc-1.12.4.2.zip
19# Source5-md5: d0f7e3d23b42cb9d26d2783d659040cf
20Source6: https://s3.amazonaws.com/rstudio-buildtools/libclang-3.5.zip
21# Source6-md5: cf1a43d2d6203a765ef16d7b12382c8a
22Source7: https://s3.amazonaws.com/rstudio-buildtools/libclang-builtin-headers.zip
23# Source7-md5: e6790a3ee6c371968eba865fc0a84daf
24Source8: packrat_0.4.1.24_bbdab984134678db91b8f372e2550e59f266de37.tar.xz
25# Source8-md5: 7607927c4adf507d67d2ba18d38c7bb0
26Source9: rmarkdown_0.3.12_8a78f712202263200f2110ec8aa24a55c2726e37.tar.xz
27# Source9-md5: 358f9f4bf2f35dd58d4771f6b24d252e
28Source10: shinyapps_0.3.61_d3ab9e1cdd02f0067d69fe6fc816a61c8a5f2218.tar.xz
29# Source10-md5: 3f5ce12f86b00a2e77067d7769fffe08
9d0bf5de
JR
30URL: http://rstudio.org/
31BuildRequires: QtWebKit-devel
32BuildRequires: QtXmlPatterns-devel
33BuildRequires: R >= 2.11.1
57694567 34BuildRequires: boost-devel >= 1.50
9d0bf5de
JR
35BuildRequires: cmake >= 2.8.0
36BuildRequires: java-junit
37BuildRequires: openssl-devel
38BuildRequires: pam-devel
39BuildRequires: pango-devel
40Requires: R >= 2.11.1
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%description
446bd661
ER
44RStudio(tm) is a free and open source integrated development
45environment (IDE) for R. You can run it on your desktop (Windows, Mac,
46or Linux) or even over the web using RStudio Server.
9d0bf5de
JR
47
48%prep
57694567
JR
49%setup -q
50mkdir -p dependencies/common/dictionaries
51unzip -qq %{SOURCE1} -d dependencies/common/dictionaries
9d0bf5de
JR
52mkdir -p src/gwt/lib/gwt
53mkdir -p src/gwt/lib/gin/1.5
57694567
JR
54unzip -qq %{SOURCE2} -d src/gwt/lib/gwt
55unzip -qq %{SOURCE3} -d src/gwt/lib/gin/1.5
56%{__mv} src/gwt/lib/gwt/gwt-2.6.0 src/gwt/lib/gwt/2.6.0
57unzip -qq %{SOURCE4} -d dependencies/common
58unzip -qq %{SOURCE5} -d dependencies/common
59%{__mv} dependencies/common/pandoc-* dependencies/common/pandoc
60mkdir -p dependencies/common/libclang
61unzip -qq %{SOURCE6} -d dependencies/common/libclang
62unzip -qq %{SOURCE7} -d dependencies/common/libclang
63%{__mv} dependencies/common/libclang/libclang-3.5 dependencies/common/libclang/3.5
64
65xz -dc %{SOURCE8} | tar xf - -C dependencies/common/
66xz -dc %{SOURCE9} | tar xf - -C dependencies/common/
67xz -dc %{SOURCE10} | tar xf - -C dependencies/common/
68
69# fix building with boost 1.56
70# specify that namespace core is in the global namespace and not
71# relative to some other namespace (like its ::core not ::boost::core)
72find . \( -name *.cpp -or -name *.hpp \) -exec sed \
73 -e 's@<core::@< ::core::@g' -e 's@\([^:]\)core::@\1::core::@g' -i {} \;
9d0bf5de
JR
74
75%build
76install -d build
77cd build
78%cmake \
57694567
JR
79 -DCMAKE_CXX_FLAGS_RELEASE="${CXXFLAGS:-%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG}" \
80 -DCMAKE_C_FLAGS_RELEASE="${CFLAGS:-%{rpmcflags} -DNDEBUG -DQT_NO_DEBUG}" \
9d0bf5de
JR
81 -DRSTUDIO_TARGET=Desktop \
82 -DCMAKE_BUILD_TYPE=Release \
83 -DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name} \
84 ../
85
86%{__make}
87
88%install
89rm -rf $RPM_BUILD_ROOT
90install -d $RPM_BUILD_ROOT%{_bindir}
91
92%{__make} -C build install/fast \
93 DESTDIR=$RPM_BUILD_ROOT
94
95ln -s %{_libdir}/%{name}/bin/rstudio $RPM_BUILD_ROOT%{_bindir}
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%files
101%defattr(644,root,root,755)
102%doc COPYING NOTICE README.md
103%attr(755,root,root) %{_bindir}/*
104%dir %{_libdir}/%{name}
105%{_libdir}/%{name}/R
106%dir %{_libdir}/%{name}/bin
1a5a515a 107%attr(755,root,root) %{_libdir}/%{name}/bin/diagnostics
9d0bf5de
JR
108%attr(755,root,root) %{_libdir}/%{name}/bin/r*
109%dir %{_libdir}/%{name}/bin/postback
110%attr(755,root,root) %{_libdir}/%{name}/bin/postback/*
111%{_libdir}/%{name}/resources
112%{_libdir}/%{name}/www
113%{_libdir}/%{name}/rstudio.png
114%{_desktopdir}/rstudio.desktop
115%{_iconsdir}/hicolor/*x*/apps/*
116%{_iconsdir}/hicolor/*x*/mimetypes/*
117%{_datadir}/mime/packages/*.xml
118%{_pixmapsdir}/rstudio.png
This page took 0.08754 seconds and 4 git commands to generate.