]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- patch to amd64 support from mdk
[packages/qemu.git] / qemu.spec
CommitLineData
cd19124e 1Summary: QEMU CPU Emulator
2Name: qemu
3Version: 0.5.2
4Release: 0.1
5Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
7beb4c5e 6# Source0-md5: 81acda062219c82973e82585b0eb357a
8bd2aee2 7Patch0: %{name}-nostatic.patch
f1ae848c 8Patch1: %{name}-DESTDIR.patch
6b415c72 9Patch2: %{name}-amd64.patch
cd19124e 10#Patch0: qemu-0.5.0-cvsupdates.patch.bz2
11#Patch1: qemu-0.1.6-glibc23-ldscripts.patch.bz2
12#Patch2: qemu-0.5.0-sdl-static-libs.patch.bz2
13#Patch3: qemu-0.5.0-DESTDIR.patch.bz2
14#Patch4: qemu-0.5.0-lib64.patch.bz2
15#Patch5: qemu-0.5.0-amd64.patch.bz2
16#Patch6: qemu-0.5.0-vl-amd64.patch.bz2
17License: GPL
18URL: http://fabrice.bellard.free.fr/qemu/
19Group: Applications/Emulators
20BuildRequires: SDL-devel
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24QEMU is a FAST! processor emulator. By using dynamic translation it
25achieves a reasonnable speed while being easy to port on new host
26CPUs. QEMU has two operating modes:
27
28- User mode emulation. In this mode, QEMU can launch Linux processes
29 compiled for one CPU on another CPU. Linux system calls are converted
30 because of endianness and 32/64 bit mismatches. Wine (Windows
31 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
32
33- Full system emulation. In this mode, QEMU emulates a full system,
34 including a processor and various peripherials. Currently, it is only
35 used to launch an x86 Linux kernel on an x86 Linux system. It enables
36 easier testing and debugging of system code. It can also be used to
37 provide virtual hosting of several virtual PC on a single server.
38
39%prep
40%setup -q
8bd2aee2 41%patch0 -p1
f1ae848c 42%patch1 -p1
6b415c72 43%patch2 -p1
cd19124e 44#%patch0 -p1 -b .cvsupdates
45#%patch1 -p1 -b .glibc23-ldscripts
46#%patch2 -p1 -b .sdl-static-libs
47#%patch3 -p1 -b .DESTDIR
48#%patch4 -p1 -b .lib64
49#%patch5 -p1 -b .amd64
50# needs to 64-bit clean softmmu code or MAP_32BIT physical_ram_base
51# but other problems remain.
52#%patch6 -p1 -b .vl-amd64
53
54%build
8bd2aee2 55./configure \
56 --prefix=%{_prefix} \
57 --cc=%{__cc} \
f1ae848c 58 --make=%{__make}
cd19124e 59%{__make}
60
61%install
62rm -rf $RPM_BUILD_ROOT
63%{__make} install \
64 DESTDIR=$RPM_BUILD_ROOT
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%files
70%defattr(644,root,root,755)
71%doc README qemu-doc.html
72%ifarch %{ix86}
73%attr(755,root,root) %{_bindir}/qemu-fast
74%endif
75%ifarch %{ix86} ppc
76%{_bindir}/qemu
77%endif
78%{_bindir}/qemu-mkcow
79%{_bindir}/qemu-arm
80%{_bindir}/qemu-i386
81%{_bindir}/qemu-sparc
f1ae848c 82%{_bindir}/qemu-ppc
cd19124e 83%{_mandir}/man1/qemu.1*
84%dir %{_datadir}/qemu
85%{_datadir}/qemu/bios.bin
86%{_datadir}/qemu/vgabios.bin
This page took 0.035254 seconds and 4 git commands to generate.