]> git.pld-linux.org Git - packages/python3-setuptools.git/blame - python3-setuptools.spec
- up to 54.2.0; builds without apidocs; easy_install gone upstream
[packages/python3-setuptools.git] / python3-setuptools.spec
CommitLineData
2f649423
MK
1#
2# Conditional build:
e2cd79ed 3%bcond_without apidocs # Sphinx based documentation
744badc2 4%bcond_with system_libs # use system modules (appdirs, packaging, pyparsing, six) # TODO
6502ae9a 5%bcond_with tests # py.test tests (few failures)
744badc2 6%bcond_with bootstrap # convenience alias for without: apidocs,system_libs,tests
25fb9ea9 7
744badc2
JB
8%if %{with bootstrap}
9%undefine with_apidocs
10%undefine with_system_libs
11%undefine with_tests
12%endif
2f649423 13
744badc2 14%define module setuptools
9fded6eb 15%define pypi_name setuptools
b79e62bc 16Summary: A collection of enhancements to the Python distutils
e4a6c4e2 17Summary(pl.UTF-8): Zestaw rozszerzeń dla pythonowych distutils
34676580 18Name: python3-setuptools
6a8a63ea
AM
19Version: 54.2.0
20Release: 1
67093d8e 21Epoch: 1
744badc2 22License: MIT
b79e62bc 23Group: Development/Languages/Python
744badc2 24#Source0Download: https://pypi.org/simple/setuptools/
6a8a63ea
AM
25Source0: https://files.pythonhosted.org/packages/source/s/setuptools/%{pypi_name}-%{version}.tar.gz
26# Source0-md5: 09f693b5d5ca8bf4fdb1da82f8110a9c
1ca207b5 27URL: https://github.com/pypa/setuptools
744badc2 28%if %(locale -a | grep -q '^C\.utf8$'; echo $?)
c034c756
JB
29BuildRequires: glibc-localedb-all
30%endif
744badc2
JB
31BuildRequires: python3-modules >= 1:3.4
32%if %{with system_libs}
33# versions from pkg_resources/_vendor/vendored.txt
34BuildRequires: python3-appdirs >= 1.4.3
403a922f 35BuildRequires: python3-packaging >= 19.2
744badc2
JB
36BuildRequires: python3-pyparsing >= 2.2.1
37BuildRequires: python3-six >= 1.10.0
38%endif
b6cbc91d 39BuildConflicts: python3-distribute < 0.7
e2cd79ed 40%if %{with tests}
744badc2
JB
41BuildRequires: python3-coverage >= 4.5.1
42# FIXME: patch to use unittest.mock
43#BuildRequires: python3-mock
44%if "%{py3_ver}" >= "3.6"
45BuildRequires: python3-paver
46%endif
403a922f 47BuildRequires: python3-pip >= 19.1
ac973a26 48BuildRequires: python3-pytest >= 3.7
744badc2
JB
49BuildRequires: python3-pytest-cov >= 2.5.1
50BuildRequires: python3-pytest-fixture-config
6502ae9a 51BuildRequires: python3-pytest-flake8
744badc2
JB
52BuildRequires: python3-pytest-virtualenv >= 1.2.7
53BuildRequires: python3-virtualenv >= 13.0.0
54BuildRequires: python3-wheel
e2cd79ed 55%endif
5c02125b 56%if %{with apidocs}
be14e546 57BuildRequires: python3-jaraco
ac973a26 58BuildRequires: python3-jaraco.packaging >= 6.1
744badc2
JB
59BuildRequires: python3-rst.linker >= 1.9
60BuildRequires: python3-setuptools >= 34
6a8a63ea 61BuildRequires: python3-tox
6502ae9a 62BuildRequires: sphinx-pdg-3 >= 1.4
5c02125b 63%endif
c034c756 64BuildRequires: rpm-pythonprov
6502ae9a 65BuildRequires: rpmbuild(macros) >= 1.714
6ef7e1f8 66BuildRequires: unzip
6a8a63ea 67Requires: python3-modules
744badc2
JB
68%if %{with system_libs}
69# versions from pkg_resources/_vendor/vendored.txt
6a8a63ea
AM
70Requires: python3-appdirs >= 1.4.0
71Requires: python3-packaging >= 16.8
72Requires: python3-pyparsing >= 2.1.10
73Requires: python3-six >= 1.10.0
744badc2 74%endif
b79e62bc
AM
75BuildArch: noarch
76BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78%description
79setuptools is a collection of enhancements to the Python distutils
c034c756
JB
80that allow you to more easily build and distribute Python 2.x
81packages, especially ones that have dependencies on other packages.
b79e62bc 82
1c17442b 83%description -l pl.UTF-8
d539774b 84setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
c034c756
JB
85łatwiejsze budowanie i rozprowadzanie pakietów Pythona 2.x,
86szczególnie tych mających zależności od innych pakietów.
d539774b
JB
87
88Ten pakiet zawiera składniki uruchomieniowe setuptools, potrzebne do
c034c756
JB
89uruchamiania kodu wymagającego pkg_resources.py, przeznaczone dla
90Pythona 2.x.
eadb908c 91
2f649423
MK
92%package apidocs
93Summary: %{module} API documentation
94Summary(pl.UTF-8): Dokumentacja API %{module}
95Group: Documentation
96
97%description apidocs
98API documentation for %{module}.
99
100%description apidocs -l pl.UTF-8
101Dokumentacja API %{module}.
102
b79e62bc 103%prep
2f649423 104%setup -q -n %{module}-%{version}
b79e62bc 105
744badc2
JB
106%if %{with system_libs}
107exit 1 # TODO: unvendor modules from pkg_resources/_vendor
108%endif
109
b79e62bc 110%build
6502ae9a
JB
111LC_ALL=C.UTF-8 \
112%py3_build
113
114%{?with_tests:%{__python3} -m pytest pkg_resources/tests setuptools/tests tests}
b79e62bc 115
c034c756 116%if %{with apidocs}
6a8a63ea 117%{_bindir}/tox -e docs
c034c756
JB
118%endif
119
b79e62bc
AM
120%install
121rm -rf $RPM_BUILD_ROOT
122
a21b5be7 123%py3_install
991fba2b 124
b79e62bc
AM
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%files
129%defattr(644,root,root,755)
744badc2 130%doc CHANGES.rst LICENSE README.rst
6a8a63ea
AM
131%{py3_sitescriptdir}//distutils-precedence.pth
132%{py3_sitescriptdir}/_distutils_hack
5c02125b
JB
133%{py3_sitescriptdir}/pkg_resources
134%{py3_sitescriptdir}/setuptools
2f649423 135%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
2f649423 136
c034c756 137%if %{with apidocs}
2f649423
MK
138%files apidocs
139%defattr(644,root,root,755)
6502ae9a 140%doc docs/build/html/{_static,*.html,*.js}
2f649423 141%endif
This page took 0.119149 seconds and 4 git commands to generate.