]> git.pld-linux.org Git - packages/python3-pytest-asyncio.git/blame - python3-pytest-asyncio.spec
- release 2 (by relup.sh)
[packages/python3-pytest-asyncio.git] / python3-pytest-asyncio.spec
CommitLineData
bda4c6eb
JB
1#
2# Conditional build:
3%bcond_with tests # unit tests (not included in release package)
4
5Summary: Pytest support for asyncio
6Summary(pl.UTF-8): Wsparcie do asyncio dla Pytesta
7Name: python3-pytest-asyncio
8Version: 0.14.0
8066e43e 9Release: 2
bda4c6eb
JB
10License: Apache v2.0
11Group: Libraries/Python
12#Source0Download: https://pypi.org/simple/pytest-asyncio/
13Source0: https://files.pythonhosted.org/packages/source/p/pytest-asyncio/pytest-asyncio-%{version}.tar.gz
14# Source0-md5: b63593bc08f445f6e3f14c34128a68ed
15URL: https://pypi.org/project/pytest-asyncio/
16BuildRequires: python3-modules >= 1:3.5
17BuildRequires: python3-setuptools
18%if %{with tests}
19%if "%{py3_ver}" < "3.6"
20BuildRequires: python3-async_generator >= 1.3
21%endif
22BuildRequires: python3-hypothesis >= 5.7.1
23BuildRequires: python3-pytest >= 5.4.0
24%endif
25BuildRequires: rpm-pythonprov
26BuildRequires: rpmbuild(macros) >= 1.714
27Requires: python3-modules >= 1:3.5
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32pytest-asyncio is an Apache 2 licensed library, written in Python, for
33testing asyncio code with pytest.
34
35asyncio code is usually written in the form of coroutines, which makes
36it slightly more difficult to test using normal testing tools.
37pytest-asyncio provides useful fixtures and markers to make testing
38easier.
39
40%description -l pl.UTF-8
41pytest-asyncio to wydana na licencji Apache 2 biblioteka, napisana w
42Pythonie, służąca do testowania kodu asynchronicznego we/wy przy
43użyciu pytesta.
44
45Kod asyncio jest zwykle pisany w postaci korutyn, co nieco utrudnia
46testowanie przy użyciu zwykłych narzędzi testowych. pytest-asyncio
47dostarcza przydatne wyposażenie i znaczniki ułatwiające testowanie.
48
49%prep
50%setup -q -n pytest-asyncio-%{version}
51
52%build
53%py3_build
54
55%if %{with tests}
56%{__python3} -m pytest ...
57%endif
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62%py3_install
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(644,root,root,755)
69%doc README.rst
70%{py3_sitescriptdir}/pytest_asyncio
71%{py3_sitescriptdir}/pytest_asyncio-%{version}-py*.egg-info
This page took 0.112804 seconds and 4 git commands to generate.