]> git.pld-linux.org Git - packages/python3-huawei-lte-api.git/blame - python3-huawei-lte-api.spec
- simplify files to assure we package all files and dirs, rel 2
[packages/python3-huawei-lte-api.git] / python3-huawei-lte-api.spec
CommitLineData
c7cd6df2
AM
1# Conditional build:
2%bcond_without tests # unit tests
3
4%define pkgname huawei-lte-api
5%define module huawei_lte_api
6
7Summary: API For huawei LAN/WAN LTE Modems
8Name: python3-huawei-lte-api
9Version: 1.4.18
33637b01 10Release: 2
c7cd6df2
AM
11License: LGPL v3
12Group: Libraries/Python
13# if pypi:
14Source0: https://github.com/Salamek/huawei-lte-api/archive/refs/tags/%{version}.tar.gz
15# Source0-md5: bca439589d1db0997256aad7f0ba8072
16URL: https://github.com/Salamek/huawei-lte-api
17BuildRequires: python3-modules >= 1:3.2
18%if %{with tests}
19BuildRequires: python3-dicttoxml
20BuildRequires: python3-xmltodict
21%endif
22BuildRequires: rpm-pythonprov
23BuildRequires: rpmbuild(macros) >= 1.714
24Requires: python3-modules >= 1:3.2
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29API For huawei LAN/WAN LTE Modems, you can use this to simply send
30SMS, get information about your internet usage, signal, and tons of
31other stuff.
32
33%prep
34%setup -q -n %{pkgname}-%{version}
35
36%build
37%py3_build
38
39%if %{with tests}
40%{__python3} -m pytest tests
41%endif
42
43%install
44rm -rf $RPM_BUILD_ROOT
45
46%py3_install
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%files
52%defattr(644,root,root,755)
53%doc README.md
33637b01 54%{py3_sitescriptdir}/%{module}
c7cd6df2 55%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
This page took 0.081615 seconds and 4 git commands to generate.