]> git.pld-linux.org Git - packages/python.git/blame - python.spec
- Release: 1.3
[packages/python.git] / python.spec
CommitLineData
2374fcc3 1
daf8bffc 2#
2374fcc3 3# todo:
4# - fix locale test to use configured locale instead of en_US (or sth.)
5#
6
9ef7b464 7# Conditional build:
8%bcond_without tkinter # disables tkinter module building
345e30e2 9%bcond_without tests # disables Python testing
daf8bffc 10#
9d0d4238 11%define py_ver 2.3
d12ec25a 12%define py_prefix %{_prefix}
49d1a533 13%define py_libdir %{py_prefix}/%{_lib}/python%{py_ver}
6c765af5 14%define py_scriptdir %{py_prefix}/share/python%{py_ver}
67c01d08 15%define py_incdir %{_includedir}/python%{py_ver}
d12ec25a 16%define py_sitedir %{py_libdir}/site-packages
6c765af5 17%define py_sitescriptdir %{py_scriptdir}/site-packages
d12ec25a 18%define py_dyndir %{py_libdir}/lib-dynload
19%define py_comp ./python -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
20%define py_ocomp ./python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
a9ce5112 21
5b13880d 22Summary: Very high level scripting language with X interface
23