]> git.pld-linux.org Git - packages/python.git/blame - python.spec
- fsync problem fixed in Python 2.3.2
[packages/python.git] / python.spec
CommitLineData
9d0d4238 1
9ef7b464 2# Conditional build:
3%bcond_without tkinter # disables tkinter module building
345e30e2 4%bcond_without tests # disables Python testing
9ef7b464 5
9d0d4238 6%define py_ver 2.3
d12ec25a 7%define py_prefix %{_prefix}
8%define py_libdir %{py_prefix}/lib/python%{py_ver}
67c01d08 9%define py_incdir %{_includedir}/python%{py_ver}
d12ec25a 10%define py_sitedir %{py_libdir}/site-packages
11%define py_dyndir %{py_libdir}/lib-dynload
12%define py_comp ./python -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
13%define py_ocomp ./python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
a9ce5112 14
5b13880d 15Summary: Very high level scripting language with X interface
16