]> git.pld-linux.org Git - packages/python.git/blame - python.spec
- do not add directory of sys.argv[0] into sys.path, so it is possible
[packages/python.git] / python.spec
CommitLineData
390a4bf0 1#
9ef7b464 2# Conditional build:
ca0308fd
JK
3%bcond_without tkinter # disables tkinter module building
4%bcond_without tests # disables Python testing
5%bcond_with verbose_tests # runs tests in verbose mode
390a4bf0 6#
ca0308fd
JK
7# tests which will not work on 64-bit platforms
8%define no64bit_tests test_audioop test_rgbimg test_imageop
9# tests which may fail because of builder environment limitations (no /proc or /dev/pts)
717bd422 10%define nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale
390a4bf0 11# tests which fail because of some unknown/unresolved reason (this list should be empty)
717bd422 12%define broken_tests test_anydbm test_bsddb test_re test_shelve test_whichdb test_zipimport
ca0308fd 13
9d0d4238 14%define py_ver 2.3
d12ec25a 15%define py_prefix %{_prefix}
49d1a533 16%define py_libdir %{py_prefix}/%{_lib}/python%{py_ver}
6c765af5 17%define py_scriptdir %{py_prefix}/share/python%{py_ver}
67c01d08 18%define py_incdir %{_includedir}/python%{py_ver}
d12ec25a 19%define py_sitedir %{py_libdir}/site-packages
6c765af5 20%define py_sitescriptdir %{py_scriptdir}/site-packages
d12ec25a 21%define py_dyndir %{py_libdir}/lib-dynload
22%define py_comp ./python -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
23%define py_ocomp ./python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
a9ce5112 24
5b13880d 25Summary: Very high level scripting language with X interface
26