]> git.pld-linux.org Git - packages/python.git/blame - python.spec
- fixed sys.path to include /usr/share/python%{ver}
[packages/python.git] / python.spec
CommitLineData
2374fcc3 1
daf8bffc 2#
2374fcc3 3# todo:
4# - fix locale test to use configured locale instead of en_US (or sth.)
5#
6
9ef7b464 7# Conditional build:
ca0308fd
JK
8%bcond_without tkinter # disables tkinter module building
9%bcond_without tests # disables Python testing
10%bcond_with verbose_tests # runs tests in verbose mode
11
12# tests which will not work on 64-bit platforms
13%define no64bit_tests test_audioop test_rgbimg test_imageop
14# tests which may fail because of builder environment limitations (no /proc or /dev/pts)
15%define nobuilder_tests test_resource test_openpty test_socket test_nis test_posix
16# test which fail because of some unknown/unresolved reason (this list should be empty)
17%define broken_tests test_anydbm test_bsddb test_re test_shelve test_whichdb test_zipimport
18
9d0d4238 19%define py_ver 2.3
d12ec25a 20%define py_prefix %{_prefix}
49d1a533 21%define py_libdir %{py_prefix}/%{_lib}/python%{py_ver}
6c765af5 22%define py_scriptdir %{py_prefix}/share/python%{py_ver}
67c01d08 23%define py_incdir %{_includedir}/python%{py_ver}
d12ec25a 24%define py_sitedir %{py_libdir}/site-packages
6c765af5 25%define py_sitescriptdir %{py_scriptdir}/site-packages
d12ec25a 26%define py_dyndir %{py_libdir}/lib-dynload
27%define py_comp ./python -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
28%define py_ocomp ./python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
a9ce5112 29
5b13880d 30Summary: Very high level scripting language with X interface
31