]> git.pld-linux.org Git - packages/python-wtforms.git/blame - python-wtforms.spec
- python 3.6
[packages/python-wtforms.git] / python-wtforms.spec
CommitLineData
e6b6a62d
MK
1#
2# Conditional build:
3%bcond_without doc # don't build doc
4%bcond_without tests # do not perform "make test"
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8%define module wtforms
9Summary: A flexible forms validation and rendering library for python web development
10Summary(pl.UTF-8): Biblioteka umożliwiająca generację i walidację formularzy html w jezyku python
11Name: python-%{module}
12Version: 2.0.1
d12f3430 13Release: 7
e6b6a62d
MK
14License: BSD
15Group: Development/Languages/Python
16Source0: http://pypi.python.org/packages/source/W/WTForms/WTForms-%{version}.zip
17# Source0-md5: aaac94c137b3cd63efeb3ded51082cde
18URL: http://wtforms.simplecodes.com/
19BuildRequires: rpm-pythonprov
81c0553a 20BuildRequires: rpmbuild(macros) >= 1.710
e6b6a62d
MK
21BuildRequires: unzip
22%if %{with python2}
23BuildRequires: python-distribute
7d4dd796 24BuildRequires: python-sqlalchemy
e6b6a62d
MK
25%endif
26%if %{with python3}
27BuildRequires: python3-distribute
28BuildRequires: python3-modules
7d4dd796 29BuildRequires: python3-sqlalchemy
e6b6a62d
MK
30%endif
31
32Requires: python-modules
33BuildArch: noarch
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37A flexible forms validation and rendering library for python web
38development.
39
40%description -l pl.UTF-8
41Biblioteka umożliwiająca generację i walidację formularzy html w
42jezyku python
43
44%package -n python3-%{module}
45Summary: -
46Summary(pl.UTF-8): -
47Group: Libraries/Python
48Requires: python3-modules
49
50%description -n python3-%{module}
51A flexible forms validation and rendering library for python web
52development.
53
54%description -n python3-%{module} -l pl.UTF-8
55Biblioteka umożliwiająca generację i walidację formularzy html w
56jezyku python
57
58%package apidocs
59Summary: %{module} API documentation
60Summary(pl.UTF-8): Dokumentacja API %{module}
61Group: Documentation
62
63%description apidocs
64API documentation for %{module}.
65
66%description apidocs -l pl.UTF-8
67Dokumentacja API %{module}.
68
69
70%prep
71%setup -q -n WTForms-%{version}
72
73%build
74%if %{with python2}
583220b6 75%py_build %{?with_tests:test}
e6b6a62d
MK
76%endif
77
78%if %{with python3}
583220b6 79%py3_build %{?with_tests:test}
e6b6a62d
MK
80%endif
81
82%if %{with doc}
83cd docs
84%{__make} -j1 html
85rm -rf _build/html/_sources
86%endif
87
88%install
89rm -rf $RPM_BUILD_ROOT
90
91%if %{with python2}
583220b6 92%py_install
e6b6a62d
MK
93
94%py_postclean
95%endif
96
97%if %{with python3}
583220b6 98%py3_install
e6b6a62d
MK
99%endif
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%if %{with python2}
105%files
106%defattr(644,root,root,755)
107%doc AUTHORS.txt CHANGES.rst LICENSE.txt README.md
108# change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
109%{py_sitescriptdir}/%{module}
110%if "%{py_ver}" > "2.4"
111%{py_sitescriptdir}/WTForms-%{version}-py*.egg-info
112%endif
113%endif
114
115%if %{with python3}
116%files -n python3-%{module}
117%defattr(644,root,root,755)
118%doc AUTHORS.txt CHANGES.rst LICENSE.txt README.md
119%{py3_sitescriptdir}/%{module}
120%{py3_sitescriptdir}/WTForms-%{version}-py*.egg-info
121%endif
122
123%if %{with doc}
124%files apidocs
125%defattr(644,root,root,755)
126%doc docs/_build/html/*
127%endif
128
129
This page took 0.11397 seconds and 4 git commands to generate.