]> git.pld-linux.org Git - packages/python-wpactrl.git/blame - python-wpactrl.spec
- imho requires just python dir
[packages/python-wpactrl.git] / python-wpactrl.spec
CommitLineData
10d23638
ER
1%define module wpactrl
2%define snap 20090609
3%define rel 1
4Summary: A Python extension for wpa_supplicant/hostapd control interface access
5Name: python-%{module}
6Version: 1.0.7
7Release: 0.%{snap}.%{rel}
8License: GPL v2
9Group: Development/Languages/Python
10Source0: http://mirror.leaseweb.com/archlinux/other/python-wpactrl/python-wpactrl-%{snap}.tar.gz
11# Source0-md5: 8d45739aa9bfa1110a4570bb5ceda768
12URL: http://projects.otaku42.de/wiki/PythonWpaCtrl
13BuildRequires: python-devel
14BuildRequires: rpm-pythonprov
15BuildRequires: rpmbuild(macros) >= 1.219
0e59dd9f 16Requires: python-libs
10d23638
ER
17Suggests: hostapd
18Suggests: wpa_supplicant
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22A Python extension for wpa_supplicant/hostapd control interface
23access.
24
25wpa_supplicant/hostapd implements a control interface that can be used
26by external programs to control the operations of the
27wpa_supplicant/hostapd daemon and to get status information and event
28notifications.
29
30The WPACtrl class provided by python-wpactrl allows Python programs to
31use helper functions to connect with the UNIX domain socket form of
32control interface and communicate with a wpa_supplicant/hostapd
33daemon.
34
35%prep
36%setup -q -n %{name}-%{snap}
37
38%build
39export CFLAGS="%{rpmcflags}"
40%{__python} setup.py build
41
42%install
43rm -rf $RPM_BUILD_ROOT
44%{__python} setup.py install \
45 --optimize=2 \
46 --root=$RPM_BUILD_ROOT
47
48%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
49%py_comp $RPM_BUILD_ROOT%{py_sitedir}
50%py_postclean
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files
56%defattr(644,root,root,755)
57%doc README example.py
58%attr(755,root,root) %{py_sitedir}/*.so
59%if "%{py_ver}" > "2.4"
60%{py_sitedir}/%{module}-*.egg-info
61%endif
This page took 0.083785 seconds and 4 git commands to generate.