]> git.pld-linux.org Git - packages/python-setuptools.git/blame - python-setuptools.spec
- split easy_install into -devel to drop python-devel requirement for pkg_resources...
[packages/python-setuptools.git] / python-setuptools.spec
CommitLineData
f4841952
ER
1# TODO:
2# - sync -pl
cb552c1a 3%define module setuptools
f4841952
ER
4%define subver c8
5%define rel 2
b79e62bc 6Summary: A collection of enhancements to the Python distutils
e4a6c4e2 7Summary(pl.UTF-8): Zestaw rozszerzeń dla pythonowych distutils
b79e62bc 8Name: python-setuptools
67093d8e 9Version: 0.6
f4841952 10Release: 1.%{subver}.%{rel}
67093d8e 11Epoch: 1
b79e62bc
AM
12License: GPL
13Group: Development/Languages/Python
f4841952 14Source0: http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-%{version}%{subver}.tar.gz
52bba8ef 15# Source0-md5: 0e9bbe1466f3ee29588cc09d3211a010
b79e62bc 16URL: http://peak.telecommunity.com/DevCenter/setuptools
b79e62bc 17BuildRequires: python-devel
b79e62bc
AM
18BuildArch: noarch
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22setuptools is a collection of enhancements to the Python distutils
f4841952
ER
23that allow you to more easily build and distribute Python packages,
24especially ones that have dependencies on other packages.
25
26This package contains the runtime components of setuptools, necessary
27to execute the software that requires pkg_resources.py.
b79e62bc 28
1c17442b
JR
29%description -l pl.UTF-8
30setuptools to zestaw rozszerzeń do pythonowych distutils (dla Pythona
312.3.5 i nowszego na większości platform; platformy 64-bitowe wymagają
32co najmniej Pythona 2.4) umożliwiający łatwiejsze budowanie i
33rozprowadzanie pakietów Pythona, szczególnie tych mających zależności
34od innych pakietów.
eadb908c 35
f4841952
ER
36%package devel
37Summary: Download, install, upgrade, and uninstall Python packages
38Group: Development/Languages
39Requires: %{name} = %{version}-%{release}
40Requires: python-devel
41
42%description devel
43setuptools is a collection of enhancements to the Python distutils
44that allow you to more easily build and distribute Python packages,
45especially ones that have dependencies on other packages.
46
47This package contains the components necessary to build and install
48software requiring setuptools.
49
b79e62bc 50%prep
f4841952 51%setup -q -n %{module}-%{version}%{subver}
b79e62bc
AM
52
53%build
f4841952 54%{__python} ./setup.py build
b79e62bc
AM
55
56%install
57rm -rf $RPM_BUILD_ROOT
58
59python ./setup.py install \
191919b9 60 --single-version-externally-managed \
b79e62bc
AM
61 --optimize 2 \
62 --root=$RPM_BUILD_ROOT
991fba2b 63
191919b9 64rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/*/*.exe
991fba2b
AM
65
66%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
67%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
b79e62bc 68%py_postclean
c2e9082a 69install site.py $RPM_BUILD_ROOT%{py_sitescriptdir}
b79e62bc
AM
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%files
75%defattr(644,root,root,755)
f4841952 76%doc pkg_resources.txt setuptools.txt
b79e62bc 77%{py_sitescriptdir}/%{module}*
f4841952
ER
78%{py_sitescriptdir}/pkg_resources.py[co]
79%{py_sitescriptdir}/site.py[co]
c2e9082a 80%{py_sitescriptdir}/site.py
f4841952
ER
81
82%files devel
83%defattr(644,root,root,755)
84%doc EasyInstall.txt README.txt api_tests.txt
85%attr(755,root,root) %{_bindir}/easy_install*
86%{py_sitescriptdir}/easy_install.py[co]
This page took 0.0815709999999999 seconds and 4 git commands to generate.