]> git.pld-linux.org Git - packages/python3-setuptools.git/blame - python-setuptools.spec
- fix
[packages/python3-setuptools.git] / python-setuptools.spec
CommitLineData
b79e62bc
AM
1
2%define module setuptools
3
4Summary: A collection of enhancements to the Python distutils
5Name: python-setuptools
6Version: 0.6a8
7Release: 1
8License: GPL
9Group: Development/Languages/Python
10Source0: http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-%{version}.zip
11# Source0-md5: 3eecdf66c1a2cf8a6556bc00b69d572a
12URL: http://peak.telecommunity.com/DevCenter/setuptools
991fba2b 13BuildRequires: findutils
b79e62bc
AM
14%pyrequires_eq python
15BuildRequires: python-devel
16BuildRequires: unzip
17BuildArch: noarch
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21setuptools is a collection of enhancements to the Python distutils
22(for Python 2.3.5 and up on most platforms; 64-bit platforms require a
23minimum of Python 2.4) that allow you to more easily build and
24distribute Python packages, especially ones that have dependencies on
25other packages.
26
27%prep
28%setup -q -n %{module}-%{version}
29
30%build
31python ./setup.py build
32
33%install
34rm -rf $RPM_BUILD_ROOT
35
36python ./setup.py install \
37 --optimize 2 \
38 --root=$RPM_BUILD_ROOT
991fba2b
AM
39
40find $RPM_BUILD_ROOT -type f -name '*.pyc' -exec rm "{}" ";"
41find $RPM_BUILD_ROOT -type f -name '*.pyo' -exec rm "{}" ";"
42find $RPM_BUILD_ROOT -type f -exec sed -i -e "s#$RPM_BUILD_ROOT##g" "{}" ";"
43
44%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
45%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
b79e62bc
AM
46%py_postclean
47
3c1d7b6f
AM
48echo '%{module}-%{version}-py%{py_ver}.egg' > $RPM_BUILD_ROOT%{py_sitescriptdir}/%{module}.pth
49
b79e62bc
AM
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files
54%defattr(644,root,root,755)
55%doc *.txt
56%attr(755,root,root) %{_bindir}/*
57%{py_sitescriptdir}/%{module}*
This page took 0.043365 seconds and 4 git commands to generate.