]> git.pld-linux.org Git - packages/python-pyparsing.git/blame - python-pyparsing.spec
- release 2
[packages/python-pyparsing.git] / python-pyparsing.spec
CommitLineData
cd580c6e 1
cd580c6e
MG
2%define module pyparsing
3
4Summary: pyparsing - a Python module for creating executing simple grammars
4c41b8a1 5Summary(pl.UTF-8): pyparsing - moduł Pythona umożliwiający tworzenie i parsowanie prostych gramatyk
cd580c6e 6Name: python-%{module}
5981dfee 7Version: 1.5.1
bf9bccb4 8Release: 2
cd580c6e
MG
9License: MIT
10Group: Libraries/Python
11Source0: http://dl.sourceforge.net/pyparsing/%{module}-%{version}.tar.gz
5981dfee 12# Source0-md5: d0777821fc4c5f2474cda1081229d76b
cd580c6e 13URL: http://pyparsing.sourceforge.net/
60e81977 14BuildRequires: python-devel >= 1:2.5
c25047aa 15BuildRequires: python-modules
60e81977 16BuildRequires: rpm-pythonprov
c00b69a0 17%pyrequires_eq python-libs
cd580c6e
MG
18BuildArch: noarch
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22The parsing module is an alternative approach to creating and
23executing simple grammars, vs. the traditional lex/yacc approach, or
24the use of regular expressions. The parsing module provides a library
25of classes that client code uses to construct the grammar directly in
26Python code.
27
bd64dee0
JR
28%description -l pl.UTF-8
29Moduł pyparsing umożliwia tworzenie i parsowanie prostych gramatyk w
30sposób odmienny od podejścia tradycyjnego, jakim jest zwykle użycie
31pary lex/yacc lub wyrażeń regularnych. Moduł ten udostępnia bibliotekę
32klas, przy pomocy których gramatyka tworzona jest wprost w kodzie
cd580c6e
MG
33Pythona.
34
35%package doc
36Summary: Documentation for pyparsing module
4c41b8a1 37Summary(pl.UTF-8): Dokumentacja do modułu pyparsing
cd580c6e
MG
38Group: Libraries/Python
39Requires: %{name} = %{version}-%{release}
40
41%description doc
42This package contains documentation files for pyparsing Python module.
43
bd64dee0
JR
44%description doc -l pl.UTF-8
45Pakiet zawierający dokumentację dla modułu Pythona pyparsing.
cd580c6e
MG
46
47%package examples
48Summary: Examples for pyparsing module
4c41b8a1 49Summary(pl.UTF-8): Przykłady do modułu pyparsing
cd580c6e
MG
50Group: Libraries/Python
51Requires: %{name} = %{version}-%{release}
52
53%description examples
54This package contains example files for pyparsing Python module.
55
bd64dee0
JR
56%description examples -l pl.UTF-8
57Pakiet zawierający przykładowe skrypty dla modułu Pythona pyparsing.
cd580c6e
MG
58
59%prep
60%setup -q -n %{module}-%{version}
61
62%build
63python setup.py build_ext
64
65%install
66rm -rf $RPM_BUILD_ROOT
67install -d $RPM_BUILD_ROOT{%{py_sitescriptdir},%{_examplesdir}/%{name}-%{version}}
68
69python setup.py install \
70 --root=$RPM_BUILD_ROOT \
cd580c6e
MG
71 --optimize=2
72
60e81977 73%py_postclean
cd580c6e
MG
74
75cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%files
81%defattr(644,root,root,755)
82%doc CHANGES README
60e81977
JB
83%{py_sitescriptdir}/pyparsing.py[co]
84%{py_sitescriptdir}/pyparsing-*.egg-info
cd580c6e
MG
85
86%files doc
87%defattr(644,root,root,755)
88%doc HowToUsePyparsing.html htmldoc pyparsingClassDiagram.{JPG,PNG}
89
90%files examples
91%defattr(644,root,root,755)
92%{_examplesdir}/%{name}-%{version}
This page took 2.003158 seconds and 4 git commands to generate.