]> git.pld-linux.org Git - packages/python-pygments_pytest.git/blame - python-pygments_pytest.spec
- release 2 (by relup.sh)
[packages/python-pygments_pytest.git] / python-pygments_pytest.spec
CommitLineData
81f58adb 1# NOTE: for versions >= 2 (for python 3.6+) see python3-pygments_pytest.spec
e1d3c87e
JB
2#
3# Conditional build:
4%bcond_without python2 # CPython 2.x module
81f58adb 5%bcond_with python3 # CPython 3.x module (built from python3-pygments_pytest.spec)
e1d3c87e
JB
6
7Summary: A pygments lexer for pytest output
8Summary(pl.UTF-8): Lexer pygments do wyjścia pytesta
9Name: python-pygments_pytest
10# keep 1.x here for python2 support
11Version: 1.3.1
af252335 12Release: 2
e1d3c87e
JB
13License: MIT
14Group: Libraries/Python
15#Source0Download: https://pypi.org/simple/pygments-pytest/
16Source0: https://files.pythonhosted.org/packages/source/p/pygments-pytest/pygments_pytest-%{version}.tar.gz
17# Source0-md5: e51a2e259bfd4eb4f93fc4f626e05e17
18URL: https://pypi.org/project/pygments-pytest/
19%if %{with python2}
20BuildRequires: python-modules >= 1:2.5
21BuildRequires: python-setuptools
22%endif
23%if %{with python3}
24BuildRequires: python3-modules >= 1:3.2
25BuildRequires: python3-setuptools
26%endif
27BuildRequires: rpm-pythonprov
28BuildRequires: rpmbuild(macros) >= 1.714
29Requires: python-modules >= 1:2.5
30BuildArch: noarch
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34This library provides a pygments lexer called pytest.
35
36%description -l pl.UTF-8
37Ta biblioteka udostępnia lexer pygments o nazwie pytest.
38
39%package -n python3-pygments_pytest
40Summary: A pygments lexer for pytest output
41Summary(pl.UTF-8): Lexer pygments do wyjścia pytesta
42Group: Libraries/Python
43Requires: python3-modules >= 1:3.2
44
45%description -n python3-pygments_pytest
46This library provides a pygments lexer called pytest.
47
48%description -n python3-pygments_pytest -l pl.UTF-8
49Ta biblioteka udostępnia lexer pygments o nazwie pytest.
50
51%prep
52%setup -q -n pygments_pytest-%{version}
53
54%build
55%if %{with python2}
56%py_build
57%endif
58
59%if %{with python3}
60%py3_build
61%endif
62
63%install
64rm -rf $RPM_BUILD_ROOT
65
66%if %{with python2}
67%py_install
68
69%py_postclean
70%endif
71
72%if %{with python3}
73%py3_install
74%endif
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%if %{with python2}
80%files
81%defattr(644,root,root,755)
82%doc LICENSE README.md
83%{py_sitescriptdir}/pygments_pytest.py[co]
84%{py_sitescriptdir}/pygments_pytest-%{version}-py*.egg-info
85%endif
86
87%if %{with python3}
88%files -n python3-pygments_pytest
89%defattr(644,root,root,755)
90%doc LICENSE README.md
91%{py3_sitescriptdir}/pygments_pytest.py
92%{py3_sitescriptdir}/__pycache__/pygments_pytest.cpython-*.py[co]
93%{py3_sitescriptdir}/pygments_pytest-%{version}-py*.egg-info
94%endif
This page took 0.068811 seconds and 4 git commands to generate.