]> git.pld-linux.org Git - packages/python-pygments_pytest.git/blame - python-pygments_pytest.spec
- new
[packages/python-pygments_pytest.git] / python-pygments_pytest.spec
CommitLineData
e1d3c87e
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: A pygments lexer for pytest output
7Summary(pl.UTF-8): Lexer pygments do wyjścia pytesta
8Name: python-pygments_pytest
9# keep 1.x here for python2 support
10Version: 1.3.1
11Release: 1
12License: MIT
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/pygments-pytest/
15Source0: https://files.pythonhosted.org/packages/source/p/pygments-pytest/pygments_pytest-%{version}.tar.gz
16# Source0-md5: e51a2e259bfd4eb4f93fc4f626e05e17
17URL: https://pypi.org/project/pygments-pytest/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.5
20BuildRequires: python-setuptools
21%endif
22%if %{with python3}
23BuildRequires: python3-modules >= 1:3.2
24BuildRequires: python3-setuptools
25%endif
26BuildRequires: rpm-pythonprov
27BuildRequires: rpmbuild(macros) >= 1.714
28Requires: python-modules >= 1:2.5
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33This library provides a pygments lexer called pytest.
34
35%description -l pl.UTF-8
36Ta biblioteka udostępnia lexer pygments o nazwie pytest.
37
38%package -n python3-pygments_pytest
39Summary: A pygments lexer for pytest output
40Summary(pl.UTF-8): Lexer pygments do wyjścia pytesta
41Group: Libraries/Python
42Requires: python3-modules >= 1:3.2
43
44%description -n python3-pygments_pytest
45This library provides a pygments lexer called pytest.
46
47%description -n python3-pygments_pytest -l pl.UTF-8
48Ta biblioteka udostępnia lexer pygments o nazwie pytest.
49
50%prep
51%setup -q -n pygments_pytest-%{version}
52
53%build
54%if %{with python2}
55%py_build
56%endif
57
58%if %{with python3}
59%py3_build
60%endif
61
62%install
63rm -rf $RPM_BUILD_ROOT
64
65%if %{with python2}
66%py_install
67
68%py_postclean
69%endif
70
71%if %{with python3}
72%py3_install
73%endif
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%if %{with python2}
79%files
80%defattr(644,root,root,755)
81%doc LICENSE README.md
82%{py_sitescriptdir}/pygments_pytest.py[co]
83%{py_sitescriptdir}/pygments_pytest-%{version}-py*.egg-info
84%endif
85
86%if %{with python3}
87%files -n python3-pygments_pytest
88%defattr(644,root,root,755)
89%doc LICENSE README.md
90%{py3_sitescriptdir}/pygments_pytest.py
91%{py3_sitescriptdir}/__pycache__/pygments_pytest.cpython-*.py[co]
92%{py3_sitescriptdir}/pygments_pytest-%{version}-py*.egg-info
93%endif
This page took 0.086989 seconds and 4 git commands to generate.