]> git.pld-linux.org Git - packages/python-msgpack.git/blame - python-msgpack.spec
- up to 1.0.0
[packages/python-msgpack.git] / python-msgpack.spec
CommitLineData
df80b467
MK
1#
2# Conditional build:
2d81bbdb 3%bcond_with doc # don't build doc
df80b467
MK
4%bcond_without tests # do not perform "make test"
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
dfacf687 7
2fb16dc5 8%define module msgpack
2d81bbdb 9%define pypi_name msgpack-python
dfacf687
MK
10Summary: Binary-based efficient data interchange format
11Summary(pl.UTF-8): Binarny efektywny format wymiany danych.
12Name: python-%{module}
2fb16dc5
JR
13Version: 1.0.0
14Release: 1
dfacf687
MK
15License: ASL
16Group: Development/Languages/Python
278786e8 17Source0: https://pypi.debian.net/msgpack/%{module}-%{version}.tar.gz
2fb16dc5 18# Source0-md5: c35ee8f991dad3969884e9585e56ebba
dfacf687 19URL: http://msgpack.org/
a575d636 20BuildRequires: libstdc++-devel
dfacf687 21BuildRequires: rpm-pythonprov
b300a6a8 22BuildRequires: rpmbuild(macros) >= 1.710
df80b467
MK
23%if %{with python2}
24BuildRequires: python-devel
25BuildRequires: python-distribute
26%endif
27%if %{with python3}
28BuildRequires: python3-devel
29BuildRequires: python3-distribute
30BuildRequires: python3-modules
31%endif
dfacf687
MK
32Requires: python-modules
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36MessagePack is a binary-based efficient object serialization library.
37It enables to exchange structured objects between many languages like
38JSON. But unlike JSON, it is very fast and small.
39
40%description -l pl.UTF-8
41MessagePack jest binarną, efektywną biblioteką serializacji obiektów.
42Pozwala wymieniać strukturalne obiekty pomiędzy wieloma językami
43podobnie jak JSON. W odróżnieniu jest bardzo szybka i mała.
44
df80b467 45%package -n python3-%{module}
2d81bbdb
ER
46Summary: Binary-based efficient data interchange format
47Summary(pl.UTF-8): Binarny efektywny format wymiany danych.
df80b467
MK
48Group: Libraries/Python
49Requires: python3-modules
50
51%description -n python3-%{module}
52MessagePack is a binary-based efficient object serialization library.
53It enables to exchange structured objects between many languages like
54JSON. But unlike JSON, it is very fast and small.
55
56%description -n python3-%{module} -l pl.UTF-8
57MessagePack jest binarną, efektywną biblioteką serializacji obiektów.
58Pozwala wymieniać strukturalne obiekty pomiędzy wieloma językami
59podobnie jak JSON. W odróżnieniu jest bardzo szybka i mała.
60
61%package apidocs
62Summary: %{module} API documentation
63Summary(pl.UTF-8): Dokumentacja API %{module}
64Group: Documentation
65
66%description apidocs
67API documentation for %{module}.
68
69%description apidocs -l pl.UTF-8
70Dokumentacja API %{module}.
71
dfacf687 72%prep
278786e8 73%setup -q -n %{module}-%{version}
dfacf687
MK
74
75%build
df80b467 76%if %{with python2}
5b646f98 77%py_build %{?with_tests:test}
df80b467
MK
78%endif
79
80%if %{with python3}
5b646f98 81%py3_build %{?with_tests:test}
df80b467
MK
82%endif
83
84%if %{with doc}
85cd docs
86%{__make} -j1 html
87rm -rf _build/html/_sources
88%endif
dfacf687
MK
89
90%install
91rm -rf $RPM_BUILD_ROOT
df80b467 92%if %{with python2}
5b646f98 93%py_install
dfacf687 94%py_postclean
df80b467
MK
95%endif
96
97%if %{with python3}
5b646f98 98%py3_install
df80b467 99%endif
dfacf687
MK
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
df80b467 104%if %{with python2}
dfacf687
MK
105%files
106%defattr(644,root,root,755)
2fb16dc5
JR
107%doc COPYING README.md
108%dir %{py_sitescriptdir}/%{module}
109%{py_sitescriptdir}/%{module}/*.py[co]
110%{py_sitescriptdir}/msgpack-%{version}-py*.egg-info
df80b467 111%endif
df80b467
MK
112
113%if %{with python3}
114%files -n python3-%{module}
115%defattr(644,root,root,755)
2fb16dc5 116%doc COPYING README.md
df80b467 117%dir %{py3_sitedir}/%{module}
2fb16dc5 118%attr(755,root,root) %{py3_sitedir}/%{module}/_cmsgpack.cpython-*.so
df80b467
MK
119%{py3_sitedir}/%{module}/*.py
120%{py3_sitedir}/%{module}/__pycache__
278786e8 121%{py3_sitedir}/msgpack-%{version}-py*.egg-info
df80b467
MK
122%endif
123
124%if %{with doc}
125%files apidocs
126%defattr(644,root,root,755)
127%doc docs/_build/html/*
dfacf687 128%endif
This page took 0.104094 seconds and 4 git commands to generate.