]> git.pld-linux.org Git - packages/python-gevent.git/blame - python-gevent.spec
attempt to convert known failures to new format
[packages/python-gevent.git] / python-gevent.spec
CommitLineData
11497ff2
JK
1
2# TODO:
6c017ba8
MK
3# - SSL Broken with python 2.7.9
4# https://github.com/gevent/gevent/issues/477
2fed4eba 5#
19395fb4
JK
6# - test__core_stat.py fails on 32-bit builds with system libev
7# investigate/fix that and enable system libev
8#
9# - investigate some other failing tests
11497ff2
JK
10# (now excluded via known_failures-pld.txt)
11
12# Conditional build:
13%bcond_without tests # do not run tests
19395fb4 14%bcond_with system_libev # build with system libev (more tests will fail)
282f7bb0 15%bcond_without system_c_ares # build with system c_ares
11497ff2 16
71c03694 17%define module gevent
78f066e6
ER
18Summary: A coroutine-based Python networking library
19Name: python-%{module}
6c017ba8
MK
20Version: 1.0.1
21Release: 1
78f066e6
ER
22License: MIT
23Group: Development/Languages
78f066e6 24Source0: http://pypi.python.org/packages/source/g/gevent/%{module}-%{version}.tar.gz
6c017ba8 25# Source0-md5: 7b952591d1a0174d6eb6ac47bd975ab6
2fed4eba
ER
26Patch0: known_failures-pld.patch
27URL: http://www.gevent.org/
140cee97
JK
28%{?with_system_c_ares:BuildRequires: c-ares-devel >= 1.10.0}
29%{?with_system_libev:BuildRequires: libev-devel >= 4.11}
282f7bb0 30#BuildRequires: python-Cython
78f066e6 31BuildRequires: python-devel
7c3f7ce6 32%if %{with tests}
282f7bb0 33BuildRequires: python-devel-src
73d3206b
JK
34BuildRequires: python-greenlet >= 0.3.2
35BuildRequires: python-test
282f7bb0 36BuildRequires: rpmbuild(macros) >= 1.688
7c3f7ce6 37%endif
78f066e6 38BuildRequires: rpm-pythonprov
27ee9f05 39Requires: python-greenlet >= 0.3.2
78f066e6 40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71c03694
ER
41
42%description
282f7bb0 43gevent is a coroutine-based Python networking library.
71c03694
ER
44
45Features include:
282f7bb0
JK
46
47- Fast event loop based on libev.
48- Lightweight execution units based on greenlet.
49- Familiar API that re-uses concepts from the Python standard library.
50- Cooperative sockets with SSL support.
51- DNS queries performed through c-ares or a threadpool.
52- Ability to use standard library and 3rd party modules written for
6c017ba8 53 standard blocking sockets
71c03694
ER
54
55%prep
56%setup -q -n %{module}-%{version}
2fed4eba 57%patch0 -p1
11497ff2 58
71c03694 59%build
282f7bb0
JK
60# when Cython-generated files are to be rebuilt
61# (BR: python-Cython must be enabled then too)
62# ln -s Makefile.ext Makefile
63
71c03694
ER
64CC="%{__cc}" \
65CFLAGS="%{rpmcflags}" \
282f7bb0
JK
66%{?with_system_libev:LIBEV_EMBED=false} \
67%{?with_system_c_ares:CARES_EMBED=false} \
71c03694
ER
68%{__python} setup.py build
69
31e6d75d
JK
70%if %{with tests}
71cd greentest
2fed4eba 72PYTHONPATH=.. python testrunner.py --config ../known_failures.py
31e6d75d
JK
73cd ..
74%endif
75
71c03694
ER
76%install
77rm -rf $RPM_BUILD_ROOT
282f7bb0
JK
78
79%{?with_system_libev:LIBEV_EMBED=false} \
80%{?with_system_c_ares:CARES_EMBED=false} \
71c03694
ER
81%{__python} setup.py install \
82 --skip-build \
83 --optimize=2 \
84 --root=$RPM_BUILD_ROOT
85
86%py_postclean
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%files
92%defattr(644,root,root,755)
93%doc LICENSE README.rst
78f066e6 94%dir %{py_sitedir}/%{module}
71c03694 95%{py_sitedir}/%{module}/*.py[co]
0f612c0f
JK
96%attr(755,root,root) %{py_sitedir}/%{module}/_semaphore.so
97%attr(755,root,root) %{py_sitedir}/%{module}/_util.so
98%attr(755,root,root) %{py_sitedir}/%{module}/ares.so
71c03694
ER
99%attr(755,root,root) %{py_sitedir}/%{module}/core.so
100%if "%{py_ver}" > "2.4"
101%{py_sitedir}/%{module}-%{version}-py%{py_ver}.egg-info
102%endif
This page took 0.076296 seconds and 4 git commands to generate.