]> git.pld-linux.org Git - packages/python-docker.git/blame - python-docker.spec
- reverted to 4.4.4, epoch 1; docker 5 is python3-only
[packages/python-docker.git] / python-docker.spec
CommitLineData
bdab460e
ER
1#
2# Conditional build:
7d5980d3 3%bcond_without tests # unit tests
bdab460e 4
72030b27 5%define module docker
b7e5dc8d 6%define egg_name docker
6f952153 7%define pypi_name docker
45c3e8fc
JB
8Summary: A Python 2 library for the Docker Engine API
9Summary(pl.UTF-8): Biblioteka Pythona 2 do API silnika Docker
bdab460e 10Name: python-%{module}
7d5980d3
JB
11Version: 4.4.4
12Release: 3
13Epoch: 1
bdab460e
ER
14License: Apache v2.0
15Group: Libraries/Python
7d5980d3
JB
16Source0: https://files.pythonhosted.org/packages/source/d/docker/%{pypi_name}-%{version}.tar.gz
17# Source0-md5: e52f862b113d14c684a6e7dfa3d9e11c
b3671e57 18Patch0: unpin-requirements.patch
bdab460e 19URL: http://docker-py.readthedocs.org/
7d5980d3
JB
20BuildRequires: python-modules >= 1:2.7
21BuildRequires: python-setuptools >= 1:42
45c3e8fc 22%if %{with tests}
7d5980d3
JB
23BuildRequires: python-ipaddress >= 1.0.16
24BuildRequires: python-backports-ssl_match_hostname >= 3.5
45c3e8fc 25BuildRequires: python-pytest >= 4.3.1
7d5980d3
JB
26BuildRequires: python-pytest-timeout >= 1.3.3
27BuildRequires: python-requests >= 2.20.0
28BuildRequires: python-six >= 1.10.0
29BuildRequires: python-urllib3 >= 1.24.3
30BuildRequires: python-websocket-client >= 0.56.0
45c3e8fc 31%endif
7d5980d3
JB
32BuildRequires: rpm-pythonprov
33BuildRequires: rpmbuild(macros) >= 1.714
2492f669 34BuildConflicts: python-docker < 2.0
99b90030
ER
35# Docker can be remote, so suggest only
36Suggests: docker >= 1.3.3
e0043ac3
JP
37# optional dep for ssh support (required by docker-compose)
38Suggests: python-paramiko >= 2.4.2
bdab460e
ER
39BuildArch: noarch
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
45c3e8fc 43A Python library for the Docker Engine API. It lets you do anything
6f952153
ER
44the `docker` command does, but from within Python apps - run
45containers, manage containers, manage Swarms, etc.
bdab460e 46
45c3e8fc
JB
47%description -l pl.UTF-8
48Biblioteka Pythona do API silnika Docker. Pozwala zrobić wszystko to,
49co polecenie "docker", ale z poziomu aplikacji w Pythonie: uruchamiać
50kontenery, zarządzać nimi, zarządzać Swarmami itp.
51
bdab460e 52%prep
6f952153 53%setup -q -n %{pypi_name}-%{version}
99b90030 54%patch0 -p1
bdab460e 55
bdab460e 56%build
45c3e8fc
JB
57%py_build
58
59%if %{with tests}
60PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
7d5980d3 61PYTEST_PLUGINS="pytest_timeout" \
45c3e8fc 62PYTHONPATH=$(pwd) \
7d5980d3 63%{__python} -m pytest tests/unit -k 'not TCPSocketStreamTest'
bdab460e
ER
64%endif
65
66%install
67rm -rf $RPM_BUILD_ROOT
7d5980d3 68
e1c7d18e 69%py_install
bdab460e 70
7d5980d3 71%py_postclean
bdab460e
ER
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
bdab460e
ER
76%files
77%defattr(644,root,root,755)
78%doc LICENSE README.md
79%{py_sitescriptdir}/%{module}
72030b27 80%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.112153 seconds and 4 git commands to generate.