]> git.pld-linux.org Git - packages/poldek.git/blame - poldek.spec
- fix issue with lack of progress bar in i686 build
[packages/poldek.git] / poldek.spec
CommitLineData
7638abfc 1#
de1099c4 2# Conditional build:
9fe14a3f 3%bcond_with static # don't use shared libraries
4%bcond_without imode # don't build interactive mode
58c31de0 5%bcond_without python # don't build python bindings
cf6c3a30 6%bcond_with snap # install configs for official Th snapshot
1fde4642 7%bcond_with db61 # DB 6.1 instead of 5.2
dbf5b095 8%bcond_with rpm4 # use rpm4/db4.7 instead of rpm5
7000d724 9
e1015166 10# current snapshot name
b831407e 11%define SNAP 2015
a584c5c5 12
373c6f03 13# required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
6e185c37 14# NOTE: poldek links with "system db" (-ldb) anyway if it exists
1fde4642
JB
15%if %{with db61}
16%define db_pkg db6.1
17%define ver_db 6.1
6e185c37
JB
18%define ver_db_rel 1
19%else
ff4e68af 20%define db_pkg db5.2
376a705c 21%define ver_db 5.2
19e679c6 22%define ver_db_rel 3
6e185c37 23%endif
5fda028a
ER
24
25%if %{with rpm4}
97791166 26%define db_pkg db4.7
5fda028a
ER
27%define ver_db 4.7.25
28%define ver_db_rel 1
29%define ver_rpm 4.5-49
30%else
a17726b5 31%define ver_rpm 5.4.10
5fda028a 32%endif
7000d724 33
d591cf54 34%define rel 17
b44549bf 35Summary: RPM packages management helper tool
9c03ea8f 36Summary(hu.UTF-8): RPM csomagkezelést segítő eszköz
9faf625a 37Summary(pl.UTF-8): Pomocnicze narzędzie do zarządzania pakietami RPM
b44549bf 38Name: poldek
e8dadd74 39Version: 0.30.1
9c1c2b52 40Release: %{rel}%{?with_snap:.%{SNAP}}
9f931ada 41License: GPL v2
8efee472 42Group: Applications/System
85398bac 43#Source0: http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
e5009a66 44Source0: http://carme.pld-linux.org/~megabajt/releases/poldek/%{name}-%{version}.tar.xz
e8dadd74 45# Source0-md5: e569c8454df0932df53b09cee9998927
911a8560 46Source1: %{name}.conf
b25cb9a7 47Source2: %{name}-multilib.conf
d9c7cedf 48Source3: %{name}-config.sh
2ccd5d66 49Source5: %{name}-aliases.conf
50Source6: %{name}.desktop
51Source7: %{name}.png
a97b47d4 52# Source7-md5: ee487abede50874e9eceb6495d5ee150
171e07f6 53Source8: %{name}-debuginfo.conf
652b5bc5 54Source9: %{name}-aidath.conf
55Source10: %{name}-multilib-aidath.conf
8db66c11 56Source11: %{name}-archive.conf
a584c5c5
JR
57Source100: %{name}-snap.conf
58Source101: %{name}-multilib-snap.conf
59Source102: %{name}-debuginfo-snap.conf
e5009a66 60Patch0: %{name}-size-type.patch
e8dadd74 61Patch1: %{name}-config.patch
1cf9975a 62Patch2: %{name}-missing-include.patch
c5d1808a 63Patch3: pm-hooks.patch
0021c1c7 64Patch4: %{name}-setenv-null.patch
966a5e45 65Patch5: %{name}-assert-sigint.patch
d20073ca 66Patch6: %{name}-upgrade-orphan.patch
eca4cdcd 67Patch7: %{name}-largefile.patch
39ca2371 68URL: http://poldek.pld-linux.org/
340a1e21 69BuildRequires: %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
a4268952 70BuildRequires: autoconf
4d0dcbcf 71BuildRequires: automake >= 1:1.11
373c6f03 72BuildRequires: bzip2-devel
065b86e0 73BuildRequires: check-devel
1d67e563 74BuildRequires: docbook-dtd412-xml
22329ccf 75BuildRequires: gettext-tools
0021c1c7 76BuildRequires: libgomp-devel
b25cb9a7
JB
77BuildRequires: libtool
78BuildRequires: libxml2-devel
cbc6f56b 79BuildRequires: openssl-devel >= 0.9.7d
13fd950e 80BuildRequires: pcre-devel
b3ea4b51 81BuildRequires: pkgconfig
13fd950e 82BuildRequires: popt-devel
58c31de0 83%{?with_python:BuildRequires: python-devel}
b25cb9a7 84BuildRequires: readline-devel >= 5.0
373c6f03 85BuildRequires: rpm-devel >= %{ver_rpm}
300927eb 86%{?with_python:BuildRequires: rpm-pythonprov}
340a1e21 87BuildRequires: tar >= 1:1.22
77cfda6e 88BuildRequires: xmlto
340a1e21 89BuildRequires: xz
96475e5e 90BuildRequires: zlib-devel
373c6f03 91%if %{with static}
ff4e68af 92BuildRequires: %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
340a1e21 93BuildRequires: bzip2-static
2fac0b02 94BuildRequires: glibc-static
b25cb9a7 95BuildRequires: libxml2-static
373c6f03
JB
96BuildRequires: ncurses-static
97BuildRequires: openssl-static
98BuildRequires: pcre-static
99BuildRequires: popt-static
100BuildRequires: readline-static
101BuildRequires: rpm-static
102BuildRequires: zlib-static
373c6f03 103%endif
b25cb9a7 104Requires(triggerpostun): awk
168acc54 105Requires(triggerpostun): sed >= 4.0
ff4e68af 106Requires: %{db_pkg} >= %{ver_db}-%{ver_db_rel}
340a1e21 107Requires: %{name}-libs = %{version}-%{release}
67e6053c 108Requires: /bin/run-parts
373c6f03 109Requires: rpm >= %{ver_rpm}
530c8c41 110Requires: rpm-db-ver = %{ver_db}
5fda028a 111Requires: rpm-lib >= %{ver_rpm}
e202a52a 112Requires: sed
c5d1808a 113Conflicts: etckeeper < 1.18-2
b44549bf 114BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
dcdcebb7
ER
116%define _libexecdir %{_prefix}/lib/%{name}
117
b44549bf 118%description
0fa0dc36 119poldek is an RPM package management tool which allows you to easily
120perform package verification, installation (including system
13fd950e 121installation from scratch), upgrading, and removal.
0fa0dc36 122
13fd950e
JB
123Program can be used in batch (like apt-get from Debian's APT) or
124interactive mode. The interactive mode puts you into a readline
125interface with command line autocompletion and history, similar to the
126shell mode of Perl's CPAN.
8efee472 127
9fe14a3f 128%{?with_static:This version is statically linked.}
d94b28a6 129
9fe14a3f 130%{!?with_imode:This version hasn't got interactive mode.}
7f07e487 131#'vim
1f84648f 132
9c03ea8f
ZU
133%description -l hu.UTF-8
134poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
135csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
136nulláról), frissítést és eltávolítást.
137
138A program használható parancssorból (mint a Debian apt-get programja)
139vagy interaktív módban. Az interaktív mód egy readline környezetet
140jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
141shell módjához.
142
143%{?with_static:Ez a verzió statikusan linkelt.}
144
145%{!?with_imode:Ennek a verziónak nincs interaktív módja.}
146
caed9b36
JR
147%description -l pl.UTF-8
148poldek jest narzędziem linii poleceń służącym do weryfikacji,
149instalacji (włączając instalację systemu od zera), aktualizacji i
150usuwania pakietów.
56e1ab51 151
caed9b36 152Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
d82a9cb2 153interaktywnym. Tryb interaktywny posiada interfejs readline z
caed9b36
JR
154dopełnianiem komend i historią, podobny do trybu shell perlowego
155modułu CPAN.
8efee472 156
9fe14a3f 157%{?with_static:Ta wersja jest konsolidowana statycznie.}
a611e0bc 158
9fe14a3f 159%{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
b44549bf 160
b25cb9a7 161%package libs
168acc54 162Summary: poldek libraries
9c03ea8f 163Summary(hu.UTF-8): A poldek könyvtárai
9faf625a 164Summary(pl.UTF-8): Biblioteki poldka
168acc54 165Group: Libraries
b25cb9a7
JB
166
167%description libs
168poldek libraries.
169
9c03ea8f
ZU
170%description libs -l hu.UTF-8
171A poldek könyvtárai.
172
caed9b36 173%description libs -l pl.UTF-8
b25cb9a7
JB
174Biblioteki poldka.
175
176%package devel
168acc54 177Summary: Header files for poldek libraries
9c03ea8f 178Summary(hu.UTF-8): A poldek könyvtár fejlesztői fájljai
9faf625a 179Summary(pl.UTF-8): Pliki nagłówkowe bibliotek poldka
168acc54 180Group: Development/Libraries
09d4c571 181Requires: %{name}-libs = %{version}-%{release}
b980560b 182Requires: rpm-devel >= %{ver_rpm}
b25cb9a7
JB
183
184%description devel
185Header files for poldek libraries.
186
9c03ea8f
ZU
187%description devel -l hu.UTF-8
188A poldek könyvtár fejlesztői fájljai.
189
caed9b36
JR
190%description devel -l pl.UTF-8
191Pliki nagłówkowe bibliotek poldka.
b25cb9a7
JB
192
193%package static
168acc54 194Summary: poldek static libraries
9c03ea8f 195Summary(hu.UTF-8): poldek statikus könyvtárak
9faf625a 196Summary(pl.UTF-8): Biblioteki statyczne poldka
168acc54 197Group: Development/Libraries
09d4c571 198Requires: %{name}-devel = %{version}-%{release}
b25cb9a7
JB
199
200%description static
201poldek static libraries.
202
9c03ea8f
ZU
203%description static -l hu.UTF-8
204poldek statikus könyvtárak.
205
caed9b36 206%description static -l pl.UTF-8
b25cb9a7
JB
207Biblioteki statyczne poldka.
208
58c31de0
JB
209%package -n python-poldek
210Summary: Python modules for poldek
9c03ea8f 211Summary(hu.UTF-8): Python modulok poldek-hez
9faf625a 212Summary(pl.UTF-8): Moduły języka Python dla poldka
58c31de0
JB
213Group: Libraries/Python
214Requires: %{name}-libs = %{version}-%{release}
340a1e21 215Requires: python-libs
58c31de0
JB
216
217%description -n python-poldek
218Python modules for poldek.
219
9c03ea8f
ZU
220%description -n python-poldek -l hu.UTF-8
221Python modulok poldek-hez.
222
caed9b36
JR
223%description -n python-poldek -l pl.UTF-8
224Moduły języka Python dla poldka.
58c31de0 225
03159b71 226%prep
a9c9446a 227%setup -q
85398bac 228%patch0 -p1
13aa6434 229%patch1 -p1
1cf9975a 230%patch2 -p1
c5d1808a 231%patch3 -p1
15f4d0b4 232%patch4 -p1
966a5e45 233%patch5 -p1
d20073ca 234%patch6 -p1
eca4cdcd 235%patch7 -p1
8dcb75fc 236
5e2c5cc3 237%{__rm} m4/libtool.m4 m4/lt*.m4
b44549bf 238
0579f9b7
ER
239# cleanup backups after patching
240find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
4fa2b79c 241chmod u+x ./configure ./doc/conf-xml2.sh
0579f9b7 242
b44549bf 243%build
5c81138a 244%{__gettextize}
bef9d2a3 245%{__libtoolize}
21a83253 246%{__aclocal} -I m4
d878a63c 247%{__autoheader}
21a83253
MM
248%{__autoconf}
249%{__automake}
f8e81a61 250cd tndb
313cd172 251%{__libtoolize}
5e2c5cc3
JB
252%{__aclocal}
253%{__autoheader}
254%{__autoconf}
255%{__automake}
f8e81a61 256cd ../trurlib
313cd172 257%{__libtoolize}
5e2c5cc3
JB
258%{__aclocal}
259%{__autoheader}
260%{__autoconf}
261%{__automake}
f8e81a61 262cd ..
b25cb9a7 263
3e975db6 264CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline"
1f84648f 265%configure \
b25cb9a7 266 %{?with_static:--enable-static --disable-shared} \
9fe14a3f 267 %{!?with_imode:--disable-imode} \
dcdcebb7 268 --with-pkglibdir=%{_libexecdir} \
58c31de0
JB
269 --enable-nls \
270 %{?with_python:--with-python}
9fb594dc 271%{__make} -j1
a1f22296 272# --enable-trace
8efee472 273
b44549bf 274%install
275rm -rf $RPM_BUILD_ROOT
c5d1808a 276install -d $RPM_BUILD_ROOT/var/cache/%{name}
8efee472 277
9fb594dc 278%{__make} install -j1 \
c8f7d829 279 DESTDIR=$RPM_BUILD_ROOT
de1099c4 280
d9c7cedf
ER
281install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
282
58c31de0 283%if %{with python}
9fb594dc 284%{__make} -C python -j1 install \
58c31de0
JB
285 DESTDIR=$RPM_BUILD_ROOT \
286 libdir=%{py_sitedir}
287%endif
288
5e2c5cc3 289%{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
a49836bb 290
9639596f 291%ifarch i486 i686 ppc sparc alpha athlon
bd621c72 292 %define ftp_arch %{_target_cpu}
36004ea3 293%endif
9639596f 294%ifarch %{x8664}
bd621c72
ER
295 %define ftp_arch x86_64
296 %define ftp_alt_arch i686
297 %define ftp_alt2_arch x32
fabc4b40
JR
298%endif
299%ifarch x32
bd621c72
ER
300 %define ftp_arch x32
301 %define ftp_alt_arch x86_64
302 %define ftp_alt2_arch i686
36004ea3 303%endif
9639596f 304%ifarch i586
bd621c72 305 %define ftp_arch i486
58820d9b 306%endif
a49836bb 307%ifarch pentium2 pentium3 pentium4
bd621c72 308 %define ftp_arch i686
36004ea3 309%endif
a49836bb 310%ifarch sparcv9 sparc64
bd621c72
ER
311 %define ftp_arch sparc
312 %define ftp_arch %{_target_cpu}
b614e8f7 313 %ifarch sparc64
bd621c72 314 %define ftp_alt_arch sparcv9
23ead09a 315 %endif
652b5bc5 316%endif
32697bd0 317
b614e8f7
JR
318%define pld_conf %{SOURCE1}
319%define pld_debuginfo_conf %{SOURCE8}
320%define pld_archive_conf %{SOURCE11}
7c0e4fc5 321
fabc4b40 322%ifarch %{x8664} x32
b614e8f7 323 %define pld_multilib_conf %{SOURCE2}
fabc4b40 324 %define pld_multilib2_conf %{SOURCE2}
b614e8f7 325%endif
7c0e4fc5 326
b614e8f7
JR
327# aidath
328%ifarch sparcv9 sparc64
329 %define pld_conf %{SOURCE9}
330 %undefine pld_archive_conf
331%endif
332%ifarch sparc64
333 %define pld_multilib_conf %{SOURCE10}
7c0e4fc5 334%endif
23ead09a 335
bd621c72 336%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
23ead09a 337
7c0e4fc5 338%if 0%{?pld_multilib_conf:1}
bd621c72 339 %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
7c0e4fc5
ER
340%endif
341
fabc4b40 342%if 0%{?pld_multilib2_conf:1}
bd621c72 343 %{__sed} 's|%%ARCH%%|%{ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt2_arch}.conf
fabc4b40
JR
344%endif
345
7c0e4fc5 346%if 0%{?pld_debuginfo_conf:1}
bd621c72 347%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
652b5bc5 348%endif
b25cb9a7 349
8db66c11 350%if 0%{?pld_archive_conf:1}
bd621c72 351%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
8db66c11
ER
352%endif
353
7e5296f4 354# Always install snapshot configs
bd621c72 355%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
a584c5c5 356 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
bd621c72 357%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
a584c5c5 358 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
fabc4b40 359%ifarch %{x8664} x32
bd621c72
ER
360 %{__sed} -e 's|%%ARCH%%|%{ftp_alt_arch}|g' \
361 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
362 %{__sed} -e 's|%%ARCH%%|%{ftp_alt2_arch}|g' \
363 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt2_arch}.conf
a584c5c5 364%endif
7e5296f4
JR
365
366%if %{with snap}
c88cf671 367%{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
7e5296f4 368%{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
a584c5c5 369%else
7e5296f4 370%{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
c88cf671 371%{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
a584c5c5
JR
372%endif
373
600f8dbc
ER
374# create "all" meta repo
375%if 0%{?ftp_alt_arch:1}%{?ftp_alt2_arch:1}
376cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-all.conf
377# group source for referring th+th-multiarch sources together, i.e poldek -n th-all
378[source]
379type = group
380name = th-all
381sources = th %{?ftp_alt_arch:th-%{ftp_alt_arch}} %{?ftp_alt2_arch:th-%{ftp_alt2_arch}}
382EOF
383%endif
384
8dbabc51 385# th-2014 snap does not exist for x32 yet
bd621c72 386%if "%{ftp_arch}" == "x32"
255ca68a
ER
387rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
388%endif
bd621c72 389%if "%{ftp_alt2_arch}" == "x32"
255ca68a
ER
390rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-x32.conf
391%endif
8dbabc51 392
27edf30a 393cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
b25cb9a7 394
9e6ff4ef 395%if %{with imode}
396# add desktop file and icon
397install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
27edf30a
ER
398cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
399cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
9e6ff4ef 400%endif
401
b43abde7 402# sources we don't package
5e2c5cc3 403%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
b25cb9a7 404# include them in %doc
c88cf671 405%{__rm} -rf configs
b25cb9a7 406cp -a conf configs
c88cf671 407%{__rm} -f configs/Makefile*
b25cb9a7 408
62e80071 409%if %{with python}
58c31de0 410%py_postclean
5e2c5cc3 411%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
62e80071 412%endif
58c31de0 413
b25cb9a7 414%find_lang %{name}
f373d903 415
b44549bf 416%clean
417rm -rf $RPM_BUILD_ROOT
418
daf0e7ce
ER
419%post
420[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
421if [ "$1" = "1" ]; then
422 # remove ignore = vserver-packages inside vserver on first install
423 {
424 while read f ctx; do
425 [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
426 done </proc/self/status
427 } 2>/dev/null
428 if [ -z "$ctx" -o "$ctx" = "0" ]; then
429 VSERVER=no
430 else
431 VSERVER=yes
432 fi
433 if [ "$VSERVER" = "yes" ]; then
434 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
435 fi
436fi
b25cb9a7 437
3896c8b1
ER
438%postun -p /sbin/postshell
439-/usr/sbin/fix-info-dir -c %{_infodir}
b25cb9a7
JB
440
441%post libs -p /sbin/ldconfig
442%postun libs -p /sbin/ldconfig
443
b43abde7
ER
444%triggerpostun -- poldek < 0.30-0.20080225.00.1
445if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
446 %{__sed} -i -e '/^%%include source.conf/{
447 a
448 a# /etc/poldek/repos.d/*.conf
449 a%%includedir repos.d
450 }' %{_sysconfdir}/%{name}/poldek.conf
451fi
452
453%{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
454%{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
455
456if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
505460c5
JR
457 %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
458 %{__mv} -v %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
b43abde7
ER
459fi
460
461%ifarch %{x8664}
462if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
505460c5
JR
463 %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
464 %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
b43abde7
ER
465fi
466%endif
467
1bacc3e0
JR
468%triggerpostun -- poldek < 0.30.1-3
469if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
bd621c72
ER
470 %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
471 %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
1bacc3e0
JR
472fi
473if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
bd621c72
ER
474 %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
475 %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
1bacc3e0
JR
476fi
477
c5d1808a
ER
478%triggerpostun -- %{name} < 0.30.1-8
479if [ $1 -le 1 ]; then
480 # revert change on --downgrade
1e921240 481 %{__sed} -i -re 's,^pm command = %{_libexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
c5d1808a
ER
482else
483 # setup pm command
1e921240 484 %{__sed} -i -re 's,#?(pm command =).*,\1 %{_libexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
c5d1808a
ER
485fi
486
767366b0 487%files -f %{name}.lang
b44549bf 488%defattr(644,root,root,755)
a9c9446a 489%doc ChangeLog README* NEWS TODO configs
b25cb9a7 490%dir %{_sysconfdir}/%{name}
c5d1808a
ER
491%dir %{_sysconfdir}/%{name}/pre-install.d
492%{_sysconfdir}/%{name}/pre-install.d/README
493%dir %{_sysconfdir}/%{name}/post-install.d
494%{_sysconfdir}/%{name}/post-install.d/README
08335479 495%dir %{_sysconfdir}/%{name}/repos.d
168acc54 496%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
b43abde7 497%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
5e2c5cc3
JB
498%attr(755,root,root) %{_bindir}/ipoldek
499%attr(755,root,root) %{_bindir}/poldek
d9c7cedf 500%attr(755,root,root) %{_bindir}/poldek-config
5e2c5cc3 501%attr(755,root,root) %{_bindir}/rpmvercmp
dcdcebb7 502%dir %{_libexecdir}
c5d1808a 503%attr(755,root,root) %{_libexecdir}/pm-command.sh
36b5e8a1
ER
504%attr(755,root,root) %{_libexecdir}/poldekuser-setup.sh
505%attr(755,root,root) %{_libexecdir}/vfcompr
506%attr(755,root,root) %{_libexecdir}/vfjuggle
507%attr(755,root,root) %{_libexecdir}/vfsmb
508%attr(755,root,root) %{_libexecdir}/zlib-in-rpm.sh
5e2c5cc3 509%{_mandir}/man1/%{name}*.1*
d8826405 510%lang(pl) %{_mandir}/pl/man1/%{name}*
b25cb9a7 511%{_infodir}/poldek.info*
9e6ff4ef 512%if %{with imode}
513%{_desktopdir}/%{name}.desktop
514%{_pixmapsdir}/%{name}.png
515%endif
27edf30a 516%dir /var/cache/%{name}
b25cb9a7 517
b43abde7 518%if %{without static}
b25cb9a7
JB
519%files libs
520%defattr(644,root,root,755)
d8aeff9a
MB
521%attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
522%attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
523%attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
524%attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
525%attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
526%attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
527%attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
528%attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
529%attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
530%attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
b25cb9a7
JB
531%endif
532
533%files devel
534%defattr(644,root,root,755)
5e2c5cc3
JB
535%if %{without static}
536%attr(755,root,root) %{_libdir}/libpoclidek.so
537%attr(755,root,root) %{_libdir}/libpoldek.so
538%attr(755,root,root) %{_libdir}/libtndb.so
539%attr(755,root,root) %{_libdir}/libtrurl.so
540%attr(755,root,root) %{_libdir}/libvfile.so
541%endif
542%{_libdir}/libpoclidek.la
543%{_libdir}/libpoldek.la
544%{_libdir}/libtndb.la
545%{_libdir}/libtrurl.la
546%{_libdir}/libvfile.la
547%{_includedir}/poldek
548%{_includedir}/tndb
549%{_includedir}/trurl
550%{_includedir}/vfile
551%{_pkgconfigdir}/tndb.pc
c9a1a81d 552%{_pkgconfigdir}/trurlib.pc
b25cb9a7
JB
553
554%files static
555%defattr(644,root,root,755)
5e2c5cc3
JB
556%{_libdir}/libtndb.a
557%{_libdir}/libtrurl.a
58c31de0
JB
558
559%if %{with python}
560%files -n python-poldek
561%defattr(644,root,root,755)
562%attr(755,root,root) %{py_sitedir}/_poldekmod.so
563%{py_sitescriptdir}/poldek.py[co]
564%{py_sitescriptdir}/poldekmod.py[co]
565%endif
This page took 0.148288 seconds and 4 git commands to generate.