]> git.pld-linux.org Git - packages/poldek.git/blame - poldek.spec
- dropped unused BR: perl-tools-pod
[packages/poldek.git] / poldek.spec
CommitLineData
065b86e0 1# TODO:
2# - fails to build without poldek-devel - fix it !
7638abfc 3#
de1099c4 4# Conditional build:
9fe14a3f 5%bcond_with static # don't use shared libraries
6%bcond_without imode # don't build interactive mode
58c31de0 7%bcond_without python # don't build python bindings
7638abfc 8#
373c6f03 9# required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
4d7ffb0a 10%if "%{pld_release}" == "ti"
530c8c41 11%define ver_db 4.5.20
473ce98d 12%define ver_db_rel 8
4d7ffb0a 13%else
530c8c41 14%define ver_db 4.7.25
473ce98d 15%define ver_db_rel 1
4d7ffb0a 16%endif
2b6db74f 17%define ver_rpm 4.5-5
5486bf2e 18#
04a91ad3 19%define snap 20080820.23
6e7ab173 20%define rel 44
b44549bf 21Summary: RPM packages management helper tool
9faf625a 22Summary(pl.UTF-8): Pomocnicze narzędzie do zarządzania pakietami RPM
b44549bf 23Name: poldek
24ad8b8d 24Version: 0.30
40ae4011 25Release: 0.%{snap}.%{rel}
9f931ada 26License: GPL v2
8efee472 27Group: Applications/System
85398bac 28#Source0: http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
c0898992 29Source0: http://carme.pld-linux.org/~megabajt/snaps/poldek/%{name}-%{version}-cvs%{snap}.tar.bz2
04a91ad3 30# Source0-md5: 2738eb3996f1cdf1e5d74b913d6e7414
911a8560 31Source1: %{name}.conf
b25cb9a7 32Source2: %{name}-multilib.conf
2ccd5d66 33Source3: %{name}-ti.conf
34Source4: %{name}-multilib-ti.conf
35Source5: %{name}-aliases.conf
36Source6: %{name}.desktop
37Source7: %{name}.png
171e07f6 38Source8: %{name}-debuginfo.conf
652b5bc5 39Source9: %{name}-aidath.conf
40Source10: %{name}-multilib-aidath.conf
85398bac
MB
41Patch0: %{name}-vserver-packages.patch
42Patch1: %{name}-config.patch
43Patch2: %{name}-abort-on-upgrade.patch
04a91ad3
MB
44Patch3: %{name}-inline.patch
45Patch4: %{name}-ls-llu.patch
46Patch5: %{name}-op-ldalldesc.patch
25838a54 47Patch6: %{name}-nocolor-upgrade.patch
f4114128
ER
48Patch7: %{name}-upgrade-dist.patch
49Patch8: %{name}-keep-reinstalled-provides.patch
bf43a3ac 50Patch9: %{name}-dont-ask-for-suggests-on-errors.patch
c7d7bdf5 51Patch10: %{name}-crash-on-invalid-locale.patch
149abeda 52Patch11: %{name}-noutf8.patch
f031015c 53Patch12: %{name}-dont-suggests-required-packages.patch
05e22a22 54Patch13: %{name}-tty-for-erasures.patch
c756c410 55Patch14: %{name}-both_langs.patch
20ff11b6 56Patch15: %{name}-317130.patch
d0d294bd 57Patch16: %{name}-321546.patch
f76d4526
PZ
58Patch17: %{name}-size-type.patch
59Patch18: %{name}-no-inlines.patch
a483213a 60Patch19: %{name}-export-missing-symbol.patch
fb2a8800 61Patch20: %{name}-skip-suggests-on-upgrade.patch
8f2fba8c 62Patch21: %{name}-po.patch
b9baa977 63Patch22: %{name}-refcnt.patch
20b92beb 64Patch23: %{name}-assertion-failed.patch
3e69de12 65Patch24: %{name}-unescape-urlencoded-strings.patch
a1f22296
BZ
66Patch25: %{name}-ls-source-rpm.patch
67Patch26: %{name}-add-arch-match.patch
68Patch27: %{name}-multilib-upgrade.patch
d9545c59
BZ
69Patch28: %{name}-score-reqs-marked-to-install.patch
70Patch29: %{name}-dont-be-greedy.patch
9adbdb06 71Patch30: %{name}-dont-lose-deps.patch
45986441 72Patch31: %{name}-ls-queryfmt.patch
207c5e8d
BZ
73Patch32: %{name}-prepare_url_fix.patch
74Patch33: %{name}-noloop_on_terminal_loos.patch
75Patch34: %{name}-show_only_relative_used_space.patch
cf07ce32 76Patch35: %{name}-zlib.patch
6e7ab173
BZ
77Patch36: %{name}-caplookup.patch
78Patch37: %{name}-local_trurlib_check.patch
39ca2371 79URL: http://poldek.pld-linux.org/
a4268952 80BuildRequires: autoconf
b25cb9a7 81BuildRequires: automake
373c6f03 82BuildRequires: bzip2-devel
065b86e0 83BuildRequires: check-devel
530c8c41 84BuildRequires: db-devel >= %{ver_db}-%{ver_db_rel}
f77a8b4c 85BuildRequires: gettext-devel
b25cb9a7
JB
86BuildRequires: libtool
87BuildRequires: libxml2-devel
cbc6f56b 88BuildRequires: openssl-devel >= 0.9.7d
13fd950e 89BuildRequires: pcre-devel
b3ea4b51 90BuildRequires: pkgconfig
13fd950e 91BuildRequires: popt-devel
58c31de0 92%{?with_python:BuildRequires: python-devel}
b25cb9a7 93BuildRequires: readline-devel >= 5.0
373c6f03 94BuildRequires: rpm-devel >= %{ver_rpm}
300927eb 95%{?with_python:BuildRequires: rpm-pythonprov}
96475e5e 96BuildRequires: zlib-devel
373c6f03
JB
97%if %{with static}
98BuildRequires: bzip2-static
530c8c41 99BuildRequires: db-static >= %{ver_db}-%{ver_db_rel}
2fac0b02 100BuildRequires: glibc-static
acb26797 101BuildRequires: libselinux-static
b25cb9a7 102BuildRequires: libxml2-static
373c6f03
JB
103BuildRequires: ncurses-static
104BuildRequires: openssl-static
105BuildRequires: pcre-static
106BuildRequires: popt-static
107BuildRequires: readline-static
108BuildRequires: rpm-static
109BuildRequires: zlib-static
373c6f03 110%endif
b25cb9a7 111Requires(triggerpostun): awk
168acc54 112Requires(triggerpostun): sed >= 4.0
09d4c571 113Requires: %{name}-libs = %{version}-%{release}
530c8c41 114Requires: db >= %{ver_db}-%{ver_db_rel}
373c6f03 115Requires: rpm >= %{ver_rpm}
530c8c41 116Requires: rpm-db-ver = %{ver_db}
78b0cd64 117Requires: rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
e202a52a
ER
118# vf* scripts use sed
119Requires: sed
b44549bf 120BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
121
122%description
0fa0dc36 123poldek is an RPM package management tool which allows you to easily
124perform package verification, installation (including system
13fd950e 125installation from scratch), upgrading, and removal.
0fa0dc36 126
13fd950e
JB
127Program can be used in batch (like apt-get from Debian's APT) or
128interactive mode. The interactive mode puts you into a readline
129interface with command line autocompletion and history, similar to the
130shell mode of Perl's CPAN.
8efee472 131
9fe14a3f 132%{?with_static:This version is statically linked.}
d94b28a6 133
9fe14a3f 134%{!?with_imode:This version hasn't got interactive mode.}
7f07e487 135#'vim
1f84648f 136
caed9b36
JR
137%description -l pl.UTF-8
138poldek jest narzędziem linii poleceń służącym do weryfikacji,
139instalacji (włączając instalację systemu od zera), aktualizacji i
140usuwania pakietów.
56e1ab51 141
caed9b36 142Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
d82a9cb2 143interaktywnym. Tryb interaktywny posiada interfejs readline z
caed9b36
JR
144dopełnianiem komend i historią, podobny do trybu shell perlowego
145modułu CPAN.
8efee472 146
9fe14a3f 147%{?with_static:Ta wersja jest konsolidowana statycznie.}
a611e0bc 148
9fe14a3f 149%{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
b44549bf 150
b25cb9a7 151%package libs
168acc54 152Summary: poldek libraries
9faf625a 153Summary(pl.UTF-8): Biblioteki poldka
168acc54 154Group: Libraries
b25cb9a7
JB
155
156%description libs
157poldek libraries.
158
caed9b36 159%description libs -l pl.UTF-8
b25cb9a7
JB
160Biblioteki poldka.
161
162%package devel
168acc54 163Summary: Header files for poldek libraries
9faf625a 164Summary(pl.UTF-8): Pliki nagłówkowe bibliotek poldka
168acc54 165Group: Development/Libraries
09d4c571 166Requires: %{name}-libs = %{version}-%{release}
b980560b 167Requires: rpm-devel >= %{ver_rpm}
b25cb9a7
JB
168
169%description devel
170Header files for poldek libraries.
171
caed9b36
JR
172%description devel -l pl.UTF-8
173Pliki nagłówkowe bibliotek poldka.
b25cb9a7
JB
174
175%package static
168acc54 176Summary: poldek static libraries
9faf625a 177Summary(pl.UTF-8): Biblioteki statyczne poldka
168acc54 178Group: Development/Libraries
09d4c571 179Requires: %{name}-devel = %{version}-%{release}
b25cb9a7
JB
180
181%description static
182poldek static libraries.
183
caed9b36 184%description static -l pl.UTF-8
b25cb9a7
JB
185Biblioteki statyczne poldka.
186
58c31de0
JB
187%package -n python-poldek
188Summary: Python modules for poldek
9faf625a 189Summary(pl.UTF-8): Moduły języka Python dla poldka
58c31de0
JB
190Group: Libraries/Python
191Requires: %{name}-libs = %{version}-%{release}
192%pyrequires_eq python-libs
193
194%description -n python-poldek
195Python modules for poldek.
196
caed9b36
JR
197%description -n python-poldek -l pl.UTF-8
198Moduły języka Python dla poldka.
58c31de0 199
03159b71 200%prep
78b0cd64 201%setup -q -n %{name}-%{version}%{?snap:-cvs%{snap}}
85398bac 202%patch0 -p1
13aa6434
AM
203%patch1 -p1
204%patch2 -p1
04a91ad3 205%patch3 -p1
2a61c5d4 206%patch4 -p1
c826891f 207%patch5 -p1
25838a54 208%patch6 -p0
f4114128
ER
209%patch7 -p0
210%patch8 -p0
bf43a3ac 211%patch9 -p0
c7d7bdf5 212%patch10 -p1
22858076 213%patch11 -p1
f031015c 214%patch12 -p1
05e22a22 215%patch13 -p1
c756c410 216%patch14 -p1
20ff11b6 217%patch15 -p1
d0d294bd 218%patch16 -p1
f76d4526
PZ
219%patch17 -p1
220%patch18 -p1
a483213a 221%patch19 -p0
fb2a8800 222%patch20 -p1
8f2fba8c 223%patch21 -p1
b9baa977 224%patch22 -p0
20b92beb 225%patch23 -p1
3e69de12 226%patch24 -p1
207c5e8d 227# LP#392984: add source rpm to ls
a1f22296
BZ
228%patch25 -p1
229# LP#408036
230%patch26 -p1
231# LP#408034
232%patch27 -p1
d9545c59
BZ
233# score reqs already marked to install
234%patch28 -p1
235# dont be greedy if upgraded pkg has needed capabilities
236%patch29 -p1
9adbdb06 237# http://lists.pld-linux.org/mailman/pipermail/pld-devel-pl/2009-November/150519.html
065b86e0 238%patch30 -p1
207c5e8d 239# LP#392984: add query format to ls
45986441 240%patch31 -p1
207c5e8d
BZ
241# LP#506568
242%patch32 -p0
243# LP#499504
244%patch33 -p1
245# do not info. about amount of transaction space req. but relative to already installed
246%patch34 -p1
cf07ce32
AM
247# fixes failures with zlib >= 1.2.3.7
248%patch35 -p0
6e7ab173
BZ
249%patch36 -p1
250%patch37 -p0
b44549bf 251
0579f9b7
ER
252# cleanup backups after patching
253find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
254
b44549bf 255%build
bef9d2a3 256%{__libtoolize}
cf07ce32 257%{__autoheader}
21a83253
MM
258%{__aclocal} -I m4
259%{__autoconf}
260%{__automake}
63bd61a7 261cp -f config.sub trurlib
b25cb9a7 262
97ecf213 263CPPFLAGS="-std=gnu99"
1f84648f 264%configure \
b25cb9a7 265 %{?with_static:--enable-static --disable-shared} \
9fe14a3f 266 %{!?with_imode:--disable-imode} \
58c31de0
JB
267 --enable-nls \
268 %{?with_python:--with-python}
03159b71 269%{__make}
a1f22296 270# --enable-trace
8efee472 271
b44549bf 272%install
273rm -rf $RPM_BUILD_ROOT
08335479 274install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d
8efee472 275
c8f7d829 276%{__make} install \
277 DESTDIR=$RPM_BUILD_ROOT
de1099c4 278
58c31de0
JB
279%if %{with python}
280%{__make} -C python install \
281 DESTDIR=$RPM_BUILD_ROOT \
282 libdir=%{py_sitedir}
283%endif
284
9fe14a3f 285%{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
a49836bb 286
9639596f 287%ifarch i486 i686 ppc sparc alpha athlon
a49836bb 288%define _ftp_arch %{_target_cpu}
36004ea3 289%endif
9639596f 290%ifarch %{x8664}
590302c4 291%define _ftp_arch x86_64
b25cb9a7 292%define _ftp_alt_arch i686
36004ea3 293%endif
9639596f 294%ifarch i586
58820d9b 295%if "%{pld_release}" == "ti"
296%define _ftp_arch i586
297%else
9639596f 298%define _ftp_arch i486
36004ea3 299%endif
58820d9b 300%endif
a49836bb 301%ifarch pentium2 pentium3 pentium4
302%define _ftp_arch i686
36004ea3 303%endif
a49836bb 304%ifarch sparcv9 sparc64
305%define _ftp_arch sparc
652b5bc5 306%if "%{pld_release}" == "th"
307%define _ftp_arch %{_target_cpu}
308%ifarch sparc64
309%define _ftp_alt_arch sparcv9
310%endif
311%endif
a49836bb 312%endif
a49836bb 313
b25cb9a7 314%{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
32697bd0 315
2ccd5d66 316%if "%{pld_release}" == "ti"
317sed -e '
318 s|%%ARCH%%|%{_ftp_arch}|g
319' < %{SOURCE3} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
320
321%ifarch %{x8664}
322sed '
323 s|%%ARCH%%|%{_ftp_alt_arch}|g
324' < %{SOURCE4} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
325%endif
326%else
171e07f6 327# pld_release = th
652b5bc5 328%ifarch sparcv9 sparc64
329sed -e '
330 s|%%ARCH%%|%{_ftp_arch}|g
331' < %{SOURCE9} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
332
333%ifarch sparc64
334sed '
335 s|%%ARCH%%|%{_ftp_alt_arch}|g
336' < %{SOURCE10} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
337%endif
338
339%else
7adf66ff
ER
340sed -e '
341 s|%%ARCH%%|%{_ftp_arch}|g
b43abde7 342' < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
171e07f6
ER
343sed -e '
344 s|%%ARCH%%|%{_ftp_arch}|g
345' < %{SOURCE8} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
b44549bf 346
590302c4 347%ifarch %{x8664}
7adf66ff
ER
348sed '
349 s|%%ARCH%%|%{_ftp_alt_arch}|g
b43abde7 350' < %{SOURCE2} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
b25cb9a7 351%endif
2ccd5d66 352%endif
652b5bc5 353%endif
b25cb9a7 354
480fc3c0 355install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
b25cb9a7 356
9e6ff4ef 357%if %{with imode}
358# add desktop file and icon
359install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
2ccd5d66 360install %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
361install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
9e6ff4ef 362%endif
363
b43abde7
ER
364# sources we don't package
365rm -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,pld,fedora,centos}-source.conf
b25cb9a7
JB
366# include them in %doc
367rm -rf configs
368cp -a conf configs
369rm -f configs/Makefile*
370
62e80071 371%if %{with python}
58c31de0
JB
372%py_postclean
373rm -f $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
62e80071 374%endif
58c31de0 375
b25cb9a7 376%find_lang %{name}
f373d903 377
b44549bf 378%clean
379rm -rf $RPM_BUILD_ROOT
380
daf0e7ce
ER
381%post
382[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
383if [ "$1" = "1" ]; then
384 # remove ignore = vserver-packages inside vserver on first install
385 {
386 while read f ctx; do
387 [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
388 done </proc/self/status
389 } 2>/dev/null
390 if [ -z "$ctx" -o "$ctx" = "0" ]; then
391 VSERVER=no
392 else
393 VSERVER=yes
394 fi
395 if [ "$VSERVER" = "yes" ]; then
396 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
397 fi
398fi
b25cb9a7 399
3896c8b1
ER
400%postun -p /sbin/postshell
401-/usr/sbin/fix-info-dir -c %{_infodir}
b25cb9a7
JB
402
403%post libs -p /sbin/ldconfig
404%postun libs -p /sbin/ldconfig
405
b25cb9a7
JB
406%triggerpostun -- poldek < 0.19.0-1.20050613.22.0
407if [ -f /etc/poldek.conf.rpmsave ]; then
408 awk '/^source/ {
409 name = $3;
410 path = $4;
411 auto = "yes";
412 autoup = "yes";
413 type = "pdir";
f154dd55 414 pri = "";
b25cb9a7
JB
415
416 if (sub(",noauto", "", name)) {
417 auto = "no";
418 }
419
f154dd55
ER
420 # process pri=\d+
421 if (match(name, /,pri=[0-9]+/)) {
422 pri = substr(name, RSTART + 5, RLENGTH - 5);
423 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
424 }
425
b25cb9a7
JB
426 # skip ac sources. already in new config.
427 if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
428 print "";
429 print "[source]";
430 print "name = " name;
431 print "type = " type;
432 print "path = " path;
433 print "auto = " auto;
434 print "autoup = " autoup;
f154dd55
ER
435 if (pri) {
436 print "pri = " pri;
437 }
b25cb9a7
JB
438 }
439
440 }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
19cae196 441 echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
b25cb9a7
JB
442
443 # copy hold=
444 hold=$(grep ^hold /etc/poldek.conf.rpmsave)
445 if [ "$hold" ]; then
446 sed -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
447 fi
448fi
449
b43abde7
ER
450%triggerpostun -- poldek < 0.30-0.20080225.00.1
451if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
452 %{__sed} -i -e '/^%%include source.conf/{
453 a
454 a# /etc/poldek/repos.d/*.conf
455 a%%includedir repos.d
456 }' %{_sysconfdir}/%{name}/poldek.conf
457fi
458
459%{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
460%{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
461
462if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
463 cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
478b6a69 464 cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
b43abde7
ER
465fi
466
467%ifarch %{x8664}
468if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
469 cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
478b6a69 470 cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
b43abde7
ER
471fi
472%endif
473
767366b0 474%files -f %{name}.lang
b44549bf 475%defattr(644,root,root,755)
b43abde7 476%doc README* NEWS TODO configs
b25cb9a7 477%dir %{_sysconfdir}/%{name}
08335479 478%dir %{_sysconfdir}/%{name}/repos.d
168acc54 479%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
b43abde7 480%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
8efee472 481%attr(755,root,root) %{_bindir}/*
b25cb9a7
JB
482%dir %{_libdir}/%{name}
483%attr(755,root,root) %{_libdir}/%{name}/*
b44549bf 484%{_mandir}/man1/%{name}*
d8826405 485%lang(pl) %{_mandir}/pl/man1/%{name}*
b25cb9a7 486%{_infodir}/poldek.info*
9e6ff4ef 487%if %{with imode}
488%{_desktopdir}/%{name}.desktop
489%{_pixmapsdir}/%{name}.png
490%endif
b25cb9a7 491
b43abde7 492%if %{without static}
b25cb9a7
JB
493%files libs
494%defattr(644,root,root,755)
d8aeff9a
MB
495%attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
496%attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
497%attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
498%attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
499%attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
500%attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
501%attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
502%attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
503%attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
504%attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
b25cb9a7
JB
505%endif
506
507%files devel
508%defattr(644,root,root,755)
509%{!?with_static:%attr(755,root,root) %{_libdir}/lib*.so}
510%{_libdir}/lib*.la
511%{_includedir}/*
512
513%files static
514%defattr(644,root,root,755)
515%{_libdir}/lib*.a
58c31de0
JB
516
517%if %{with python}
518%files -n python-poldek
519%defattr(644,root,root,755)
520%attr(755,root,root) %{py_sitedir}/_poldekmod.so
521%{py_sitescriptdir}/poldek.py[co]
522%{py_sitescriptdir}/poldekmod.py[co]
523%endif
This page took 0.195443 seconds and 4 git commands to generate.