]> git.pld-linux.org Git - packages/pokerth.git/blame - pokerth.spec
boost rebuild
[packages/pokerth.git] / pokerth.spec
CommitLineData
c98f7e6a
AG
1Summary: The Open Source Texas-Holdem Poker Engine
2Summary(pl.UTF-8): Silnik gry Texas-Holdem poker
3Name: pokerth
b5517f57 4Version: 1.1.2
ccbbf584 5Release: 15
b5517f57 6License: AGPL v3+
c98f7e6a 7Group: X11/Applications/Games
e0935f50
JB
8#Source0Download: https://github.com/pokerth/pokerth/releases
9#future releases: https://github.com/pokerth/pokerth/archive/%{version}/%{name}-%{version}.tar.gz
b5517f57
JB
10Source0: http://downloads.sourceforge.net/pokerth/pokerth-%{version}.tar.gz
11# Source0-md5: 8fd7d7fc7ece17315e58aa3240dd4586
bc1371f4 12Patch0: x32.patch
b5517f57
JB
13Patch1: system-qtsingleapp.patch
14Patch2: moc.patch
15Patch3: %{name}-protobuf.patch
16Patch4: %{name}-boost.patch
17# from https://github.com/zaphoyd/websocketpp/pull/814/commits/c769c9238ad62178f506038178714a1c35aa2769.patch
18Patch5: %{name}-websocketpp-boost.patch
e0935f50 19URL: https://pokerth.net/
b5517f57
JB
20BuildRequires: QtCore-devel >= 4.4.3
21BuildRequires: QtGui-devel >= 4.4.3
22BuildRequires: QtNetwork-devel >= 4.4.3
072aff66 23BuildRequires: QtSingleApplication-devel
b5517f57
JB
24BuildRequires: QtSql-devel >= 4.4.3
25BuildRequires: SDL-devel
c98f7e6a 26BuildRequires: SDL_mixer-devel
b5517f57 27BuildRequires: boost-devel >= 1.49
c98f7e6a
AG
28BuildRequires: curl-devel >= 7.16
29BuildRequires: gnutls-devel
b5517f57
JB
30BuildRequires: gsasl-devel >= 1.4
31BuildRequires: libircclient-devel >= 1.3
32BuildRequires: libstdc++-devel >= 6:4.7
33BuildRequires: protobuf-devel >= 2.3.0
c98f7e6a
AG
34BuildRequires: qt4-build >= 4.3.1
35BuildRequires: qt4-qmake >= 4.3.1
4a178bf3 36BuildRequires: sed >= 4.0
b5517f57 37BuildRequires: sqlite3-devel >= 3
8482ca5a 38BuildRequires: tinyxml-devel
c98f7e6a
AG
39BuildRequires: zlib-devel >= 1.2.3
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
4a178bf3 43PokerTH is a poker game written in C++/Qt4. You can play the popular
c98f7e6a
AG
44"Texas Hold'em" poker variant against up to six computer-opponents or
45play network games with people all over the world. This poker engine
4a178bf3 46is available for Linux, Windows, and MacOS X.
c98f7e6a
AG
47
48%description -l pl.UTF-8
4a178bf3 49PokerTH to komputerowa gra w pokera napisana w C++/Qt4. Umożliwia ona
c98f7e6a
AG
50grę w popularny wariant "Texas Hold'em" przeciwko maksymalnie sześciu
51komputerowym przeciwnikom lub sieciową grę z innymi zawodnikami.
4a178bf3 52Silnik gry dostępny jest na platformy Linux, Windows oraz MacOS X.
c98f7e6a
AG
53
54%prep
b5517f57 55%setup -q -n pokerth-%{version}-rc
2a63ac07 56%patch0 -p1
d89f6892 57%patch1 -p1
072aff66
JR
58%patch2 -p1
59%patch3 -p1
60%patch4 -p1
61%patch5 -p1
072aff66
JR
62
63%{__rm} -r src/third_party/qtsingleapplication
4a178bf3 64
c98f7e6a 65%build
b5517f57
JB
66install -d build-client build-server
67cd build-server
68qmake-qt4 ../pokerth.pro \
4a178bf3 69 QMAKE_CXX="%{__cxx}" \
b5517f57
JB
70 QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}" \
71 QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
72%{__make}
73
74cd ../build-client
75qmake-qt4 ../pokerth.pro \
76 CONFIG+=client \
77 QMAKE_CXX="%{__cxx}" \
78 QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}" \
4a178bf3 79 QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
c98f7e6a
AG
80%{__make}
81
82%install
83rm -rf $RPM_BUILD_ROOT
b5517f57
JB
84install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
85
86%{__make} -C build-client install \
c98f7e6a
AG
87 INSTALL_ROOT=$RPM_BUILD_ROOT
88
b5517f57
JB
89install build-client/pokerth build-server/bin/pokerth_server $RPM_BUILD_ROOT%{_bindir}
90cp -p docs/pokerth.1 $RPM_BUILD_ROOT%{_mandir}/man1
c98f7e6a
AG
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%files
96%defattr(644,root,root,755)
97%doc COPYING ChangeLog TODO
b5517f57
JB
98%attr(755,root,root) %{_bindir}/pokerth
99%attr(755,root,root) %{_bindir}/pokerth_server
100%{_desktopdir}/pokerth.desktop
101%{_pixmapsdir}/pokerth.png
102%{_datadir}/pokerth
103%{_mandir}/man1/pokerth.1*
This page took 0.32815 seconds and 5 git commands to generate.